self-build-ffmpeg2theora-vl.spec 5.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161
  1. #% global posttag svn18423
  2. %define pkgname ffmpeg2theora
  3. %define name self-build-%{pkgname}
  4. %define version 0.29
  5. %define release 2%{?posttag:.%{posttag}}%{?_dist_release}
  6. %define sourceurl http://www.v2v.cc/~j/ffmpeg2theora/downloads/%{pkgname}-%{version}.tar.bz2
  7. Summary: Package to automatically build %{pkgname} rpm package
  8. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  9. Name: %{name}
  10. Version: %{version}
  11. Release: %{release}
  12. Source0: %{pkgname}-vl.spec
  13. Source10: ffmpeg2theora-snapshot.sh
  14. #Source100: ffmpeg2theora-0.28+%{posttag}.patch
  15. License: GPLv2+
  16. Group: Restricted Software
  17. Requires(post): self-build-setup >= 0.9.9
  18. # (build)requies of target package.
  19. Requires(post): scons
  20. Requires(post): libogg-devel >= 1.1
  21. Requires(post): libtheora-devel >= 1.1.0
  22. Requires(post): libvorbis-devel
  23. Requires(post): self-build-ffmpeg >= 1.2
  24. BuildArch: noarch
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  26. Packager: munepi
  27. %description
  28. ffmpeg2theora is a tool to convert any file that ffmpeg can
  29. decode to theora.
  30. If you install this package, it automaticaly downloads source
  31. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  32. And the created rpm packages are automatically installed
  33. if installation is executed by apt-get command or synaptic
  34. package manager.
  35. [Note]
  36. This package requires many other packages to compile
  37. targetsoftware. So it consume more disk space than usual.
  38. Also installation takes logner time because of compilation.
  39. (This will take a few minutes to quarter or half of an hour,
  40. depends on building environment)
  41. [About self-build package]
  42. For some kind of software, distributing of binary package
  43. may viorate the patent or law. Therefore we chose self-build
  44. packge, create binary package on your machine, for such kind
  45. of softwares instead of distributing binary package.
  46. Please obey the national law when you use the created binary
  47. packages. And if you want to use the softwares using patented
  48. thechnology, it may be required to get a permission, make an
  49. agreement or purchas a license. Please consider it with your
  50. purpose or way of use and take appropriate action.
  51. %description -l ja
  52. ffmpeg2theora は ffmpeg がデコードできるファイルを theora 形式
  53. に変換するツールです。
  54. このパッケージをインストールすると、自動的にソースコードを
  55. ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
  56. パッケージを作成します。
  57. また apt-get コマンドや synaptic パッケージマネージャから実行
  58. した場合は、作成された rpm パッケージのインストールも自動的に
  59. 行います。
  60. [注意]
  61. コンパイルに必要な多くの関連パッケージを要求するので通常より
  62. ディスクの領域を多く消費します。
  63. またインストール時にコンパイルを行うため、通常より時間がかか
  64. る場合があります。(環境にもよりますが数分から数十分程度)
  65. [self-build パッケージについて]
  66. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  67. 違反する可能性があるものがあります。その為、このような問題が
  68. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  69. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  70. ジという方法を採っています。
  71. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  72. アのライセンス、および利用する国の各種法令に従ってください。
  73. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  74. センスの購入などが必要となる場合がありますので、利用する目的
  75. や形態に応じて各自で判断し適切な対応を取ってください。
  76. %prep
  77. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  78. %install
  79. %{__rm} -rf ${RPM_BUILD_ROOT}
  80. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  81. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  82. #%{__install} -m 644 %{SOURCE100} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  83. %clean
  84. %{__rm} -rf ${RPM_BUILD_ROOT}
  85. %posttrans
  86. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 11000
  87. #/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release}
  88. %files
  89. %defattr(-,root,root)
  90. %{_datadir}/%{name}
  91. %changelog
  92. * Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.29-2
  93. - rebuilt with ffmpeg-1.2.3
  94. * Mon Feb 4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.29-1
  95. - new upstream release
  96. * Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.28-2.svn18423
  97. - update to the latest upstream commit
  98. - for ffmpeg 0.10 compatibility
  99. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.28-1
  100. - new upstream release
  101. - License: GPLv2+
  102. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 0.27-1
  103. - new upstream release
  104. - fixed the location of %%sourceurl
  105. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.25-2
  106. - renamed %%{Source0} to ffmpeg2theora-vl.spec
  107. * Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.25-1
  108. - new upstream release
  109. - with recent ffmpeg
  110. * Sat Jun 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.24-1
  111. - new upstream release
  112. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.23-2
  113. - added BuildArch: noarch
  114. - avoided to execute self-build-rpm.sh on RPM transaction
  115. - moved %%post actions to %%posttrans
  116. * Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.23-1
  117. - new upstream release
  118. - dropped ffmpeg2theora-0.20-new_ffmpeg.patch
  119. - added PreReq: scons
  120. * Sat May 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.20-2
  121. - spec in utf8
  122. * Sat May 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.20-1
  123. - initial build for Vine Linux.