self-build-broadcom-wl.spec 5.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146
  1. %define pkgname broadcom-wl
  2. %define name self-build-%{pkgname}
  3. %define oname hybrid-portsrc
  4. %define over %(echo %{version} | tr . _)
  5. %ifarch %{ix86}
  6. %define source0path http://www.broadcom.com/docs/linux_sta/%{oname}_x86_32-v%{over}.tar.gz
  7. %endif
  8. %ifarch x86_64
  9. %define source0path http://www.broadcom.com/docs/linux_sta/%{oname}_x86_64-v%{over}.tar.gz
  10. %endif
  11. Summary: Package to automatically build %{pkgname} rpm package
  12. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  13. Name: %{name}
  14. Version: 5.100.82.112
  15. Release: 1%{?_dist_release}
  16. Source0: %{pkgname}.spec
  17. Source1: blacklist-broadcom.conf
  18. Source2: 5_100_82_112.patch
  19. License: Freeware and GPLv2 with exception
  20. Group: Restricted Software
  21. Requires(pre): self-build-setup >= 0.7-1
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. ExclusiveArch: %{ix86} x86_64
  24. %description
  25. Proprietary hybrid driver for Broadcom wireless adapters.
  26. If you install this package, it automaticaly downloads source
  27. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  28. And the created rpm packages are automatically installed
  29. if installation is executed by apt-get command or synaptic
  30. package manager.
  31. [Note]
  32. This package requires many other packages to compile
  33. targetsoftware. So it consume more disk space than usual.
  34. Also installation takes logner time because of compilation.
  35. (This will take a few minutes to quarter or half of an hour,
  36. depends on building environment)
  37. [About self-build package]
  38. For some kind of software, distributing of binary package
  39. may viorate the patent or law. Therefore we chose self-build
  40. packge, create binary package on your machine, for such kind
  41. of softwares instead of distributing binary package.
  42. Please obey the national law when you use the created binary
  43. packages. And if you want to use the softwares using patented
  44. thechnology, it may be required to get a permission, make an
  45. agreement or purchas a license. Please consider it with your
  46. purpose or way of use and take appropriate action.
  47. %description -l ja
  48. Broadcom ワイヤレスアダプタ用のプロプライエタリドライバです。
  49. このパッケージをインストールすると、自動的にソースコードを
  50. ダウンロードしてコンパイルし、%{pkgname}-%{version}
  51. の rpm パッケージを作成します。
  52. また apt-get コマンドや synaptic パッケージマネージャから実行
  53. した場合は、作成された rpm パッケージのインストールも自動的に
  54. 行います。
  55. [注意]
  56. コンパイルに必要な多くの関連パッケージを要求するので通常より
  57. ディスクの領域を多く消費します。
  58. またインストール時にコンパイルを行うため、通常より時間がかか
  59. る場合があります。(環境にもよりますが数分から数十分程度)
  60. [self-build パッケージについて]
  61. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  62. 違反する可能性があるものがあります。その為、このような問題が
  63. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  64. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  65. ジという方法を採っています。
  66. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  67. アのライセンス、および利用する国の各種法令に従ってください。
  68. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  69. センスの購入などが必要となる場合がありますので、利用する目的
  70. や形態に応じて各自で判断し適切な対応を取ってください。
  71. %install
  72. rm -rf %{buildroot}
  73. install -d %{buildroot}%{_datadir}/%{name}
  74. install -m 644 %{SOURCE1} %{buildroot}%{_datadir}/%{name}
  75. install -m 644 %{SOURCE2} %{buildroot}%{_datadir}/%{name}
  76. sed -e 's|##VERSION##|%{version}|g' -e 's|##RELEASE##|%{release}|g' \
  77. %{SOURCE0} > %{buildroot}%{_datadir}/%{name}/%{pkgname}.spec
  78. %clean
  79. rm -rf %{buildroot}
  80. %posttrans
  81. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}.spec "%{source0path}"
  82. /usr/lib/rpm/pre-allocate-rpm.sh dkms-%{pkgname}-%{version}-%{release}
  83. %files
  84. %defattr(-,root,root)
  85. %{_datadir}/%{name}/*
  86. %changelog
  87. * Tue May 01 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.100.82.112-1
  88. - new upstream release.
  89. - dropped an old patch.
  90. - added SOURCE2 to compile for kernel-3.2.x.
  91. * Tue Oct 4 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.100.82.38-3
  92. - update SOURCE1 (see: http://www.broadcom.com/docs/linux_sta/bcma.txt)
  93. * Sun Aug 14 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.100.82.38-2
  94. - add a patch to fix build failure on linux > 2.6.37
  95. * Sun Jan 01 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.100.82.38-1
  96. - new upstream release
  97. * Tue Aug 17 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.60.48.36-2
  98. - add Source2 to fix build failure on kernel >= 2.6.35
  99. (https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/590924)
  100. * Tue Aug 17 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.60.48.36-1
  101. - new upstream release
  102. * Wed Sep 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9.3-1
  103. - new upstream release
  104. * Tue May 05 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9-3
  105. - fix to ensure Source0 has correct version/release numbers
  106. * Tue May 05 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9-2
  107. - add ExclusiveArch
  108. * Tue May 05 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9-1
  109. - initial build for Vine Linux