nodejs-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346
  1. %global system_zlib 1
  2. %global system_v8 1
  3. %global system_openssl 1
  4. %global system_http_parser 0
  5. %global system_cares 0
  6. %global system_libuv 0
  7. %if "%{_dist_release}" < "vl7"
  8. %global system_openssl 0
  9. %endif
  10. Name: nodejs
  11. Version: 0.10.26
  12. Release: 1%{?_dist_release}
  13. Summary: JavaScript runtime
  14. Summary(ja): JavaScript runtime
  15. License: MIT and ASL 2.0 and ISC and BSD
  16. Group: Development/Languages
  17. URL: http://nodejs.org/
  18. # Exclusive archs must match v8
  19. ExclusiveArch: %{ix86} x86_64 %{arm}
  20. Source0: http://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
  21. Source1: macros.nodejs
  22. Source2: nodejs.attr
  23. Source3: nodejs.prov
  24. Source4: nodejs.req
  25. Source5: nodejs-symlink-deps
  26. Source6: nodejs-fixdep
  27. # V8 presently breaks ABI at least every x.y release while never bumping SONAME,
  28. # so we need to be more explicit until spot fixes that
  29. %global v8_ge 3.13.7.5
  30. %global v8_lt 3.14
  31. %if %{system_v8}
  32. BuildRequires: v8-devel >= %{v8_ge}
  33. %endif
  34. %if %{system_http_parser}
  35. BuildRequires: http-parser-devel >= 2.0
  36. %endif
  37. %if %{system_libuv}
  38. BuildRequires: libuv-devel
  39. %endif
  40. %if %{system_cares}
  41. BuildRequires: c-ares-devel
  42. %endif
  43. %if %{system_zlib}
  44. BuildRequires: zlib-devel
  45. %endif
  46. %if %{system_openssl}
  47. # Node.js requires some features from openssl 1.0.1 for SPDY support
  48. BuildRequires: openssl-devel >= 1.0.1
  49. %endif
  50. %if %{system_v8}
  51. Requires: v8%{?isa} >= %{v8_ge}
  52. Requires: v8%{?isa} < %{v8_lt}
  53. %endif
  54. #virtual provides for automatic depedency generation
  55. Provides: nodejs(engine) = %{version}
  56. #npm
  57. Provides: npm = %{version}-%{release}
  58. # Node.js currently has a conflict with the 'node' package in Fedora
  59. # The ham-radio group has agreed to rename their binary for us, but
  60. # in the meantime, we're setting an explicit Conflicts: here
  61. Conflicts: node <= 0.3.2-11
  62. %description
  63. Node.js is a platform built on Chrome's JavaScript runtime
  64. for easily building fast, scalable network applications.
  65. Node.js uses an event-driven, non-blocking I/O model that
  66. makes it lightweight and efficient, perfect for data-intensive
  67. real-time applications that run across distributed devices.
  68. %package devel
  69. Summary: JavaScript runtime - development headers
  70. Summary(ja): JavaScript runtime - development headers
  71. Group: Development/Languages
  72. Requires: %{name} == %{version}-%{release}
  73. %if %{system_libuv}
  74. Requires: libuv-devel
  75. %endif
  76. %if %{system_http_parser}
  77. Requires: http-parser-devel
  78. %endif
  79. %if %{system_cares}
  80. Requires: c-ares-devel
  81. %endif
  82. %if %{system_zlib}
  83. Requires: zlib-devel
  84. %endif
  85. %if %{system_openssl}
  86. Requires: openssl-devel
  87. %endif
  88. %description devel
  89. Development headers for the Node.js JavaScript runtime.
  90. %package docs
  91. Summary: Node.js API documentation
  92. Summary(ja): Node.js API documentation
  93. Group: Documentation
  94. %description docs
  95. The API documentation for the Node.js JavaScript runtime.
  96. %prep
  97. %setup -q -n node-v%{version}
  98. # Make sure nothing gets included from bundled deps:
  99. # We only delete the source and header files, because
  100. # the remaining build scripts are still used.
  101. %if %{system_cares}
  102. find deps/cares -name "*.c" -exec rm -f {} \;
  103. find deps/cares -name "*.h" -exec rm -f {} \;
  104. %endif
  105. %if %{system_zlib}
  106. find deps/zlib -name "*.c" -exec rm -f {} \;
  107. find deps/zlib -name "*.h" -exec rm -f {} \;
  108. %endif
  109. %if %{system_v8}
  110. find deps/v8 -name "*.c" -exec rm -f {} \;
  111. find deps/v8 -name "*.h" -exec rm -f {} \;
  112. %endif
  113. %if %{system_http_parser}
  114. find deps/http_parser -name "*.c" -exec rm -f {} \;
  115. find deps/http_parser -name "*.h" -exec rm -f {} \;
  116. %endif
  117. %if %{system_openssl}
  118. find deps/openssl -name "*.c" -exec rm -f {} \;
  119. find deps/openssl -name "*.h" -exec rm -f {} \;
  120. %endif
  121. %if %{system_libuv}
  122. find deps/uv -name "*.c" -exec rm -f {} \;
  123. find deps/uv -name "*.h" -exec rm -f {} \;
  124. %endif
  125. %build
  126. # build with debugging symbols and add defines from libuv (#892601)
  127. export CFLAGS='%{optflags} -g -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64'
  128. export CXXFLAGS='%{optflags} -g -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64'
  129. ./configure --prefix=%{_prefix} \
  130. %if %{system_v8}
  131. --shared-v8 \
  132. %endif
  133. %if %{system_openssl}
  134. --shared-openssl \
  135. %endif
  136. %if %{system_zlib}
  137. --shared-zlib \
  138. %endif
  139. %if %{system_cares}
  140. --shared-cares \
  141. %endif
  142. %if %{system_libuv}
  143. --shared-libuv \
  144. %endif
  145. %if %{system_http_parser}
  146. --shared-http-parser \
  147. %endif
  148. --without-dtrace
  149. # Setting BUILDTYPE=Debug builds both release and debug binaries
  150. make BUILDTYPE=Debug %{?_smp_mflags}
  151. %install
  152. rm -rf %{buildroot}
  153. ./tools/install.py install %{buildroot}
  154. # and remove dtrace file again
  155. rm -rf %{buildroot}/%{_prefix}/lib/dtrace
  156. # Set the binary permissions properly
  157. chmod 0755 %{buildroot}/%{_bindir}/node
  158. # Install the debug binary and set its permissions
  159. install -Dpm0755 out/Debug/node %{buildroot}/%{_bindir}/node_g
  160. # own the sitelib directory
  161. mkdir -p %{buildroot}%{_prefix}/lib/node_modules
  162. # install rpm magic
  163. install -Dpm0644 %{SOURCE1} %{buildroot}%{_sysconfdir}/rpm/macros.nodejs
  164. install -Dpm0644 %{SOURCE2} %{buildroot}%{_rpmconfigdir}/fileattrs/nodejs.attr
  165. install -pm0755 %{SOURCE3} %{buildroot}%{_rpmconfigdir}/nodejs.prov
  166. install -pm0755 %{SOURCE4} %{buildroot}%{_rpmconfigdir}/nodejs.req
  167. install -pm0755 %{SOURCE5} %{buildroot}%{_rpmconfigdir}/nodejs-symlink-deps
  168. install -pm0755 %{SOURCE6} %{buildroot}%{_rpmconfigdir}/nodejs-fixdep
  169. #install documentation
  170. mkdir -p %{buildroot}%{_defaultdocdir}/%{name}-docs-%{version}/html
  171. cp -pr doc/* %{buildroot}%{_defaultdocdir}/%{name}-docs-%{version}/html
  172. rm -f %{_defaultdocdir}/%{name}-docs-%{version}/html/nodejs.1
  173. #install development headers
  174. #FIXME: we probably don't really need *.h but node-gyp downloads the whole
  175. #freaking source tree so I can't be sure ATM
  176. mkdir -p %{buildroot}%{_includedir}/node
  177. cp -p src/*.h %{buildroot}%{_includedir}/node
  178. #node-gyp needs common.gypi too
  179. mkdir -p %{buildroot}%{_datadir}/node
  180. cp -p common.gypi %{buildroot}%{_datadir}/node
  181. %files
  182. %doc ChangeLog LICENSE README.md AUTHORS
  183. %{_bindir}/node
  184. %{_bindir}/npm
  185. %{_mandir}/man1/node.*
  186. %dir %{_prefix}/lib/node_modules
  187. %{_prefix}/lib/node_modules/npm
  188. %files devel
  189. %{_bindir}/node_g
  190. %{_includedir}/node
  191. %{_datadir}/node
  192. %{_sysconfdir}/rpm/macros.nodejs
  193. %{_rpmconfigdir}/fileattrs/nodejs.attr
  194. %{_rpmconfigdir}/nodejs*
  195. %files docs
  196. #%{_defaultdocdir}/%{name}-docs-%{version}
  197. %doc LICENSE
  198. %changelog
  199. * Mon Mar 24 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.26-1
  200. - update to 0.10.26
  201. * Thu May 02 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.5-1
  202. - update to 0.10.5
  203. - fix deps
  204. * Fri Mar 15 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-2
  205. - build with internal openssl on Vine Linux 6
  206. * Wed Mar 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-1
  207. - update to 0.10.0
  208. * Mon Mar 11 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.5-1
  209. - initial build for Vine Linux
  210. - include npm
  211. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.5-11
  212. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  213. * Tue Jan 22 2013 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.9.5-10
  214. - minor bugfixes to RPM magic
  215. - nodejs-symlink-deps: don't create an empty node_modules dir when a module
  216. has no dependencies
  217. - nodes-fixdep: support adding deps when none exist
  218. - Add the full set of headers usually bundled with node as deps to nodejs-devel.
  219. This way `npm install` for native modules that assume the stuff bundled with
  220. node exists will usually "just work".
  221. -move RPM magic to nodejs-devel as requested by FPC
  222. * Sat Jan 12 2013 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.9.5-9
  223. - fix brown paper bag bug in requires generation script
  224. * Thu Jan 10 2013 Stephen Gallagher <sgallagh@redhat.com> - 0.9.5-8
  225. - Build debug binary and install it in the nodejs-devel subpackage
  226. * Thu Jan 10 2013 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.9.5-7
  227. - don't use make install since it rebuilds everything
  228. * Thu Jan 10 2013 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.9.5-6
  229. - add %%{?isa}, epoch to v8 deps
  230. * Wed Jan 09 2013 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.9.5-5
  231. - add defines to match libuv (#892601)
  232. - make v8 dependency explicit (and thus more accurate)
  233. - add -g to $C(XX)FLAGS instead of patching configure to add it
  234. - don't write pointless 'npm(foo) > 0' deps
  235. * Sat Jan 05 2013 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.9.5-4
  236. - install development headers
  237. - add nodejs_sitearch macro
  238. * Wed Jan 02 2013 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.9.5-3
  239. - make nodejs-symlink-deps actually work
  240. * Tue Jan 01 2013 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.9.5-2
  241. - provide nodejs-devel so modules can BuildRequire it (and be consistent
  242. with other interpreted languages in the distro)
  243. * Tue Jan 01 2013 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.9.5-1
  244. - new upstream release 0.9.5
  245. - provide nodejs-devel for the moment
  246. - fix minor bugs in RPM magic
  247. - add nodejs_fixdep macro so packagers can easily adjust dependencies in
  248. package.json files
  249. * Wed Dec 26 2012 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.9.4-1
  250. - new upstream release 0.9.4
  251. - system library patches are now upstream
  252. - respect optflags
  253. - include documentation in subpackage
  254. - add RPM dependency generation and related magic
  255. - guard libuv depedency so it always gets bumped when nodejs does
  256. - add -devel subpackage with enough to make node-gyp happy
  257. * Wed Dec 19 2012 Dan Horák <dan[at]danny.cz> - 0.9.3-8
  258. - set exclusive arch list to match v8
  259. * Tue Dec 18 2012 Stephen Gallagher <sgallagh@redhat.com> - 0.9.3-7
  260. - Add remaining changes from code review
  261. - Remove unnecessary BuildRequires on findutils
  262. - Remove %%clean section
  263. * Fri Dec 14 2012 Stephen Gallagher <sgallagh@redhat.com> - 0.9.3-6
  264. - Fixes from code review
  265. - Fix executable permissions
  266. - Correct the License field
  267. - Build debuginfo properly
  268. * Thu Dec 13 2012 Stephen Gallagher <sgallagh@redhat.com> - 0.9.3-5
  269. - Return back to using the standard binary name
  270. - Temporarily adding a conflict against the ham radio node package until they
  271. complete an agreed rename of their binary.
  272. * Wed Nov 28 2012 Stephen Gallagher <sgallagh@redhat.com> - 0.9.3-4
  273. - Rename binary and manpage to nodejs
  274. * Mon Nov 19 2012 Stephen Gallagher <sgallagh@redhat.com> - 0.9.3-3
  275. - Update to latest upstream development release 0.9.3
  276. - Include upstreamed patches to unbundle dependent libraries
  277. * Tue Oct 23 2012 Adrian Alves <alvesadrian@fedoraproject.org> 0.8.12-1
  278. - Fixes and Patches suggested by Matthias Runge
  279. * Mon Apr 09 2012 Adrian Alves <alvesadrian@fedoraproject.org> 0.6.5
  280. - First build.