nghttp2-vl.spec 6.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213
  1. %bcond_with test
  2. Summary: Experimental HTTP/2 client, server and proxy
  3. Summary(ja): HTTP/2クライアント・サーバ・プロキシの実験的実装
  4. Name: nghttp2
  5. Version: 1.12.0
  6. Release: 1%{?_dist_release}
  7. License: MIT
  8. Group: Applications/Internet
  9. URL: https://nghttp2.org/
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Source0: https://github.com/tatsuhiro-t/nghttp2/releases/download/v%{version}/nghttp2-%{version}.tar.xz
  13. %if %{with test}
  14. BuildRequires: CUnit-devel
  15. %endif
  16. BuildRequires: jemalloc-devel
  17. BuildRequires: libboost-devel
  18. BuildRequires: libboost-thread
  19. BuildRequires: libev-devel
  20. BuildRequires: openssl-devel
  21. BuildRequires: zlib-devel
  22. Requires: libnghttp2 = %{version}-%{release}
  23. %description
  24. This package contains the HTTP/2 client, server and proxy programs.
  25. %description -l ja
  26. This package contains the HTTP/2 client, server and proxy programs.
  27.  このパッケージにはHTTP/2クライアント・サーバ。プロキシのプログラム
  28. が含まれています。
  29. %package -n libnghttp2
  30. Summary: A library implementing the HTTP/2 protocol
  31. Summary(ja): HTTP/2ライブラリ
  32. Group: Development/Libraries
  33. %description -n libnghttp2
  34. libnghttp2 is a library implementing the Hypertext Transfer Protocol
  35. version 2 (HTTP/2) protocol in C.
  36. %description -l ja -n libnghttp2
  37.  libnghttp2はHypertext Transfer Protocol version 2 (HTTP/2)をC言語で
  38. 実装したライブラリです。
  39. %package -n libnghttp2-devel
  40. Summary: Files needed for building applications with libnghttp2
  41. Summary(ja): libnghttp2を利用するアプリケーションをビルドするために必要なファイル
  42. Group: Development/Libraries
  43. Requires: libnghttp2%{?_isa} = %{version}-%{release}
  44. Requires: pkgconfig
  45. %description -n libnghttp2-devel
  46. The libnghttp2-devel package includes libraries and header files needed
  47. for building applications with libnghttp2.
  48. %description -l ja -n libnghttp2-devel
  49.  libnghttp2-develパッケージにはlibnghttp2を利用するアプリケーション
  50. をビルドするために必要となるライブラリ・ヘッダファイルが含まれていま
  51. す。
  52. %prep
  53. %setup -q
  54. %build
  55. LIBEV_CFLAGS=`pkg-config --cflags libev`
  56. CFLAGS="%{optflags} -fPIC $LIBEV_CFLAGS" \
  57. CXXFLAGS="%{optflags} -fPIC $LIBEV_CFLAGS" \
  58. %configure \
  59. --enable-app \
  60. --enable-asio-lib \
  61. --with-pic \
  62. --with-boost \
  63. --with-boost-asio \
  64. --with-boost-system \
  65. --with-boost-thread \
  66. --disable-python-bindings \
  67. --disable-static \
  68. --without-libxml2 \
  69. --without-spdylay
  70. # avoid using rpath
  71. sed -i libtool \
  72. -e 's/^runpath_var=.*/runpath_var=/' \
  73. -e 's/^hardcode_libdir_flag_spec=".*"$/hardcode_libdir_flag_spec=""/'
  74. make %{?_smp_mflags} V=1
  75. %install
  76. %make_install
  77. # not needed on Fedora/RHEL
  78. rm -f $RPM_BUILD_ROOT%{_libdir}/libnghttp2*.la
  79. # will be installed via %%doc
  80. rm -f "$RPM_BUILD_ROOT%{_datadir}/doc/nghttp2/README.rst"
  81. %post -n libnghttp2 -p /sbin/ldconfig
  82. %postun -n libnghttp2 -p /sbin/ldconfig
  83. %check
  84. %if %{with test}
  85. # test the just built library instead of the system one, without using rpath
  86. export "LD_LIBRARY_PATH=$RPM_BUILD_ROOT%{_libdir}:$LD_LIBRARY_PATH"
  87. make %{?_smp_mflags} check
  88. %endif
  89. %files
  90. %{_bindir}/h2load
  91. %{_bindir}/nghttp
  92. %{_bindir}/nghttpd
  93. %{_bindir}/nghttpx
  94. %{_datadir}/nghttp2
  95. %{_mandir}/man1/h2load.1*
  96. %{_mandir}/man1/nghttp.1*
  97. %{_mandir}/man1/nghttpd.1*
  98. %{_mandir}/man1/nghttpx.1*
  99. %files -n libnghttp2
  100. %{_libdir}/libnghttp2*.so.*
  101. %{!?_licensedir:%global license %%doc}
  102. %license COPYING
  103. %files -n libnghttp2-devel
  104. %{_includedir}/nghttp2
  105. %{_libdir}/pkgconfig/libnghttp2*.pc
  106. %{_libdir}/libnghttp2*.so
  107. %doc README.rst
  108. %changelog
  109. * Thu Jul 7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-1
  110. - new upstream release.
  111. * Tue Jun 7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.11.1-2
  112. - initial build for Vne Linux.
  113. * Sun May 29 2016 Kamil Dudka <kdudka@redhat.com> 1.11.1-1
  114. - update to the latest upstream release
  115. * Thu May 26 2016 Kamil Dudka <kdudka@redhat.com> 1.11.0-1
  116. - update to the latest upstream release
  117. * Mon Apr 25 2016 Kamil Dudka <kdudka@redhat.com> 1.10.0-1
  118. - update to the latest upstream release
  119. * Sun Apr 03 2016 Kamil Dudka <kdudka@redhat.com> 1.9.2-1
  120. - update to the latest upstream release
  121. * Tue Mar 29 2016 Kamil Dudka <kdudka@redhat.com> 1.9.1-1
  122. - update to the latest upstream release
  123. * Thu Feb 25 2016 Kamil Dudka <kdudka@redhat.com> 1.8.0-1
  124. - update to the latest upstream release
  125. * Thu Feb 11 2016 Kamil Dudka <kdudka@redhat.com> 1.7.1-1
  126. - update to the latest upstream release (fixes CVE-2016-1544)
  127. * Fri Feb 05 2016 Kamil Dudka <kdudka@redhat.com> 1.7.0-3
  128. - make the package compile with gcc-6
  129. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.0-2
  130. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  131. * Mon Jan 25 2016 Kamil Dudka <kdudka@redhat.com> 1.7.0-1
  132. - update to the latest upstream release
  133. * Fri Dec 25 2015 Kamil Dudka <kdudka@redhat.com> 1.6.0-1
  134. - update to the latest upstream release (fixes CVE-2015-8659)
  135. * Thu Nov 26 2015 Kamil Dudka <kdudka@redhat.com> 1.5.0-1
  136. - update to the latest upstream release
  137. * Mon Oct 26 2015 Kamil Dudka <kdudka@redhat.com> 1.4.0-1
  138. - update to the latest upstream release
  139. * Thu Sep 24 2015 Kamil Dudka <kdudka@redhat.com> 1.3.4-1
  140. - update to the latest upstream release
  141. * Wed Sep 23 2015 Kamil Dudka <kdudka@redhat.com> 1.3.3-1
  142. - update to the latest upstream release
  143. * Wed Sep 16 2015 Kamil Dudka <kdudka@redhat.com> 1.3.2-1
  144. - update to the latest upstream release
  145. * Mon Sep 14 2015 Kamil Dudka <kdudka@redhat.com> 1.3.1-1
  146. - update to the latest upstream release
  147. * Mon Aug 31 2015 Kamil Dudka <kdudka@redhat.com> 1.3.0-1
  148. - update to the latest upstream release
  149. * Mon Aug 17 2015 Kamil Dudka <kdudka@redhat.com> 1.2.1-1
  150. - update to the latest upstream release
  151. * Sun Aug 09 2015 Kamil Dudka <kdudka@redhat.com> 1.2.0-1
  152. - update to the latest upstream release
  153. * Wed Jul 15 2015 Kamil Dudka <kdudka@redhat.com> 1.1.1-1
  154. - update to the latest upstream release
  155. * Tue Jun 30 2015 Kamil Dudka <kdudka@redhat.com> 1.0.5-1
  156. - packaged for Fedora (#1237247)