mod_perl2-vl.spec 3.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106
  1. Summary: An embedded Perl interpreter for the Apache Web server Version 2
  2. Summary(ja): Apache2 Web サーバ用 組み込み Perl インタプリタ
  3. Name: mod_perl2
  4. Version: 2.0.5
  5. Release: 1%{?_dist_release}
  6. URL: http://perl.apache.org/
  7. Source0: http://perl.apache.org/dist/mod_perl-%{version}.tar.gz
  8. Source1: perl.conf
  9. Source2: filter-requires.sh
  10. Source3: filter-provides.sh
  11. License: The Apache Software License, Version 2.0
  12. Group: System Environment/Daemons
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: apache2-devel >= 2.0.51
  15. BuildRequires: perl >= 5.6.0
  16. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. %if %{?_dist_release} == "vl5" || %{?_dist_release} == "vl4"
  20. # Provide perl-specific find-{provides,requires}.
  21. %define __find_requires %{SOURCE2}
  22. %define __find_provides %{SOURCE3}
  23. %else
  24. %define __perl_requires %{SOURCE2}
  25. %endif
  26. %description
  27. Mod_perl incorporates a Perl interpreter into the Apache web server,
  28. so that the Apache web server can directly execute Perl code.
  29. Mod_perl links the Perl runtime library into the Apache web server and
  30. provides an object-oriented Perl interface for Apache's C language
  31. API. The end result is a quicker CGI script turnaround process, since
  32. no external Perl interpreter has to be started.
  33. Install mod_perl if you're installing the Apache web server and you'd
  34. like for it to directly incorporate a Perl interpreter.
  35. %prep
  36. %setup -q -n mod_perl-%{version}
  37. %build
  38. perl Makefile.PL PREFIX=%{buildroot}/usr \
  39. MP_APXS=%{_bindir}/apxs \
  40. INSTALLDIRS=vendor
  41. make
  42. %install
  43. rm -rf %{buildroot}
  44. %makeinstall \
  45. MODPERL_AP_INCLUDEDIR=%{buildroot}%{_includedir}/apache2 \
  46. MODPERL_AP_LIBEXECDIR=%{buildroot}%{_libdir}/apache2/modules
  47. install -d -m 755 %{buildroot}%{_sysconfdir}/apache2/conf.d
  48. install -p -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/apache2/conf.d/
  49. find %{buildroot} -type f -name perllocal.pod -exec rm -f {} ';'
  50. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  51. chmod -R u+w %{buildroot}/*
  52. %clean
  53. rm -rf %{buildroot}
  54. %files
  55. %defattr(-,root,root)
  56. %doc Changes INSTALL LICENSE README* STATUS SVN-MOVE docs
  57. %config(noreplace) %{_sysconfdir}/apache2/conf.d/*.conf
  58. %{_bindir}/*
  59. %{_mandir}/man3/*
  60. %{_includedir}/apache2/mod_perl*
  61. %{_includedir}/apache2/modperl*
  62. %{_libdir}/apache2/modules/mod_perl.so
  63. %{perl_vendorarch}/*.pm
  64. %{perl_vendorarch}/APR
  65. %{perl_vendorarch}/Apache
  66. %{perl_vendorarch}/Apache2
  67. %{perl_vendorarch}/Bundle
  68. %{perl_vendorarch}/ModPerl
  69. %{perl_vendorarch}/auto
  70. %changelog
  71. * Fri Sep 9 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.5-1
  72. - new upstream release
  73. - add Requires: perl:(MODULE_COMPAT_x.y.z)
  74. - update Requires filter routine
  75. - add Vendor and Distribution tags
  76. * Sun Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.4-2
  77. - rebuilt with openldap-2.4.16
  78. * Fri Jan 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.4-1
  79. - new upstream release
  80. - new versioning policy
  81. - add default config file (SOURCE1) and prov/req filters (SOURCE2/3)
  82. - install under vendor_perl dir instead of site_perl
  83. * Mon Sep 22 2003 IWAI, Masaharu <iwai@alib.jp> 1.99_09-0vl1
  84. - Initial build.