libmemcached-vl.spec 7.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263
  1. %bcond_with tests
  2. Name: libmemcached
  3. Summary: Client library and command line tools for memcached server
  4. Version: 1.0.18
  5. Release: 2%{?_dist_release}
  6. License: BSD
  7. Group: System Environment/Libraries
  8. URL: http://libmemcached.org/
  9. # Original sources:
  10. # http://launchpad.net/libmemcached/1.0/%{version}/+download/libmemcached-%{version}.tar.gz
  11. # The source tarball must be repackaged to remove the Hsieh hash
  12. # code, since the license is non-free. When upgrading, download the new
  13. # source tarball, and run "./strip-hsieh.sh <version>" to produce the
  14. # "-exhsieh" tarball.
  15. Source0: libmemcached-%{version}-exhsieh.tar.gz
  16. Source1: strip-hsieh.sh
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  18. BuildRequires: cyrus-sasl-devel
  19. BuildRequires: flex bison
  20. %if %{with tests}
  21. BuildRequires: memcached
  22. %endif
  23. BuildRequires: libevent-devel
  24. Vendor: Project Vine
  25. Distribution: Vine Linux
  26. Packager: tomop
  27. %description
  28. libmemcached is a C/C++ client library and tools for the memcached server
  29. (http://memcached.org/). It has been designed to be light on memory
  30. usage, and provide full access to server side methods.
  31. It also implements several command line tools:
  32. memcapable Checking a Memcached server capibilities and compatibility
  33. memcat Copy the value of a key to standard output
  34. memcp Copy data to a server
  35. memdump Dumping your server
  36. memerror Translate an error code to a string
  37. memexist Check for the existance of a key
  38. memflush Flush the contents of your servers
  39. memparse Parse an option string
  40. memping Test to see if a server is available.
  41. memrm Remove a key(s) from the server
  42. memslap Generate testing loads on a memcached cluster
  43. memstat Dump the stats of your servers to standard output
  44. memtouch Touches a key
  45. %package devel
  46. Summary: Header files and development libraries for %{name}
  47. Group: Development/Libraries
  48. Requires: %{name}%{?_isa} = %{version}-%{release}
  49. Requires: pkgconfig
  50. Requires: cyrus-sasl-devel%{?_isa}
  51. %description devel
  52. This package contains the header files and development libraries
  53. for %{name}. If you like to develop programs using %{name},
  54. you will need to install %{name}-devel.
  55. %prep
  56. %setup -q
  57. mkdir examples
  58. cp -p tests/*.{cc,h} examples/
  59. # Will be regenerated during build
  60. rm -f libmemcached/csl/{parser,scanner}.cc
  61. # Temporary fix for SASL detection
  62. sed -i -e s/ax_cv_sasl/ac_enable_sasl/ configure
  63. # fix library dependency
  64. # perl -pi -e 's/^(Libs:.+)$/$1 -lpthread/' ./support/libmemcached.pc.in
  65. %build
  66. aclocal
  67. autoconf
  68. automake --add-missing
  69. # option --with-memcached=false to disable server binary check (as we don't run test)
  70. %configure --disable-static \
  71. %if ! %{with tests}
  72. --with-memcached=false
  73. %endif
  74. make %{_smp_mflags}
  75. %install
  76. rm -rf %{buildroot}
  77. make install DESTDIR="%{buildroot}" AM_INSTALL_PROGRAM_FLAGS=""
  78. %check
  79. %if %{with tests}
  80. # test suite cannot run in mock (same port use for memcache servers on all arch)
  81. # All tests completed successfully
  82. # diff output.res output.cmp fails but result depend on server version
  83. make test
  84. %else
  85. echo 'Test suite disabled (missing "--with tests" option)'
  86. %endif
  87. %clean
  88. rm -rf %{buildroot}
  89. %post
  90. /sbin/ldconfig
  91. %postun
  92. /sbin/ldconfig
  93. %files
  94. %defattr (-,root,root,-)
  95. %doc AUTHORS COPYING README THANKS TODO ChangeLog
  96. %{_bindir}/mem*
  97. %exclude %{_libdir}/lib*.la
  98. %{_libdir}/lib*.so.*
  99. %{_mandir}/man1/mem*
  100. %files devel
  101. %defattr (-,root,root,-)
  102. %doc examples
  103. %{_datadir}/aclocal/ax_libmemcached.m4
  104. %{_includedir}/*
  105. %{_libdir}/lib*.so
  106. %{_libdir}/pkgconfig/libmemcached.pc
  107. %{_mandir}/man3/libmemcached*
  108. %{_mandir}/man3/libhashkit*
  109. %{_mandir}/man3/memcached*
  110. %{_mandir}/man3/hashkit*
  111. %changelog
  112. * Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.18-2
  113. - rebuild with gcc-5.4.0
  114. * Fri Apr 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.18-1
  115. - new upstream release.
  116. - removed all patches (fixed in upstream).
  117. * Sat Jan 18 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.17-1
  118. - new upstream release.
  119. * Thu May 03 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.7-2
  120. - built for Vine Linux.
  121. * Sun Apr 22 2012 Remi Collet <remi@fedoraproject.org> - 1.0.7-1
  122. - update to 1.0.7
  123. - regenerate parser using flex/bison (#816766)
  124. * Sun Apr 22 2012 Remi Collet <remi@fedoraproject.org> - 1.0.6-2
  125. - workaround for SASL detection
  126. * Sat Apr 21 2012 Remi Collet <remi@fedoraproject.org> - 1.0.6-1
  127. - update to 1.0.6
  128. - soname bump to libmemcached.so.10 and libhashkit.so.2
  129. * Sat Mar 03 2012 Remi Collet <remi@fedoraproject.org> - 1.0.4-1
  130. - update to 1.0.4
  131. - soname bump to libmemcached.so.9
  132. - update description
  133. * Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-3
  134. - Rebuilt for c++ ABI breakage
  135. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-2
  136. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  137. * Thu Oct 27 2011 Remi Collet <remi@fedoraproject.org> - 1.0.2-1
  138. - update to 1.0.2
  139. * Sun Oct 16 2011 Remi Collet <remi@fedoraproject.org> - 0.53-1
  140. - update to 0.53
  141. * Sat Sep 17 2011 Remi Collet <remi@fedoraproject.org> - 0.52-1
  142. - update to 0.52
  143. * Sun Jul 31 2011 Remi Collet <remi@fedoraproject.org> - 0.51-1
  144. - update to 0.51 (soname bump libmemcached.so.8)
  145. * Thu Jun 02 2011 Remi Collet <Fedora@famillecollet.com> - 0.49-1
  146. - update to 0.49
  147. - add build option : --with tests
  148. * Mon Feb 28 2011 Remi Collet <Fedora@famillecollet.com> - 0.47-1
  149. - update to 0.47
  150. - remove patch merged upstream
  151. * Sun Feb 20 2011 Remi Collet <Fedora@famillecollet.com> - 0.46-2
  152. - patch Makefile.in instead of include.am (to avoid autoconf)
  153. - donc requires pkgconfig with arch
  154. * Fri Feb 18 2011 Remi Collet <Fedora@famillecollet.com> - 0.46-1
  155. - update to 0.46
  156. * Sat Feb 12 2011 Remi Collet <Fedora@famillecollet.com> - 0.44-6
  157. - arch specific requires
  158. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.44-5
  159. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  160. * Wed Nov 24 2010 Joe Orton <jorton@redhat.com> - 0.44-4
  161. - repackage source tarball to remove non-free Hsieh hash code
  162. * Sat Oct 02 2010 Remi Collet <Fedora@famillecollet.com> - 0.44-3
  163. - improves SASL patch
  164. * Sat Oct 02 2010 Remi Collet <Fedora@famillecollet.com> - 0.44-2
  165. - enable SASL support
  166. * Fri Oct 01 2010 Remi Collet <Fedora@famillecollet.com> - 0.44-1
  167. - update to 0.44
  168. - add soname version in %%file to detect change
  169. * Fri Jul 30 2010 Remi Collet <Fedora@famillecollet.com> - 0.43-1
  170. - update to 0.43
  171. * Wed Jul 07 2010 Remi Collet <Fedora@famillecollet.com> - 0.42-1
  172. - update to 0.42
  173. * Tue May 04 2010 Remi Collet <Fedora@famillecollet.com> - 0.40-1
  174. - update to 0.40 (new soname for libmemcached.so.5)
  175. - new URI (site + source)
  176. * Sat Mar 13 2010 Remi Collet <Fedora@famillecollet.com> - 0.38-1
  177. - update to 0.38
  178. * Sat Feb 06 2010 Remi Collet <Fedora@famillecollet.com> - 0.37-1
  179. - update to 0.37 (soname bump)
  180. - new libhashkit (should be a separated project in the futur)
  181. * Sun Sep 13 2009 Remi Collet <Fedora@famillecollet.com> - 0.31-1
  182. - update to 0.31
  183. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.30-2
  184. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  185. * Sun Jun 14 2009 Remi Collet <Fedora@famillecollet.com> - 0.30-1
  186. - update to 0.30
  187. * Tue May 19 2009 Remi Collet <Fedora@famillecollet.com> - 0.29-1
  188. - update to 0.29
  189. * Fri May 01 2009 Remi Collet <Fedora@famillecollet.com> - 0.28-2
  190. - add upstream patch to disable nonfree hsieh hash method
  191. * Sat Apr 25 2009 Remi Collet <Fedora@famillecollet.com> - 0.28-1
  192. - Initial RPM from Brian Aker spec
  193. - create -devel subpackage
  194. - add %%post %%postun %%check section