linux-igd-vl.spec 2.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586
  1. %define name linux-igd
  2. %define source_name linuxigd
  3. %define version 1.0
  4. %define release 3%{?_dist_release}
  5. Summary: The Linux UPNP Internet GATEWAY DEVICE
  6. Summary(ja): ユニバーサルプラグアンドプレイゲートウェイデバイス
  7. Name: %{name}
  8. Version: %{version}
  9. Release: %{release}
  10. Source0: %{source_name}-%{version}.tar.gz
  11. Patch0: %{source_name}-%{version}.patch
  12. Patch1: linux-igd-include.patch
  13. License: GPL
  14. Group: System Environment/Daemons
  15. URL: http://linux-igd.sourceforge.net/
  16. Vendor: Project Vine
  17. Distribution: Vine Linux
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: libupnp-devel >= 1.3.1
  20. Requires: libupnp >= 1.3.1
  21. %description
  22. This is a deamon that emulates Microsoft's Internet Connection Service (ICS).
  23. It implements the UPnP Internet Gateway Device specification (IGD) and allows UPnP aware clients, such as MSN Messenger to work properly from behind a Linux NAT firewall.
  24. %prep
  25. %setup -q -n %{source_name}-%{version}
  26. %patch0 -p1
  27. %patch1 -p1
  28. %build
  29. %{__make}
  30. %install
  31. %{__rm} -rf ${RPM_BUILD_ROOT}
  32. %{__make} install DESTDIR="${RPM_BUILD_ROOT}"
  33. %post
  34. if [ $1 = 1 ] ; then
  35. /sbin/chkconfig --add upnpd
  36. fi
  37. %preun
  38. if [ $1 = 0 ] ; then
  39. /etc/rc.d/init.d/upnpd stop
  40. /sbin/chkconfig --del upnpd
  41. fi
  42. %clean
  43. %__rm -rf ${RPM_BUILD_ROOT}
  44. %files
  45. %defattr(-, root, root)
  46. %doc CHANGES LICENSE doc/config_options
  47. %dir %{_sysconfdir}/linuxigd/
  48. %attr(0644, root, root) %{_sysconfdir}/linuxigd/*.xml
  49. %{_sbindir}/upnpd
  50. %{_mandir}/man8/upnpd.8.gz
  51. %attr(0644, root, root) %config %{_sysconfdir}/upnpd.conf
  52. %attr(0755, root, root) %{_sysconfdir}/rc.d/init.d/upnpd
  53. %attr(0644, root, root) %config %{_sysconfdir}/sysconfig/upnpd
  54. %changelog
  55. * Mon Jan 13 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0-3
  56. - rebuilt with current environment.
  57. * Tue May 01 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0-2
  58. - rebuilt with current environment.
  59. - added Patch1.
  60. * Sun Mar 1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0-1vl5
  61. - applied new versioning policy, spec in UTF-8
  62. - fixed Group tag
  63. - added files to %%doc section
  64. * Thu Feb 14 2008 Masahiro INOUE <miyabi.-.inoue@nifty.com> 1.0
  65. - initial build for Vine Linux
  66. * Mon Aug 14 2006 Tim Brody <tdb01r@ecs.soton.ac.uk>
  67. - Version 0.95 Release 1
  68. - first build for version 0.95 (Release)
  69. * Sun Sep 26 2004 Watanabe Keiji <k@elt.ne.jp>
  70. - Version 0.99 Release ELT1
  71. - first build for version 0.92 (CVS Version on Sep 25, 2004.)