korundum-vl.spec 8.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277
  1. %global ruby_vendorlib %(ruby -rrbconfig -e 'puts RbConfig::CONFIG["vendorlibdir"]')
  2. %global ruby_vendorarch %(ruby -rrbconfig -e 'puts RbConfig::CONFIG["vendorarchdir"]')
  3. Name: korundum
  4. Summary: Ruby bindings for KDE
  5. Summary(ja): KDE の Ruby バインディング
  6. Version: 4.14.3
  7. Release: 3%{?_dist_release}
  8. License: LGPLv2+ and GPLv2+
  9. Group: System Environment/Libraries
  10. URL: https://techbase.kde.org/Development/Languages/Ruby
  11. Source0: http://download.kde.org/stable/%{version}/src/%{name}-%{version}.tar.xz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: cmake
  14. BuildRequires: akonadi-devel
  15. BuildRequires: kate-devel >= %{version}
  16. BuildRequires: kdelibs4-devel >= %{version}
  17. BuildRequires: kdepimlibs-devel >= %{version}
  18. BuildRequires: okular-devel >= %{version}
  19. BuildRequires: QtRuby-devel >= %{version}
  20. BuildRequires: ruby-devel >= 1.8
  21. BuildRequires: shared-desktop-ontologies-devel
  22. BuildRequires: smokekde-devel >= %{version}
  23. BuildRequires: smokeqt-devel >= %{version}
  24. BuildRequires: soprano-devel
  25. Requires: QtRuby >= %{version}
  26. Requires: smokekde >= %{version}
  27. Requires: smokeqt >= %{version}
  28. %description
  29. %{summary}.
  30. %package devel
  31. Summary: Development libraries for %{name}
  32. Summary(ja): %{name} の開発用ファイル
  33. Group: Development/Libraries
  34. Requires: %{name} = %{version}-%{release}
  35. %description devel
  36. %{summary}.
  37. %prep
  38. %setup -q
  39. %build
  40. mkdir -p %{_target_platform}
  41. pushd %{_target_platform}
  42. %cmake \
  43. -DCMAKE_BUILD_TYPE=release \
  44. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  45. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  46. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  47. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  48. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  49. -DCUSTOM_RUBY_SITE_ARCH_DIR:PATH=%{ruby_vendorarch} \
  50. -DCUSTOM_RUBY_SITE_LIB_DIR:PATH=%{ruby_vendorlib} \
  51. ..
  52. popd
  53. make %{?_smp_mflags} -C %{_target_platform}
  54. %install
  55. rm -rf $RPM_BUILD_ROOT
  56. make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
  57. %post -p /sbin/ldconfig
  58. %postun -p /sbin/ldconfig
  59. %clean
  60. rm -rf $RPM_BUILD_ROOT
  61. %files
  62. %defattr(-,root,root,-)
  63. %doc AUTHORS COPYING COPYING.LIB README
  64. %{_bindir}/krubyapplication
  65. %{ruby_vendorlib}/KDE/
  66. %{ruby_vendorlib}/akonadi/
  67. %{ruby_vendorlib}/khtml/
  68. %{ruby_vendorlib}/kio/
  69. %{ruby_vendorlib}/ktexteditor/
  70. %{ruby_vendorlib}/okular/
  71. %{ruby_vendorlib}/solid/
  72. %{ruby_vendorlib}/soprano/
  73. %{ruby_vendorlib}/nepomuk/
  74. %{ruby_vendorarch}/akonadi.so
  75. %{ruby_vendorarch}/kate.so
  76. %{ruby_vendorarch}/khtml.so
  77. %{ruby_vendorarch}/kio.so
  78. %{ruby_vendorarch}/korundum4.so
  79. %{ruby_vendorarch}/ktexteditor.so
  80. %{ruby_vendorarch}/okular.so
  81. %{ruby_vendorarch}/plasma_applet.so
  82. %{ruby_vendorarch}/solid.so
  83. %{ruby_vendorarch}/soprano.so
  84. %{ruby_vendorarch}/nepomuk.so
  85. %{_libdir}/kde4/krubypluginfactory.so
  86. %{_datadir}/applications/kde4/dbpedia_references.desktop
  87. %{_datadir}/kde4/apps/dbpedia_references
  88. %{_datadir}/kde4/apps/plasma_applet_ruby_clock/
  89. %{_datadir}/kde4/apps/plasma_ruby_digital_clock/
  90. %{_datadir}/kde4/services/*.desktop
  91. %files devel
  92. %defattr(-,root,root,-)
  93. %{_bindir}/rbkconfig_compiler4
  94. %changelog
  95. * Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-3
  96. - rebuild with gcc-5.4.0
  97. * Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-2
  98. - rebuild with ruby-2.2.3
  99. * Sun Jan 11 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.14.3-1
  100. - updated to 4.14.3
  101. - built with okluar-libs 4.14.3
  102. * Wed Nov 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.12.5-2
  103. - installed modules to vendor_ruby
  104. * Sun Nov 9 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.12.5-1
  105. - splitted from kdebindings
  106. * Thu Jun 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
  107. - new upstream release
  108. * Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
  109. - updated to 4.6.1
  110. - added BR: kdesdk-devel
  111. - disabled attica plugins temporaly
  112. - rebuilt with mono-2.10.1
  113. * Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-2
  114. - rebuilt with rpm-4.8.1 for pkg-config
  115. * Sat Sep 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-1
  116. - new upstream release
  117. - added Patch50
  118. - added more japanese summaries
  119. * Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
  120. - new upstream release
  121. * Sun Jul 4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
  122. - new upstream release
  123. * Fri May 7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
  124. - new upstream release
  125. * Thu Apr 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
  126. - new upstream release
  127. * Tue Mar 9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
  128. - new upstream release
  129. - added -DCMAKE_SKIP_RPATH:BOOL=OFF option to cmake
  130. (see https://bugs.kde.org/show_bug.cgi?id=214824)
  131. - built with new toolchain
  132. * Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
  133. - new upstream release
  134. * Thu Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-4
  135. - merged 4.3.1-2 %changelog
  136. - re-define %%{mono_dir} to %{_prefix}/lib/mono (again)
  137. * Tue Oct 27 2009 Shu KONNO <owa@bg.wakwak.com> 4.3.2-3
  138. - use %%{_prefix}/lib for mono-dll (for x86_64)
  139. * Tue Oct 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-2
  140. - new upstream release
  141. - built with PyQt4-4.6
  142. * Sun Sep 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> 4.3.1-2
  143. - define %%{mono_dir} to specify mono library install path
  144. * Sun Sep 6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
  145. - new upstream release
  146. - fixed ruby modules installation path
  147. * Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
  148. - new upstream release
  149. - spilt sub package based on Fedora
  150. * Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
  151. - applied new versioning policy
  152. - added Patch1
  153. (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=484191)
  154. * Fri Nov 23 2007 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.8-0vl3
  155. - added --with-qt-libraries option
  156. * Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
  157. - rebuild for VineSeed
  158. * Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
  159. - new upstream release
  160. * Mon Jun 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
  161. - rebuild for VineSeed
  162. * Thu May 31 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
  163. - new upstream release
  164. - update Patch0
  165. - drop Patch1
  166. * Mon Jan 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
  167. - new upstream release
  168. - add Patch1
  169. - add --enable-libsuffix option
  170. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
  171. - rebuild for VineSeed
  172. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
  173. - new upstream release
  174. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
  175. - rebuild for VineSeed
  176. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
  177. - new upstream release
  178. * Thu Jun 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
  179. - rebuild for VineSeed
  180. * Thu Jun 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
  181. - new upstream release
  182. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
  183. - rebuild for VineSeed
  184. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
  185. - new upstream release
  186. * Wed Feb 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
  187. - rebuild for VineSeed
  188. * Wed Feb 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
  189. - new upstream release
  190. - renew BuildPrereq and build section
  191. - renew %%files
  192. - enable python
  193. - change spec to make main and devel package
  194. - add BuildPrereq: ruby ruby-devel
  195. - add Patch0 to install ruby-bindings under /usr/lib/ruby
  196. * Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
  197. - build for VineSeed
  198. - disable python and mozilla
  199. - objprelink (i386 only)
  200. * Wed Nov 21 2001 Than Ngo <than@redhat.com> <bero@redhat.com> 2.2.2-1
  201. - 2.2.2
  202. - build kmozilla binding only on x86/alpha
  203. * Thu Aug 9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-2
  204. - Make sure %%{name}-kmozilla isn't built on ia64
  205. * Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010723.2
  206. - Move python bindings to separate package
  207. - Add perl bindings
  208. - Shut up rpmlint
  209. * Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  210. - 2.1
  211. * Sun Jan 28 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  212. - initial RPM