kimono-vl.spec 7.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269
  1. %global monodir %{_prefix}/lib/mono
  2. %global _kde4_version 4.14.3
  3. Name: kimono
  4. Summary: .NET/Mono KDE bindings
  5. Summary(ja): KDE の .NET/Mono バインディング
  6. Version: 4.14.3
  7. Release: 3%{?_dist_release}
  8. # most items are pure GPLv2+
  9. # plasma bindings mix LGPLv2+ and GPLv2+ (combined result is GPLv2+ too)
  10. License: GPLv2+
  11. Group: System Environment/Libraries
  12. URL: https://projects.kde.org/projects/kde/kdebindings/csharp/kimono
  13. Source0: http://download.kde.org/stable/%{version}/src/%{name}-%{version}.tar.xz
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: kdelibs4-devel >= %{version}
  16. BuildRequires: kdepimlibs-devel >= %{version}
  17. BuildRequires: nepomuk-core-devel
  18. BuildRequires: soprano-devel
  19. BuildRequires: akonadi-devel
  20. BuildRequires: mono-devel
  21. BuildRequires: monodoc
  22. BuildRequires: qyoto-devel >= %{version}
  23. BuildRequires: smokekde-devel >= %{version}
  24. Requires: qyoto >= %{_kde4_version}
  25. Requires: smokekde >= %{_kde4_version}
  26. %{?mono_arches:ExclusiveArch: %{mono_arches}}
  27. %description
  28. %{summary}.
  29. %package akonadi
  30. Summary: Akonadi runtime support for %{name}
  31. Summary(ja): %{name} の Akonadi ランタイムサポート
  32. Group: System Environment/Libraries
  33. Requires: %{name} = %{version}-%{release}
  34. Requires: smokekde-akonadi >= %{version}
  35. %description akonadi
  36. %{summary}.
  37. %prep
  38. %setup -q
  39. %build
  40. mkdir -p %{_target_platform}
  41. pushd %{_target_platform}
  42. %cmake \
  43. -DCMAKE_BUILD_TYPE=release \
  44. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  45. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  46. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  47. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  48. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  49. ..
  50. popd
  51. make %{?_smp_mflags} -C %{_target_platform}
  52. %install
  53. rm -rf $RPM_BUILD_ROOT
  54. make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
  55. %clean
  56. rm -rf $RPM_BUILD_ROOT
  57. %post -p /sbin/ldconfig
  58. %postun -p /sbin/ldconfig
  59. %files
  60. %defattr(-,root,root,-)
  61. %doc ChangeLog COPYING.GPLv2 COPYING.LGPLv2
  62. %{_libdir}/kde4/kimonopluginfactory.so
  63. %{_libdir}/libkhtml-sharp.so
  64. %{_libdir}/libkimono.so
  65. %{_libdir}/libktexteditor-sharp.so
  66. %{_libdir}/libnepomuk-sharp.so
  67. %{_libdir}/libplasma-sharp.so
  68. %{_libdir}/libsoprano-sharp.so
  69. %{monodir}/qyoto/kde-dotnet.dll
  70. %{monodir}/qyoto/khtml-dll.dll
  71. %{monodir}/qyoto/ktexteditor-dotnet.dll
  72. %{monodir}/qyoto/nepomuk-dll.dll
  73. %{monodir}/qyoto/plasma-dll.dll
  74. %{monodir}/qyoto/soprano.dll
  75. %{monodir}/gac/kde-dotnet/
  76. %{monodir}/gac/khtml-dll/
  77. %{monodir}/gac/ktexteditor-dotnet/
  78. %{monodir}/gac/nepomuk-dll/
  79. %{monodir}/gac/plasma-dll/
  80. %{monodir}/gac/soprano/
  81. %{_datadir}/kde4/apps/plasma_scriptengine_kimono/
  82. %{_datadir}/kde4/services/plasma-scriptengine-kimono-applet.desktop
  83. %{_datadir}/kde4/services/plasma-scriptengine-kimono-dataengine.desktop
  84. %files akonadi
  85. %defattr(-,root,root,-)
  86. %{_libdir}/libakonadi-sharp.so
  87. %{monodir}/qyoto/akonadi.dll
  88. %{monodir}/gac/akonadi/
  89. %changelog
  90. * Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-3
  91. - rebuild with gcc-5.4.0
  92. * Sat Mar 28 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.14.3-2
  93. - rebuilt with mono 3.12.1
  94. * Sun Jan 11 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.14.3-1
  95. - updated to 4.14.3
  96. - added BR: nepomuk-devel and soprano-devel
  97. * Sun Nov 9 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.12.5-1
  98. - splitted from kdebindings
  99. * Thu Jun 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
  100. - new upstream release
  101. * Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
  102. - updated to 4.6.1
  103. - added BR: kdesdk-devel
  104. - disabled attica plugins temporaly
  105. - rebuilt with mono-2.10.1
  106. * Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-2
  107. - rebuilt with rpm-4.8.1 for pkg-config
  108. * Sat Sep 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-1
  109. - new upstream release
  110. - added Patch50
  111. - added more japanese summaries
  112. * Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
  113. - new upstream release
  114. * Sun Jul 4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
  115. - new upstream release
  116. * Fri May 7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
  117. - new upstream release
  118. * Thu Apr 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
  119. - new upstream release
  120. * Tue Mar 9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
  121. - new upstream release
  122. - added -DCMAKE_SKIP_RPATH:BOOL=OFF option to cmake
  123. (see https://bugs.kde.org/show_bug.cgi?id=214824)
  124. - built with new toolchain
  125. * Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
  126. - new upstream release
  127. * Thu Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-4
  128. - merged 4.3.1-2 %changelog
  129. - re-define %%{mono_dir} to %{_prefix}/lib/mono (again)
  130. * Tue Oct 27 2009 Shu KONNO <owa@bg.wakwak.com> 4.3.2-3
  131. - use %%{_prefix}/lib for mono-dll (for x86_64)
  132. * Tue Oct 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-2
  133. - new upstream release
  134. - built with PyQt4-4.6
  135. * Sun Sep 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> 4.3.1-2
  136. - define %%{mono_dir} to specify mono library install path
  137. * Sun Sep 6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
  138. - new upstream release
  139. - fixed ruby modules installation path
  140. * Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
  141. - new upstream release
  142. - spilt sub package based on Fedora
  143. * Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
  144. - applied new versioning policy
  145. - added Patch1
  146. (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=484191)
  147. * Fri Nov 23 2007 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.8-0vl3
  148. - added --with-qt-libraries option
  149. * Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
  150. - rebuild for VineSeed
  151. * Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
  152. - new upstream release
  153. * Mon Jun 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
  154. - rebuild for VineSeed
  155. * Thu May 31 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
  156. - new upstream release
  157. - update Patch0
  158. - drop Patch1
  159. * Mon Jan 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
  160. - new upstream release
  161. - add Patch1
  162. - add --enable-libsuffix option
  163. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
  164. - rebuild for VineSeed
  165. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
  166. - new upstream release
  167. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
  168. - rebuild for VineSeed
  169. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
  170. - new upstream release
  171. * Thu Jun 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
  172. - rebuild for VineSeed
  173. * Thu Jun 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
  174. - new upstream release
  175. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
  176. - rebuild for VineSeed
  177. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
  178. - new upstream release
  179. * Wed Feb 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
  180. - rebuild for VineSeed
  181. * Wed Feb 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
  182. - new upstream release
  183. - renew BuildPrereq and build section
  184. - renew %%files
  185. - enable python
  186. - change spec to make main and devel package
  187. - add BuildPrereq: ruby ruby-devel
  188. - add Patch0 to install ruby-bindings under /usr/lib/ruby
  189. * Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
  190. - build for VineSeed
  191. - disable python and mozilla
  192. - objprelink (i386 only)
  193. * Wed Nov 21 2001 Than Ngo <than@redhat.com> <bero@redhat.com> 2.2.2-1
  194. - 2.2.2
  195. - build kmozilla binding only on x86/alpha
  196. * Thu Aug 9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-2
  197. - Make sure %%{name}-kmozilla isn't built on ia64
  198. * Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010723.2
  199. - Move python bindings to separate package
  200. - Add perl bindings
  201. - Shut up rpmlint
  202. * Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  203. - 2.1
  204. * Sun Jan 28 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  205. - initial RPM