kde-partitionmanager-vl.spec 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145
  1. Name: kde-partitionmanager
  2. Summary: KDE Partition Manager
  3. Summary(ja): KDE パーティションマネージャ
  4. Version: 1.0.3
  5. Release: 4%{?_dist_release}
  6. Group: Applications/Administration
  7. License: GPLv2+
  8. URL: http://partitionman.sourceforge.net/
  9. Source0: http://downloads.sourceforge.net/project/partitionman/partitionmanager/1.0.3/partitionmanager-%{version}.tar.bz2
  10. Patch0: partitionmanager-1.0.3-r1263692.patch
  11. ## upstreamable patches
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: kdelibs4-devel
  14. BuildRequires: parted-devel
  15. BuildRequires: e2fsprogs-devel
  16. %if %{?_dist_release} !="vl5"
  17. BuildRequires: libuuid-devel
  18. BuildRequires: libblkid-devel
  19. BuildRequires: libatasmart-devel
  20. %endif
  21. BuildRequires: pkgconfig
  22. BuildRequires: gettext
  23. BuildRequires: cmake
  24. Requires: parted
  25. Requires: e2fsprogs
  26. %global kde4_version %((kde4-config --version 2>/dev/null || echo "KDE 4.4.5") | grep ^KDE | cut -d' ' -f2)
  27. #{?_kde4_macros_api:Requires: kde4-macros(api) = %{_kde4_macros_api} }
  28. %description
  29. KDE Partition Manager is a utility program to help you manage the disk devices,
  30. partitions and file systems on your computer. It allows you to easily create,
  31. copy, move, delete, resize without losing data, backup and restore partitions.
  32. KDE Partition Manager supports a large number of file systems,
  33. including ext2/3/4, reiserfs, NTFS, FAT16/32, jfs, xfs and more.
  34. It makes use of external programs to get its job done, so you might have to
  35. install additional software (preferably packages from your distribution)
  36. to make use of all features and get full support for all file systems.
  37. %prep
  38. %setup -q -n partitionmanager-%{version}
  39. %patch0 -p1
  40. ## Due to the name change
  41. mv src/partitionmanager.desktop src/kde-partitionmanager.desktop
  42. #mv src/kcm/kcm_partitionmanager.desktop src/kcm/kcm_kde-partitionmanager.desktop
  43. sed -i 's,partitionmanager.desktop,kde-partitionmanager.desktop,' src/CMakeLists.txt
  44. %build
  45. mkdir -p %{_target_platform}
  46. pushd %{_target_platform}
  47. %{cmake} \
  48. -DCMAKE_BUILD_TYPE=release \
  49. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  50. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  51. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  52. ..
  53. popd
  54. make %{?_smp_mflags} -C %{_target_platform}
  55. %install
  56. rm -rf %{buildroot}
  57. make install/fast -C %{_target_platform} DESTDIR=%{buildroot}
  58. %find_lang partitionmanager --with-kde
  59. %check
  60. desktop-file-validate %{buildroot}%{_datadir}/applications/kde4/%{name}.desktop
  61. %clean
  62. rm -rf %{buildroot}
  63. %post
  64. touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
  65. %posttrans
  66. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  67. %postun
  68. if [ $1 -eq 0 ] ; then
  69. touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
  70. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  71. fi
  72. %files -f partitionmanager.lang
  73. %defattr(-,root,root,-)
  74. %doc README COPYING CHANGES
  75. %{_bindir}/partitionmanager*
  76. %{_libdir}/*.so
  77. %{_libdir}/kde4/pmlibpartedbackendplugin.so
  78. %{_datadir}/applications/kde4/%{name}.desktop
  79. %{_datadir}/icons/hicolor/*/*/*.png
  80. %{_datadir}/kde4/apps/partitionmanager
  81. %{_datadir}/kde4/services/pmlibpartedbackendplugin.desktop
  82. %{_datadir}/kde4/servicetypes/pmcorebackendplugin.desktop
  83. ## %{_kde4_datadir}/kde4/services/kcm_kde-partitionmanager.desktop
  84. %changelog
  85. * Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-4
  86. - rebuild with gcc-5.4.0
  87. * Sun Jul 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-3
  88. - rebuild with parted-3.1
  89. * Fri Jan 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-2
  90. - add Patch0 (partitionmanager-1.0.3-r1263692.patch)
  91. - add BuildRequires: libatasmart-devel
  92. * Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-1
  93. - new upstream release
  94. * Fri Jul 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-3
  95. - disabled BR: libuuid-devel, libblkid-devel on Vine Linux 5
  96. * Mon Jul 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-2
  97. - Initial build for Vine Linux
  98. * Tue May 18 2010 Thomas Janssen <thomasj@fedoraproject.org> 1.0.2-1
  99. - bugfix release
  100. * Wed Mar 31 2010 Thomas Janssen <thomasj@fedoraproject.org> 1.0.1-1%{?dist}.2
  101. - rebuild for new parted
  102. * Sun Feb 14 2010 Thomas Janssen <thomasj@fedoraproject.org> 1.0.1-1%{?dist}.1
  103. - DSO fix for rawhide
  104. * Mon Jan 25 2010 Thomas Janssen <thomasj@fedoraproject.org> 1.0.1-1
  105. - New upstream source
  106. * Wed Nov 18 2009 Thomas Janssen <thomasj@fedoraproject.org> 1.0.0-2
  107. - Moved desktop-file-validate to %%install
  108. - Removed superfluous BR qt4-devel
  109. * Wed Nov 18 2009 Thomas Janssen <thomasj@fedoraproject.org> 1.0.0-1
  110. - Initial Fedora release