jemalloc-vl.spec 8.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262
  1. Name: jemalloc
  2. Version: 4.2.1
  3. Release: 1%{?_dist_release}
  4. Summary: General-purpose scalable concurrent malloc implementation
  5. Summary(ja): 汎用・スケーラブル・並行な malloc 実装
  6. Group: System Environment/Libraries
  7. License: BSD
  8. URL: http://www.canonware.com/jemalloc/
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. Source0: https://github.com/jemalloc/%{name}/releases/download/%{version}/%{name}-%{version}.tar.bz2
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  13. # ARMv5tel has no atomic operations
  14. Patch2: jemalloc-armv5-force-atomic.patch
  15. # RHEL5/POWER has no atomic operations
  16. Patch3: jemalloc-3.0.0.atomic_h_ppc_32bit_operations.patch
  17. Patch4: jemalloc-3.6.0.no_explicit_altivec.patch
  18. BuildRequires: /usr/bin/xsltproc
  19. %ifnarch s390
  20. BuildRequires: valgrind-devel
  21. %endif
  22. %description
  23. General-purpose scalable concurrent malloc(3) implementation.
  24. This distribution is the stand-alone "portable" implementation of %{name}.
  25. %package devel
  26. Summary: Development files for %{name}
  27. Requires: %{name} = %{version}-%{release}
  28. Group: Development/Libraries
  29. %description devel
  30. The %{name}-devel package contains libraries and header files for
  31. developing applications that use %{name}.
  32. %prep
  33. %setup -q
  34. #% patch2 -p1 -b .armv5tel
  35. %ifarch ppc ppc64
  36. %if 0%{?rhel} == 5
  37. %patch3 -b .ppc
  38. %patch4 -b .ppc
  39. %endif
  40. %endif
  41. %build
  42. %ifarch i686
  43. %if 0%{?fedora} >= 21
  44. CFLAGS="%{optflags} -msse2"
  45. %endif
  46. %endif
  47. %if 0%{?rhel} && 0%{?rhel} < 7
  48. export LDFLAGS="%{?__global_ldflags} -lrt"
  49. %endif
  50. %configure
  51. make %{?_smp_mflags}
  52. %check
  53. make check
  54. %install
  55. rm -rf %{buildroot}
  56. make install DESTDIR=%{buildroot}
  57. # Install this with doc macro instead
  58. rm %{buildroot}%{_datadir}/doc/%{name}/jemalloc.html
  59. # None of these in fedora
  60. find %{buildroot}%{_libdir}/ -name '*.a' -exec rm -vf {} ';'
  61. %clean
  62. rm -rf %{buildroot}
  63. %files
  64. %defattr(-,root,root,-)
  65. %license COPYING
  66. %doc README VERSION
  67. %doc doc/jemalloc.html
  68. %{_libdir}/libjemalloc.so.*
  69. %{_bindir}/jemalloc.sh
  70. %{_bindir}/jemalloc-config
  71. %{_bindir}/jeprof
  72. %{_libdir}/pkgconfig/jemalloc.pc
  73. %files devel
  74. %defattr(-,root,root,-)
  75. %{_includedir}/jemalloc
  76. %{_libdir}/libjemalloc.so
  77. %{_mandir}/man3/jemalloc.3*
  78. %post
  79. /sbin/ldconfig
  80. %postun
  81. /sbin/ldconfig
  82. %changelog
  83. * Fri Jul 8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.2.1-1
  84. - new upstream release.
  85. * Wed May 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.1.1-1
  86. - new upstream release.
  87. * Fri Oct 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.0.4-2
  88. - initial build for Vine Linux.
  89. * Sat Oct 24 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.4-1
  90. - New upstream release
  91. * Fri Sep 25 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.3-1
  92. - New upstream release
  93. - Removed oom test patch, it has been fixed upstream
  94. * Thu Sep 24 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.2-2
  95. - oom test also fails on 32bit ppc, so patch it out there as well
  96. * Tue Sep 22 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.2-1
  97. - New upstream release
  98. - Added a patch removing a non-critical test that fails on i386
  99. - Removed now included negative bitshift patch.
  100. * Wed Aug 19 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.0-1
  101. - New upstream release
  102. - Removed the no-pprof patch, as jemalloc now comes with its own prof variant
  103. - Removed atomic.h patch for armv5tel. jemalloc now provides a specific
  104. variant for armv5tel
  105. - Added a patch from upstream for errnous bitshift by negative amounts on pagesize >8KiB
  106. - Added -lrt to LDFLAGS for rhel<7
  107. * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6.0-9
  108. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  109. * Mon Aug 18 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-8
  110. - valgrind-devel is not available on s390, closes #1131014
  111. * Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6.0-7
  112. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  113. * Fri Aug 15 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-6
  114. - bz #1106933 fix only for fedora 21 and above
  115. * Fri Aug 15 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-5
  116. - Added valgrind-devel to BuildRequires, fixing bz #974270
  117. * Fri Aug 15 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-4
  118. - Added an i686 build fixing bz #1106933
  119. * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6.0-3
  120. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  121. * Tue Apr 01 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-2
  122. - Patch that removes explicit altivec on el5/ppc
  123. * Mon Mar 31 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-1
  124. - New upstream release. This release fixes a critical regression
  125. * Fri Mar 28 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.5.1-1
  126. - New upstream release
  127. - Updated nopprof patch to match new release
  128. - Fixed a few bogus changelog entries
  129. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.4.0-2
  130. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  131. * Fri Jun 07 2013 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.4.0-1
  132. - New upstream release
  133. * Mon Mar 11 2013 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.3.1-1
  134. - New upstream release
  135. - Dropped s390 patch, it's in upstream now.
  136. * Fri Jan 25 2013 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.3.0-1
  137. - New upstream release
  138. * Mon Nov 19 2012 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.2.0-1
  139. - New upstream release
  140. * Tue Oct 23 2012 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.1.0-1
  141. - New upstream release
  142. - Removed ptmalloc_lock_all patch, it is merged upstream
  143. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.0-3
  144. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  145. * Thu May 24 2012 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.0.0-2
  146. - Added a patch from upstream, fixing a crash in ptmalloc_lock_all,
  147. closing #824646
  148. * Mon May 14 2012 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.0.0-1
  149. - New upstream release
  150. - Updated no_pprof patch to match new release
  151. - Updated s390 patch to match new relase
  152. - Added make check
  153. - Added new script jemalloc.sh
  154. - Added a patch for atomic operations on epel5/ppc
  155. * Sat Apr 21 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 2.2.5-5
  156. - Improve ARM patch
  157. * Fri Apr 20 2012 Dennis Gilmore <dennis@ausil.us> - 2.2.5-4
  158. - no attomics on armv5tel
  159. * Wed Feb 08 2012 Dan Horák <dan[at]danny.cz> - 2.2.5-3
  160. - substitute version information in the header (#788517)
  161. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.5-2
  162. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  163. * Sun Nov 06 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.5-1
  164. - New upstream release, closes #75618
  165. * Sun Nov 06 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.4-1
  166. - New upstream release
  167. * Thu Oct 13 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.3-1
  168. - New upstream release, closes #735057
  169. * Mon Aug 01 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.2-1
  170. - New upstream release, closes #727103
  171. - Updated no_pprof patch for 2.2.2
  172. * Thu Mar 31 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.1-1
  173. - New upstream release
  174. * Sun Mar 27 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.0-1
  175. - New upstream release
  176. - Updated no_pprof patch for 2.2.0
  177. * Tue Mar 15 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.1.3-2
  178. - New upstream release
  179. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.1-2
  180. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  181. * Tue Feb 01 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.1.1-1
  182. - New upstream release
  183. * Wed Jan 05 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.1.0-1
  184. - New upstream release
  185. - Updated patch to remove pprof
  186. - Added html doc and xsltproc as a requirement to build it
  187. * Sat Dec 11 2010 Dan Horák <dan[at]danny.cz> - 2.0.1-3
  188. - fix build on s390
  189. * Thu Nov 18 2010 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.0.1-2
  190. - Added a patch that removes pprof, as it already exists in the
  191. google-perftools package
  192. - Cosmetic fixes as requested in the package review (rhbz#653682)
  193. * Mon Nov 15 2010 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.0.1-1
  194. - First cut of an rpm distribution of jemalloc