irrlicht-vl.spec 7.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219
  1. %global irrxml_version 1.8.1
  2. %global irrlicht_version 1.8.1
  3. Name: irrlicht
  4. Summary: A high performance realtime 3D engine
  5. Summary(ja): 高性能なリアルタイム3Dエンジン
  6. Version: %{irrlicht_version}
  7. Release: 2%{?_dist_release}
  8. License: zlib
  9. Group: System Environment/Libraries
  10. URL: http://irrlicht.sourceforge.net/
  11. Source0: http://downloads.sourceforge.net/irrlicht/%{name}-%{irrlicht_version}.zip
  12. # Various fixes, optflags, system libraries/headers
  13. # http://irrlicht.sourceforge.net/phpBB2/viewtopic.php?t=24076&highlight=
  14. Patch0: irrlicht-1.8-optflags.patch
  15. # Get the code compiling
  16. Patch1: irrlicht-1.8-glext.patch
  17. # Use system libaesgm
  18. Patch2: irrlicht18-libaesgm.patch
  19. # Use improved fastatof from assimp
  20. # Upstream applied a modified version of most of this.
  21. # Patch3: irrlicht18-fastatof-improvements-typefixes.patch
  22. # Make libIrrXML.so
  23. Patch4: irrlicht-1.8-irrXML-shared-library.patch
  24. # Fix issue with definition of LOCALE_DECIMAL_POINTS
  25. Patch5: irrlicht-1.8-fix-locale-decimal-points.patch
  26. # Fix build with Mesa 10
  27. Patch6: irrlicht-1.8.1-mesa10.patch
  28. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  29. BuildRequires: libXxf86vm-devel, mesa-libGL-devel, mesa-libGLU-devel
  30. BuildRequires: libjpeg-turbo-devel, zlib-devel, libaesgm-devel
  31. BuildRequires: libpng-devel, bzip2-devel, unzip
  32. %description
  33. The Irrlicht Engine is an open source high performance realtime 3D engine
  34. written and usable in C++ and also available for .NET languages. It is
  35. completely cross-platform, using D3D, OpenGL and its own software renderer,
  36. and has all of the state-of-the-art features which can be found in
  37. commercial 3d engines.
  38. %package devel
  39. Summary: Development headers and libraries for irrlicht
  40. Summary(ja): irrlicht の開発用ヘッダファイルとライブラリ
  41. Group: Development/Libraries
  42. Requires: %{name} = %{version}-%{release}
  43. Requires: mesa-libGL-devel, mesa-libGLU-devel, libXxf86vm-devel
  44. Requires: libjpeg-devel, zlib-devel, libpng-devel
  45. Requires: irrXML-devel = %{irrxml_version}
  46. %description devel
  47. Development headers and libraries for irrlicht.
  48. %package -n irrXML
  49. Summary: Simple and fast XML parser for C++
  50. Summary(ja): C++ 用のシンプルかつ高速な XML パーサ
  51. Group: System Environment/Libraries
  52. Version: %{irrxml_version}
  53. %description -n irrXML
  54. irrXML is a simple and fast open source xml parser for C++.
  55. %package -n irrXML-devel
  56. Summary: Development headers and libraries for irrXML
  57. Summary(ja): irrXML の開発用ヘッダファイルとライブラリ
  58. Version: %{irrxml_version}
  59. Group: Development/Libraries
  60. Requires: irrXML = %{irrxml_version}-%{release}
  61. %description -n irrXML-devel
  62. Development headers and libraries for irrXML.
  63. %prep
  64. %setup -q
  65. %patch0 -p1 -b .optflags
  66. %patch1 -p1 -b .glext
  67. %patch2 -p1 -b .libaesgm
  68. # %patch3 -p1 -b .fastatof
  69. %patch4 -p1 -b .irrXML
  70. %patch5 -p1 -b .fix-locale-decimal-points
  71. %patch6 -p1 -b .mesa10
  72. # Upstream forgot to increment VERSION_RELEASE to 1 in 1.8.1
  73. sed -i 's|VERSION_RELEASE = 0|VERSION_RELEASE = 1|g' source/Irrlicht/Makefile
  74. sed -i 's/\r//' readme.txt
  75. iconv -o readme.txt.iso88591 -f iso88591 -t utf8 readme.txt
  76. mv readme.txt.iso88591 readme.txt
  77. # We don't use any of this. Deleting it so the debuginfo doesn't pick it up.
  78. rm -rf source/Irrlicht/jpeglib source/Irrlicht/zlib source/Irrlicht/libpng source/Irrlicht/aesGladman
  79. for i in include/*.h doc/upgrade-guide.txt source/Irrlicht/*.cpp source/Irrlicht/*.h; do
  80. sed -i 's/\r//' $i
  81. chmod -x $i
  82. touch -r changes.txt $i
  83. done
  84. # https://bugzilla.redhat.com/show_bug.cgi?id=1035757
  85. sed -i -e '/_IRR_MATERIAL_MAX_TEXTURES_/s/4/8/' include/IrrCompileConfig.h
  86. %build
  87. cd source/Irrlicht
  88. make %{?_smp_mflags} sharedlib
  89. %install
  90. rm -rf %{buildroot}
  91. mkdir -p %{buildroot}%{_libdir}
  92. mkdir -p %{buildroot}%{_includedir}/%{name}
  93. make -C source/Irrlicht INSTALL_DIR=%{buildroot}%{_libdir} install
  94. cp -a include/*.h %{buildroot}%{_includedir}/%{name}/
  95. pushd %{buildroot}%{_libdir}
  96. ln -s libIrrlicht.so.%{irrlicht_version} libIrrlicht.so.1
  97. ln -s libIrrXML.so.%{irrlicht_version} libIrrXML.so.1
  98. popd
  99. %clean
  100. rm -rf %{buildroot}
  101. %post -p /sbin/ldconfig
  102. %postun -p /sbin/ldconfig
  103. %post -n irrXML -p /sbin/ldconfig
  104. %postun -n irrXML -p /sbin/ldconfig
  105. %files
  106. %defattr(-,root,root,-)
  107. %doc readme.txt
  108. %{_libdir}/libIrrlicht*.so.*
  109. %{_libdir}/libIrrXML*.so.*
  110. %files devel
  111. %defattr(-,root,root,-)
  112. %doc doc/upgrade-guide.txt
  113. %{_includedir}/%{name}/
  114. %exclude %{_includedir}/%{name}/fast_atof.h
  115. %exclude %{_includedir}/%{name}/heapsort.h
  116. %exclude %{_includedir}/%{name}/irrArray.h
  117. %exclude %{_includedir}/%{name}/irrString.h
  118. %exclude %{_includedir}/%{name}/irrTypes.h
  119. %exclude %{_includedir}/%{name}/irrXML.h
  120. %{_libdir}/libIrrlicht*.so
  121. %{_libdir}/libIrrXML*.so
  122. %files -n irrXML
  123. %defattr(-,root,root,-)
  124. %doc readme.txt
  125. %{_libdir}/libIrrXML*.so.*
  126. %files -n irrXML-devel
  127. %defattr(-,root,root,-)
  128. %dir %{_includedir}/%{name}/
  129. %{_includedir}/%{name}/fast_atof.h
  130. %{_includedir}/%{name}/heapsort.h
  131. %{_includedir}/%{name}/irrArray.h
  132. %{_includedir}/%{name}/irrString.h
  133. %{_includedir}/%{name}/irrTypes.h
  134. %{_includedir}/%{name}/irrXML.h
  135. %{_libdir}/libIrrXML*.so
  136. %changelog
  137. * Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-2
  138. - rebuild with gcc-5.4.0
  139. * Thu Jan 29 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.8.1-1
  140. - updated to 1.8.1
  141. - built on current VineSeed
  142. * Wed Mar 16 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 1.7.2-1
  143. - initial build for Vine Linux based of fedora development
  144. * Wed Dec 15 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 1.7.2-4
  145. - add post/postun scripts for irrXML
  146. * Wed Dec 15 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 1.7.2-3
  147. - fix versioning on irrXML-devel
  148. * Wed Dec 15 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 1.7.2-2
  149. - make subpackages for irrXML
  150. - use assimp patch for performance improvement in IrrXML
  151. * Wed Nov 17 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 1.7.2-1
  152. - update to 1.7.2
  153. * Mon May 24 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 1.7.1-2
  154. - rebuild against fixed libaesgm
  155. * Thu Feb 18 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 1.7.1-1
  156. - update to 1.7.1
  157. * Thu Jan 14 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 1.6.1-1
  158. - update to 1.6.1
  159. * Wed Sep 30 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.6-1
  160. - update to 1.6
  161. * Wed Aug 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.5.1-1
  162. - update to 1.5.1
  163. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-4
  164. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  165. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-3
  166. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  167. * Sat Jan 10 2009 Tom "spot" Callaway <tcallawa@redhat.com> 1.5-2
  168. - fix libpng calls so we can use system libpng (thanks to tom lane)
  169. - fix license tag
  170. * Thu Jan 8 2009 Tom "spot" Callaway <tcallawa@redhat.com> 1.5-1
  171. - build against system libpng
  172. - update to 1.5 final
  173. * Thu Dec 4 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5-0.2.beta
  174. - fix optflags patch so that ldconfig isn't called during make install
  175. * Wed Dec 3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5-0.1.beta
  176. - Initial package for Fedora