htdig-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330
  1. %define buildweb 1
  2. %define beta b6
  3. %define contentdir /var/www
  4. %define apachebin %{_sbindir}/apache2
  5. Name: htdig
  6. Summary: ht://Dig - Web search engine
  7. Summary(ja): ht://Dig Web 検索エンジン
  8. Version: 3.2.0
  9. Release: 9.%{beta}%{?_dist_release}
  10. License: GPLv2
  11. Group: Applications/Internet
  12. URL: http://www.htdig.org/
  13. Source: http://www.htdig.org/files/%{name}-%{version}%{beta}.tar.bz2
  14. Source1: htdig.conf
  15. Patch1: htdig-3.1.5-rh.patch
  16. Patch2: htdig-3.2.0b4-xopen.patch
  17. Patch4: htdig-3.2.0b5-overflow.patch
  18. Patch5: htdig-3.2.0b6-robots.patch
  19. Patch6: htdig-3.2.0b6-unescaped_output.patch
  20. Patch8: htdig-3.2.0b6-compile-fix.patch
  21. Patch9: htdig-3.2.0b6-opts.patch
  22. Patch11: htdig-3.2.0b6-incremental.patch
  23. Patch12: htdig-3.2-CVE-2007-6110.patch
  24. Patch13: htdig-3.2.0b6-htstat-segv.patch
  25. Patch14: htdig-3.2.0-external_parsers.patch
  26. Patch15: htdig-3.2.0-allow_numbers.patch
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  28. BuildRequires: flex >= 2.5.4a-13
  29. BuildRequires: zlib-devel
  30. BuildRequires: openssl-devel
  31. BuildRequires: apache2
  32. BuildRequires: autoconf automake libtool
  33. Vendor: Project Vine
  34. Distribution: Vine Linux
  35. %package web
  36. Summary: Scripts and HTML code needed for using ht://Dig as a web search engine
  37. Group: Applications/Internet
  38. Requires: %{name} = %{version}
  39. Requires: webserver
  40. %description
  41. The ht://Dig system is a complete world wide web indexing and searching
  42. system for a small domain or intranet. This system is not meant to replace
  43. the need for powerful internet-wide search systems like Lycos, Infoseek,
  44. Webcrawler and AltaVista. Instead it is meant to cover the search needs for
  45. a single company, campus, or even a particular sub section of a web site. As
  46. opposed to some WAIS-based or web-server based search engines, ht://Dig can
  47. span several web servers at a site. The type of these different web servers
  48. doesn't matter as long as they understand the HTTP 1.0 protocol.
  49. ht://Dig is also used by KDE to search KDE's HTML documentation.
  50. ht://Dig was developed at San Diego State University as a way to search the
  51. various web servers on the campus network.
  52. %description web
  53. The ht://Dig system is a complete world wide web indexing and searching
  54. system for a small domain or intranet. This system is not meant to replace
  55. the need for powerful internet-wide search systems like Lycos, Infoseek,
  56. Webcrawler and AltaVista. Instead it is meant to cover the search needs for
  57. a single company, campus, or even a particular sub section of a web site. As
  58. opposed to some WAIS-based or web-server based search engines, ht://Dig can
  59. span several web servers at a site. The type of these different web servers
  60. doesn't matter as long as they understand the HTTP 1.0 protocol.
  61. The %{name}-web package includes CGI scripts and HTML code needed to use
  62. ht://Dig on a website.
  63. ht://Dig was developed at San Diego State University as a way to search the
  64. various web servers on the campus network.
  65. %prep
  66. %setup -q -n %{name}-%{version}%{beta}
  67. %patch1 -p1 -b .rh
  68. %patch2 -p1 -b .xopen
  69. %patch4 -p1 -b .overflow
  70. %patch5 -p1 -b .robots
  71. %patch6 -p1 -b .unescaped_output
  72. %patch8 -p1 -b .compile-fix
  73. %patch9 -p1 -b .opts
  74. %patch11 -p1 -b .incremental
  75. %patch12 -p1 -b .CVE-2007-6110
  76. %patch13 -p1 -b .htstat-segv
  77. %patch14 -p1 -b .external_parsers
  78. %patch15 -p1 -b .allow_numbers
  79. autoreconf -fiv
  80. %build
  81. %configure \
  82. --enable-shared \
  83. --enable-tests \
  84. --enable-bigfile \
  85. --with-config-dir=%{_sysconfdir}/htdig \
  86. --with-common-dir=%{contentdir}/html/htdig \
  87. --with-database-dir=/var/lib/htdig \
  88. --localstatedir=/var/lib/htdig \
  89. --with-cgi-bin-dir=%{contentdir}/cgi-bin \
  90. --with-image-dir=%{contentdir}/html/htdig \
  91. --with-search-dir=%{contentdir}/html/htdig \
  92. --with-default-config-file=%{_sysconfdir}/htdig/htdig.conf \
  93. --with-apache=%{apachebin} \
  94. --with-zlib=%{_prefix} \
  95. --with-ssl
  96. make
  97. %install
  98. rm -rf $RPM_BUILD_ROOT
  99. make install DESTDIR=$RPM_BUILD_ROOT
  100. ln $RPM_BUILD_ROOT%{contentdir}/cgi-bin/htsearch $RPM_BUILD_ROOT%{_bindir}
  101. chmod 644 $RPM_BUILD_ROOT%{contentdir}/html/htdig/*
  102. ln -sf search.html $RPM_BUILD_ROOT%{contentdir}/html/htdig/index.html
  103. # now get rid of the $RPM_BUILD_ROOT paths in the conf files
  104. for i in %{_sysconfdir}/htdig/htdig.conf /usr/bin/rundig ; do
  105. perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT/$i
  106. done
  107. mkdir -p $RPM_BUILD_ROOT%{_prefix}/share
  108. mv $RPM_BUILD_ROOT%{contentdir}/html/htdig $RPM_BUILD_ROOT%{_prefix}/share
  109. mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d/
  110. install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/httpd/conf.d/htdig.conf
  111. rm -rf $RPM_BUILD_ROOT%{_includedir}
  112. rm -rf $RPM_BUILD_ROOT%{_libdir}/htdig/*.a
  113. rm -rf $RPM_BUILD_ROOT%{_libdir}/htdig/*.la
  114. rm -rf $RPM_BUILD_ROOT%{_libdir}/htdig_db/*.a
  115. rm -rf $RPM_BUILD_ROOT%{_libdir}/htdig_db/*.la
  116. %clean
  117. rm -rf $RPM_BUILD_ROOT
  118. %files
  119. %defattr(-,root,root)
  120. %doc htdoc/*
  121. %dir %{_sysconfdir}/htdig
  122. %config %{_sysconfdir}/htdig/htdig.conf
  123. %config %{_sysconfdir}/htdig/cookies.txt
  124. %{_sysconfdir}/htdig/HtFileType-magic.mime
  125. %{_sysconfdir}/htdig/mime.types
  126. %dir /var/lib/htdig
  127. %{_bindir}/*
  128. %{_libdir}/htdig
  129. %{_libdir}/htdig_db
  130. %{_mandir}/man1/*
  131. %if %buildweb
  132. %files web
  133. %defattr(-,root,root)
  134. %{contentdir}/cgi-bin/*
  135. %config %{_sysconfdir}/httpd/conf.d/htdig.conf
  136. %dir %{_datadir}/htdig
  137. %{_datadir}/htdig/*
  138. %{_mandir}/man8/*
  139. %endif
  140. %changelog
  141. * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-9.b6
  142. - rebuild with VineSeed environment
  143. * Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2.0-8.b6
  144. - rebuilt with current VineSeed
  145. - replaced Patch100 to Patch8
  146. - added --with-ssl option to %%configure
  147. * Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 3.2.0-7.b6vl5
  148. - applied new versioning policy
  149. * Sun Sep 2 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2.0-6.1vl1.b6
  150. - new upstream release
  151. - added Patch100 for building with gcc4
  152. * Thu Mar 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-6.1vl1.b5
  153. - rebuild for VineSeedPlus
  154. * Thu Mar 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-6.1vl0.b5
  155. - build for VinePlus/2.6
  156. - remove commented lines
  157. - change configure options for apache of Vine
  158. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  159. - rebuilt
  160. * Thu Feb 26 2004 Phil Knirsch <pknirsch@redhat.com> 3.2.0b5-6
  161. - Removed buildroot cruft from HtFileFype (#116442).
  162. - Use mktemp in HtFileFype to create temporary file (#116443).
  163. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  164. - rebuilt
  165. * Thu Jan 15 2004 Phil Knirsch <pknirsch@redhat.com> 3.2.0b5-4
  166. - Fixed missing & in if clause.
  167. * Tue Jan 13 2004 Phil Knirsch <pknirsch@redhat.com> 3.2.0b5-3
  168. - Fixed latin1 char translation (#71921).
  169. - Fixed overflow bug in WordDBPage.cc (#110802).
  170. * Mon Jan 12 2004 Phil Knirsch <pknirsch@redhat.com> 3.2.0b5-2
  171. - Moved /usr/share/htdig files to web package (#111938).
  172. * Fri Dec 12 2003 Phil Knirsch <pknirsch@redhat.com> 3.2.0b5-1
  173. - Update to latest stable upstream version htdig-3.2.0b5.
  174. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  175. - rebuilt
  176. * Wed Jun 04 2003 Phil Knirsch <pknirsch@redhat.com> 3.2.0-18.20030601
  177. - Update to htdig-3.2.0b4-20030601 snapshot.
  178. - Fixed build problems.
  179. * Thu Mar 06 2003 Phil Knirsch <pknirsch@redhat.com> 3.2.0-17.20030302
  180. - Update to htdig-3.2.0b4-20030302 snapshot.
  181. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  182. - rebuilt
  183. * Wed Jan 8 2003 Jeff Johnson <jbj@redhat.com> 3.2.0-15.20021103
  184. - don't include -debuginfo files in package.
  185. * Tue Dec 17 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-14.20021103
  186. - Forgot to create conf.d directory. Fixed.
  187. - Fixed wrong files section.
  188. * Tue Dec 10 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-13.20021103
  189. - Removed symlink from %{contentdir}/html and replaced it with httpd.d conf
  190. file (#73518).
  191. * Tue Dec 10 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-12.20021103
  192. - Added webserver requirement for htdig-web package (#73986).
  193. * Wed Dec 04 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-11.20021103
  194. - Fix for autoFOO patch.
  195. - Fix x64_64 build.
  196. * Wed Nov 27 2002 Tim Powers <timp@redhat.com> 3.2.0-9.20021103
  197. - rebuild on all arches
  198. * Fri Nov 08 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-8.20021103
  199. - Updated to htdig-3.2.0b4-20021103.
  200. - Fixed %files section errors.
  201. * Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com> 3.2.0-7.20020505
  202. - rebuilt with gcc-3.2 (we hope)
  203. * Tue Jul 23 2002 Tim Powers <timp@redhat.com> 3.2.0-6.20020505
  204. - build using gcc-3.2-0.1
  205. * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 3.2.0-5.20020505
  206. - automated rebuild
  207. * Wed Jun 19 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-4.20020505
  208. - Don't forcibly strip binaries
  209. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  210. - automated rebuild
  211. * Mon May 6 2002 Bernhard Rosenkraenzer <bero@linux-easy.com> 3.2.0-2.20020505
  212. - Fix build with current toolchain (automake 1.6, autoconf 2.53 changes)
  213. - Update snapshot, fixes some more problems
  214. * Thu Jan 24 2002 Phil Knirsch <pknirsch@redhat.com>
  215. - Updated to latest snapshot to fix several problems.
  216. - Fixed a problem with htdig segfaulting on s390 (#58202).
  217. * Fri Jul 20 2001 Philipp Knirsch <pknirsch@redhat.de>
  218. - Added missing BuildRequires: zlib-devel (#49500)
  219. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
  220. - Bump release + rebuild.
  221. * Fri Apr 27 2001 Bill Nottingham <notting@redhat.com>
  222. - rebuild for C++ exception handling on ia64
  223. * Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.2.0-0.b3.4
  224. - move pictures etc. to base package and to a directory outside of
  225. /var/www - The current KDevelop search function doesn't work without
  226. them.
  227. * Mon Mar 5 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  228. - Add htsearch to the base package, kdevelop needs it
  229. * Wed Jan 10 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  230. - Move the web related files to a separate package
  231. * Tue Oct 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  232. - 3.2.0b2
  233. - fix build with glibc 2.2 and gcc 2.96
  234. * Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  235. - fix syntax error introduced in our patch (#16598)
  236. * Tue Aug 1 2000 Tim Powers <timp@redhat.com>
  237. - fixed group to be a valid one
  238. * Mon Jul 24 2000 Prospector <prospector@redhat.com>
  239. - rebuilt
  240. * Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  241. - rebuild for Power Tools
  242. * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  243. - rebuild for Power Tools
  244. * Sat Feb 26 2000 Nalin Dahyabhai <nalin@redhat.com>
  245. - 3.1.5
  246. * Wed Jan 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  247. - 3.1.4
  248. - fix URL and source location
  249. * Tue Sep 28 1999 Preston Brown <pbrown@redhat.com>
  250. - 3.1.3 for SWS 3.1
  251. * Wed May 05 1999 Preston Brown <pbrown@redhat.com>
  252. - updates for SWS 3.0
  253. * Mon Aug 31 1998 Preston Brown <pbrown@redhat.com>
  254. - Updates for SWS 2.0
  255. * Sat Feb 07 1998 Cristian Gafton <gafton@redhat.com>
  256. - built against glibc
  257. - build all the fuzzy databases before packaging, because it is time
  258. consuming operation and we don't want the user to be impatient