gsm-vl.spec 8.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: Shared libraries for GSM speech compressor
  3. Name: gsm
  4. Version: 1.0.14
  5. Release: 1%{?_dist_release}
  6. Group: System Environment/Libraries
  7. License: MIT
  8. URL: http://www.quut.com/gsm/
  9. Source: http://www.quut.com/gsm/%{name}-%{version}.tar.gz
  10. Patch0: %{name}-makefile.patch
  11. Patch1: %{name}-1.0.14-warnings.patch
  12. Patch2: %{name}-64bit.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. %define srcver 1.0-pl14
  15. %define soname 1.0.12
  16. Vendor: Project Vine
  17. Distribution: Vine Linux
  18. %description
  19. Contains runtime shared libraries for libgsm, an implementation of
  20. the European GSM 06.10 provisional standard for full-rate speech
  21. transcoding, prI-ETS 300 036, which uses RPE/LTP (residual pulse
  22. excitation/long term prediction) coding at 13 kbit/s.
  23. GSM 06.10 compresses frames of 162 13-bit samples (8 kHz sampling
  24. rate, i.e. a frame rate of 50 Hz) into 260 bits; for compatibility
  25. with typical UNIX applications, our implementation turns frames of 160
  26. 16-bit linear samples into 33-byte frames (1650 Bytes/s).
  27. The quality of the algorithm is good enough for reliable speaker
  28. recognition; even music often survives transcoding in recognizable
  29. form (given the bandwidth limitations of 8 kHz sampling rate).
  30. The interfaces offered are a front end modelled after compress(1), and
  31. a library API. Compression and decompression run faster than realtime
  32. on most SPARCstations. The implementation has been verified against the
  33. ETSI standard test patterns.
  34. %package tools
  35. Summary: GSM speech compressor tools
  36. Group: Applications/Multimedia
  37. %description tools
  38. Contains command line utilities for libgsm, an implementation of
  39. the European GSM 06.10 provisional standard for full-rate speech
  40. transcoding, prI-ETS 300 036, which uses RPE/LTP (residual pulse
  41. excitation/long term prediction) coding at 13 kbit/s.
  42. %package devel
  43. Summary: Header files and development libraries for libgsm
  44. Group: Development/Libraries
  45. Requires: %{name} = %{version}-%{release}
  46. %description devel
  47. Contains header files and development libraries for libgsm, an
  48. implementation of the European GSM 06.10 provisional standard for
  49. full-rate speech transcoding, prI-ETS 300 036, which uses RPE/LTP
  50. (residual pulse excitation/long term prediction) coding at 13 kbit/s.
  51. # compat32
  52. %package -n compat32-%{name}
  53. Summary: Shared libraries for GSM speech compressor
  54. Group: System Environment/Libraries
  55. Requires: %{name} = %{version}-%{release}
  56. %description -n compat32-%{name}
  57. Contains runtime shared libraries for libgsm, an implementation of
  58. the European GSM 06.10 provisional standard for full-rate speech
  59. transcoding, prI-ETS 300 036, which uses RPE/LTP (residual pulse
  60. excitation/long term prediction) coding at 13 kbit/s.
  61. GSM 06.10 compresses frames of 162 13-bit samples (8 kHz sampling
  62. rate, i.e. a frame rate of 50 Hz) into 260 bits; for compatibility
  63. with typical UNIX applications, our implementation turns frames of 160
  64. 16-bit linear samples into 33-byte frames (1650 Bytes/s).
  65. The quality of the algorithm is good enough for reliable speaker
  66. recognition; even music often survives transcoding in recognizable
  67. form (given the bandwidth limitations of 8 kHz sampling rate).
  68. The interfaces offered are a front end modelled after compress(1), and
  69. a library API. Compression and decompression run faster than realtime
  70. on most SPARCstations. The implementation has been verified against the
  71. ETSI standard test patterns.
  72. %package -n compat32-%{name}-devel
  73. Summary: Header files and development libraries for libgsm
  74. Group: Development/Libraries
  75. Requires: compat32-%{name} = %{version}-%{release}
  76. Requires: %{name}-devel = %{version}-%{release}
  77. %description -n compat32-%{name}-devel
  78. Contains header files and development libraries for libgsm, an
  79. implementation of the European GSM 06.10 provisional standard for
  80. full-rate speech transcoding, prI-ETS 300 036, which uses RPE/LTP
  81. (residual pulse excitation/long term prediction) coding at 13 kbit/s.
  82. %prep
  83. %setup -n gsm-%{srcver} -q
  84. %patch0 -p1 -b .mk
  85. %patch1 -p1 -b .warn
  86. %patch2 -p1 -b .64bit
  87. %build
  88. export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -fPIC";
  89. make %{?_smp_mflags} all
  90. %install
  91. rm -rf $RPM_BUILD_ROOT
  92. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  93. mkdir -p $RPM_BUILD_ROOT%{_includedir}/gsm
  94. mkdir -p $RPM_BUILD_ROOT%{_libdir}
  95. mkdir -p $RPM_BUILD_ROOT%{_mandir}/{man1,man3}
  96. make install \
  97. INSTALL_ROOT=$RPM_BUILD_ROOT%{_prefix} \
  98. GSM_INSTALL_INC=$RPM_BUILD_ROOT%{_includedir}/gsm \
  99. GSM_INSTALL_LIB=$RPM_BUILD_ROOT%{_libdir}
  100. cp -p $RPM_BUILD_DIR/gsm-%{srcver}/lib/libgsm.so.%{soname} $RPM_BUILD_ROOT%{_libdir}
  101. ln -s libgsm.so.%{soname} $RPM_BUILD_ROOT%{_libdir}/libgsm.so.1
  102. ln -s libgsm.so.%{soname} $RPM_BUILD_ROOT%{_libdir}/libgsm.so
  103. # some apps look for this in /usr/include
  104. ln -s gsm/gsm.h $RPM_BUILD_ROOT%{_includedir}
  105. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.a
  106. %check
  107. # This is to ensure that the patch creates the proper library version.
  108. [ -f $RPM_BUILD_ROOT%{_libdir}/libgsm.so.%{soname} ]
  109. make addtst
  110. %clean
  111. rm -rf $RPM_BUILD_ROOT
  112. %post -p /sbin/ldconfig
  113. %postun -p /sbin/ldconfig
  114. %post -n compat32-%{name} -p /sbin/ldconfig
  115. %postun -n compat32-%{name} -p /sbin/ldconfig
  116. %files
  117. %defattr(-,root,root,-)
  118. %doc ChangeLog COPYRIGHT MACHINES README
  119. %{_libdir}/libgsm.so.*
  120. %files tools
  121. %{_bindir}/tcat
  122. %{_bindir}/toast
  123. %{_bindir}/untoast
  124. %{_mandir}/man1/toast.1*
  125. %files devel
  126. %defattr(-,root,root,-)
  127. %dir %{_includedir}/gsm
  128. %{_includedir}/gsm/gsm.h
  129. %{_includedir}/gsm.h
  130. %{_libdir}/libgsm.so
  131. %{_mandir}/man3/*
  132. # compat32
  133. %if %{build_compat32}
  134. %files -n compat32-%{name}
  135. %defattr(-,root,root,-)
  136. %{_libdir}/libgsm.so.*
  137. %files -n compat32-%{name}-devel
  138. %defattr(-,root,root,-)
  139. %{_libdir}/libgsm.so
  140. %endif
  141. %changelog
  142. * Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.14-1
  143. - new upstream release
  144. - update Patch1 (%%{name}-1.0.14-warnings.patch)
  145. * Mon Jul 7 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.13-1
  146. - new upstream release.
  147. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.12-3
  148. - create compat32 sub package
  149. * Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.12-2
  150. - rebuilt with current VineSeed
  151. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
  152. - initial build for Vine Linux
  153. * Mon Feb 11 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.0.12-6
  154. - Rebuild for GCC 4.3
  155. * Sun Aug 26 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-5
  156. - install symlinks instead of binaries in -devel
  157. * Sat Aug 25 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-4
  158. - rebuild for BuildID
  159. - specfile cleanups
  160. * Sun May 13 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-3
  161. - fix parallel make
  162. * Fri May 11 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-2
  163. - fix some warnings
  164. - fix 64bit testsuite issue as described at gsm homepage
  165. - add compatibility header symlink
  166. - split off binaries into a separate package
  167. * Sun Apr 15 2007 Michael Schwendt <mschwendt[AT]users.sf.net> 1.0.12-1
  168. - Update to Release 1.0 Patchlevel 12.
  169. - Build with -fPIC not just for non-ix86.
  170. - Add check section to ensure proper library version.
  171. - Remove static library.
  172. * Fri Oct 06 2006 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> 1.0.10-12
  173. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  174. * Tue Sep 26 2006 Thomas Vander Stichele <thomas at apestaart dot org>
  175. - 1.0.10-11
  176. - rebuild for FC6
  177. * Thu Mar 09 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  178. - switch to new release field
  179. * Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  180. - add dist
  181. * Mon Jun 27 2005 David Woodhouse <dwmw2@infradead.org>
  182. - 1.0.10-0.lvn.10: Clean up installation
  183. * Sat Jun 25 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info>
  184. - 1.0.10-0.lvn.9: mv libgsm.a only when needed
  185. * Fri Dec 31 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info>
  186. - 1.0.10-0.lvn.8: Use -fPIC on non ix86
  187. * Tue Mar 02 2004 Thomas Vander Stichele <thomas at apestaart dot org>
  188. - 1.0.10-0.lvn.7: moved to rpm.livna.org
  189. * Tue Mar 02 2004 Thomas Vander Stichele <thomas at apestaart dot org>
  190. - 1.0.10-0.fdr.7: applied patch from Ville, remove epoch since it's allowed
  191. * Sat Sep 13 2003 Thomas Vander Stichele <thomas at apestaart dot org>
  192. - 0:1.0.10-0.fdr.6: remove second makeinstall
  193. * Sun Sep 07 2003 Thomas Vander Stichele <thomas at apestaart dot org>
  194. - 0:1.0.10-0.fdr.5
  195. - added back epochs, I surrender
  196. - fix RPM_OPT_FLAGS hackery
  197. * Fri Jul 18 2003 Thomas Vander Stichele <thomas at apestaart dot org>
  198. - 1.0.10-0.fdr.4: remove epoch mentions
  199. * Sat Jul 05 2003 Thomas Vander Stichele <thomas at apestaart dot org>
  200. - 1.0.10-0.fdr.3
  201. - pull in RPM_OPT_FLAGS in patch instead of using perl to wedge it in
  202. - fix group
  203. - -p'ize ldconfig
  204. * Tue Jun 10 2003 Thomas Vander Stichele <thomas at apestaart dot org>
  205. - 1.0.10-0.fdr.2
  206. - Fix libgsm.so.* being files instead of symlinks
  207. * Thu May 29 2003 Thomas Vander Stichele <thomas at apestaart dot org>
  208. - 0:1.0.10-0.fdr.1: initial RPM release