freerdp-vl.spec 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234
  1. Name: freerdp
  2. Summary: Remote Desktop Protocol client
  3. Summary(ja): リモートデスクトッププロトコルクライアント
  4. Version: 1.0.2
  5. Release: 2%{?_dist_release}
  6. Group: Applications/Internet
  7. License: GPLv2+
  8. URL: http://www.freerdp.com/
  9. Source0: https://github.com/downloads/FreeRDP/FreeRDP/%{name}-%{version}.tar.gz
  10. # https://github.com/FreeRDP/FreeRDP/commit/165d39a290a109c0af16a1d223d1426cb524a844 backport
  11. Patch0: fastpath_send_input_pdu-sec_bytes.patch
  12. Patch1: c10866db66c0d462ea7c2c38bb01740bcfb4fcb4.patch
  13. Patch2: freerdp-1.0.2_xmlto.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildRequires: cmake
  16. BuildRequires: xmlto
  17. BuildRequires: openssl-devel
  18. BuildRequires: libX11-devel
  19. BuildRequires: libXext-devel
  20. BuildRequires: libXinerama-devel
  21. BuildRequires: libXcursor-devel
  22. BuildRequires: libXdamage-devel
  23. BuildRequires: libXv-devel
  24. BuildRequires: libxkbfile-devel
  25. BuildRequires: pulseaudio-libs-devel
  26. BuildRequires: alsa-lib-devel
  27. BuildRequires: cups-devel
  28. BuildRequires: pcsc-lite-devel
  29. BuildRequires: desktop-file-utils
  30. Provides: xfreerdp = %{version}-%{release}
  31. Requires: %{name}-libs = %{version}-%{release}, %{name}-plugins = %{version}-%{release}
  32. Requires: %{name}-plugins = %{version}-%{release}
  33. %description
  34. The xfreerdp Remote Desktop Protocol (RDP) client from the FreeRDP
  35. project.
  36. xfreerdp can connect to RDP servers such as Microsoft Windows
  37. machines, xrdp and VirtualBox.
  38. %package libs
  39. Summary: Core libraries implementing the RDP protocol
  40. Summary(ja): RDPプロトコル実装のコアライブラリ
  41. Group: System Environment/Libraries
  42. %description libs
  43. libfreerdp implements the core of the RDP protocol.
  44. libfreerdpchanman can be used to load plugins that can handle channels
  45. in the RDP protocol.
  46. libfreerdpkbd implements functionality for handling keyboards in X.
  47. %package plugins
  48. Summary: Plugins for handling the standard RDP channels
  49. Summary(ja): 標準RDPチャンネルを扱うためのプラグイン
  50. Group: System Environment/Libraries
  51. Requires: %{name}-libs = %{version}-%{release}
  52. %description plugins
  53. A set of plugins to the channel manager implementing the standard virtual
  54. channels extending RDP core functionality. For example, sounds, clipboard
  55. sync, disk/printer redirection, etc.
  56. %package devel
  57. Summary: Development files for %{name}
  58. Summary(ja): %{name}の開発ファイル
  59. Group: Development/Libraries
  60. Requires: %{name}-libs = %{version}-%{release}
  61. Requires: pkgconfig
  62. %description devel
  63. The %{name}-devel package contains libraries and header files for
  64. developing applications that use %{name}-libs.
  65. %prep
  66. %setup -q -n FreeRDP-%{version}
  67. #patch0 -p1
  68. #patch1 -p1
  69. %patch2 -p1
  70. cat << EOF > xfreerdp.desktop
  71. [Desktop Entry]
  72. Type=Application
  73. Name=X FreeRDP
  74. NoDisplay=true
  75. Comment=Connect to RDP server and display remote desktop
  76. Icon=%{name}
  77. Exec=/usr/bin/xfreerdp
  78. Terminal=false
  79. Categories=Network;RemoteAccess;
  80. EOF
  81. %build
  82. %cmake \
  83. -DCMAKE_BUILD_TYPE=Release \
  84. -DWITH_CUPS=ON \
  85. -DWITH_PCSC=ON \
  86. -DWITH_PULSEAUDIO=ON \
  87. -DWITH_X11=ON \
  88. -DWITH_XCURSOR=ON \
  89. -DWITH_XEXT=ON \
  90. -DWITH_XINERAMA=ON \
  91. -DWITH_XKBFILE=ON \
  92. -DWITH_XV=ON \
  93. -DWITH_ALSA=ON \
  94. -DWITH_CUNIT=OFF \
  95. -DWITH_DIRECTFB=OFF \
  96. -DWITH_FFMPEG=OFF \
  97. -DWITH_SSE2=OFF \
  98. -DCMAKE_INSTALL_LIBDIR:PATH=%{_lib} \
  99. .
  100. make %{?_smp_mflags}
  101. %install
  102. rm -rf $RPM_BUILD_ROOT
  103. make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
  104. # No need for keymap files when using xkbfile
  105. rm -rf $RPM_BUILD_ROOT/usr/share/freerdp
  106. desktop-file-install --dir=$RPM_BUILD_ROOT%{_datadir}/applications xfreerdp.desktop
  107. install -p -D resources/FreeRDP_Icon_256px.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/%{name}.png
  108. %clean
  109. rm -rf $RPM_BUILD_ROOT
  110. %post
  111. # This is no gtk application, but try to integrate nicely with GNOME if it is available
  112. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  113. %post libs -p /sbin/ldconfig
  114. %postun libs -p /sbin/ldconfig
  115. %files
  116. %defattr(-,root,root,-)
  117. %{_bindir}/xfreerdp
  118. %{_mandir}/man1/xfreerdp.*
  119. %{_datadir}/applications/xfreerdp.desktop
  120. %{_datadir}/icons/hicolor/256x256/apps/%{name}.png
  121. %files libs
  122. %defattr(-,root,root,-)
  123. %doc LICENSE README ChangeLog
  124. %{_libdir}/lib%{name}-*.so.*
  125. %dir %{_libdir}/%{name}/
  126. %files plugins
  127. %defattr(-,root,root,-)
  128. %{_libdir}/%{name}/*
  129. %files devel
  130. %defattr(-,root,root,-)
  131. %{_includedir}/%{name}/
  132. %{_libdir}/lib%{name}-*.so
  133. %{_libdir}/pkgconfig/%{name}.pc
  134. %changelog
  135. * Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-2
  136. - add BuildRequires: alsa-lib-devel
  137. * Tue Sep 23 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.0.2-1
  138. - update to 1.0.2
  139. - fixed typo in Group
  140. - dropped Patch0 and Patch1
  141. - added Patch2 to build with current xmlto
  142. * Mon Sep 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
  143. - update to 1.0.1
  144. - import patches from fedora package.
  145. - add BRs.
  146. * Fri May 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
  147. - initial build for Vine Linux
  148. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.2-3
  149. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  150. * Fri Jan 28 2011 Mads Kiilerich <mads@kiilerich.com> - 0.8.2-2
  151. - rebuild on rawhide because of broken dependencies
  152. * Tue Nov 16 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.2-1
  153. - freerdp-0.8.2
  154. * Mon Nov 08 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.1-2
  155. - make -devel require pkgconfig
  156. - first official Fedora package
  157. * Sun Nov 07 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.1-1
  158. - freerdp-0.8.1
  159. * Sat Sep 25 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.4-2
  160. - hack the generated libtool to not set rpath on x86_64
  161. - configure with alsa explicitly
  162. * Tue Aug 24 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.4-1
  163. - freerdp-0.7.4
  164. - cleanup of packaging structure
  165. * Wed Jul 28 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.3-1
  166. - 0.7.3
  167. - fix some minor pylint warnings
  168. * Fri Jul 23 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.2-2
  169. - 0.7.2
  170. - Address many comments from cwickert:
  171. - - cleanup of old formatting, alignment with spectemplate-lib.spec and
  172. cwickert spec from #616193
  173. - - add alsa as build requirement
  174. - - remove superfluous configure options and disable static libs
  175. - - add missing rpm groups
  176. * Sun Jun 13 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.0-1
  177. - First official release, first review request