foomatic-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569
  1. %define enginever 4.0.12
  2. Summary: Foomatic printer database.
  3. Name: foomatic
  4. Version: %{enginever}
  5. Release: 2%{?_dist_release}
  6. License: GPL
  7. Group: System Environment/Libraries
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: tomop, daisuke, machino
  11. Source0: http://www.linuxprinting.org/download/foomatic/foomatic-db-engine-%{enginever}.tar.gz
  12. Patch101: foomatic-manpages.patch
  13. Url: http://www.linuxprinting.org
  14. Requires: cups-filters
  15. Requires: dbus
  16. Requires: foomatic-db
  17. Requires: hplip
  18. Requires: %(eval `perl -V:version`; echo "perl(:MODULE_COMPAT_$version)")
  19. # For 'rm' and '/sbin/service' in post
  20. Requires: fileutils initscripts
  21. BuildRequires: cups
  22. BuildRequires: perl >= 5.12.3
  23. BuildRequires: libxml2-devel
  24. BuildRequires: autoconf, automake
  25. BuildRequires: mpage
  26. BuildRequires: dbus-devel
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  28. Provides: perl(Foomatic::GrovePath)
  29. # For 'rm' and '/sbin/service' in post
  30. Requires(pre): coreutils initscripts
  31. Obsoletes: foomatic-db < 4.0
  32. Obsoletes: foomatic-ppd < 4.0
  33. Obsoletes: foomatic-ppd-gimp-print < 4.0
  34. Obsoletes: foomatic-ppd-gimp-print-ijs < 4.0
  35. Obsoletes: foomatic-ppd-omni < 4.0
  36. # We need ghostscript to have the gimp-print-4.2.0 driver, and hpijs 1.1.
  37. Conflicts: ghostscript < 7.05
  38. %description
  39. Foomatic is a comprehensive, spooler-independent database of printers,
  40. printer drivers, and driver descriptions. It contains utilities to
  41. generate driver description files and printer queues for CUPS, LPD,
  42. LPRng, and PDQ using the database. There is also the possibility to
  43. read the PJL options out of PJL-capable laser printers and take them
  44. into account at the driver description file generation.
  45. There are spooler-independent command line interfaces to manipulate
  46. queues (foomatic-configure) and to print files/manipulate jobs
  47. (foomatic printjob).
  48. The site http://www.linuxprinting.org/ is based on this database.
  49. %prep
  50. %setup -q -n foomatic-db-engine-%{version}
  51. # Ship more manpages.
  52. %patch101 -p1 -b .manpages
  53. chmod a+x mkinstalldirs
  54. %build
  55. export LIB_CUPS=%{_libdir}/cups
  56. export CUPS_BACKENDS=%{_libdir}/cups/backend
  57. export CUPS_FILTERS=%{_libdir}/cups/filter
  58. export CUPS_PPDS=%{_datadir}/cups/model
  59. aclocal
  60. autoconf
  61. %configure --disable-xmltest
  62. make PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS"
  63. %install
  64. make DESTDIR=%buildroot PREFIX=%{_prefix} \
  65. INSTALLSITELIB=%{perl_vendorlib} \
  66. INSTALLSITEARCH=%{perl_vendorarch} \
  67. install
  68. # Use relative, not absolute, symlink for CUPS driver.
  69. ln -sf ../../../bin/foomatic-ppdfile %{buildroot}%{_libdir}/cups/driver/foomatic
  70. mkdir -p %{buildroot}%{_var}/cache/foomatic
  71. echo cups > %{buildroot}%{_sysconfdir}/foomatic/defaultspooler
  72. # Remove things we don't ship.
  73. rm -rf \
  74. %{buildroot}%{_libdir}/ppr \
  75. %{buildroot}%{_sysconfdir}/foomatic/filter.conf.sample \
  76. %{buildroot}%{_datadir}/foomatic/templates
  77. #%{buildroot}%%{_libdir}/perl5/site_perl
  78. find %{buildroot} -name .packlist | xargs rm -f
  79. %post
  80. /bin/rm -f /var/cache/foomatic/*
  81. exit 0
  82. %clean
  83. rm -fr %buildroot $RPM_BUILD_DIR/%{name}
  84. %files
  85. %defattr(-,root,root)
  86. %doc ChangeLog COPYING README TODO
  87. %dir %{_sysconfdir}/foomatic
  88. %config(noreplace) %{_sysconfdir}/foomatic/defaultspooler
  89. %{_bindir}/*
  90. %{_sbindir}/*
  91. %{perl_vendorlib}/Foomatic
  92. %{_libdir}/cups/driver/*
  93. %{_datadir}/foomatic
  94. %{_mandir}/*/*
  95. %{_var}/cache/foomatic
  96. %changelog
  97. * Sun Oct 4 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.12-2
  98. - removed foomatic-filters (moved to cups-filters).
  99. - moved foomatic-db as a standalone package.
  100. * Tue Jun 9 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.12-1
  101. - new upstream release.
  102. * Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 4.0.11-2
  103. - rebuild with perl-5.16
  104. - add BR: dbus-devel
  105. * Sun Jun 8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.11-1
  106. - new upstream release.
  107. * Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.9-1
  108. - new upstream release.
  109. * Mon Jun 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-2
  110. - added hplip and coreutils to "Requires:".
  111. - removed hpijs and fileutils from "Requires:".
  112. * Wed Apr 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-1
  113. - new upstream release.
  114. - dropped Source3 (no longer provided by upstream).
  115. - updated Patch2.
  116. * Thu Mar 24 2011 IWAI, Masaharu <iwai@alib.jp> 4.0.1-3
  117. - rebuild with perl 5.12.3
  118. * Fri Jul 24 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 4.0.1-2
  119. - add Requires: hpijs
  120. * Fri May 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
  121. - new upstream release
  122. * Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.0-1
  123. - new upstream release.
  124. - applied some patches from Fedora development.
  125. - remove subpackages.
  126. * Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.2-1vl5
  127. - applied new versioning policy
  128. - used rpm macros: %%perl_sitelib %%perl_sitearch
  129. - added foomatic-db-engine-3.1-20050411-combo-xml.patch
  130. - added foomatic-db-engine-3.1-20050411-perl-data.patch
  131. - fixed permission of %%{_datadir}/foomatic/db
  132. * Sat Dec 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 3.0.2-0vl5
  133. - add BuildRequires: libxml2-devel, mpage, Omni
  134. - use %%{_prefix}/lib/{cups,ppr} instead of %%{_libdir}/{cups,ppr}
  135. - run foomatic-cleanupdrivers, foomatic-compiledb with 'perl -Ilib'
  136. - not create ppd-omni package if omni support is disabled
  137. * Mon Apr 11 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl4
  138. - updated foomatic-db to 20050411
  139. - updated foomatic-db-engine to 3.1-20050411
  140. - updated foomatic-db-hpijs to 1.5-20050411
  141. - updated foomatic-filters to 3.1-20050411
  142. * Wed Jan 12 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl3
  143. - updated foomatic-db to 20050112
  144. - updated foomatic-db-engine to 3.1-20050112
  145. - updated foomatic-db-hpijs to 1.5-20050112
  146. * Tue Dec 21 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl2
  147. - updated foomatic-db to 20041220
  148. - updated foomatic-db-hpijs to 1.5-20041220
  149. * Sun Sep 19 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl1
  150. - updated foomatic-db to 20040919
  151. - updated foomatic-db-engine to 3.0.2
  152. - updated foomatic-db-hpijs to 1.5-20040919
  153. - updated foomatic-filters to 3.0.2
  154. * Wed May 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl4
  155. - update foomatic-db to 20040526
  156. - update foomatic-db-hpijs to 1.5-20040526
  157. * Tue May 25 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl3
  158. - sprit foomatic-ppd to ppd,ppd-hpijs,ppd-omni,ppd-gimp-print,
  159. ppd-gimp-print-ijs
  160. - add Requires: to ppd-* subpackages.
  161. * Thu Apr 15 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.1-0vl2
  162. - new upstream version
  163. -- Omni-printers-0.9.1
  164. -- gimp-print-foomatic-db-4.2.6
  165. - foomatic.spec -> foomatic-vl.spec
  166. * Fri Feb 20 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.1-0vl1
  167. - new upstream version
  168. -- foomatic-filters-3.0.1
  169. -- foomatic-db-engine-3.0.1
  170. -- foomatic-db-20040219
  171. -- foomatic-db-hpijs-1.5-20040219
  172. * Mon Jan 26 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl11
  173. - new upstream version
  174. -- foomatic-filters-3.0.1rc3(bug fix. in configure script)
  175. -- defined filterver
  176. - dropped patch101
  177. * Sun Jan 25 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl10
  178. - new upstream cvs version(foomatic-3.0.1rc2)
  179. -- foomatic-db-20040125
  180. -- foomatic-db-engine-3.0.1rc2
  181. -- foomatic-db-hpijs-1.5-20040125
  182. -- foomatic-filters-3.0.1rc2
  183. - added patch101
  184. -- tests diris null in foomatic-filters-3.0.1rc2
  185. * Fri Jan 23 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl9
  186. - new upstream cvs version
  187. -- foomatic-db-20040123
  188. -- foomatic-db-engine-3.0-20040123
  189. -- foomatic-db-hpijs-1.5-20040123
  190. -- foomatic-filters-3.0-20040123
  191. - dropped old patches
  192. * Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl8
  193. - built on perl-5.8.2
  194. * Tue Nov 11 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl7
  195. - separated foomatic-db package included xml files
  196. * Mon Nov 10 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl6
  197. - added description of ppd sub package
  198. * Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl5
  199. - separated foomatic-ppd package included PPD files
  200. * Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl4
  201. - new upstream version
  202. -- foomatic-db-20031109, foomatic-db-engine-3.0-20031109
  203. -- foomatic-filters-3.0-20031109, foomatic-db-hpijs-1.4-1
  204. - dropped patches
  205. -- foomatic-filters-path.patch(patch0)
  206. -- foomatic-2.0.2-fontpath.patch(patch3)
  207. - updated patches
  208. -- foomatic-filters-3.0-20031109-libdir.patch (patch1)
  209. -- foomatic-db-engine-3.0-20031109-libdir.patch (patch2)
  210. -- foomatic-filters-3.0-20031109-vine.patch (patch100)
  211. * Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl3
  212. - built on perl-5.8.1
  213. - fixed install section in spec file
  214. * Sat Aug 30 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 3.0.0-0vl2
  215. - fix some bugs of foomatic-filters.
  216. A
  217. * Sat Jun 07 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl1
  218. - new upstream version
  219. -- rewrote spec file
  220. -- added some patches from rawhide(foomatic-3.0.0-5)
  221. - enable cups support
  222. * Sun Apr 20 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl2
  223. - imported some patches from foomatic-2.0.2-18
  224. -- added foomatic-2.0.2-psc2210.patch
  225. -- added foomatic-2.0.2-duplex184.patch
  226. * Sun Mar 02 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl1
  227. - imported foomatic-2.0.2-15
  228. * Tue Feb 4 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-15
  229. - Update data-generators to CVS.
  230. * Thu Jan 30 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-14
  231. - Use hpijs, not hpijs-rss (we don't ship the RSS patch now).
  232. * Thu Jan 23 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-13
  233. - Pacify printers that don't understand duplex (bug #82385).
  234. * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 2.0.2-12
  235. - rebuilt
  236. * Tue Jan 21 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-11
  237. - Add autodetect info for HP DeskJet 656C. It doesn't really do
  238. IEEE 1284 IDs, but since it's a USB device we can figure out it's
  239. manufacturer and model anyway.
  240. * Thu Jan 9 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-10
  241. - Set GS_FONTPATH in gs wrapper (bug #81410).
  242. * Sat Jan 4 2003 Jeff Johnson <jbj@redhat.com> 2.0.2-9
  243. - use internal dep generator.
  244. * Sun Dec 15 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-8
  245. - Add several device IDs.
  246. * Sat Dec 14 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-7
  247. - Update Omni printers to 0.7.2.
  248. - No longer need Omni badxml patch.
  249. * Sat Dec 14 2002 Tim Powers <timp@redhat.com> 2.0.2-6
  250. - don't use rpms internal dep generator
  251. * Fri Dec 6 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-5
  252. - Omni XML wasn't well-formed.
  253. * Wed Nov 20 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-4
  254. - Update gimp-print data.
  255. - Add 'generic postscript' model.
  256. * Mon Nov 11 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-3
  257. - Update Omni printers to 0.7.1.
  258. * Tue Oct 22 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-2
  259. - Fix file manifest for perl modules.
  260. - Add autodetect information for HP DeskJet 990C.
  261. * Mon Oct 21 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-1
  262. - 2.0.2.
  263. - No longer need 67973, 970c patches.
  264. - Remove cups-drivers-* packages (no longer needed).
  265. - Remove files not shipped. Ship filter.conf.
  266. - Conditionally restart cups.
  267. - Use libdir.
  268. - Don't put things in site_perl; use vendor_perl instead (bug #73528).
  269. * Fri Aug 9 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.6
  270. - Fix autodetect information for HPDJ970C.
  271. * Thu Aug 8 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.5
  272. - For gimp-print, use the Ghostscript stp driver in preference to the
  273. IJS interface.
  274. * Thu Jul 25 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.4
  275. - Quieten scriptlets.
  276. * Fri Jul 5 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.3
  277. - Fix autodetect information for HPLJ2100/2100M.
  278. * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.9-1.20020617.2
  279. - automated rebuild
  280. * Wed Jun 19 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.2
  281. - Omni 0.7.0 printers.
  282. * Mon Jun 17 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.1
  283. - Update to CVS.
  284. - Remove some more explicit perl dependencies that are picked up
  285. automatically.
  286. * Wed May 29 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.3
  287. - Remove explicit perl-Storable dependency; it should be perl(Storable),
  288. and that is picked up automatically.
  289. * Tue May 28 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.2
  290. - Fix release number.
  291. - Drop gen-ppds from the file manifest---use foomatic-compiledb instead
  292. (bug #63622).
  293. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  294. - automated rebuild
  295. * Thu May 23 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.1
  296. - Remove ghostscript UPP drivers that are gone in 7.05.
  297. * Sat May 18 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.0.1
  298. - Update to CVS.
  299. - Updated requirements.
  300. - Updated path and libdir patches.
  301. - Drop hpijs 1.0.2 patch.
  302. - foomatic-datafile has moved to %%{_bindir}.
  303. - Update gimp-print data to 4.2.1.
  304. - Update Omni printer data to 0.6.1.
  305. * Thu Apr 4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.3
  306. - Fix the hpijs option data too (bug #62587).
  307. * Wed Apr 3 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.2
  308. - Back off to 1.0.2 for hpijs driver data (bug #62587).
  309. * Thu Mar 14 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.1
  310. - Update to CVS.
  311. * Wed Mar 6 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020306.1
  312. - Update to CVS.
  313. - Patches no longer needed: conffile, sys, cachedir, fd0.
  314. - Adapted path patch.
  315. * Tue Mar 5 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.10
  316. - Fix bug #58319.
  317. - Drop dbg patch.
  318. * Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.9
  319. - Fix file lists.
  320. * Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.8
  321. - Fix %post scriplet bug (bug #59942).
  322. * Thu Feb 21 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.7
  323. - Rebuild in new environment.
  324. * Wed Feb 13 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.6
  325. - Merge cups-drivers. No epoch needed.
  326. - Require perl-URI.
  327. * Wed Feb 06 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.5
  328. - Cache fix.
  329. * Mon Feb 4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.4
  330. - Don't ship backup files.
  331. * Mon Feb 4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.3
  332. - Rebuild to pick up new perl installsitelib.
  333. * Thu Jan 31 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.2
  334. - Fix a thinko in DB.pl.
  335. * Wed Jan 30 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.1
  336. - Update to CVS.
  337. - No longer need the cachedir patch.
  338. - Fix config file path.
  339. - Look in /usr/local/bin last, not first, in lpdomatic (bug #57915).
  340. * Tue Jan 29 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020129.1
  341. - Update to CVS.
  342. - Patches no longer needed: prepend, fd3.
  343. - Use RPM_OPT_FLAGS.
  344. - Allow non-root users to use foomatic-datafile (bug #58956).
  345. * Sat Jan 26 2002 Jeff Johnson <jbj@redhat.com> 1.1-0.20020124.2
  346. - added Provides: perl(Foomatic::GrovePath)
  347. * Thu Jan 24 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020124.1
  348. - Update to CVS.
  349. - Updated Omni printers to those in Omni 0.5.1.
  350. - Updated patches: prepend, fd3.
  351. - Patches no longer needed: utf8, lpdomatic.
  352. - Added gimp-print (formerly stp) foomatic db info, and removed the old
  353. stp.xml file.
  354. - Conflict with ghostscript if it doesn't have gimp-print-4.2.0 yet.
  355. * Fri Jan 18 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20011218.2
  356. - REALLY fix PCL fixup code (bug #55909, others).
  357. - PreReq fileutils, initscripts (bug #56984).
  358. - Fix prepends in lpdomatic (bug #57371).
  359. - Run foomatic-cleanupdrivers during install, to remove driver entries
  360. with no command line.
  361. - Put lpdomatic in /usr/sbin again.
  362. - Fix foomatic-gswrapper's file descriptor manipulations (bug #56871).
  363. * Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011218.1
  364. - re-imported from upstream to fix some perl fixup code on pcl printers.
  365. * Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.2
  366. - fix the rest of the quoting issues with foomatic-combo-xml with the patch
  367. - foomatic-1.1-20011217-quotes.patch. This has been sent upstream.
  368. * Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.1
  369. - respin to pull in latest foomatic database, fixes:
  370. - properly use the cache in relation to foomatic-combo-xml's output
  371. - fix _some_ of the quoting issues with calling foomatic-combo-xml
  372. * Wed Dec 5 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011205.1
  373. - respin to pull in latest foomatic database, fixes:
  374. - droping half of a large job
  375. - -Mutf8 added to the upstream filters
  376. - miscelaneous printer db updates
  377. * Thu Nov 29 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.8
  378. - added Requires: fileutils for the 'rm' in post
  379. * Mon Nov 26 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.7
  380. - /var/chache => /var/cache, doh!
  381. * Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 1.1-0.20011018.6
  382. - fix %%post scriptlet
  383. * Tue Nov 13 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.5
  384. - changed the patch to use the -Mutf8 command line option,
  385. - and to restart the printserver, after rebuilding the settings.
  386. * Fri Nov 9 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.4
  387. - grumble. Some drivers use inline perl scripts, and need the 'use utf8;'
  388. - pragma. Without it, they break on _some_ of their options.
  389. * Wed Oct 31 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.3
  390. - patched lpdomatic to prepend PostScript options in the _right_ place.
  391. * Thu Oct 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.2
  392. - zap the foomatic cache on install
  393. * Thu Oct 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.1
  394. - rolled to pull in latest information.
  395. - added Omni printers to the printer list.
  396. * Fri Oct 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011005.1
  397. - rolled to pull in an ia64 fix to foomatic-combo-xml.c
  398. * Mon Oct 01 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011001.1
  399. - rolled to pull in foomatic fixes to foomatic-combo-xml.c
  400. * Wed Sep 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010905.1
  401. - upgraded to latest foomatic, we now have fast overview generation!
  402. - this means that there is no prebuilt overview file.
  403. * Tue Aug 28 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010828.1
  404. - WOW! The latest foomatic uses Till Kamppeter's C based combo compiler.
  405. - It is now fast enough that there is no real benifit to precompiling.
  406. - NOTE: this forces the package to stop being noarched.
  407. * Mon Aug 27 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010827.1
  408. - fresh pull, maybe it fixes the build errors.
  409. * Sat Aug 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010825.1
  410. - did a fresh database pull, which contains the old japanese printers as well.
  411. - removed japanese hack.
  412. * Tue Aug 14 2001 Akira TAGOH <tagoh@redhat.com> 1.1-0.20010717.5
  413. - Add Japanese printer entry.
  414. * Mon Aug 6 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.4
  415. - move the cache back to /var, sigh.
  416. * Mon Jul 23 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.2
  417. - made foomatic pre-compute its db
  418. * Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.1
  419. - imported from mandrake.
  420. * Tue Jul 17 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010717mdk
  421. - Added job listing/removal/manipulation and queue control to
  422. foomatic-printjob
  423. - Support for printing multiple copies with PDQ
  424. * Sat Jul 14 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010714mdk
  425. - Included the cupsomatic filter script
  426. - When a queue is set up, default options can be set now
  427. - Help messages of foomatic-configure and foomatic-printjob cleaned up.
  428. * Fri Jul 13 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010713mdk
  429. - Many bugfixes in "foomatic-printjob".
  430. - "foomatic-configure" adds the Foomatic config file directory automatically
  431. to the search paths of PDQ.
  432. - Printing a help page under PDQ was broken.
  433. * Thu Jul 12 2001 Stefan van der Eijk <stefan@eijk.nu> 1.1-0.20010712mdk
  434. - BuildRequires: perl-devel
  435. * Wed Jul 11 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010711mdk
  436. - initial release.
  437. - Deleted the obsolete drivers "stp", "cZ11", and "hpdj".
  438. - Patch applied which flushes the memory cache regularly, otherwise
  439. foomatic-configure would hang when the Foomatic data of GIMP-Print is
  440. installed.