dpkg-vl.spec 8.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267
  1. Summary: Package maintenance system for Debian GNU/Linux
  2. Summary(ja): Debian GNU/Linux のパッケージ管理システム
  3. Name: dpkg
  4. Version: 1.15.5.6
  5. Release: 2%{?_dist_release}
  6. Group: System Environment/Base
  7. # The entire source code is GPLv2+ with exception of the following
  8. # lib/dpkg/md5.c, lib/dpkg/md5.h - Public domain
  9. # lib/dpkg/showpkg.c, dselect/methods/multicd, lib/dpkg/utils.c, lib/dpkg/showpkg.c - GPLv2
  10. # dselect/methods/ftp - GPL no version info
  11. # scripts/Dpkg/Gettext.pm - BSD
  12. # lib/compat/obstack.h, lib/compat/gettext.h,lib/compat/obstack.c - LGPLv2+
  13. License: GPLv2 and GPLv2+ and LGPLv2+ and Public Domain and BSD
  14. URL: http://packages.debian.org/unstable/admin/dpkg
  15. Source0: http://ftp.debian.org/debian/pool/main/d/dpkg/%{name}_%{version}.tar.bz2
  16. # obtained from dpkg-source -x dpkg_1.15.5.6.dsc
  17. Source1: dpkg.archtable
  18. # Fedora specific patch to store files under /usr/share/dpkg, not these are not binary
  19. # libs. and set user search path to /usr/local/share/dpkg
  20. Patch1: dpkg-change-libdir-path.patch
  21. # Fixes CVE-2010-0396 bugzilla #572522
  22. Patch2: fedora-fix-CVE-2010-0396-00.patch
  23. Patch3: fedora-fix-CVE-2010-0396-01.patch
  24. Patch4: fedora-bug642160-empty-argv.patch
  25. Patch5: fedora-fix-CVE-2010-1679_CVE-2011-0402.patch
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  27. BuildRequires: zlib-devel, bzip2-devel, gettext, ncurses-devel
  28. %description
  29. This package contains the tools (including dpkg-source) required
  30. to unpack, build and upload Debian source packages.
  31. This package also contains the programs dpkg which used to handle the
  32. installation and removal of packages on a Debian system.
  33. This package also contains dselect, an interface for managing the
  34. installation and removal of packages on the system.
  35. dpkg and dselect will certainly be non-functional on a rpm-based system
  36. because packages dependencies will likely be unmet.
  37. %package devel
  38. Summary: Debian package development tools
  39. Summary(ja): Debian パッケージ開発ツール
  40. Group: Development/System
  41. Requires: %{name} = %{version}-%{release}
  42. Requires: perl, patch, make, binutils, bzip2, lzma
  43. BuildArch: noarch
  44. %description devel
  45. This package provides the development tools (including dpkg-source).
  46. Required to unpack, build and upload Debian source packages
  47. %package -n dselect
  48. Summary: Debian package management front-end
  49. Summary(ja): Debian パッケージ管理フロントエンド
  50. Group: System Environment/Base
  51. Requires: %{name} = %{version}-%{release}
  52. %description -n dselect
  53. dselect is a high-level interface for the installation/removal of debs .
  54. %prep
  55. %setup -q
  56. %patch1 -p1
  57. %patch2 -p1
  58. %patch3 -p1
  59. %patch4 -p1
  60. %patch5 -p1
  61. # Filter unwanted Requires:
  62. cat << \EOF > %{name}-req
  63. #!/bin/sh
  64. %{__perl_requires} $* |\
  65. sed -e '/perl(Dselect::Ftp)/d' -e '/perl(extra)/d' -e '/perl(file)/d' -e '/perl(dpkg-gettext.pl)/d' -e '/perl(controllib.pl)/d' -e '/perl(in)/d'
  66. EOF
  67. %define __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
  68. chmod +x %{__perl_requires}
  69. %build
  70. %configure --without-start-stop-daemon \
  71. --disable-linker-optimisations \
  72. --with-admindir=%{_localstatedir}/lib/dpkg \
  73. --libdir=%{_datadir} \
  74. --with-zlib \
  75. --with-bz2 \
  76. --disable-silent-rules
  77. make %{?_smp_mflags}
  78. %install
  79. rm -rf $RPM_BUILD_ROOT
  80. make install DESTDIR=$RPM_BUILD_ROOT
  81. install -pm0644 %SOURCE1 $RPM_BUILD_ROOT/%{_datadir}/dpkg/archtable
  82. %find_lang dpkg
  83. %find_lang dpkg-dev
  84. %find_lang dselect
  85. # fedora has its own implementation
  86. rm -rf $RPM_BUILD_ROOT%{_bindir}/update-alternatives
  87. rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/alternatives/
  88. %clean
  89. rm -rf $RPM_BUILD_ROOT
  90. %files -f dpkg.lang
  91. %defattr(-,root,root,-)
  92. %doc debian/changelog README AUTHORS COPYING THANKS TODO
  93. %dir %{_sysconfdir}/dpkg
  94. %{_bindir}/dpkg
  95. %{_bindir}/dpkg-deb
  96. %{_bindir}/dpkg-query
  97. %{_bindir}/dpkg-split
  98. %{_bindir}/dpkg-trigger
  99. %{_bindir}/dpkg-divert
  100. %{_bindir}/dpkg-statoverride
  101. %{_sbindir}/*
  102. %dir %{_datadir}/dpkg
  103. %{_datadir}/dpkg/mksplit
  104. %{_datadir}/dpkg/archtable
  105. %{_datadir}/dpkg/cputable
  106. %{_datadir}/dpkg/ostable
  107. %{_datadir}/dpkg/triplettable
  108. %{perl_vendorlib}/Dpkg.pm
  109. %dir %{perl_vendorlib}/Dpkg
  110. %{perl_vendorlib}/Dpkg/Gettext.pm
  111. %{_mandir}/man1/dpkg-deb.1.gz
  112. %{_mandir}/man1/dpkg-query.1.gz
  113. %{_mandir}/man1/dpkg-split.1.gz
  114. %{_mandir}/man1/dpkg-trigger.1.gz
  115. %{_mandir}/man1/dpkg.1.gz
  116. %{_mandir}/man5/dpkg.cfg.5.gz
  117. %{_mandir}/man8/dpkg-divert.8.gz
  118. %{_mandir}/man8/dpkg-statoverride.8.gz
  119. #fedora has own implemenation
  120. %exclude %{_sbindir}/install-info
  121. #fedora has own implemenation
  122. %exclude %{_mandir}/man8/update-alternatives.8.gz
  123. %files devel -f dpkg-dev.lang
  124. %defattr(-,root,root,-)
  125. %doc doc/README.api
  126. %{_bindir}/dpkg-architecture
  127. %{_bindir}/dpkg-buildpackage
  128. %{_bindir}/dpkg-checkbuilddeps
  129. %{_bindir}/dpkg-distaddfile
  130. %{_bindir}/dpkg-genchanges
  131. %{_bindir}/dpkg-gencontrol
  132. %{_bindir}/dpkg-gensymbols
  133. %{_bindir}/dpkg-name
  134. %{_bindir}/dpkg-parsechangelog
  135. %{_bindir}/dpkg-scanpackages
  136. %{_bindir}/dpkg-scansources
  137. %{_bindir}/dpkg-shlibdeps
  138. %{_bindir}/dpkg-source
  139. %{_bindir}/dpkg-vendor
  140. %dir %{_datadir}/dpkg/parsechangelog
  141. %{_datadir}/dpkg/parsechangelog/*
  142. %exclude %{perl_vendorlib}/Dpkg/Gettext.pm
  143. %{perl_vendorlib}/Dpkg/*.pm
  144. %{perl_vendorlib}/Dpkg/Changelog
  145. %{perl_vendorlib}/Dpkg/Shlibs
  146. %{perl_vendorlib}/Dpkg/Source
  147. %{perl_vendorlib}/Dpkg/Vendor
  148. %{perl_vendorlib}/Dpkg/Control
  149. %{_mandir}/man1/dpkg-architecture.1.gz
  150. %{_mandir}/man1/dpkg-buildpackage.1.gz
  151. %{_mandir}/man1/dpkg-checkbuilddeps.1.gz
  152. %{_mandir}/man1/dpkg-distaddfile.1.gz
  153. %{_mandir}/man1/dpkg-genchanges.1.gz
  154. %{_mandir}/man1/dpkg-gencontrol.1.gz
  155. %{_mandir}/man1/dpkg-gensymbols.1.gz
  156. %{_mandir}/man1/dpkg-name.1.gz
  157. %{_mandir}/man1/dpkg-parsechangelog.1.gz
  158. %{_mandir}/man1/dpkg-scanpackages.1.gz
  159. %{_mandir}/man1/dpkg-scansources.1.gz
  160. %{_mandir}/man1/dpkg-shlibdeps.1.gz
  161. %{_mandir}/man1/dpkg-source.1.gz
  162. %{_mandir}/man1/dpkg-vendor.1.gz
  163. %{_mandir}/man5/deb-control.5.gz
  164. %{_mandir}/man5/deb-old.5.gz
  165. %{_mandir}/man5/deb-override.5.gz
  166. %{_mandir}/man5/deb-extra-override.5.gz
  167. %{_mandir}/man5/deb-shlibs.5.gz
  168. %{_mandir}/man5/deb-substvars.5.gz
  169. %{_mandir}/man5/deb-symbols.5.gz
  170. %{_mandir}/man5/deb-triggers.5.gz
  171. %{_mandir}/man5/deb-version.5.gz
  172. %{_mandir}/man5/deb.5.gz
  173. %files -n dselect -f dselect.lang
  174. %defattr(-,root,root,-)
  175. %doc dselect/methods/multicd/README.multicd dselect/methods/ftp/README.mirrors.txt
  176. %{_bindir}/dselect
  177. %{perl_vendorlib}/Debian
  178. %{_datadir}/dpkg/methods
  179. %{_mandir}/man*/dselect*.gz
  180. %changelog
  181. * Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.15.5.6-2
  182. - rebuild with gcc-5.4.0
  183. * Tue Dec 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.15.5.6-1
  184. - initial build for Vine Linux
  185. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15.5.6-7
  186. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  187. * Wed Jan 12 2011 Andrew Colin Kissa <andrew@topdog.za.net> - 1.15.5.6-6
  188. - Fix CVE-2010-1679
  189. - Fix CVE-2011-0402
  190. * Sun Oct 17 2010 Jeroen van Meeuwen <kanarip@kanarip.com> - 1.15.5.6-5
  191. - Apply minimal fix for rhbz #642160
  192. * Thu Mar 11 2010 Andrew Colin Kissa <andrew@topdog.za.net> - 1.15.5.6-4
  193. - Fix CVE-2010-0396
  194. * Mon Feb 15 2010 Andrew Colin Kissa <andrew@topdog.za.net> - 1.15.5.6-3
  195. - review changes
  196. * Sun Feb 14 2010 Andrew Colin Kissa <andrew@topdog.za.net> - 1.15.5.6-2
  197. - review changes
  198. * Sat Feb 13 2010 Andrew Colin Kissa <andrew@topdog.za.net> - 1.15.5.6-1
  199. - Upgrade to latest upstream
  200. - review changes
  201. * Tue Nov 10 2009 Andrew Colin Kissa <andrew@topdog.za.net> - 1.15.4.1-1
  202. - Upgrade to latest upstream
  203. - review changes
  204. * Tue Dec 30 2008 Leigh Scott <leigh123linux@googlemail.com> - 1.14.23-3
  205. - more review changes
  206. * Mon Dec 15 2008 Leigh Scott <leigh123linux@googlemail.com> - 1.14.23-1
  207. - bump version and make some of the review changes
  208. * Tue Aug 19 2008 Leigh Scott <leigh123linux@googlemail.com> - 1.14.20-5
  209. - made changes for review
  210. * Thu Jul 31 2008 Leigh Scott <leigh123linux@googlemail.com> - 1.14.20-4
  211. - Change release to -4 as server refused -3
  212. * Thu Jul 31 2008 Leigh Scott <leigh123linux@googlemail.com> - 1.14.20-3
  213. - split the package into dkpg, dpkg-dev & dselect
  214. * Tue Jul 29 2008 Leigh Scott <leigh123linux@googlemail.com> - 1.14.20-2
  215. - recode man files to UTF8
  216. * Tue Jul 29 2008 Leigh Scott <leigh123linux@googlemail.com> - 1.14.20-1
  217. - Rebuild ans add build requires ncurses-devel
  218. * Thu Jul 19 2007 Patrice Dumas <pertusus@free.fr> - 1.14.5-1
  219. - initial packaging