dbus-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define gettext_package dbus
  3. %define expat_version 2.0.1
  4. %define dbus_user_uid 81
  5. %define _localstatedir %{_var}
  6. Summary: D-BUS message bus
  7. Summary(ja): D-BUS メッセージバスシステム
  8. Name: dbus
  9. Version: 1.8.20
  10. Release: 1%{?_dist_release}
  11. URL: http://www.freedesktop.org/software/dbus/
  12. License: AFL/GPLv2
  13. Group: System Environment/Libraries
  14. Source0: %{name}-%{version}.tar.gz
  15. Source1: doxygen_to_devhelp.xsl
  16. # from fedora package
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. Requires(post): chkconfig >= 1.3.34
  19. Requires(preun): chkconfig >= 1.3.34
  20. Requires(pre): shadow-utils
  21. BuildRequires: libtool
  22. BuildRequires: expat-devel >= %{expat_version}
  23. BuildRequires: libxml2-devel
  24. BuildRequires: python-devel
  25. BuildRequires: doxygen
  26. BuildRequires: xmlto
  27. BuildRequires: libxslt
  28. BuildRequires: gettext
  29. BuildRequires: libX11-devel
  30. BuildRequires: libSM-devel
  31. Vendor: Project Vine
  32. Distribution: Vine Linux
  33. %description
  34. D-BUS is a system for sending messages between applications. It is
  35. used both for the systemwide message bus service, and as a
  36. per-user-login-session messaging facility.
  37. %description -l ja
  38. D-BUS はアプリケーション間でメッセージを送受信するためのシステムです。
  39. システム全体のメッセージバスサービスとしても利用されますが、同様に
  40. ユーザ毎のログインセッションにおけるメッセージ基盤としても利用されます。
  41. %package devel
  42. Summary: Libraries and headers for D-BUS
  43. Summary(ja): D-BUS 用のライブラリとヘッダファイル
  44. Group: Development/Libraries
  45. Requires: %{name} = %{version}-%{release}
  46. %description devel
  47. Headers and static libraries for D-BUS.
  48. %package x11
  49. Summary: X11-requiring add-ons for D-BUS
  50. Summary(ja): X11 を利用する D-BUS 用ツール
  51. Group: Applications/System
  52. Requires: %{name} = %{version}-%{release}
  53. %description x11
  54. D-BUS contains some tools that require Xlib to be installed, those are
  55. in this separate package so server systems need not install X.
  56. %package doc
  57. Summary: Developer documentation for D-BUS
  58. Group: Documentation
  59. Requires: %{name} = %{version}-%{release}
  60. BuildArch: noarch
  61. %description doc
  62. This package contains developer documentation for D-Bus along with
  63. other supporting documentation such as the introspect dtd file.
  64. # compat32
  65. %package -n compat32-%{name}
  66. Summary: D-BUS message bus
  67. Summary(ja): D-BUS メッセージバスシステム
  68. Group: System Environment/Libraries
  69. %description -n compat32-%{name}
  70. D-BUS is a system for sending messages between applications. It is
  71. used both for the systemwide message bus service, and as a
  72. per-user-login-session messaging facility.
  73. %description -n compat32-%{name} -l ja
  74. D-BUS はアプリケーション間でメッセージを送受信するためのシステムです。
  75. システム全体のメッセージバスサービスとしても利用されますが、同様に
  76. ユーザ毎のログインセッションにおけるメッセージ基盤としても利用されます。
  77. %package -n compat32-%{name}-devel
  78. Summary: Libraries and headers for D-BUS
  79. Summary(ja): D-BUS 用のライブラリとヘッダファイル
  80. Group: Development/Libraries
  81. Requires: compat32-%{name} = %{version}-%{release}
  82. Requires: %{name}-devel = %{version}-%{release}
  83. %description -n compat32-%{name}-devel
  84. Headers and static libraries for D-BUS.
  85. %prep
  86. %setup -q
  87. %build
  88. autoreconf -f -i
  89. COMMON_ARGS="--enable-selinux=no \
  90. --disable-libaudit \
  91. --with-init-scripts=redhat \
  92. --with-system-pid-file=%{_localstatedir}/run/messagebus.pid \
  93. --with-dbus-user=dbus \
  94. --libdir=/%{_lib} --bindir=/bin \
  95. --libexecdir=/%{_lib}/dbus-1 \
  96. --sysconfdir=%{_sysconfdir} --exec-prefix=/"
  97. %configure $COMMON_ARGS --disable-tests --disable-verbose-mode --disable-asserts --enable-doxygen-docs --enable-xml-docs
  98. %__make
  99. doxygen Doxyfile
  100. xsltproc -o dbus.devhelp %{SOURCE1} doc/api/xml/index.xml
  101. %install
  102. rm -rf %{buildroot}
  103. %__make install DESTDIR=$RPM_BUILD_ROOT
  104. mkdir -p $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
  105. #change the arch-deps.h include directory to /usr/lib[64] instead of /lib[64]
  106. sed -e 's@-I${libdir}@-I${prefix}/%{_lib}@' $RPM_BUILD_ROOT/%{_lib}/pkgconfig/dbus-1.pc > $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/dbus-1.pc
  107. rm -f $RPM_BUILD_ROOT/%{_lib}/pkgconfig/dbus-1.pc
  108. mkdir -p $RPM_BUILD_ROOT/%{_bindir}
  109. mv -f $RPM_BUILD_ROOT/bin/dbus-launch $RPM_BUILD_ROOT/%{_bindir}
  110. mkdir -p $RPM_BUILD_ROOT/%{_libdir}/dbus-1.0/include/
  111. mv -f $RPM_BUILD_ROOT/%{_lib}/dbus-1.0/include/* $RPM_BUILD_ROOT/%{_libdir}/dbus-1.0/include/
  112. rm -rf $RPM_BUILD_ROOT/%{_lib}/dbus-1.0
  113. rm -f $RPM_BUILD_ROOT/%{_lib}/*.a
  114. rm -f $RPM_BUILD_ROOT/%{_lib}/*.la
  115. mkdir -p $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
  116. mkdir -p $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus/api
  117. cp dbus.devhelp $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
  118. cp doc/dbus-specification.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
  119. cp doc/dbus-faq.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
  120. cp doc/dbus-tutorial.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
  121. cp doc/api/html/* $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus/api
  122. ## %find_lang %{gettext_package}
  123. mkdir -p $RPM_BUILD_ROOT%{_datadir}/dbus-1/interfaces
  124. %clean
  125. rm -rf %{buildroot}
  126. %pre
  127. # Add the "dbus" user
  128. /usr/sbin/useradd -c 'System message bus' -u %{dbus_user_uid} \
  129. -s /sbin/nologin -r -d '/' dbus 2> /dev/null || :
  130. %post
  131. /sbin/ldconfig
  132. /sbin/chkconfig --add messagebus
  133. /sbin/chkconfig messagebus resetpriorities
  134. %preun
  135. if [ $1 = 0 ]; then
  136. service messagebus stop > /dev/null 2>&1
  137. /sbin/chkconfig --del messagebus
  138. fi
  139. %postun
  140. /sbin/ldconfig
  141. %post -n compat32-%{name} -p /sbin/ldconfig
  142. %postun -n compat32-%{name} -p /sbin/ldconfig
  143. %files
  144. %defattr(-,root,root)
  145. %doc COPYING ChangeLog NEWS
  146. %dir %{_sysconfdir}/dbus-1
  147. %config %{_sysconfdir}/dbus-1/*.conf
  148. %{_sysconfdir}/rc.d/init.d/*
  149. %dir %{_sysconfdir}/dbus-1/system.d
  150. %dir %{_sysconfdir}/dbus-1/session.d
  151. %dir %{_localstatedir}/run/dbus
  152. %dir %{_localstatedir}/lib/dbus/
  153. /bin/dbus-daemon
  154. /bin/dbus-send
  155. /bin/dbus-cleanup-sockets
  156. /bin/dbus-monitor
  157. /bin/dbus-run-session
  158. /bin/dbus-uuidgen
  159. /%{_lib}/*dbus-1*.so.*
  160. %{_datadir}/man/man*/dbus-cleanup-sockets.1.gz
  161. %{_datadir}/man/man*/dbus-daemon.1.gz
  162. %{_datadir}/man/man*/dbus-monitor.1.gz
  163. %{_datadir}/man/man*/dbus-run-session.1.gz
  164. %{_datadir}/man/man*/dbus-send.1.gz
  165. %{_datadir}/man/man*/dbus-uuidgen.1.gz
  166. %dir %{_datadir}/dbus-1
  167. %{_datadir}/dbus-1/services
  168. %{_datadir}/dbus-1/system-services
  169. %{_datadir}/dbus-1/interfaces
  170. %dir /%{_lib}/dbus-1
  171. %attr(4750,root,dbus) /%{_lib}/dbus-1/dbus-daemon-launch-helper
  172. %files devel
  173. %defattr(-,root,root)
  174. /%{_lib}/lib*.so
  175. %{_libdir}/dbus-1.0/include
  176. %{_libdir}/pkgconfig/*
  177. %{_includedir}/*
  178. %{_datadir}/devhelp/books/dbus
  179. %files x11
  180. %defattr(-,root,root)
  181. %{_bindir}/dbus-launch
  182. %{_datadir}/man/man*/dbus-launch.1.gz
  183. %files doc
  184. %defattr(-,root,root)
  185. %doc %{_docdir}/dbus
  186. # compat32
  187. %if %{build_compat32}
  188. %files -n compat32-%{name}
  189. /%{_lib}/*dbus-1*.so.*
  190. %files -n compat32-%{name}-devel
  191. %defattr(-,root,root)
  192. /%{_lib}/lib*.so
  193. %{_libdir}/dbus-1.0/include
  194. %endif
  195. %changelog
  196. * Sun Aug 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.20-1
  197. - new upstream release
  198. * Sun Jun 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.18-1
  199. - new upstream release
  200. * Sun Mar 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.16-1
  201. - new upstream release
  202. * Sat Jan 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.14-1
  203. - new upstream release
  204. * Mon Dec 01 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.28-1
  205. - new upstream release
  206. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.24-1
  207. - new upstream release
  208. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.22-1
  209. - new upstream release
  210. * Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.20-1
  211. - new upstream release
  212. * Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.18-1
  213. - new upstream release
  214. * Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
  215. - new upstream release
  216. * Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
  217. - new upstream release
  218. * Sun Oct 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-2
  219. - remove BuildRequires: audit-libs-devel, libcap-ng-devel
  220. * Sat Oct 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
  221. - new upstream release
  222. - remove old patches
  223. * Sun Apr 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.20-1
  224. - new upstream release
  225. - add BuildRequires: audit-libs-devel, libcap-ng-devel
  226. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.18-1
  227. - new upstream release
  228. - remove Requires: libxml2-python
  229. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.16-1
  230. - new upstream release
  231. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-1
  232. - new upstream release
  233. - drop Patch1
  234. - create -doc sub package
  235. * Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
  236. - new upstream release
  237. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
  238. - new upstream release
  239. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.2.24-3
  240. - add BuildRequires: libSM-devel
  241. * Tue Sep 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.24-2
  242. - rebuilt with rpm-4.8.1
  243. * Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.24-1
  244. - new upstream release
  245. - drop Patch0
  246. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.16-2
  247. - rebuilt with new toolchain
  248. * Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.16-1
  249. - new upstream release
  250. * Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.14-1
  251. - new upstream release
  252. - do not restart dbus on upgrade
  253. * Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.12-3
  254. - added compat32 package for x86_64 arch support
  255. * Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.12-2
  256. - add Patch10 for workaround deny send_interface
  257. http://bugs.freedesktop.org/show_bug.cgi?id=18961
  258. Bug 18961: Skip bare <deny send_interface=""/> for not (method_call|signal)
  259. Bare <deny send_interface=""/> rules have a far larger impact than one would think.
  260. It's really always wrong to use them without also using send_destination.
  261. - XXX: this should be fixed in each dbus configuration.
  262. * Tue Mar 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1
  263. - new upstream release with security fix (CVE-2008-4311)
  264. * Fri Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.4-1
  265. - new upstream release with security fix (CVE-2008-3834)
  266. * Fri Aug 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-1
  267. - new upstream release
  268. * Thu Aug 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-3
  269. - own the directories /usr/share/dbus-1/{system-services,interfaces}
  270. - set 'dbus' instead of '81' to --with-dbus-user
  271. * Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-2
  272. - import some patches from fedora
  273. - move dbus-daemon-launch-helper to /%%{_lib}/dbus-1/
  274. * Wed May 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
  275. - new upstream release
  276. * Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl5
  277. - new upstream release
  278. * Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.2-0vl4
  279. - rebuild with expat-2.0.1
  280. * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl3
  281. - rebuild with new environment/toolchain
  282. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl2
  283. - require new chkconfig to reset initscript priorities
  284. * Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
  285. - new upstream release
  286. - split out bindings
  287. - move base binaries and libraries to /bin and /%{_lib}
  288. * Wed Dec 27 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.62-0vl2
  289. - rebuilt for VineSeed
  290. * Thu Dec 21 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.62-0vl1.2
  291. - add Vendor/Distribution tag
  292. * Thu Dec 14 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.62-0vl1.1
  293. - add patch100 for fix CVE-2006-6107
  294. * Wed Nov 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.62-0vl1
  295. - new upstream release
  296. * Sat Jun 10 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.61-0vl2
  297. - disabled dbus-qt
  298. - added BuildConflicts: qt-devel
  299. - removed work around for 64 bit archs
  300. * Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.61-0vl1
  301. - new upstream release
  302. * Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.60-0vl1
  303. - new upstream release
  304. * Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50-0vl1
  305. - new upstream release
  306. * Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.34-0vl1
  307. - new upstream release
  308. - enable python bindings
  309. * Sat Mar 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.23-4vl1
  310. - initial build for Vine Linux based on FC package
  311. - disable python bindings
  312. - disable selinux
  313. * Tue Feb 01 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-4
  314. - Explicitly pass in the pid file location to ./configure instead of
  315. letting it guess based on the build enviornment
  316. * Mon Jan 31 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-3
  317. - Add patch to fix random users from connecting to a users session bus
  318. * Fri Jan 21 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-2
  319. - Add Steve Grubb's SE-Linux audit patch (Bug# 144920)
  320. * Fri Jan 21 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-1
  321. - Update to upstream version 0.23
  322. - Drop all patches except for the UDI patch as they have been
  323. integrated upstream
  324. - List of API changes:
  325. * add setgroups() to drop supplementary groups
  326. * removed dbus_bug_get_with_g_main since it's been replaced by dbus_g_bus_get
  327. * added support for int64 and uint64 to the python bindings
  328. * use SerivceOwnerChanges signal instead of ServiceCreated and ServiceDeleted
  329. * Mon Nov 8 2004 Jeremy Katz <katzj@redhat.com> - 0.22-12
  330. - rebuild against python 2.4
  331. * Tue Nov 02 2004 John (J5) Palmieri <johnp@redhat.com>
  332. - Add a requires for glib2-devel in the devel package
  333. - Add SE-Linux backport from Colin Walters that fixes
  334. messages getting lost in SE-Linux contexts
  335. * Wed Oct 13 2004 John (J5) Palmieri <johnp@redhat.com>
  336. - Bump up release and rebuild
  337. * Mon Oct 11 2004 Tim Waugh <twaugh@redhat.com>
  338. - Run /sbin/ldconfig for glib sub-package (bug #134062).
  339. * Wed Sep 22 2004 John (J5) Palmieri <johnp@redhat.com>
  340. - Fixed patch to use dbus-1 instead of dbus-1.0
  341. - (configure.in): Exported just the datadir instead of
  342. the full path to the dbus datadir for consistency
  343. * Wed Sep 22 2004 John (J5) Palmieri <johnp@redhat.com>
  344. - Adding patch to move /usr/lib/dbus-1.0/services to
  345. /usr/share/dbus-1.0/services
  346. * Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
  347. - reverting BuildRequires: redhat-release because of issues with build system
  348. - added precompiled version of the messagebus init script
  349. * Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
  350. - changed /etc/redhat-release to the package redhat-release
  351. * Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
  352. - added python int64 patch from davidz
  353. * Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
  354. - added BuildRequires: /etc/redhat-release (RH Bug #132436)
  355. * Wed Aug 18 2004 John (J5) Palmieri <johnp@redhat.com>
  356. - Added Steve Grubb's spec file patch (RH Bug #130201)
  357. * Mon Aug 16 2004 John (J5) Palmieri <johnp@redhat.com>
  358. - Disabled dbus-gtk since dbus-viewer doesn't do anything right now
  359. * Mon Aug 16 2004 John (J5) Palmieri <johnp@redhat.com>
  360. - Moved dbus-viewer to new dbus-gtk package so that dbus-glib
  361. no longer requires X or GTK libraries. (RH Bug #130029)
  362. * Thu Aug 12 2004 John (J5) Palmieri <johnp@redhat.com>
  363. - Update to new 0.22 release
  364. * Thu Aug 05 2004 John (J5) Palmieri <johnp@redhat.com>
  365. - Added BuildRequires for libselinux-devel and Requires for libselinux
  366. * Mon Aug 02 2004 Colin Walters <walters@redhat.com>
  367. - Add SE-DBus patch
  368. * Fri Jul 30 2004 John (J5) Palmieri <johnp@redhat.com>
  369. - Added lib64 workaround for python bindings installing to
  370. the wrong lib directory on 64 bit archs
  371. * Fri Jul 30 2004 John (J5) Palmieri <johnp@redhat.com>
  372. - Updated console-auth patch
  373. - rebuild
  374. * Thu Jul 22 2004 John (J5) Palmieri <johnp@redhat.com>
  375. - Update to upstream CVS build
  376. - Added console-auth patch
  377. * Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
  378. - Workaround added to fix gcc-3.4 bug on ia64
  379. * Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
  380. - require new Pyrex version and see if it builds this time
  381. * Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
  382. - rebuild with updated Pyrex (0.9.2.1)
  383. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  384. - rebuilt
  385. * Fri Jun 04 2004 John (J5) Palmieri <johnp@redhat.com>
  386. - Moved dbus-viewer, dbus-monitor and dbus-glib-tool
  387. into the dbus-glib package so that the main dbus
  388. package does not depend on glib (Bug #125285)
  389. * Thu Jun 03 2004 John (J5) Palmieri <johnp@redhat.com>
  390. - rebuilt
  391. * Thu May 27 2004 John (J5) Palmieri <johnp@redhat.com>
  392. - added my Python patch
  393. - took out the qt build requires
  394. - added a gtk+ build requires
  395. * Fri Apr 23 2004 John (J5) Palmieri <johnp@redhat.com>
  396. - Changed build requirement to version 0.9-3 of Pyrex
  397. to fix problem with builing on x86_64
  398. * Tue Apr 20 2004 John (J5) Palmieri <johnp@redhat.com>
  399. - update to upstream 0.21
  400. - removed dbus-0.20-varargs.patch patch (fixed upstream)
  401. * Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com>
  402. - added a dbus-python package to generate python bindings
  403. - added Pyrex build dependacy
  404. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  405. - rebuilt
  406. * Wed Feb 25 2004 Bill Nottingham <notting@redhat.com> 0.20-4
  407. - fix dbus error functions on x86-64 (#116324)
  408. - add prereq (#112027)
  409. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  410. - rebuilt
  411. * Fri Feb 13 2004 Tim Waugh <twaugh@redhat.com>
  412. - Conflict with cups prior to configuration file change, so that the
  413. %%postun service condrestart works.
  414. * Wed Feb 11 2004 Havoc Pennington <hp@redhat.com> 0.20-2
  415. - rebuild in fc2, cups now updated
  416. * Wed Jan 7 2004 Bill Nottingham <notting@redhat.com> 0.20-1
  417. - update to upstream 0.20
  418. * Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-6
  419. - hmm, dbus doesn't support uids in the config file. fix.
  420. * Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-5
  421. - put uid instead of username in the config file, to keep things working with name change
  422. * Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-4
  423. - make subpackages require the specific release, not just version, of base package
  424. * Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-3
  425. - change system user "messagebus" -> "dbus" to be under 8 chars
  426. * Mon Sep 29 2003 Havoc Pennington <hp@redhat.com> 0.13-2
  427. - see if removing qt subpackage for now will get us through the build system,
  428. qt bindings not useful yet anyway
  429. * Sun Sep 28 2003 Havoc Pennington <hp@redhat.com> 0.13-1
  430. - 0.13 fixes a little security oops
  431. * Mon Aug 4 2003 Havoc Pennington <hp@redhat.com> 0.11.91-3
  432. - break the tiny dbus-launch that depends on X into separate package
  433. so a CUPS server doesn't need X installed
  434. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  435. - rebuilt
  436. * Sat May 17 2003 Havoc Pennington <hp@redhat.com> 0.11.91-1
  437. - 0.11.91 cvs snap properly merges system.d
  438. * Fri May 16 2003 Havoc Pennington <hp@redhat.com> 0.11.90-1
  439. - build a cvs snap with a few more fixes
  440. * Fri May 16 2003 Havoc Pennington <hp@redhat.com> 0.11-2
  441. - fix a crash that was breaking cups
  442. * Thu May 15 2003 Havoc Pennington <hp@redhat.com> 0.11-1
  443. - 0.11
  444. * Thu May 15 2003 Havoc Pennington <hp@redhat.com> 0.10.90-1
  445. - use rc.d/init.d not init.d, bug #90192
  446. - include the new man pages
  447. * Fri Apr 11 2003 Havoc Pennington <hp@redhat.com> 0.9-1
  448. - 0.9
  449. - export QTDIR explicitly
  450. - re-enable qt, the problem was most likely D-BUS configure
  451. * Tue Apr 1 2003 Havoc Pennington <hp@redhat.com> 0.6.94-1
  452. - update from CVS with a fix to set uid after gid
  453. * Tue Apr 1 2003 Havoc Pennington <hp@redhat.com> 0.6.93-1
  454. - new cvs snap that actually forks to background and changes
  455. user it's running as and so forth
  456. - create our system user in pre
  457. * Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.92-1
  458. - fix for "make check" test that required a home directory
  459. * Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.91-1
  460. - disable qt for now because beehive hates me
  461. - pull a slightly newer cvs snap that creates socket directory
  462. - cat the make check log after make check fails
  463. * Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.90-1
  464. - initial build