cryptsetup-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418
  1. %define _root_sbindir /sbin
  2. %define upstream_version %{version}
  3. Summary: A utility for setting up encrypted disks
  4. Summary(ja): 暗号化ファイルシステム設定用ユーティリティ
  5. Name: cryptsetup
  6. Version: 1.4.1
  7. Release: 4%{?_dist_release}
  8. License: GPLv2 and LGPLv2+
  9. Group: Applications/System
  10. URL: http://cryptsetup.googlecode.com/
  11. Source0: http://cryptsetup.googlecode.com/files/cryptsetup-%{upstream_version}.tar.bz2
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: libgcrypt-devel
  14. BuildRequires: popt-devel
  15. BuildRequires: device-mapper-devel
  16. BuildRequires: libgpg-error-devel
  17. BuildRequires: libuuid-devel
  18. BuildRequires: python-devel
  19. Provides: cryptsetup-luks = %{version}-%{release}
  20. Obsoletes: cryptsetup-luks < 1.4.0
  21. Requires: cryptsetup-libs = %{version}-%{release}
  22. %description
  23. The cryptsetup package contains a utility for setting up
  24. disk encryption using dm-crypt kernel module.
  25. %description -l ja
  26. cryptsetup パッケージには、dm-crypt カーネルモジュールを使って
  27. ディスクの暗号化を設定するユーティリティが収録されています。
  28. %package devel
  29. Summary: Headers and libraries for using encrypted file systems
  30. Summary(ja): 暗号化ファイルシステムを使うためのヘッダとライブラリ
  31. Group: Development/Libraries
  32. Requires: %{name} = %{version}-%{release}
  33. Requires: libgcrypt-devel > 1.1.42
  34. Requires: device-mapper-devel
  35. Requires: libuuid-devel
  36. Requires: pkgconfig
  37. Provides: cryptsetup-luks-devel = %{version}-%{release}
  38. Obsoletes: cryptsetup-luks-devel < 1.4.0
  39. %description devel
  40. The cryptsetup-devel package contains libraries and header files
  41. used for writing code that makes use of disk encryption.
  42. %description devel -l ja
  43. cryptsetup-devel パッケージには、ディスクの暗号化を使うコードを
  44. 書くのに使われるライブラリとヘッダファイルが収録されています。
  45. %package libs
  46. Summary: Cryptsetup shared library
  47. Summary(ja): Cryptsetup 共有ライブラリ
  48. Group: System Environment/Libraries
  49. Provides: cryptsetup-luks-libs = %{version}-%{release}
  50. Obsoletes: cryptsetup-luks-libs < 1.4.0
  51. %description libs
  52. This package contains the cryptsetup shared library, libcryptsetup.
  53. %description libs -l ja
  54. このパッケージには、cryptsetup の共有ライブラリ、libcryptsetup が
  55. 収録されています。
  56. %package python
  57. Summary: Python bindings for libcryptsetup
  58. Summary(ja): libcryptsetup の Python バインディング
  59. Group: System Environment/Libraries
  60. Requires: %{name}-libs = %{version}-%{release}
  61. Provides: python-cryptsetup = %{version}-%{release}
  62. Obsoletes: python-cryptsetup < 1.4.0
  63. %description python
  64. This package provides Python bindings for libcryptsetup, a library
  65. for setting up disk encryption using dm-crypt kernel module.
  66. %description python -l ja
  67. このパッケージには、dm-crypt カーネルモジュールを使って
  68. ディスクの暗号化を設定するライブラリ libcryptsetup の
  69. Python バインディングが収録されています。
  70. %prep
  71. %setup -q -n cryptsetup-%{upstream_version}
  72. chmod -x python/pycryptsetup-test.py
  73. %build
  74. %configure --sbindir=%{_root_sbindir} --libdir=/%{_lib} \
  75. --enable-python \
  76. --disable-selinux
  77. # remove rpath
  78. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  79. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  80. make %{?_smp_mflags}
  81. %install
  82. rm -rf %{buildroot}
  83. make install DESTDIR=%{buildroot}
  84. rm -rf %{buildroot}/%{_lib}/*.la %{buildroot}/%{_lib}/cryptsetup
  85. # move libcryptsetup.so to %%{_libdir}
  86. pushd %{buildroot}/%{_lib}
  87. rm libcryptsetup.so
  88. mkdir -p %{buildroot}/%{_libdir}
  89. ln -s ../../%{_lib}/$(ls libcryptsetup.so.?.?.?) %{buildroot}/%{_libdir}/libcryptsetup.so
  90. mv %{buildroot}/%{_lib}/pkgconfig %{buildroot}/%{_libdir}
  91. popd
  92. %find_lang cryptsetup
  93. %post -n cryptsetup-libs -p /sbin/ldconfig
  94. %postun -n cryptsetup-libs -p /sbin/ldconfig
  95. %files -f cryptsetup.lang
  96. %doc COPYING ChangeLog AUTHORS TODO FAQ
  97. %{_mandir}/man8/cryptsetup.8.gz
  98. %{_root_sbindir}/cryptsetup
  99. %files devel
  100. %doc docs/examples/*
  101. %{_includedir}/libcryptsetup.h
  102. %{_libdir}/libcryptsetup.so
  103. %{_libdir}/pkgconfig/libcryptsetup.pc
  104. %files libs
  105. %doc COPYING
  106. /%{_lib}/libcryptsetup.so.*
  107. %files python
  108. %doc COPYING.LGPL python/pycryptsetup-test.py
  109. %exclude %{python_sitearch}/pycryptsetup.la
  110. %{python_sitearch}/pycryptsetup.so
  111. %clean
  112. rm -rf %{buildroot}
  113. %changelog
  114. * Sat Dec 6 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.4.1-4
  115. - rebuilt with libgcrypt 1.6.0
  116. * Fri Mar 23 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.1-3
  117. - updated to 1.4.1; spec revamp; Japanese summary & description
  118. - Sun Sep 21 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.5-8vl5
  119. - applied new versioning policy
  120. - Sun Dec 9 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.5-7vl1
  121. - initial build for VineSeed
  122. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.1-2
  123. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  124. * Wed Nov 09 2011 Milan Broz <mbroz@redhat.com> - 1.4.1-1
  125. - Update to cryptsetup 1.4.1.
  126. - Add Python cryptsetup bindings.
  127. - Obsolete separate python-cryptsetup package.
  128. * Wed Oct 26 2011 Milan Broz <mbroz@redhat.com> - 1.4.0-1
  129. - Update to cryptsetup 1.4.0.
  130. * Mon Oct 10 2011 Milan Broz <mbroz@redhat.com> - 1.4.0-0.1
  131. - Update to cryptsetup 1.4.0-rc1.
  132. - Rename package back from cryptsetup-luks to cryptsetup.
  133. * Wed Jun 22 2011 Milan Broz <mbroz@redhat.com> - 1.3.1-2
  134. - Fix return code for status command when device doesn't exist.
  135. * Tue May 24 2011 Milan Broz <mbroz@redhat.com> - 1.3.1-1
  136. - Update to cryptsetup 1.3.1.
  137. * Tue Apr 05 2011 Milan Broz <mbroz@redhat.com> - 1.3.0-1
  138. - Update to cryptsetup 1.3.0.
  139. * Tue Mar 22 2011 Milan Broz <mbroz@redhat.com> - 1.3.0-0.2
  140. - Update to cryptsetup 1.3.0-rc2
  141. * Mon Mar 14 2011 Milan Broz <mbroz@redhat.com> - 1.3.0-0.1
  142. - Update to cryptsetup 1.3.0-rc1
  143. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-2
  144. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  145. * Mon Dec 20 2010 Milan Broz <mbroz@redhat.com> - 1.2.0-1
  146. - Update to cryptsetup 1.2.0
  147. * Thu Nov 25 2010 Milan Broz <mbroz@redhat.com> - 1.2.0-0.2
  148. - Fix crypt_activate_by_keyfile() to work with PLAIN devices.
  149. * Tue Nov 16 2010 Milan Broz <mbroz@redhat.com> - 1.2.0-0.1
  150. - Add FAQ to documentation.
  151. - Update to cryptsetup 1.2.0-rc1
  152. * Sat Jul 03 2010 Milan Broz <mbroz@redhat.com> - 1.1.3-1
  153. - Update to cryptsetup 1.1.3
  154. * Mon Jun 07 2010 Milan Broz <mbroz@redhat.com> - 1.1.2-2
  155. - Fix alignment ioctl use.
  156. - Fix API activation calls to handle NULL device name.
  157. * Sun May 30 2010 Milan Broz <mbroz@redhat.com> - 1.1.2-1
  158. - Update to cryptsetup 1.1.2
  159. - Fix luksOpen handling of new line char on stdin.
  160. * Sun May 23 2010 Milan Broz <mbroz@redhat.com> - 1.1.1-1
  161. - Update to cryptsetup 1.1.1
  162. - Fix luksClose for stacked LUKS/LVM devices.
  163. * Mon May 03 2010 Milan Broz <mbroz@redhat.com> - 1.1.1-0.2
  164. - Update to cryptsetup 1.1.1-rc2.
  165. * Sat May 01 2010 Milan Broz <mbroz@redhat.com> - 1.1.1-0.1
  166. - Update to cryptsetup 1.1.1-rc1.
  167. * Sun Jan 17 2010 Milan Broz <mbroz@redhat.com> - 1.1.0-1
  168. - Update to cryptsetup 1.1.0.
  169. * Fri Jan 15 2010 Milan Broz <mbroz@redhat.com> - 1.1.0-0.6
  170. - Fix gcrypt initialisation.
  171. - Fix backward compatibility for hash algorithm (uppercase).
  172. * Wed Dec 30 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.5
  173. - Update to cryptsetup 1.1.0-rc4
  174. * Mon Nov 16 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.4
  175. - Update to cryptsetup 1.1.0-rc3
  176. * Thu Oct 01 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.3
  177. - Update to cryptsetup 1.1.0-rc2
  178. - Fix libcryptsetup to properly export only versioned symbols.
  179. * Tue Sep 29 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.2
  180. - Update to cryptsetup 1.1.0-rc1
  181. - Add luksHeaderBackup and luksHeaderRestore commands.
  182. * Thu Sep 11 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.1
  183. - Update to new upstream testing version with new API interface.
  184. - Add luksSuspend and luksResume commands.
  185. - Introduce pkgconfig.
  186. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.7-2
  187. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  188. * Wed Jul 22 2009 Milan Broz <mbroz@redhat.com> - 1.0.7-1
  189. - Update to upstream final release.
  190. - Split libs subpackage.
  191. - Remove rpath setting from cryptsetup binary.
  192. * Wed Jul 15 2009 Till Maas <opensource@till.name> - 1.0.7-0.2
  193. - update BR because of libuuid splitout from e2fsprogs
  194. * Mon Jun 22 2009 Milan Broz <mbroz@redhat.com> - 1.0.7-0.1
  195. - Update to new upstream 1.0.7-rc1.
  196. - Wipe old fs headers to not confuse blkid (#468062)
  197. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.6-7
  198. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  199. * Thu Oct 30 2008 Milan Broz <mbroz@redhat.com> - 1.0.6-6
  200. - Wipe old fs headers to not confuse blkid (#468062)
  201. * Tue Sep 23 2008 Milan Broz <mbroz@redhat.com> - 1.0.6-5
  202. - Change new project home page.
  203. - Print more descriptive messages for initialization errors.
  204. - Refresh patches to versions commited upstream.
  205. * Sat Sep 06 2008 Milan Broz <mbroz@redhat.com> - 1.0.6-4
  206. - Fix close of zero decriptor.
  207. - Fix udevsettle delays - use temporary crypt device remapping.
  208. * Wed May 28 2008 Till Maas <opensource till name> - 1.0.6-3
  209. - remove a duplicate sentence from the manpage (RH #448705)
  210. - add patch metadata about upstream status
  211. * Tue Apr 15 2008 Bill Nottinghm <notting@redhat.com> - 1.0.6-2
  212. - Add the device to the luksOpen prompt (#433406)
  213. - Use iconv, not recode (#442574)
  214. * Thu Mar 13 2008 Till Maas <opensource till name> - 1.0.6-1
  215. - Update to latest version
  216. - remove patches that have been merged upstream
  217. * Mon Mar 03 2008 Till Maas <opensource till name> - 1.0.6-0.1.pre2
  218. - Update to new version with several bugfixes
  219. - remove patches that have been merged upstream
  220. - add patch from cryptsetup newsgroup
  221. - fix typo / missing luksRemoveKey in manpage (patch)
  222. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.5-9
  223. - Autorebuild for GCC 4.3
  224. * Sat Jan 19 2008 Peter Jones <pjones@redhat.com> - 1.0.5-8
  225. - Rebuild for broken deps.
  226. * Thu Aug 30 2007 Till Maas <opensource till name> - 1.0.5-7
  227. - update URL
  228. - update license tag
  229. - recode ChangeLog from latin1 to uf8
  230. - add smp_mflags to make
  231. * Fri Aug 24 2007 Till Maas <opensource till name> - 1.0.5-6
  232. - cleanup BuildRequires:
  233. - removed versions, packages in Fedora are new enough
  234. - changed popt to popt-devel
  235. * Thu Aug 23 2007 Till Maas <opensource till name> - 1.0.5-5
  236. - fix devel subpackage requires
  237. - remove empty NEWS README
  238. - remove uneeded INSTALL
  239. - remove uneeded ldconfig requires
  240. - add readonly detection patch
  241. * Wed Aug 08 2007 Till Maas <opensource till name> - 1.0.5-4
  242. - disable patch2, libsepol is now detected by configure
  243. - move libcryptsetup.so to %%{_libdir} instead of /%%{_lib}
  244. * Fri Jul 27 2007 Till Maas <opensource till name> - 1.0.5-3
  245. - Use /%%{_lib} instead of /lib to use /lib64 on 64bit archs
  246. * Thu Jul 26 2007 Till Maas <opensource till name> - 1.0.5-2
  247. - Use /lib as libdir (#243228)
  248. - sync header and library (#215349)
  249. - do not use %%makeinstall (recommended by PackageGuidelines)
  250. - select sbindir with %%configure instead with make
  251. - add TODO
  252. * Wed Jun 13 2007 Jeremy Katz <katzj@redhat.com> - 1.0.5-1
  253. - update to 1.0.5
  254. * Mon Jun 04 2007 Peter Jones <pjones@redhat.com> - 1.0.3-5
  255. - Don't build static any more.
  256. * Mon Feb 05 2007 Alasdair Kergon <agk@redhat.com> - 1.0.3-4
  257. - Add build dependency on new device-mapper-devel package.
  258. - Add preun and post ldconfig requirements.
  259. - Update BuildRoot.
  260. * Wed Nov 1 2006 Peter Jones <pjones@redhat.com> - 1.0.3-3
  261. - Require newer libselinux (#213414)
  262. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0.3-2.1
  263. - rebuild
  264. * Wed Jun 7 2006 Jeremy Katz <katzj@redhat.com> - 1.0.3-2
  265. - put shared libs in the right subpackages
  266. * Fri Apr 7 2006 Bill Nottingham <notting@redhat.com> 1.0.3-1
  267. - update to final 1.0.3
  268. * Wed Feb 27 2006 Bill Nottingham <notting@redhat.com> 1.0.3-0.rc2
  269. - update to 1.0.3rc2, fixes bug with HAL & encrypted devices (#182658)
  270. * Wed Feb 22 2006 Bill Nottingham <notting@redhat.com> 1.0.3-0.rc1
  271. - update to 1.0.3rc1, reverts changes to default encryption type
  272. * Tue Feb 21 2006 Bill Nottingham <notting@redhat.com> 1.0.2-1
  273. - update to 1.0.2, fix incompatiblity with old cryptsetup (#176726)
  274. * Mon Feb 20 2006 Karsten Hopp <karsten@redhat.de> 1.0.1-5
  275. - BuildRequires: libselinux-devel
  276. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-4.2.1
  277. - bump again for double-long bug on ppc(64)
  278. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-4.2
  279. - rebuilt for new gcc4.1 snapshot and glibc changes
  280. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  281. - rebuilt
  282. * Mon Dec 5 2005 Bill Nottingham <notting@redhat.com> 1.0.1-4
  283. - rebuild against new libdevmapper
  284. * Thu Oct 13 2005 Florian La Roche <laroche@redhat.com>
  285. - add -lsepol to rebuild on current fc5
  286. * Mon Aug 22 2005 Karel Zak <kzak@redhat.com> 1.0.1-2
  287. - fix cryptsetup help for isLuks action
  288. * Fri Jul 1 2005 Bill Nottingham <notting@redhat.com> 1.0.1-1
  289. - update to 1.0.1 - fixes incompatiblity with previous cryptsetup for
  290. piped passwords
  291. * Thu Jun 16 2005 Bill Nottingham <notting@redhat.com> 1.0-2
  292. - add patch for 32/64 bit compatibility (#160445, <redhat@paukstadt.de>)
  293. * Tue Mar 29 2005 Bill Nottingham <notting@redhat.com> 1.0-1
  294. - update to 1.0
  295. * Thu Mar 10 2005 Bill Nottingham <notting@redhat.com> 0.993-1
  296. - switch to cryptsetup-luks, for LUKS support
  297. * Tue Oct 12 2004 Bill Nottingham <notting@redhat.com> 0.1-4
  298. - oops, make that *everything* static (#129926)
  299. * Tue Aug 31 2004 Bill Nottingham <notting@redhat.com> 0.1-3
  300. - link some things static, move to /sbin (#129926)
  301. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  302. - rebuilt
  303. * Fri Apr 16 2004 Bill Nottingham <notting@redhat.com> 0.1-1
  304. - initial packaging