cegui06-vl.spec 6.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194
  1. Name: cegui06
  2. Version: 0.6.2
  3. Release: 3%{?_dist_release}
  4. Summary: CEGUI library 0.6 for apps which need this specific version
  5. Group: System Environment/Libraries
  6. License: MIT and LGPLv2+
  7. URL: http://www.cegui.org.uk
  8. # This is
  9. # http://downloads.sourceforge.net/crayzedsgui/CEGUI-0.6.2b.tar.gz
  10. # with the bundled GLEW: RendererModules/OpenGLGUIRenderer/GLEW
  11. # removed as its an older GLEW version which contains
  12. # parts under then non Free SGI OpenGL and GLX licenses
  13. # To regenerate do:
  14. # wget http://downloads.sourceforge.net/crayzedsgui/CEGUI-0.6.2b.tar.gz
  15. # tar xvfz CEGUI-0.6.2b.tar.gz'
  16. # rm -r CEGUI-0.6.2/RendererModules/OpenGLGUIRenderer/GLEW
  17. # tar cvfz CEGUI-0.6.2b-clean.tar.gz
  18. Source0: CEGUI-0.6.2b-clean.tar.gz
  19. Source1: http://downloads.sourceforge.net/crayzedsgui/CEGUI-%{version}-DOCS.tar.gz
  20. # Both submitted upstream: http://www.cegui.org.uk/mantis/view.php?id=197
  21. Patch1: cegui-0.6.0-release-as-so-ver.patch
  22. Patch2: cegui-0.6.0-userverso.patch
  23. # TODO: submit upstream
  24. Patch3: cegui-0.6.2-new-DevIL.patch
  25. Patch4: cegui-0.6.2-new-tinyxml.patch
  26. Patch5: cegui-0.6.2-gcc46.patch
  27. BuildRequires: expat-devel
  28. BuildRequires: freetype2-devel > 2.0.0
  29. BuildRequires: libICE-devel
  30. BuildRequires: libGLU-devel
  31. BuildRequires: libSM-devel
  32. BuildRequires: pcre-devel
  33. BuildRequires: glew-devel
  34. %description
  35. Crazy Eddie's GUI System is a free library providing windowing and widgets for
  36. graphics APIs / engines. This package contains the older version 0.6 for
  37. apps which cannot be easily ported to 0.7. As such this version has been build
  38. without additional image codecs or xml parsers.
  39. %package devel
  40. Summary: Development files for cegui06
  41. Group: Development/Libraries
  42. Requires: %{name} = %{version}-%{release}
  43. Requires: libGLU-devel
  44. %description devel
  45. Development files for cegui06
  46. %package devel-doc
  47. Summary: API documentation for cegui06
  48. Group: Documentation
  49. Requires: %{name}-devel = %{version}-%{release}
  50. %description devel-doc
  51. API and Falagard skinning documentation for cegui06
  52. %prep
  53. %setup -qb1 -qn CEGUI-%{version}
  54. %patch1 -p1
  55. %patch2 -p1
  56. %patch3 -p1
  57. %patch4 -p1
  58. %patch5 -p1
  59. # Permission fixes for debuginfo RPM
  60. chmod -x include/falagard/*.h
  61. # Delete zero length file
  62. rm -f documentation/api_reference/keepme
  63. # Encoding fixes
  64. iconv -f iso8859-1 AUTHORS -t utf8 > AUTHORS.conv && mv -f AUTHORS.conv AUTHORS
  65. iconv -f iso8859-1 TODO -t utf8 > TODO.conv && mv -f TODO.conv TODO
  66. iconv -f iso8859-1 README -t utf8 > README.conv && mv -f README.conv README
  67. # Make makefile happy even though we've removed the (unused) included copy of
  68. # GLEW due to license reasons
  69. mkdir -p RendererModules/OpenGLGUIRenderer/GLEW/GL
  70. touch RendererModules/OpenGLGUIRenderer/GLEW/GL/glew.h
  71. touch RendererModules/OpenGLGUIRenderer/GLEW/GL/glxew.h
  72. touch RendererModules/OpenGLGUIRenderer/GLEW/GL/wglew.h
  73. touch RendererModules/OpenGLGUIRenderer/GLEW/GLEW-LICENSE
  74. %build
  75. %configure --disable-static --disable-samples --disable-lua-module \
  76. --disable-corona --disable-devil --disable-silly --disable-freeimage \
  77. --disable-irrlicht-renderer --disable-directfb-renderer \
  78. --disable-xerces-c --disable-libxml --disable-tinyxml \
  79. --with-default-xml-parser=ExpatParser \
  80. --with-default-image-codec=TgaImageCodec \
  81. --with-pic
  82. # We do not want to get linked against a system copy of ourselves!
  83. sed -i 's|-L%{_libdir}||g' RendererModules/OpenGLGUIRenderer/Makefile
  84. # Don't use rpath!
  85. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  86. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  87. make %{?_smp_mflags}
  88. %install
  89. make install DESTDIR=%{buildroot}
  90. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  91. # Move some things around to make cegui06-devel co-exist peacefully with
  92. # cegui-devel
  93. mkdir -p %{buildroot}/%{_libdir}/CEGUI-0.6
  94. for i in libCEGUIBase libCEGUIExpatParser libCEGUIFalagardWRBase \
  95. libCEGUIOpenGLRenderer libCEGUITGAImageCodec; do
  96. rm %{buildroot}/%{_libdir}/$i.so
  97. ln -s ../$i-%{version}.so %{buildroot}/%{_libdir}/CEGUI-0.6/$i.so
  98. done
  99. mv %{buildroot}/%{_includedir}/CEGUI %{buildroot}/%{_includedir}/CEGUI-0.6
  100. mv %{buildroot}/%{_datadir}/CEGUI %{buildroot}/%{_datadir}/CEGUI-0.6
  101. sed -e 's|/CEGUI|/CEGUI-0.6|g' \
  102. -e 's|libdir=%{_libdir}|libdir=%{_libdir}/CEGUI-0.6|g' \
  103. -i %{buildroot}/%{_libdir}/pkgconfig/*.pc
  104. for i in %{buildroot}/%{_libdir}/pkgconfig/*.pc; do
  105. mv $i `echo $i | sed 's|\.pc\$|-0.6.pc|'`
  106. done
  107. %post -p /sbin/ldconfig
  108. %postun -p /sbin/ldconfig
  109. %files
  110. %doc AUTHORS ChangeLog COPYING README TODO
  111. %{_libdir}/libCEGUI*-%{version}.so
  112. %files devel
  113. %{_libdir}/CEGUI-0.6
  114. %{_libdir}/pkgconfig/CEGUI-OPENGL-0.6.pc
  115. %{_libdir}/pkgconfig/CEGUI-0.6.pc
  116. %{_includedir}/CEGUI-0.6
  117. %{_datadir}/CEGUI-0.6
  118. %files devel-doc
  119. %doc documentation/FalagardSkinning.pdf documentation/api_reference
  120. %changelog
  121. * Sat Jul 09 2016 Yoji TOYODA <bsymaato@sea.plala.or.jp> 0.6.2-3
  122. - rebuild with gcc-5.4.0
  123. * Thu Oct 15 2015 Yoji TOYODA <bsymaato@sea.plala.or.jp> 0.6.2-2
  124. - rebuild with glew-1.13.0
  125. * Sun Nov 11 2012 Yoji TOYODA <bsymaato@sea.plala.or.jp> 0.6.2-1
  126. - initial build for Vine Linux
  127. * Thu Jul 26 2012 Hans de Goede <hdegoede@redhat.com> - 0.6.2-12
  128. - Rebuilt for new GLEW
  129. * Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.2-11
  130. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  131. * Fri Feb 10 2012 Petr Pisar <ppisar@redhat.com> - 0.6.2-10
  132. - Rebuild against PCRE 8.30
  133. * Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.2-9
  134. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  135. * Mon Jun 20 2011 ajax@redhat.com - 0.6.2-8
  136. - Rebuild for new glew soname
  137. * Sun Feb 13 2011 Hans de Goede <hdegoede@redhat.com> - 0.6.2-7
  138. - Fix building with gcc-4.6
  139. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.2-6
  140. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  141. * Fri Jan 07 2011 Bruno Wolff III <bruno@wolff.to> - 0.6.2-5
  142. - Rebuild against ogre that uses boost instead of poco.
  143. * Tue Jan 04 2011 Bruno Wolff III <bruno@wolff.to> - 0.6.2-4
  144. - Fix requires to be cegui06-devel rather than cegui-devel
  145. * Mon Jan 3 2011 Hans de Goede <hdegoede@redhat.com> 0.6.2-3
  146. - Update License tag to "MIT and LGPLv2+" and some files did not have
  147. their copyright header updated when upstream moved from LGPLv2+ to MIT.
  148. This is fixed in the 0.7.x (and later) versions of cegui.
  149. * Tue Nov 9 2010 Hans de Goede <hdegoede@redhat.com> 0.6.2-2
  150. - Switch to new upstream 0.6.2b tarbal (#650643)
  151. * Sun Nov 7 2010 Hans de Goede <hdegoede@redhat.com> 0.6.2-1
  152. - First release of CEGUI-0.6.2 as cegui06