bind-vl.spec 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709
  1. %define _localstatedir /var
  2. %define sname bind
  3. %define pname bind
  4. %define pversion 9.9.8.P4
  5. %define sversion 9.9.8-P4
  6. %define bind_epoch 1
  7. # fixed <BTS:VineLinux:1139>
  8. %define old_bind_version 1:9.9.2p2-1vl7
  9. %define bind_uid 25
  10. %define bind_gid 25
  11. %bcond_with readline
  12. Summary: A DNS (Domain Name System) server.
  13. Summary(ja): DNS (Domain Name System) サーバ
  14. Name: %{pname}
  15. Version: %{pversion}
  16. Release: 1%{?_dist_release}
  17. Epoch: %{bind_epoch}
  18. License: ISC and BSD and Public Domain
  19. Group: System Environment/Daemons
  20. URL: http://www.isc.org/bind.html
  21. Source: ftp://ftp.isc.org/isc/bind9/%{version}/%{sname}-%{sversion}.tar.gz
  22. Source1: bind-manpages.tar.bz2
  23. Source2: named.sysconfig
  24. Source3: named.init
  25. Source4: named.logrotate
  26. Source5: keygen.c
  27. Patch1: bind-9.3.3rc2-rndckey.patch
  28. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  29. BuildRequires: openssl-devel glibc-devel libtool
  30. BuildRequires: libxml2-devel
  31. BuildRequires: libcap-devel
  32. %if %{with readline}
  33. BuildRequires: readline-devel
  34. %endif
  35. Requires(pre): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
  36. Requires(pre): shadow-utils
  37. Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
  38. Requires(post): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
  39. Requires(post): coreutils, chkconfig
  40. Requires(preun): initscripts, chkconfig
  41. Conflicts: bind9 <= 9.2.1-0vl5, bind-current
  42. Obsoletes: bind9 <= 9.2.1-0vl5
  43. Obsoletes: bind-current < 1:9.9.4-1
  44. Vendor: Project Vine
  45. Distribution: Vine Linux
  46. Packager: daisuke
  47. %description
  48. BIND (Berkeley Internet Name Domain) is an implementation of the DNS
  49. (Domain Name System) protocols. BIND includes a DNS server (named),
  50. which resolves host names to IP addresses, and a resolver library
  51. (routines for applications to use when interfacing with DNS). A DNS
  52. server allows clients to name resources or objects and share the
  53. information with other network machines. The named DNS server can be
  54. used on workstations as a caching name server, but is generally only
  55. needed on one machine for an entire network. Note that the
  56. configuration files for making BIND act as a simple caching nameserver
  57. are included in the caching-nameserver package.
  58. Install the bind package if you need a DNS server for your network. If
  59. you want bind to act a caching name server, you will also need to install
  60. the caching-nameserver package.
  61. %package libs
  62. Summary: Libraries used by various DNS packages
  63. Summary(ja): さまざまな DNS パッケージで使用されるライブラリ
  64. Group: System Environment/Libraries
  65. Obsoletes: bind-current-libs <= %{old_bind_version}
  66. %description libs
  67. Contains libraries used by both the bind server package as well as the utils packages.
  68. %package utils
  69. Summary: Utilities for querying DNS name servers.
  70. Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
  71. Group: Applications/System
  72. Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
  73. Conflicts: bind9-utils <= 9.2.1-0vl5
  74. Conflicts: bind-current-utils
  75. Obsoletes: bind9-utils <= 9.2.1-0vl5
  76. Obsoletes: bind-current-utils <= %{old_bind_version}
  77. %description utils
  78. Bind-utils contains a collection of utilities for querying DNS (Domain
  79. Name Service) name servers to find out information about Internet hosts.
  80. These tools will provide you with the IP addresses for given host names,
  81. as well as other information about registered domains and network
  82. addresses.
  83. You should install bind-utils if you need to get information from DNS name
  84. servers.
  85. %package devel
  86. Summary: Include files and libraries needed for bind DNS development.
  87. Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
  88. Group: Development/Libraries
  89. Requires: %{pname} = %{bind_epoch}:%{version}-%{release}
  90. Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
  91. Conflicts: bind9-devel <= 9.2.1-0vl5
  92. Conflicts: bind-current-devel
  93. Obsoletes: bind9-devel <= 9.2.1-0vl5
  94. Obsoletes: bind-current-devel <= %{old_bind_version}
  95. %description devel
  96. The bind-devel package contains all the include files and the
  97. library required for DNS (Domain Name Service) development for
  98. BIND versions 9.x.x.
  99. You should install bind-devel if you want to develop bind DNS
  100. applications. If you install bind-devel, you'll also need to install
  101. bind.
  102. #'
  103. %prep
  104. %setup -n bind-%{sversion} -q
  105. %patch1 -p1 -b .key
  106. perl -pi -e 's/^(SUBDIRS =.+)dlzexternal(.+)$/\1\2/' bin/tests/system/Makefile.in
  107. %build
  108. libtoolize --copy --force
  109. aclocal
  110. autoconf
  111. %configure \
  112. --with-libtool \
  113. --with-openssl=/usr \
  114. %if %{without readline}
  115. --without-readline \
  116. %endif
  117. --disable-openssl-version-ceck \
  118. --enable-threads \
  119. --enable-ipv6 \
  120. --with-pic \
  121. --with-dlz-dlopen \
  122. --enable-filter-aaaa \
  123. --enable-fixed-rrset
  124. make %{?_smp_mflags}
  125. %install
  126. rm -rf $RPM_BUILD_ROOT
  127. mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
  128. mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
  129. mkdir -p ${RPM_BUILD_ROOT}/var/named
  130. mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
  131. mkdir -p ${RPM_BUILD_ROOT}/var/run/named
  132. make DESTDIR=$RPM_BUILD_ROOT install
  133. install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
  134. install -c -m 755 contrib/named-bootconf/named-bootconf.sh $RPM_BUILD_ROOT/usr/sbin/named-bootconf
  135. install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
  136. install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
  137. touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
  138. gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
  139. cd $RPM_BUILD_ROOT%{_mandir}
  140. tar xjf %{SOURCE1}
  141. # newer version is contained in source
  142. rm -f man5/named.conf.5.gz
  143. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
  144. cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
  145. chmod +x $RPM_BUILD_ROOT%{_libdir}/*.so.*
  146. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  147. %clean
  148. rm -rf $RPM_BUILD_ROOT ${RPM_BUILD_DIR}/%{name}-%{version}
  149. %pre
  150. if [ "$1" -eq 1 ]; then
  151. /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
  152. /usr/sbin/useradd -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
  153. fi;
  154. :;
  155. %post
  156. /sbin/ldconfig
  157. /sbin/chkconfig --add named
  158. if [ "$1" -eq 1 ]; then
  159. if [ ! -e /etc/rndc.key ]; then
  160. /usr/sbin/rndc-confgen -a > /dev/null 2>&1
  161. fi
  162. [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
  163. # rndc.key has to have correct perms and ownership, CVE-2007-6283
  164. [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
  165. [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
  166. # Check DNSSEC settings if this is a fresh install
  167. if [ -r /etc/sysconfig/dnssec ]; then
  168. . /etc/sysconfig/dnssec
  169. [ -x /usr/sbin/dnssec-configure ] && \
  170. dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
  171. /dev/null 2>&1
  172. fi;
  173. fi
  174. :;
  175. %preun
  176. if [ "$1" -eq 0 ]; then
  177. /sbin/service named stop >/dev/null 2>&1 || :
  178. /sbin/chkconfig --del named ||:
  179. fi
  180. exit 0
  181. %postun
  182. if [ "$1" -ge 1 ]; then
  183. %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
  184. fi
  185. /sbin/ldconfig
  186. %triggerpostun -- bind < 8.2.2_P5-15
  187. /sbin/chkconfig --add named
  188. /sbin/ldconfig
  189. %triggerpostun -- bind-current < 1:9.9.4-1
  190. /sbin/chkconfig --add named
  191. /sbin/ldconfig
  192. %post libs -p /sbin/ldconfig
  193. %postun libs -p /sbin/ldconfig
  194. %files
  195. %defattr(-,root,root)
  196. %doc CHANGES README
  197. %doc doc/arm doc/misc
  198. %config(noreplace) %{_sysconfdir}/logrotate.d/named
  199. %config %{_sysconfdir}/rc.d/init.d/named
  200. %config(noreplace) %{_sysconfdir}/sysconfig/named
  201. %config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
  202. %config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
  203. %config(noreplace) %attr(0640,root,named) %{_sysconfdir}/bind.keys
  204. %{_sbindir}/dnssec*
  205. %{_sbindir}/lwresd
  206. %{_sbindir}/named
  207. %{_sbindir}/named-bootconf
  208. %{_sbindir}/named-check*
  209. %{_sbindir}/named-compilezone
  210. %{_sbindir}/rndc*
  211. %{_sbindir}/dns-keygen
  212. %{_sbindir}/arpaname
  213. %{_sbindir}/ddns-confgen
  214. %{_sbindir}/genrandom
  215. %{_sbindir}/isc-hmac-fixup
  216. %{_sbindir}/named-journalprint
  217. %{_sbindir}/nsec3hash
  218. %{_mandir}/man1/arpaname.1*
  219. %{_mandir}/man5/resolv.conf.5*
  220. %{_mandir}/man5/named.conf.5*
  221. %{_mandir}/man5/rndc.conf.5*
  222. %{_mandir}/man8/rndc.8*
  223. %{_mandir}/man8/named.8*
  224. %{_mandir}/man8/lwresd.8*
  225. %{_mandir}/man8/dnssec*.8*
  226. %{_mandir}/man8/named-checkconf.8*
  227. %{_mandir}/man8/named-checkzone.8*
  228. %{_mandir}/man8/named-compilezone.8*
  229. %{_mandir}/man8/rndc-confgen.8*
  230. %{_mandir}/man8/ddns-confgen.8*
  231. %{_mandir}/man8/genrandom.8*
  232. %{_mandir}/man8/isc-hmac-fixup.8*
  233. %{_mandir}/man8/named-journalprint.8*
  234. %{_mandir}/man8/nsec3hash.8*
  235. %attr(-,named,named) %dir %{_var}/named
  236. %attr(-,named,named) %dir %{_var}/run/named
  237. %files libs
  238. %defattr(-,root,root)
  239. %{_libdir}/*.so.*
  240. %files utils
  241. %defattr(-,root,root)
  242. %{_bindir}/dig
  243. %{_bindir}/host
  244. %{_bindir}/nslookup
  245. %{_bindir}/nsupdate
  246. %{_mandir}/man1/host.1*
  247. %{_mandir}/man1/nsupdate.1*
  248. %{_mandir}/man1/dig.1*
  249. %{_mandir}/man5/resolver.5*
  250. %{_mandir}/man1/nslookup.1*
  251. %{_mandir}/man8/nslookup.8*
  252. %files devel
  253. %defattr(-,root,root)
  254. %{_libdir}/*.so
  255. %{_libdir}/*.a
  256. %{_includedir}/*
  257. %{_mandir}/man3/*
  258. %{_mandir}/man1/bind9-config.1*
  259. %{_mandir}/man1/isc-config.sh.1*
  260. %{_bindir}/bind9-config
  261. %{_bindir}/isc-config.sh
  262. %changelog
  263. * Mon Mar 14 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.8.P4-1
  264. - new upstream release with secrity fix (CVE-2016-1285,1286)
  265. - built with openssl 1.0.2g
  266. * Wed Jan 20 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.8.P3-1
  267. - new upstream release with secrity fix (CVE-2015-4620)
  268. * Thu Jul 9 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P1-1
  269. - new upstream release with secrity fix (CVE-2015-4620)
  270. * Mon Mar 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P2-2
  271. - rebuilt without readline to avoid GPL infection
  272. * Fri Feb 27 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P2-1
  273. - new upstream release with secrity fix (CVE-2015-1349)
  274. - added BR: readline-devel
  275. * Fri Feb 6 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P1-3
  276. - new upstream release with secrity fix (CVE-2014-8500)
  277. - used "3" as release number because of being newer than Vine Linux/6 updates
  278. * Tue Oct 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.4-1
  279. - update to 9.9.4(ESV)
  280. * Thu Mar 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.2p2-1
  281. - update to 9.9.2-P2
  282. - remove .la
  283. - remove Conflicts/Obsoletes from libs subpackage.
  284. - add configure options
  285. --enable-ipv6 --with-pic --enable-filter-aaaa --enable-fixed-rrset
  286. * Tue Dec 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.8.4p1-1
  287. - new upstream release.
  288. - added an option "--with-dlz-dlopen".
  289. * Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 9.8.0p2-2
  290. - Obosoletes: bind.* < 1:9.6.ESV.R1
  291. - fixed <BTS:VineLinux:1139>
  292. * Sun May 29 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p2-1
  293. - new upstream release with security fix (CVE-2011-1910)
  294. * Tue May 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.8.0p1-2
  295. - add BuildRequires: libxml2-devel, libcap-devel
  296. * Mon May 9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p1-1
  297. - new upstream release with security fix (CVE-2011-1907)
  298. - fix changelog typo
  299. * Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-2
  300. - Obosoletes: bind.* < 1:9.6.ESV.R1
  301. * Thu Apr 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-1
  302. - update to 9.8.0
  303. - remove Provides: bind.* = %%{bind_epoch}:%{version}-%{release}
  304. * Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.7.2P2-3
  305. - rebuild with openssl-1.0.0c
  306. * Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-2
  307. - fix Req: in bind package
  308. * Wed Oct 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-1
  309. - change package name bind -> bind-current
  310. - add epoch 1
  311. - new upstream release
  312. * Sat Jul 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9.7.1P2-1
  313. - new upstream release
  314. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 9.6.1P3-4
  315. - rebuilt with gcc-4.4.3-3 on ppc
  316. * Sat Feb 6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9.6.1P3-3
  317. - rebuilt with new toolchains (for VineSeed)
  318. - s/BuildPrereq/BuildRequires/
  319. * Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
  320. - add man1/isc-config.sh.1 into devel file list
  321. * Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
  322. - new upstream release with security fix (CVE-2009-4022, 2010-0097)
  323. * Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
  324. - new upstream release with security fix (CVE-2009-4022)
  325. * Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
  326. - new upstream release with security fix
  327. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
  328. - new upstream release
  329. - clean up %%post/%%pre scriptlet
  330. - create named user and group in %%pre
  331. - don't remove named user/group in %%preun
  332. - use rndc-confgen to create rndc.key
  333. * Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
  334. - new upstream release
  335. - drop patch0 and patch14, merged in upstream
  336. * Sun Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
  337. - new upstream release with security fix
  338. * Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
  339. - new upstream release with security fix
  340. - new versioning policy
  341. * Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
  342. - new upstream release with security fix
  343. * Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
  344. - new upstream release
  345. - build with new openssl/toolchain
  346. * Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
  347. - new upstream release with security fix
  348. * Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
  349. - new upstream release
  350. * Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
  351. - add Prereq sed
  352. * Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
  353. - new upstream release for security fix (CVE-2006-4095,4096)
  354. * Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
  355. - separate -libs package
  356. - remove old named.conf.5.gz
  357. - newer version is contained in source
  358. * Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
  359. - add bsdcompat patch (Patch4)
  360. - add fix_h_errno patch from FC
  361. - h_errno not being accessed / set correctly in libbind
  362. * Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
  363. - new upstream release
  364. * Sun Nov 7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
  365. - added PreReq to bind-utils (see: [VineSeed:09555])
  366. * Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
  367. - new upstream release
  368. * Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
  369. - fix /etc/init.d/named to use rndc
  370. * Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
  371. - rebuild to remove unneeded dependancy
  372. * Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
  373. - new upstream release
  374. * Tue Mar 4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
  375. - new upstream release
  376. * Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
  377. - fix dependancies.
  378. * Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
  379. - add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
  380. - change package name to bind for VineSeed.
  381. - use more macros.
  382. * Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
  383. - fixed some macros
  384. - add conflicts: to bind-* in bind9-devel and bind9-utils
  385. - add provides: bind = %%{version}
  386. * Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
  387. - use %%configure macros
  388. * Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
  389. - fixed inconsistent dependency
  390. * Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
  391. - updated to 9.2.2rc1
  392. * Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
  393. - updated to bind9(9.2.1), test packages ;)
  394. -- based on Rawhide's bind-9.2.0-8
  395. -- changed name bind9
  396. -- added Conflicts: bind
  397. * Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
  398. - release 8.3.1 includes security fixes
  399. * Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
  400. - Upgraded to current stable release 8.3.0
  401. * Mon Oct 8 2001 <zn@mbf.nifty.com>
  402. - 8.2.5-0vl0: Upgraded to new upstream version.
  403. * Thu May 24 2001 <sagami@vinelinux.org>
  404. - 8.2.4-0vl1: eliminate CVS related files from %%doc
  405. * Thu May 17 2001 <sagami@vinelinux.org>
  406. - 8.2.4-0vl0
  407. * Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  408. - 8.2.3-1vl2
  409. - built on VineSeed
  410. * Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
  411. - add doc/old
  412. - build for Vine 2.1
  413. * Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  414. - 8.2.3, fixes several security problems
  415. * Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
  416. - static libraries may be used in shared objects. Build with -fPIC on ia64
  417. * Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  418. - 8.2.2-P7 (fixes Bug #20546)
  419. * Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
  420. - condrestart fixes
  421. * Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
  422. - change the init script to take condrestart, not cond-restart
  423. - add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
  424. the %pre and %post scripts
  425. * Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  426. - Don't prereq /etc/init.d
  427. * Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
  428. - move initscript back
  429. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  430. - automatic rebuild
  431. * Sun Jul 9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  432. - add "exit 0" for uninstall case
  433. * Fri Jul 7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  434. - add prereq init.d and cleanup install section
  435. * Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
  436. - fix the init script
  437. * Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  438. - make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
  439. * Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  440. - Fix up the initscript (Bug #13033)
  441. - Fix build with current glibc (Bug #12755)
  442. - /etc/rc.d/init.d -> /etc/init.d
  443. - use %%{_mandir} rather than /usr/share/man
  444. * Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
  445. - fix conflict with man-pages
  446. - remove compatibilty chkconfig links
  447. - initscript munging
  448. * Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
  449. - modify logrotate setup to use PID file
  450. - temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
  451. - actually bump the release this time
  452. * Sun Jun 4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  453. - FHS compliance
  454. * Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
  455. - clean up restart patch
  456. * Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
  457. - provide /var/named (fix for bugs #9847, #10205)
  458. - preserve args when restarted via ndc(8) (bug #10227)
  459. - make resolv.conf(5) a link to resolver(5) (bug #10245)
  460. - fix SYSTYPE bug in all makefiles
  461. - move creation of named user from %%post into %%pre
  462. * Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  463. - Fix TTL (patch from ISC, Bug #9820)
  464. * Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  465. - fix typo in spec (it's %post, without a leading blank) introduced in -6
  466. - change SYSTYPE to linux
  467. * Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
  468. - pick a standard < 100 uid/gid for named
  469. * Fri Feb 04 2000 Elliot Lee <sopwith@redhat.com>
  470. - Pass named a '-u named' parameter by default, and add/remove user.
  471. * Thu Feb 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  472. - fix host mx bug (Bug #9021)
  473. * Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
  474. - rebuild to fix dependencies
  475. - man pages are compressed
  476. * Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  477. - It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
  478. * Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  479. - Fix up location of named-bootconf.pl and make it executable
  480. (Bug #8028)
  481. - bind-devel requires bind
  482. * Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
  483. - update to 8.2.2-P5
  484. * Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
  485. - update to 8.2.2-P3
  486. * Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
  487. - add patch to stop a cache only server from complaining about lame servers
  488. on every request.
  489. * Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
  490. - use real stop and start in named.init for restart, not ndc restart, it has
  491. problems when named has changed during a package update... (# 4890)
  492. * Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
  493. - chkconfig --del in %preun, not %postun
  494. * Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
  495. - initscript munging
  496. * Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
  497. - fix installed chkconfig links to match init file
  498. * Sat Jul 3 1999 Jeff Johnson <jbj@redhat.com>
  499. - conflict with new (in man-1.24) man pages (#3876,#3877).
  500. * Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
  501. - fix named.logrotate (wrong %SOURCE)
  502. * Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
  503. - update to 8.2.1.
  504. - add named.logrotate (#3571).
  505. - hack around egcs-1.1.2 -m486 bug (#3413, #3485).
  506. - vet file list.
  507. * Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
  508. - don't run by default
  509. * Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
  510. - nslookup fixes (#2463).
  511. - missing files (#3152).
  512. * Sat May 1 1999 Stepan Kasal <kasal@math.cas.cz>
  513. - nslookup patched:
  514. to count numRecords properly
  515. to fix subsequent calls to ls -d
  516. to parse "view" and "finger" commands properly
  517. the view hack updated for bind-8 (using sed)
  518. * Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
  519. - add ISC patch
  520. - add quick hack to make host not crash
  521. - add more docs
  522. * Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
  523. - add probing information in the init file to keep linuxconf happy
  524. - dont strip libbind
  525. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  526. - auto rebuild in the new build environment (release 3)
  527. * Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
  528. - removed 'done' output at named shutdown.
  529. * Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
  530. - version 8.2
  531. * Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
  532. - patch to use the __FDS_BITS macro
  533. - build for glibc 2.1
  534. * Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
  535. - change named.restart to /usr/sbin/ndc restart
  536. * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
  537. - install man pages correctly.
  538. - change K10named to K45named.
  539. * Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
  540. - don't start if /etc/named.conf doesn't exist.
  541. * Sat Aug 8 1998 Jeff Johnson <jbj@redhat.com>
  542. - autmagically create /etc/named.conf from /etc/named.boot in %post
  543. - remove echo in %post
  544. * Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
  545. - merge in 5.1 mods
  546. * Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
  547. - Several essential modifications to build and install correctly.
  548. - Modified 'ndc' to avoid deprecated use of '-'
  549. * Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
  550. - Used buildroot
  551. - patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
  552. on Redhat 5.0 instead of <nlist.h>