WebKit3-vl.spec 8.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296
  1. %define add_to_doc_files() \
  2. mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}; \
  3. cp -p %1 %{buildroot}%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') \
  4. echo %%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') >> docfiles.list
  5. #define svn_revision 43436
  6. # --with coverage: Enables compile-time checking of code coverage. (default: no)
  7. %bcond_with coverage
  8. # --with jit: Enable JIT ("just-in-time") JavaScript compiling support.
  9. #%bcond_with jit
  10. # --with pango : use pango for font rendering instead of freetype2 (default: use freetype2)
  11. %bcond_with pango
  12. # --with wml: Build support for WML
  13. %bcond_with wml
  14. Name: WebKit3
  15. Version: 2.4.11
  16. Release: 2%{?_dist_release}
  17. Summary: Web content engine library
  18. Summary(ja): ウェブコンテンツエンジンライブラリ
  19. Group: Development/Libraries
  20. License: LGPLv2+ and BSD
  21. URL: http://webkitgtk.org/
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Packager: Takemikaduchi
  25. Source0: http://www.webkitgtk.org/webkitgtk-%{version}.tar.xz
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  27. BuildRequires: bison
  28. BuildRequires: flex
  29. BuildRequires: gperf
  30. BuildRequires: ruby
  31. BuildRequires: gtk3-devel
  32. BuildRequires: at-spi2-core-devel
  33. BuildRequires: gtk2-devel
  34. BuildRequires: harfbuzz-icu-devel
  35. BuildRequires: libjpeg-turbo-devel
  36. BuildRequires: libtool
  37. BuildRequires: libxslt-devel
  38. BuildRequires: libXt-devel
  39. BuildRequires: pcre-devel
  40. BuildRequires: sqlite3-devel
  41. BuildRequires: geoclue-devel
  42. BuildRequires: gcr-devel
  43. BuildRequires: gstreamer1-devel
  44. BuildRequires: gstreamer1-plugins-base-devel
  45. BuildRequires: enchant-devel
  46. BuildRequires: libwebp-devel
  47. BuildRequires: libsecret-devel
  48. BuildRequires: gobject-introspection-devel
  49. BuildRequires: gsettings-desktop-schemas
  50. BuildRequires: gtk-doc
  51. %if %{with pango}
  52. BuildRequires: pango-devel
  53. %else
  54. BuildRequires: cairo-devel
  55. BuildRequires: fontconfig-devel
  56. BuildRequires: freetype2-devel
  57. %endif
  58. BuildRequires: libsoup-devel >= 2.28.2
  59. %description
  60. WebKit is an open source web browser engine.
  61. %package gtk
  62. Summary: GTK+ port of WebKit
  63. Summary(ja): WebKit の GTK+ ポート
  64. Group: Development/Libraries
  65. Provides: webkitgtk3 = %{version}-%{release}
  66. %description gtk
  67. %{name} is an open-source Web content engine library. This package contains
  68. the shared libraries for the WebKit GTK+ port as well as the sample
  69. GtkLauncher tool.
  70. %package gtk-devel
  71. Summary: Development package for %{name}
  72. Summary(ja): %{name} の開発パッケージ
  73. Group: Development/Libraries
  74. Provides: webkitgtk3-devel = %{version}-%{release}
  75. Requires: %{name}-gtk = %{version}-%{release}
  76. Requires: pkgconfig
  77. Requires: gtk3-devel
  78. Requires: libsoup-devel >= 2.28.2
  79. %description gtk-devel
  80. The %{name}-gtk-devel package contains libraries, build data, and header
  81. files for developing applications that use %{name}-gtk.
  82. Please note that the WebKit/GTK+ API is not yet stable. This should
  83. only be used as a "preview" rather than a stable platform library.
  84. %package docs
  85. Summary: Documentation for %{name}
  86. Summary(ja): %{name} のドキュメント
  87. Group: Documentation
  88. BuildArch: noarch
  89. Provides: webkitgtk3-docs = %{version}-%{release}
  90. Provides: %{name}-doc = %{version}-%{release}
  91. %description docs
  92. %{name} is an open-source Web content engine library. This package contains
  93. the documentation for %{name}, including various LICENSE, README, and
  94. AUTHORS files.
  95. %prep
  96. %setup -q -n webkitgtk-%{version}
  97. %build
  98. %configure \
  99. --with-gtk=3.0 \
  100. --with-gstreamer=1.0 \
  101. --enable-icon-database \
  102. --enable-geolocation \
  103. --enable-introspection=yes \
  104. --enable-dependency-tracking \
  105. %{?with_coverage: --enable-coverage } \
  106. %{?with_pango: --with-font-backend=pango } \
  107. %{?with_wml: --enable-wml }
  108. make %{?_smp_mflags}
  109. #make V=1
  110. # workaround for bug 488112
  111. # Compile libJavaScriptCore.a with -fno-strict-aliasing
  112. ##touch JavaScriptCore/AllInOneFile.cpp
  113. ##make %{?_smp_mflags} CXXFLAGS="%{optflags} -fno-strict-aliasing"
  114. %install
  115. rm -rf %{buildroot}
  116. make install DESTDIR=%{buildroot}
  117. install -d -m 755 %{buildroot}%{_libexecdir}/%{name}
  118. install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
  119. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  120. # conflict with WebKit-doc
  121. rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc
  122. # Finally, copy over and rename the various files for %%doc inclusion.
  123. %add_to_doc_files Source/WebKit/LICENSE
  124. %add_to_doc_files Source/WebKit/gtk/NEWS
  125. %add_to_doc_files Source/WebCore/icu/LICENSE
  126. %add_to_doc_files Source/WebCore/LICENSE-APPLE
  127. %add_to_doc_files Source/WebCore/LICENSE-LGPL-2
  128. %add_to_doc_files Source/WebCore/LICENSE-LGPL-2.1
  129. %add_to_doc_files Source/JavaScriptCore/COPYING.LIB
  130. %add_to_doc_files Source/JavaScriptCore/THANKS
  131. %add_to_doc_files Source/JavaScriptCore/AUTHORS
  132. %add_to_doc_files Source/JavaScriptCore/icu/README
  133. %find_lang WebKitGTK-3.0
  134. %clean
  135. rm -rf %{buildroot}
  136. %post gtk -p /sbin/ldconfig
  137. %posttrans gtk
  138. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  139. %postun gtk
  140. /sbin/ldconfig
  141. if [ $1 -eq 0 ] ; then
  142. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  143. fi
  144. # %files -f webkit.lang gtk
  145. %files gtk -f WebKitGTK-3.0.lang
  146. %defattr(-,root,root,-)
  147. %{_bindir}/jsc-3
  148. %{_libdir}/*.so.*
  149. %{_libdir}/webkit2gtk-3.0/injected-bundle/libwebkit2gtkinjectedbundle.so
  150. %{_libdir}/girepository-1.0/*.typelib
  151. %{_libexecdir}/WebKit3/
  152. %{_libexecdir}/WebKitNetworkProcess
  153. %{_libexecdir}/WebKitPluginProcess
  154. %{_libexecdir}/WebKitWebProcess
  155. %{_datadir}/webkitgtk-3.0/*
  156. %files gtk-devel
  157. %defattr(-,root,root,-)
  158. %exclude %{_libdir}/*.la
  159. %{_includedir}/webkitgtk-3.0
  160. %{_libdir}/*.so
  161. %{_libdir}/pkgconfig/*.pc
  162. %{_datadir}/gir-1.0/*.gir
  163. %files docs -f docfiles.list
  164. %defattr(-,root,root,-)
  165. %changelog
  166. * Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.4.11-2
  167. - rebuilt with new toolchain.
  168. * Sun Apr 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.11-1
  169. - new upstream release
  170. * Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.9-2
  171. - rebuild with icu-56.1
  172. * Fri May 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.9-1
  173. - new upstream release
  174. * Sun Jan 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.8-1
  175. - new upstream release
  176. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.7-1
  177. - new upstream release
  178. * Sun Aug 31 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.5-1
  179. - new upstream release
  180. * Wed Jul 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.4-1
  181. - new upstream release
  182. * Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.3-1
  183. - new upstream release
  184. * Wed May 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.2-1
  185. - new upstream release
  186. * Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.1-1
  187. - new upstream release
  188. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.0-1
  189. - new upstream release
  190. * Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.4-1
  191. - new upstream release
  192. * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.3-2
  193. - rebuild with icu-52.1
  194. * Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.3-1
  195. - new upstream release
  196. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.2-1
  197. - new upstream release
  198. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.1-1
  199. - new upstream release
  200. - add BuildRequires: at-spi2-core-devel, libwebp-devel, libsecret-devel
  201. - change BuildRequires: harfbuzz-icu-devel instead of libicu-devel
  202. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.2-1
  203. - new upstream release
  204. * Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.1-1
  205. - new upstream release
  206. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.0-1
  207. - new upstream release
  208. - add BuildRequires: ruby, gtk2-devel
  209. - change BuildRequires: gstreamer1-devel instead of gstreamer-devel
  210. - change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-pluings-base-devel
  211. * Tue Aug 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.3-1
  212. - new upstream release
  213. * Thu Aug 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.2-1
  214. - new upstream release
  215. * Sat Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.1-1
  216. - new upstream release
  217. - change BuildRequires: gcr-devel instead of gnome-keyring-devel
  218. - add BuildRequires: gsettings-desktop-schemas, gtk-doc
  219. * Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.6.1-1
  220. - new upstream release
  221. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.90-1
  222. - new upstream release
  223. * Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.2-1
  224. - new upstream release
  225. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.1-1
  226. - initial build for Vine Linux