WMSoundSet-vl.spec 6.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257
  1. %define pversion 1.1.1
  2. %define sversion 0.4.0
  3. %define wsprefs WSoundPrefs-%{pversion}
  4. %define wmsound WSoundServer-%{sversion}
  5. Summary: Sound tools for WindowMaker
  6. Summary(ja): Window Maker 用のサウンド・ツール
  7. Name: WMSoundSet
  8. Version: %{pversion}
  9. License: GPL2 & OPL
  10. Release: 3%{?_dist_release}
  11. Group: User Interface/Desktops
  12. Source0: %{wsprefs}.tar.bz2
  13. Source1: %{wmsound}.tar.bz2
  14. Source2: wmsdefault.tar.gz
  15. Source3: VineSounds.tar.gz
  16. Source5: WSoundPrefs-%{pversion}.ja.po
  17. Patch0: patch-af
  18. Patch1: WSoundServer-0.4.0-WM-0.92.patch
  19. Patch2: WSoundServer-0.4.0-config.x86_64.patch
  20. Patch10: WSoundPrefs-%{pversion}-nls.vine.patch
  21. Patch11: WSoundPrefs-1.1.1-wsound.patch
  22. Patch12: WSoundPrefs-1.1.1-fix.patch
  23. Patch13: WSoundPrefs-1.1.1-WM-0.92.patch
  24. BuildRequires: libPropList
  25. BuildRequires: xorg-x11-devel imake
  26. BuildRequires: WindowMaker-devel >= 0.92.0
  27. BuildRequires: audiofile-devel
  28. Requires: WindowMaker >= 0.92.0
  29. Buildroot: %{_tmppath}/%{name}-%{version}-root
  30. %description
  31. Sound tools for WindowMaker:
  32. WSoundPrefs-%{pversion}
  33. WSoundServer-%{sversion}
  34. wmsdefault (default sound set)
  35. %description -l ja
  36. Window Maker で 効果音の設定等を可能にするツール集です.
  37. 以下を収録しています.
  38. WSoundPrefs-%{pversion}
  39. WSoundServer-%{sversion}
  40. wmsdefault (wmsoundデフォルトの音源)
  41. WindowMaker-0.92 以上に対応しています.
  42. %prep
  43. %setup -q -a 1 -a 3 -c -n WMSoundSet
  44. cd %{wmsound}
  45. %patch0 -p0 -b .patch-af
  46. %patch1 -p0 -b .WM-0.92~
  47. %patch2 -p0 -b .x86_64~
  48. cd ..
  49. cd %{wsprefs}
  50. %patch10 -p1 -b .nls.vine
  51. %patch11 -p0 -b .wsound
  52. %patch12 -p1 -b .fix
  53. %patch13 -p1 -b .WM-0.92
  54. cp %SOURCE5 po/ja.po
  55. cd ..
  56. %build
  57. # make WSoundServer
  58. pushd %{wmsound}
  59. %configure --x-libraries=%{_libdir} --x-includes=%{_includedir}/X11
  60. make
  61. popd
  62. # make WSoundPrefs
  63. pushd %{wsprefs}
  64. cp ../%{wmsound}/wslib/{get-wsound-flags,wsound.h} src/
  65. IMAKEINCLUDE="-I%{_datadir}/X11/config" xmkmf -a
  66. touch src/WSoundPrefs.man
  67. PATH=$PATH:. make\
  68. PREFIX=%{_libdir}\
  69. EXTRA_DEFINES="-DI18N -DHAVE_LIBINTL_H"\
  70. EXTRA_INCLUDES=-I../../%{wmsound}/wslib\
  71. EXTRA_LIBRARIES=-L../../%{wmsound}/wslib/.libs/
  72. make -C po
  73. popd
  74. %install
  75. %define SYSDEFDIR $RPM_BUILD_ROOT/etc/X11/WindowMaker
  76. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  77. # Install WSoundPrefs
  78. cd %{wsprefs}
  79. make install PREFIX=$RPM_BUILD_ROOT%{_prefix}/lib/GNUstep
  80. mkdir -p $RPM_BUILD_ROOT%{_localedir}/ja/LC_MESSAGES/
  81. make nlsdir=$RPM_BUILD_ROOT%{_localedir} -C po install
  82. cd ..
  83. # Install wmsound
  84. cd %{wmsound}
  85. %makeinstall
  86. cd ..
  87. # Install default sounds
  88. mkdir -p $RPM_BUILD_ROOT%{_datadir}/WindowMaker
  89. tar xzvf %{SOURCE2} -C $RPM_BUILD_ROOT%{_datadir}/WindowMaker
  90. # install configurations
  91. mkdir -p %{SYSDEFDIR}
  92. mkdir -p $RPM_BUILD_ROOT%{_datadir}/WindowMaker/{Sounds,SoundSets}
  93. (
  94. cd VineSounds
  95. for i in Sounds SoundSets ; do
  96. cp $i/* $RPM_BUILD_ROOT%{_datadir}/WindowMaker/$i/
  97. done
  98. cd Defaults
  99. cp * %{SYSDEFDIR}
  100. )
  101. # prepare documents with preserving time stamps
  102. mkdir -p doc/WSoundPrefs
  103. cp -p %{wsprefs}/{AUTHORS,ChangeLog,COPYING*,INSTALL} doc/WSoundPrefs
  104. mkdir -p doc/WSoundServer
  105. cp -p %{wmsound}/{AUTHORS,COPYING,ChangeLog,INSTALL,NEWS,README} doc/WSoundServer
  106. # remove files
  107. rm -f $RPM_BUILD_ROOT%{_libdir}/libwsound.la
  108. %clean
  109. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  110. %files
  111. %defattr(-,root,root)
  112. %doc doc/*
  113. %{_sysconfdir}/X11/WindowMaker/*
  114. %{_prefix}/lib/GNUstep/Applications/WSoundPrefs.app/
  115. %{_includedir}/wsound.h
  116. %{_libdir}/libwsound.a
  117. %{_libdir}/libwsound.so*
  118. #%{_libdir}/libwsound.la
  119. %{_localedir}/ja/LC_MESSAGES/WSoundPrefs.mo
  120. %{_datadir}/WindowMaker/Sounds/
  121. %{_datadir}/WindowMaker/SoundSets/
  122. %{_bindir}/get-wsound-flags
  123. %{_bindir}/wsoundserver
  124. %{_bindir}/wsoundplay
  125. %{_bindir}/getsoundset
  126. %{_bindir}/setsoundset
  127. %{_mandir}/man1/get-wsound-flags.1x*
  128. %{_mandir}/man1/getsoundset.1x*
  129. %{_mandir}/man1/setsoundset.1x*
  130. %{_mandir}/man1/wsoundplay.1x*
  131. %{_mandir}/man1/wsoundserver.1x*
  132. %changelog
  133. * Sat Apr 23 2011 Shu KONNO <owa@bg.wakwak.com> 1.1.1-3
  134. - rebuilt with rpm-4.8.1-3
  135. - added BR: libPropList
  136. * Mon Feb 22 2010 Shu KONNO <owa@bg.wakwak.com> 1.1.1-2
  137. - added BR: audiofile-devel
  138. - rebuilt with new environment
  139. * Tue Jun 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.1-1vl5
  140. - applied new versioning policy and utf-8
  141. - added BuildRequires: xorg-x11-devel imake
  142. - set IMAKEINCLUDE to xmkmf
  143. * Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.1-0vl9
  144. - changed Group to User Interface/Desktops
  145. * Tue Mar 07 2006 Shu KONNO <owa@bg.wakwak.com> 1.1.1-0vl8
  146. - added WSoundServer-0.4.0-config.x86_64.patch
  147. - rebuilt for x86_64 architecture support
  148. * Sat Feb 25 2006 Shu KONNO <owa@bg.wakwak.com> 1.1.1-0vl7
  149. - rebuilt for VineSeed
  150. * Sun Nov 13 2005 Shu KONNO <owa@bg.wakwak.com> 1.1.1-0vl6
  151. - added WSoundServer-0.4.0.WM-0.92.patch
  152. - added WSoundPrefs-1.1.1.WM-0.92.patch
  153. - added %{_mandir}/man1/get-wsound-flags.1x*
  154. - changed encoding to utf-8 of WSoundPrefs-1.1.1.ja.po
  155. - changed app path with '/usr/X11R6/lib/GNUstep/Applications/WSoundPrefs.app'
  156. - rebuilt for WindowMaker-0.92.0
  157. * Fri Dec 20 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.1-0vl5
  158. - rebuilt for VineSeed
  159. * Fri Dec 20 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.1-0vl4.2
  160. - added Patch3 for better compatibility with WindowMaker-0.80.2
  161. * Fri Dec 20 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.1-0vl4.1
  162. - rebuilt with WindowMaker-0.80.2
  163. * Wed Jul 18 2001 <sagami@vinelinux.org>
  164. - 1.1.1-0vl4: erase unneeded files in %%doc and minor spec fixes
  165. - added patch to build with current audiofile.h in audiofile-0.2.1
  166. - added patch to include wsound.h correctly
  167. * Tue Jan 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  168. - 1.1.1-0vl3
  169. - use better macros
  170. - added forgotten %%clean section
  171. * Fri Sep 08 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  172. - 1.1.1-0vl2
  173. - modified %files section to handle compressed man page(s)
  174. * Sun Apr 2 2000 Jun Nishii <jun@vinelinux.org>
  175. - WMSoundSet-1.1.1
  176. - WSoundPrefs-1.1.1, WSoundServer-0.4.0
  177. - requires WindowMaker >= 0.62.1
  178. * Thu Oct 14 1999 Jun Nishii <jun@vinelinux.org>
  179. - WMSoundSet-1.0-1
  180. - build for Vine-1.9
  181. - WSoundPrefs-1.1.0, WSoundServer-0.2.1
  182. - requires WindowMaker >= 0.61.1
  183. * Sat Mar 27 1999 Jun Nishii <jun@vinelinux.org>
  184. - added new sounds and use them as a default set
  185. * Sun Mar 14 1999 Jun Nishii <jun@vinelinux.org>
  186. - remove requires WindowMaker >= 0.51.2
  187. * Sun Mar 14 1999 Jun Nishii <jun@vinelinux.org>
  188. - updated WSoundPrefs to 0.9.3
  189. * Sun Mar 7 1999 Jun Nishii <jun@vinelinux.org>
  190. - updated WSoundPrefs to 0.9.2
  191. - updated wmsound to 0.9.3
  192. * Tue Feb 24 1999 Jun Nishii <jun@vinelinux.org>
  193. - updated wmsound to 0.9.2
  194. - added Japanese summary and description
  195. - change Group name
  196. * Tue Feb 2 1999 Jun Nishii <jun@vinelinux.org>
  197. - updated to 0.9.1
  198. * Sat Dec 19 1998 Jun Nishii <jun@vinelinux.org>
  199. - modify ja.po
  200. * Thu Dec 17 1998 Jun Nishii <jun@vinelinux.org>
  201. - merge ja.po
  202. * Sat Dec 12 1998 Jun Nishii <jun@vinelinux.org>
  203. - use /dev/dsp as a default audio device