SysVinit-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371
  1. Summary: Programs which control basic system processes.
  2. Summary(ja): 基本的なシステムプロセスを制御するプログラム
  3. Name: SysVinit
  4. Version: 2.88dsf
  5. Release: 3%{_dist_release}
  6. License: GPLv2+
  7. Group: System Environment/Base
  8. Source: http://download.savannah.gnu.org/releases/sysvinit/sysvinit-%{version}.tar.bz2
  9. URL: http://savannah.nongnu.org/projects/sysvinit/
  10. Patch1: sysvinit-2.78-man.patch
  11. Patch2: sysvinit-2.86-autofsck.patch
  12. Patch3: sysvinit-2.86-loginshell.patch
  13. Patch4: sysvinit-2.86-inittab.patch
  14. Patch5: sysvinit-2.86-single.patch
  15. Patch6: sysvinit-2.88-quiet.patch
  16. Patch14: sysvinit-2.88-ipv6.patch
  17. Patch15: sysvinit-2.88-omit.patch
  18. Patch16: sysvinit-2.88-wall-maxlines.patch
  19. Patch17: sysvinit-2.88-wall-broadcast-message.patch
  20. Buildroot: %{_tmppath}/%{name}-%{version}-root
  21. Requires: pam >= 0.66-5
  22. Requires: %{name}-tools = %{version}-%{release}
  23. Requires: filesystem
  24. Vendor: Project Vine
  25. Distribution: Vine Linux
  26. Packager: daisuke
  27. %description
  28. The SysVinit package contains a group of processes that control
  29. the very basic functions of your system. SysVinit includes the init
  30. program, the first program started by the Linux kernel when the
  31. system boots. Init then controls the startup, running, and shutdown
  32. of all other programs.
  33. %description -l ja
  34. SysVinit パッケージには,システムの非常に基本的な機能を制御する
  35. プロセスが収められています.例えば,システム起動時に Linux カーネルに
  36. よって最初に起動されるプログラムである init 等です.init はその後
  37. システムの起動や,他のプログラムの起動/終了を制御します.
  38. %package tools
  39. Summary: Tools used for process management.
  40. Summary(ja): プロセス管理に使用するツール
  41. Group: System Environment/Base
  42. %description tools
  43. The sysvinit-tools package contains various tools used for process
  44. management.
  45. $description -l ja tools
  46. SysVinit-tools パッケージにはプロセス管理に使用するさまざまなツール
  47. が含まれています。
  48. %prep
  49. %setup -q -n sysvinit-%{version}
  50. # We use a shell, not sulogin. Other random man fixes go here (such as #192804)
  51. %patch1 -p1 -b .manpatch
  52. # Unlink /.autofsck on shutdown -f
  53. %patch2 -p1 -b .autofsck
  54. # Invoke single-user shell as a login shell (#105653)
  55. %patch3 -p1 -b .loginshell
  56. # Adjust examples in inittab(5) to more accurately reflect RH/Fedora
  57. # usage (#173572)
  58. %patch4 -p1 -b .inittabdocs
  59. # Fix single user mode (#176348)
  60. %patch5 -p1 -b .single
  61. # Be less verbose when booted with 'quiet'
  62. %patch6 -p1 -b .quiet
  63. # Change accepted ipv6 addresses (#573346)
  64. %patch14 -p1 -b .ipv6
  65. # Add option to pidof to exclude similar processes to omitted processes (#632321)
  66. %patch15 -p1 -b .omit
  67. # Fix counting MAXLINES in wall
  68. %patch16 -p1 -b .maxlines
  69. # Raise limit for broadcast message
  70. %patch17 -p1 -b .broadcast
  71. %build
  72. make %{?_smp_mflags} CC=%{__cc} CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE" LDFLAGS="-lcrypt" -C src
  73. %install
  74. rm -rf $RPM_BUILD_ROOT
  75. for I in bin sbin %{_bindir} %{_mandir}/man{1,3,5,8} etc var/run dev %{_includedir}; do
  76. mkdir -p $RPM_BUILD_ROOT/$I
  77. done
  78. make -C src ROOT=$RPM_BUILD_ROOT MANDIR=%{_mandir} STRIP=/bin/true \
  79. BIN_OWNER=`id -nu` BIN_GROUP=`id -ng` install
  80. rm -f $RPM_BUILD_ROOT/bin/pidof
  81. ln -snf killall5 $RPM_BUILD_ROOT/sbin/pidof
  82. rm -f $RPM_BUILD_ROOT/sbin/bootlogd
  83. rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/bootlogd*
  84. chmod 755 $RPM_BUILD_ROOT/usr/bin/utmpdump
  85. # Remove these files, as we use upstart as /sbin/init.
  86. rm -f $RPM_BUILD_ROOT/sbin/{halt,init,poweroff,reboot,runlevel,shutdown,telinit}
  87. rm -f $RPM_BUILD_ROOT/%{_includedir}/initreq.h
  88. rm -f $RPM_BUILD_ROOT/%{_mandir}/man5/*
  89. rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/{halt,init,poweroff,reboot,runlevel,shutdown,telinit}*
  90. # /sbin/fstab-decode is part of initscripts
  91. rm -f $RPM_BUILD_ROOT/sbin/fstab-decode
  92. rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/fstab-decode.8
  93. # /bin/mountpoint is part of util-linux >= 2.20
  94. rm -f $RPM_BUILD_ROOT/bin/mountpoint
  95. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/mountpoint.*
  96. # utmpdump and sulogin is part of util-linux >= 2.22
  97. rm -f $RPM_BUILD_ROOT%{_bindir}/utmpdump
  98. rm -f $RPM_BUILD_ROOT/sbin/sulogin
  99. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/utmpdump.*
  100. rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/sulogin.*
  101. %post
  102. [ -x /sbin/telinit -a -p /dev/initctl -a -f /proc/1/exe -a -d /proc/1/root ] && /sbin/telinit u
  103. exit 0
  104. %clean
  105. rm -rf $RPM_BUILD_ROOT
  106. %files tools
  107. %defattr(-,root,root)
  108. %doc doc/Changelog COPYRIGHT
  109. %{_bindir}/last
  110. %{_bindir}/lastb
  111. %{_bindir}/mesg
  112. %attr(2555,root,tty) %{_bindir}/wall
  113. /sbin/pidof
  114. /sbin/killall5
  115. %{_mandir}/man1/*
  116. %{_mandir}/man8/killall5*
  117. %{_mandir}/man8/pidof*
  118. %changelog
  119. * Tue Nov 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.88dsf-3
  120. - remove sulogin and utmpdump which are part of util-linux >= 2.22
  121. * Tue Feb 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.88dsf-2
  122. - remove mountpoint which is part of util-linux >= 2.20
  123. * Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.88dsf-1
  124. - update to 2.88dsf
  125. - only build -tools subpackage
  126. * Fri Apr 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.87dsf-1
  127. - new upstream release (2.87dsf)
  128. - remove upstreamed or obsoleted patches
  129. - split off a -tools subpackage to avoid upstart conflicts
  130. * Mon Aug 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.86-1
  131. - new upstream release
  132. * Thu Jul 06 2006 Shu KONNO <owa@bg.wakwak.com> 2.85-5vl3
  133. - add script to create $RPM_BUILD_ROOT/bin in %%install section
  134. * Wed Dec 10 2003 <tkoba@vinelinux.org> 2.85-5vl2
  135. - install initreq.h
  136. * Fri Nov 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.85-5vl1
  137. - new upstream release
  138. - merged with fedora package.
  139. * Tue Jul 17 2001 <sagami@vinelinux.org>
  140. - 2.78-10vl3: fix orphan symlink in %%doc
  141. * Tue Jan 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  142. - 2.78-10vl1
  143. - rebuilt under new %%{_mandir} definition
  144. - added Japanese summary and description
  145. * Sat Nov 18 2000 Satoshi MACHINO <machino@vinelinux.org> 2.78-10vl1
  146. - build with gcc-2.95.3
  147. - partially used rpmmacros
  148. * Mon Sep 22 2003 Bill Nottingham <notting@redhat.com> 2.85-5
  149. - add change_console, for changing console used by init
  150. * Wed Jun 25 2003 Bill Nottingham <notting@redhat.com> 2.85-4
  151. - block signals when calling syslog() (#97534, <joden@lee.k12.nc.us>)
  152. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  153. - rebuilt
  154. * Fri May 23 2003 Bill Nottingham <notting@redhat.com> 2.85-2
  155. - clean up killall5 some
  156. * Thu May 22 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  157. - update to 2.85, remove already applied patches
  158. * Mon Feb 10 2003 Bill Nottingham <notting@redhat.com> 2.84-13
  159. - fix s390x build
  160. - fix silly warning (#83943)
  161. * Mon Feb 10 2003 Arjan van de Ven <arjanv@redhat.com>
  162. - fix wait() handling wrt setting SIGCHLD to SIG_IGN in shutdown
  163. - fix segfault in spawn() function in shutdown
  164. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  165. - rebuilt
  166. * Thu Dec 05 2002 Elliot Lee <sopwith@redhat.com> 2.84-7
  167. - Pass __cc macro to build, to facilitate cross-compiling
  168. - _smp_mflags
  169. * Mon Dec 2 2002 Bill Nottingham <notting@redhat.com> 2.84-6
  170. - rebuild on all arches
  171. - change sulogin message to be slightly more correct (#65828)
  172. * Thu Jul 18 2002 Bill Nottingham <notting@redhat.com>
  173. - don't strip binaries
  174. - have wall not write to non-ttys (#65412)
  175. - update usage for halt/reboot (#57753)
  176. - allow '-t' argument to last for checking state at certain times (#56863)
  177. - make 'pidof /foo/bar' not match /baz/bar (#53918)
  178. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  179. - automated rebuild
  180. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  181. - automated rebuild
  182. * Thu Mar 12 2002 Bill Nottingham <notting@redhat.com> 2.84-2
  183. - add patch to log messages on shutdown/reboot
  184. * Fri Feb 22 2002 Bill Nottingham <notting@redhat.com> 2.84-1
  185. - update to 2.84
  186. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  187. - automated rebuild
  188. * Fri Nov 9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.79-2
  189. - Fix pidof -o (#55954)
  190. - Handle RPM_OPT_FLAGS
  191. - s/Copyright/License/
  192. * Mon Sep 17 2001 Bill Nottingham <notting@redhat.com>
  193. - update to 2.79
  194. * Tue Aug 28 2001 Bill Nottingham <notting@redhat.com>
  195. - unlink /.autofsck on shutdown -f
  196. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
  197. - Bump release + rebuild.
  198. * Thu Jun 21 2001 Bill Nottingham <notting@redhat.com>
  199. - update 'no logout' patch
  200. - fix setting of CREAD to work with 2.4.3+ kernels (#45284)
  201. * Tue Jun 12 2001 Bill Nottingham <notting@redhat.com>
  202. - show users with no login pid but no logout record as gone (#42550,
  203. <cwolf@starclass.com>)
  204. - fix sulogin to *always* work without a tty (#40934)
  205. * Tue Apr 3 2001 Bill Nottingham <notting@redhat.com>
  206. - set umask 022 on startup
  207. - manpage tweaks (#21628, #27173)
  208. * Mon Apr 2 2001 Bill Nottingham <notting@redhat.com>
  209. - fix dangling symlink in %%doc (#34383)
  210. * Thu Mar 15 2001 Bill Nottingham <notting@redhat.com>
  211. - don't run telinit u if we don't appear to be on the root fs
  212. * Fri Feb 16 2001 Bill Nottingham <notting@redhat.com>
  213. - run telinit u on upgrade
  214. * Wed Jan 31 2001 Bill Nottingham <notting@redhat.com>
  215. - document '-n' option to wall, make it root-only (#18672)
  216. - don't open files in sulogin unless they're really ttys (#21862)
  217. * Tue Aug 8 2000 Bill Nottingham <notting@redhat.com>
  218. - set SHLVL in sulogin so /etc/profile.d stuff isn't run by default
  219. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  220. - automatic rebuild
  221. * Thu Jun 8 2000 Bill Nottingham <notting@redhat.com>
  222. - fix the md5 code (#11534)
  223. - rebuild for FHS & the like
  224. * Wed Apr 19 2000 Bill Nottingham <notting@redhat.com>
  225. - ignore sigint in sulogin (#9803)
  226. - touch file in root directory if powering off (#7318)
  227. * Tue Mar 7 2000 Jeff Johnson <jbj@redhat.com>
  228. - rebuild for sparc baud rates > 38400.
  229. * Thu Feb 24 2000 Bill Nottingham <notting@redhat.com>
  230. - update to 2.78-final
  231. * Mon Feb 7 2000 Bill Nottingham <notting@redhat.com>
  232. - handle compressed manpages
  233. * Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
  234. - build to fix dependency problem
  235. * Tue Jan 10 2000 Bill Nottingham <notting@redhat.com>
  236. - update to 2.78
  237. * Mon Sep 06 1999 Jakub Jelinek <jj@ultra.linux.cz>
  238. - on big endian machines use a kludge for broken pam md5 passwords
  239. * Fri Aug 27 1999 Bill Nottingham <notting@redhat.com>
  240. - update to 2.77
  241. * Tue Jul 06 1999 Bill Nottingham <notting@redhat.com>
  242. - move pam_console stuff to usermode package
  243. * Fri Jul 02 1999 Cristian Gafton <gafton@redhat.com>
  244. - requires usermode to express the dependency on /usr/bin/consolehelper
  245. (#2813)
  246. * Wed Jun 23 1999 Bill Nottingham <notting@redhat.com>
  247. - make man page references to single-user mode consistent with RH usage
  248. * Sat Apr 17 1999 Jeff Johnson <jbj@redhat.com>
  249. - remove /etc/initlvl compatibility symlink from file list (#2236).
  250. * Fri Mar 26 1999 Michael Johnson <johnsonm@redhat.com>
  251. - pam.d files marked noreplace
  252. - added poweroff as a console application
  253. * Mon Mar 22 1999 Michael Johnson <johnsonm@redhat.com>
  254. - marked config files as such in consolehelper part of filelist
  255. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  256. - auto rebuild in the new build environment (release 8)
  257. * Fri Mar 19 1999 Michael Johnson <johnsonm@redhat.com>
  258. - consolehelper support
  259. * Wed Jan 06 1999 Cristian Gafton <gafton@redhat.com>
  260. - glibc 2.1
  261. * Sun Aug 23 1998 Jeff Johnson <jbj@redhat.com>
  262. - poweroff symlink not included (problem #762)
  263. * Thu Jul 09 1998 Chris Evans <chris@ferret.lmh.ox.ac.uk>
  264. - Fix a securelevel releated security hole. Go on, try and break append
  265. only files + securelevel now ;-)
  266. * Wed Jul 8 1998 Jeff Johnson <jbj@redhat.com>
  267. - remove /etc/nologin at end of shutdown.
  268. - compile around missing SIGPWR on sparc
  269. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  270. - translations modified for de, fr, tr
  271. * Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
  272. - upgraded to 2.74
  273. - fixed the package source url... (yeah, it was wrong !)
  274. * Wed Oct 1 1997 Cristian Gafton <gafton@redhat.com>
  275. - fixed the MD5 check in sulogin (128 hash bits encoded with base64 gives
  276. 22 bytes, not 24...). Fix in -md5.patch
  277. * Thu Sep 11 1997 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
  278. - /etc/initrunlvl gets linked to /tmp/init-root/var/run/initrunlvl which is
  279. just plain wrong..
  280. - /usr/bin/utmpdump was missing in the files section, although it was
  281. explicitly patched into PROGS.
  282. - added attr's to the files section.
  283. - various small fixes.
  284. * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
  285. - updated to 2.71
  286. - built against glibc 2.0.4
  287. * Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
  288. - Added sulogin.8 man page to file list.