PyQt4-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353
  1. %global python_ver %(%{__python} -c "import sys ; print sys.version[:3]")
  2. %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
  3. %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")
  4. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.8.6)
  5. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
  6. %define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
  7. %define qt4qmake %{_qt4_prefix}/bin/qmake
  8. Name: PyQt4
  9. Summary: Python bindings for Qt4
  10. Summary(ja): Qt4 の Python バインディング
  11. Version: 4.11.2
  12. Release: 2%{?_dist_release}
  13. # GPLv2 exceptions(see GPL_EXCEPTIONS*.txt)
  14. License: GPLv3 or GPLv2 with exceptions
  15. Group: System Environment/Libraries
  16. URL: http://www.riverbankcomputing.com/software/pyqt/
  17. Source0: http://www.riverbankcomputing.com/static/Downloads/PyQt4/PyQt-x11-gpl-%{version}.tar.gz
  18. ## upstreamable patches
  19. # fix multilib conflict because of timestamp
  20. Patch50: PyQt-x11-gpl-4.9.5-timestamp_multilib.patch
  21. Patch52: PyQt-x11-gpl-4.10.4-pyuic_shbang.patch
  22. # Vine Patch
  23. Patch100: PyQt-x11-gpl-4.7.3-phononpath_vine.patch
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. BuildRequires: dbus-devel dbus-python-devel
  26. BuildRequires: findutils
  27. BuildRequires: libXext-devel
  28. BuildRequires: phonon-devel
  29. BuildRequires: python-devel
  30. # beware of PyQt4/qscintilla bootstap issues
  31. #BuildRequires: qscintilla
  32. BuildRequires: qt4-devel >= 4.5.0
  33. BuildRequires: qt-assistant-adp-devel
  34. BuildRequires: sip-devel >= 4.13.1
  35. Requires: sip >= 4.13.1
  36. Requires: dbus-python
  37. Requires: qt4
  38. %description
  39. These are Python bindings for Qt4.
  40. %package devel
  41. Summary: Files needed to build other bindings based on Qt4
  42. Group: Development/Libraries
  43. Requires: %{name} = %{version}-%{release}
  44. Requires: qt4-devel >= 4.5.0
  45. Requires: qt-assistant-adp-devel
  46. Requires: sip-devel >= 4.13.1
  47. %description devel
  48. Files needed to build other bindings for C++ classes that inherit from any
  49. of the Qt4 classes (e.g. KDE or your own).
  50. %prep
  51. %setup -q -n PyQt-x11-gpl-%{version}
  52. %patch50 -p1 -b .timestamp
  53. # skip -b on this one, so the backup copy doesnt end up packaged too
  54. %patch52 -p1
  55. #patch100 -p1 -b .phononpath_vine
  56. # permissions, mark examples non-executable
  57. find examples/ -name "*.py" | xargs chmod a-x
  58. chmod a+rx pyuic/uic/pyuic.py
  59. %build
  60. QT4DIR=%{_qt4_prefix}
  61. PATH=%{_qt4_bindir}:$PATH ; export PATH
  62. %{__python} configure.py \
  63. --assume-shared \
  64. --confirm-license \
  65. --no-timestamp \
  66. --qmake=%{qt4qmake} \
  67. --no-qsci-api \
  68. --verbose
  69. make %{?_smp_mflags}
  70. %install
  71. rm -rf $RPM_BUILD_ROOT
  72. make install DESTDIR=$RPM_BUILD_ROOT INSTALL_ROOT=$RPM_BUILD_ROOT
  73. # HACK: fix multilb conflict, http://bugzilla.redhat.com/509415
  74. rm -fv $RPM_BUILD_ROOT%{_bindir}/pyuic4
  75. mv $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py \
  76. $RPM_BUILD_ROOT%{_bindir}/pyuic4
  77. ln -s %{_bindir}/pyuic4 \
  78. $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py
  79. %clean
  80. rm -rf $RPM_BUILD_ROOT
  81. %files
  82. %defattr(-,root,root,-)
  83. %doc NEWS README
  84. %doc OPENSOURCE-NOTICE.TXT
  85. %doc LICENSE.GPL2 GPL_EXCEPTION*.TXT
  86. %doc LICENSE.GPL3
  87. %{python_sitearch}/PyQt4/
  88. %exclude %{python_sitearch}/PyQt4/uic/pyuic.py*
  89. # fixme? -> sitearch? -- Rex
  90. %{python_sitelib}/dbus/mainloop/qt.so
  91. %{_qt4_plugindir}/designer/*
  92. %files devel
  93. %defattr(-,root,root,-)
  94. %doc doc/*
  95. %doc examples/
  96. %{_bindir}/pylupdate4
  97. %{_bindir}/pyrcc4
  98. %{_bindir}/pyuic4
  99. %{python_sitearch}/PyQt4/uic/pyuic.py*
  100. %{_datadir}/sip/PyQt4/
  101. #{_qt4_prefix}/qsci/api/python/PyQt4.api
  102. %changelog
  103. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.2-2
  104. - rebuild with gcc-5.4.0
  105. * Sat Nov 8 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.11.2-1
  106. - new upstream release
  107. - added Patch50 and 52
  108. - moved to System Environment/Libraries Group
  109. * Mon May 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.4-1
  110. - new upstream release
  111. - update Patch1 (PyQt-x11-gpl-4.10.4-64bit.patch)
  112. * Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.3-1
  113. - new upstream release
  114. * Sat Sep 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.2-1
  115. - new upstream release
  116. * Wed Jun 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.1-1
  117. - new upstream release
  118. * Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.4-1
  119. - new upstream release
  120. - update Patch1 (PyQt-x11-gpl-4.9.4-64bit.patch)
  121. * Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-2
  122. - rebuild with python-2.7.2
  123. * Sat Jan 7 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.9.0-1
  124. - new upstream release
  125. - aaded BR: qt-assistant-adp-devel
  126. * Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.4-2
  127. - update Patch1 (PyQt-x11-gpl-4.8.4-64bit.patch) (x86_64 only)
  128. * Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.4-1
  129. - new upstream release
  130. * Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.3-4
  131. - re-add Patch1 (PyQt-x11-gpl-4.8.3-64bit.patch) (x86_64 only)
  132. - remove %%sip_ver
  133. * Thu Mar 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.3-3
  134. - rebuilt with qt4-4.7.2
  135. * Tue Feb 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.3-2
  136. - update Patch1 (PyQt-x11-gpl-4.8.3-64bit.patch)
  137. * Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.3-1
  138. - new upstream release
  139. - built with sip-4.12.1 and qt4-4.7.1
  140. * Wed Aug 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-2
  141. - rebuild with qt4-4.6.3
  142. - fix %qtver (from 4.6.1 to 4.6.3)
  143. * Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
  144. - new upstream release
  145. - rebuilt with sip-4.10.5 and qt4-4.6.3
  146. * Sun May 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.3-1
  147. - new upstream release
  148. - updated Patch100
  149. * Fri Feb 05 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7-2
  150. - updated Patch100 to build phonon module
  151. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 4.7-1
  152. - new upstream release
  153. - rebuilt with python-2.6.4
  154. - dropt Patch100: PyQt-x11-gpl-4.5.4-vine_phonon.patch
  155. * Fri Oct 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.6-2
  156. - now BuildRequires sip-devel >= 4.9 (was 4.8.2)
  157. * Thu Oct 22 2009 Shu KONNO <owa@bg.wakwak.com> 4.6-1
  158. - new upstream release
  159. - added BR: libXext-devel
  160. * Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-3
  161. - added Patch100 for building phonon modules
  162. * Tue Aug 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-2
  163. - Initial build for Vine
  164. * Tue Jul 28 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.4-1
  165. - PyQt4-4.5.4
  166. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.2-2
  167. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  168. * Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.2-1
  169. - PyQt4-4.5.2
  170. * Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-2
  171. - fix build with qt-4.5.2
  172. - PyQt4-devel multilib conflict (#509415)
  173. * Tue Jun 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-1
  174. - PyQt-4.5.1
  175. * Fri Jun 05 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-1
  176. - PyQt-4.5
  177. * Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.2.20090520
  178. - fix generation of sip_ver
  179. * Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.1.20090520
  180. - PyQt-4.5-snapshot-20090520
  181. * Sun Apr 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.4.4-6
  182. - rebuild for phonon bindings (#497680)
  183. * Thu Mar 05 2009 Rex Dieter <rdieter@fedorproject.org> - 4.4.4-5
  184. - move designer plugins to main/runtime (#487622)
  185. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.4.4-4
  186. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  187. * Fri Feb 13 2009 Than Ngo <than@redhat.com> - 4.4.4-3
  188. - rebuild against qt-4.5rc1
  189. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 4.4.4-2
  190. - Rebuild for Python 2.6
  191. * Mon Nov 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.4-1
  192. - PyQt-4.4.4
  193. * Tue Aug 26 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.3-1
  194. - PyQt-4.4.3
  195. * Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-2
  196. - PyQt4 is built without QtWebKit support (#451490)
  197. * Wed May 21 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-1
  198. - PyQt-4.4.2
  199. * Wed May 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4-1
  200. - PyQt-4.4
  201. - License: GPLv3 or GPLv2 with exceptions
  202. * Mon Feb 11 2008 Rex Dieter <rdieter@fedoraproject.org> 4.3.3-2
  203. - respin (gcc43)
  204. * Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.3-1
  205. - PyQt-4.3.3
  206. * Thu Nov 22 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-3
  207. - dbus support (#395741)
  208. * Mon Nov 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-1
  209. - PyQt-4.3.1
  210. * Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-8
  211. - drop ExcludeArch: ppc64 , qt4 bug is (hopefully) fixed.
  212. * Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-7
  213. - fix QtDesigner plugin install
  214. * Wed Oct 03 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-6
  215. - 64bit QtDesigner patch
  216. * Mon Aug 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-5
  217. - -devel: Requires: qt4-devel
  218. * Sun Aug 26 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-4
  219. - use %%python_sitearch
  220. - License: GPLv2
  221. * Thu Aug 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-3
  222. - fix python_sitelib typo (wrt chrpath call)
  223. - move %%_bindir stuff to -devel
  224. - mark %%doc examples non-executable
  225. - add shebang to %%_bindir/pyuic4
  226. * Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-2
  227. - remove rpath from QtDesigner.so
  228. - BR: qt4-devel > 4.3.0-8
  229. * Wed Apr 11 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-1
  230. - PyQt4-4.2
  231. * Wed Feb 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.1.1-2
  232. - fix build against multilib'd qt4
  233. * Mon Dec 11 2006 Rex Dieter <rexdieter[AT]usres.sf.net> 4.1.1-1
  234. - PyQt4-4.1.1
  235. - BR: sip-devel >= 4.5.1
  236. * Mon Nov 06 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.1-1
  237. - PyQt4-4.1
  238. * Wed Oct 04 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-4
  239. - don't own %%_datadir/sip (bug #206633)
  240. * Mon Aug 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-3
  241. - BR: qt4-devel < 4.2
  242. * Sat Jul 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-2
  243. - fix reference(s) to qmake(4)
  244. * Sun Jul 16 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-1
  245. - PyQt-4.0.1
  246. * Mon Jun 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-1
  247. - PyQt-4.0(final)
  248. - BR: sip-devel >= 4.4.4 (see bug #199430)
  249. * Fri May 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.6.beta1
  250. - drop BR: qt4-MySQL qt4-ODBC qt4-PostgreSQL
  251. - drop usage of (undefined) %%sip_min
  252. * Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.5.beta1
  253. - cleanup for Extras
  254. * Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.4.beta1
  255. - 4.0beta1
  256. * Thu Apr 27 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.3.20060421
  257. - respin for sip-4.4.3
  258. - use sip-abi, sip-abi-min
  259. * Mon Apr 24 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.2.20060421
  260. - 20060421 snapshot
  261. * Wed Apr 19 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.0-0.1.20060417
  262. - first try, using 20060417 snapshot