PyQt-vl.spec 3.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117
  1. %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
  2. %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")
  3. %define name PyQt
  4. %define version 3.18.1
  5. %define release 5%{?_dist_release}
  6. Summary: Python bindings for Qt.
  7. Summary(ja): Qt の Python バインディング
  8. Name: %{name}
  9. Version: %{version}
  10. Release: %{release}
  11. License: GPLv2
  12. Group: System Environment/Libraries
  13. URL: http://www.riverbankcomputing.co.uk/pyqt
  14. Source: http://www.riverbankcomputing.com/Downloads/PyQt3/GPL/%{name}-x11-gpl-%{version}.tar.gz
  15. # FTBFS against sip-4.15+
  16. Patch1: PyQt-x11-gpl-3.18.1-sip415.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. BuildRequires: libXmu-devel
  19. BuildRequires: python-devel
  20. BuildRequires: qt-devel
  21. BuildRequires: sip-devel
  22. Requires: python
  23. %description
  24. Python bindings for the Qt C++ class library.
  25. %package devel
  26. Summary: Files needed to build other bindings based on Qt
  27. Group: Development/Libraries
  28. Requires: %{name} = %{version}
  29. Requires: sip-devel qt-devel
  30. %description devel
  31. Files needed to build other bindings for C++ classes that inherit from any
  32. of the Qt classes (e.g. KDE or your own).
  33. %prep
  34. %setup -q -n %{name}-x11-gpl-%{version}
  35. %patch1 -p0 -b .sip415
  36. %build
  37. unset QTDIR || : ; . /etc/profile.d/qt.sh
  38. echo yes | python configure.py -d %{python_sitearch} CXXFLAGS="%{optflags} -DANY=void" CFLAGS="%{optflags} -DANY=void"
  39. # Makefiles are broken, workaround
  40. make -C qt %{?_smp_mflags}
  41. make %{?_smp_mflags}
  42. %install
  43. rm -rf $RPM_BUILD_ROOT
  44. make DESTDIR=$RPM_BUILD_ROOT install
  45. mkdir -p $RPM_BUILD_ROOT%{_datadir}/sip/qt
  46. cp -r sip/* $RPM_BUILD_ROOT%{_datadir}/sip/qt/
  47. %clean
  48. rm -rf %{buildroot}
  49. %files
  50. %defattr(-, root, root, 755)
  51. %doc NEWS README ChangeLog THANKS
  52. %doc doc/PyQt.html
  53. %{_bindir}/*
  54. %{python_sitearch}/*
  55. %files devel
  56. %defattr(-,root,root)
  57. %doc examples*
  58. %{_datadir}/sip/*
  59. %changelog
  60. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-5
  61. - rebuild with gcc-5.4.0
  62. * Sat Nov 8 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.18.1-4
  63. - rebuilt on current VineSeed
  64. - added patch1
  65. - moved to System Environment/Libraries Group
  66. * Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-3
  67. - rebuilt with python-2.7.2
  68. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 3.18.1-2
  69. - rebuilt with python-2.6.4
  70. * Thu Nov 12 2009 Ryoichi INAGAKI <owa@bg.wakwak.com> 3.18.1-1
  71. - new upstream release
  72. - removed qscintilla dependency
  73. * Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 3.17.3-1vl5
  74. - rebuilt with python-2.5.2
  75. - added pyexeclib macro
  76. - applied new versioning policy
  77. * Fri Nov 30 2007 Shu KONNO <owa@bg.wakwak.com> 3.17.3-0vl2
  78. - changed source url
  79. - fixed python site-packages path (for lib64)
  80. * Thu Sep 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.17.3-0vl1
  81. - updated to 3.16
  82. - rebuilt with new toolchain
  83. * Sun Jun 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.16-0vl1
  84. - updated to 3.16
  85. - changed Group to Development/Languages
  86. - rebuild with python-2.4.3, sip-4.4.5, qscinteilla-1.6
  87. * Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 3.13-0vl2
  88. - rebuild with python-2.4.1
  89. * Sat Jan 15 2005 Satoshi MACHINO <machino@vinelinux.org> 3.13-0vl1
  90. - initial release for VineLinux