PyOpenGL-vl.spec 3.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135
  1. %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. %define pyver %(python -c 'import sys;print(sys.version[0:3])')
  3. Name: PyOpenGL
  4. Version: 3.1.0
  5. Release: 1%{_dist_release}
  6. Summary: Python bindings for OpenGL
  7. Summary(ja): OpenGL の Python バインディング
  8. License: BSD
  9. Group: System Environment/Libraries
  10. URL: http://pyopengl.sourceforge.net/
  11. Source0: http://downloads.sourceforge.net/pyopengl/%{name}-%{version}.tar.gz
  12. Patch0: PyOpenGL-3.0.0a6-shebang.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildArch: noarch
  15. BuildRequires: python-devel
  16. BuildRequires: python-setuptools
  17. Requires: python-numeric
  18. Requires: python-setuptools
  19. Requires: freeglut
  20. # in some other repositories this is named python-opengl
  21. Provides: python-opengl = %{version}-%{release}
  22. Obsoletes: python-opengl < %{version}-%{release}
  23. Vendor: Project Vine
  24. Distribution: Vine Linux
  25. %description
  26. PyOpenGL is the cross platform Python binding to OpenGL and related APIs. It
  27. includes support for OpenGL v1.1, GLU, GLUT v3.7, GLE 3 and WGL 4. It also
  28. includes support for dozens of extensions (where supported in the underlying
  29. implementation).
  30. PyOpenGL is interoperable with a large number of external GUI libraries
  31. for Python including (Tkinter, wxPython, FxPy, PyGame, and Qt).
  32. %package Tk
  33. Summary: %{name} OpenGL Tk widget
  34. Group: System Environment/Libraries
  35. Requires: %{name} = %{version}-%{release}, tkinter
  36. Requires: tkinter
  37. %description Tk
  38. %{name} Togl (Tk OpenGL widget) 1.6 support.
  39. %package doc
  40. Summary: Documentation files for %{name}
  41. Summary(ja): %{name} のドキュメント
  42. Group: Documentation
  43. Requires: %{name} = %{version}-%{release}
  44. %description doc
  45. Documentation files for %{name}.
  46. %prep
  47. %setup -q
  48. #patch0 -p1 -z .shebang
  49. %build
  50. python setup.py build
  51. %install
  52. rm -rf $RPM_BUILD_ROOT
  53. python setup.py install -O1 --skip-build \
  54. --root="$RPM_BUILD_ROOT" --prefix="%{_prefix}"
  55. #chmod -x $RPM_BUILD_ROOT%{python_sitelib}/%{name}-%{version}-py%{pyver}.egg-info
  56. %clean
  57. rm -rf $RPM_BUILD_ROOT
  58. %files
  59. %defattr(-,root,root,-)
  60. %doc license.txt
  61. %{python_sitelib}/*OpenGL*
  62. %exclude %{python_sitelib}/OpenGL/Tk
  63. %files Tk
  64. %defattr(-,root,root,-)
  65. %{python_sitelib}/OpenGL/Tk
  66. %files doc
  67. %defattr(-,root,root,-)
  68. #doc documentation/*
  69. %changelog
  70. * Wed Nov 19 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.1.0-1
  71. - updated to 3.1.0
  72. * Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.0-4
  73. - rebuild with python-2.7.2
  74. * Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 3.0.0-3
  75. - rebuilt with rpm-4.8.1-3
  76. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 3.0.0-2
  77. - rebuilt with python-2.6.4
  78. * Sat Jul 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1
  79. - new upstream release 3.0.0
  80. - remove Requires: XOrg-gl (libGL should be pulled by freeglut)
  81. * Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.0-0.b1.2
  82. - rebuilt with python-2.5.2
  83. * Mon Apr 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.0.0-0.b1.1
  84. - Initial build for Vine Linux
  85. * Mon Dec 31 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-0.5.b1
  86. - New upstream release 3.0.0b1
  87. * Thu Aug 30 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-0.4.a6
  88. - Change BuildRequires python-setuptools to python-setuptools-devel for
  89. the python-setuptools package split
  90. * Fri Apr 13 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-0.3.a6
  91. - Add missing freeglut, libGL and libGLU requires (bz 236159)
  92. * Thu Mar 29 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-0.2.a6
  93. - Remove tests from the package (bz 234121)
  94. - Add -Tk subpackage (bz 234121)
  95. - Remove shebang from files with shebang instead of chmod +x (bz 234121)
  96. - Better description
  97. * Sat Mar 24 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0.0-0.1.a6
  98. - Initial Fedora Extras package