PolicyKit-gnome-vl.spec 7.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235
  1. %define dbus_version 1.2
  2. %define dbus_glib_version 0.80
  3. %define gtk2_version 2.16
  4. %define gnome_vfs2_version 2.24
  5. %define libsexy_version 0.1.11
  6. %define gnome_doc_utils_version 0.3.2
  7. %define polkit_version 0.9
  8. %define intltool_version 0.35
  9. Summary: PolicyKit integration for the GNOME desktop
  10. Name: PolicyKit-gnome
  11. Version: 0.9.2
  12. Release: 2%{?_dist_release}
  13. License: GPLv2+
  14. Group: System Environment/Libraries
  15. URL: http://gitweb.freedesktop.org/?p=users/david/PolicyKit-gnome.git;a=summary
  16. Source0: http://hal.freedesktop.org/releases/%{name}-%{version}.tar.bz2
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  18. BuildRequires: dbus-devel >= %{dbus_version}
  19. BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
  20. BuildRequires: dbus-glib >= %{dbus_glib_version}
  21. BuildRequires: gtk2-devel >= %{gtk2_version}
  22. BuildRequires: gnome-vfs2-devel >= %{gnome_vfs2_version}
  23. BuildRequires: libsexy-devel >= %{libsexy_version}
  24. BuildRequires: PolicyKit-devel >= %{polkit_version}
  25. BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
  26. BuildRequires: intltool >= %{intltool_version}
  27. BuildRequires: gettext
  28. BuildRequires: desktop-file-utils
  29. Requires: dbus >= %{dbus_version}
  30. Requires: dbus-glib >= %{dbus_glib_version}
  31. Requires: gtk2 >= %{gtk2_version}
  32. Requires: gnome-vfs2 >= %{gnome_vfs2_version}
  33. Requires: PolicyKit >= %{polkit_version}
  34. Requires: libsexy >= %{libsexy_version}
  35. Patch0: PolicyKit-gnome-0.9.2-dont-spawn-when-running-under-gdm.patch
  36. Patch1: PolicyKit-gnome-0.9.2-fix-clickable-buttons.patch
  37. %description
  38. PolicyKit-gnome provides a GNOME integration library and tools for
  39. PolicyKit including an Authentication Agent that matches the look and
  40. feel of the GNOME desktop.
  41. %package demo
  42. License: GPLv2+
  43. Summary: Demo application for PolicyKit-gnome
  44. Group: Development/Libraries
  45. Requires: %{name} = %{version}-%{release}
  46. %description demo
  47. Policy-gnome-demo provides a sample application that demonstrates the
  48. features of both PolicyKit and PolicyKit-gnome. You normally don't
  49. want to have this package installed.
  50. %package libs
  51. License: LGPLv2+
  52. Summary: PolicyKit-gnome libraries
  53. Group: Development/Libraries
  54. Requires: gtk2 >= %{gtk2_version}
  55. Requires: PolicyKit >= %{polkit_version}
  56. %description libs
  57. Libraries provided by PolicyKit-gnome
  58. %package devel
  59. License: LGPLv2+
  60. Summary: Headers, libraries and API docs for PolicyKit-gnome
  61. Group: Development/Libraries
  62. Requires: %{name} = %{version}-%{release}
  63. Requires: pkgconfig
  64. Requires: PolicyKit-devel >= %{polkit_version}
  65. Requires: PolicyKit-docs >= %{polkit_version}
  66. %description devel
  67. This package provides headers, libraries and API docs for
  68. PolicyKit-gnome.
  69. %prep
  70. %setup -q
  71. %patch0 -p0 -b .no-spawning-under-gdm
  72. %patch1 -p0 -b .fix-clickable-buttons
  73. %build
  74. %configure
  75. make
  76. %install
  77. rm -rf $RPM_BUILD_ROOT
  78. make install DESTDIR=$RPM_BUILD_ROOT
  79. desktop-file-install --delete-original \
  80. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  81. --remove-only-show-in=GNOME \
  82. $RPM_BUILD_ROOT%{_datadir}/applications/polkit-gnome-authorization.desktop
  83. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  84. rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
  85. %find_lang %{name}
  86. %clean
  87. rm -rf $RPM_BUILD_ROOT
  88. %post
  89. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  90. gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/polkit-gnome.schemas >& /dev/null || :
  91. %pre
  92. if [ "$1" -gt 1 ]; then
  93. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  94. gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/polkit-gnome.schemas >& /dev/null || :
  95. fi
  96. %preun
  97. if [ "$1" -eq 0 ]; then
  98. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  99. gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/polkit-gnome.schemas >& /dev/null || :
  100. fi
  101. %files -f %{name}.lang
  102. %defattr(-,root,root,-)
  103. %doc README AUTHORS NEWS COPYING HACKING TODO
  104. %{_libexecdir}/polkit-gnome-manager
  105. %{_datadir}/dbus-1/services/org.gnome.PolicyKit.service
  106. %{_datadir}/dbus-1/services/org.gnome.PolicyKit.AuthorizationManager.service
  107. %{_datadir}/dbus-1/services/gnome-org.freedesktop.PolicyKit.AuthenticationAgent.service
  108. %{_bindir}/polkit-gnome-authorization
  109. %{_datadir}/applications/polkit-gnome-authorization.desktop
  110. %{_sysconfdir}/gconf/schemas/polkit-gnome.schemas
  111. %files libs
  112. %{_libdir}/lib*.so.*
  113. %files devel
  114. %{_libdir}/lib*.so
  115. %{_libdir}/pkgconfig/*
  116. %{_includedir}/*
  117. %dir %{_datadir}/gtk-doc/html/polkit-gnome
  118. %{_datadir}/gtk-doc/html/polkit-gnome/*
  119. %files demo
  120. %defattr(-,root,root,-)
  121. %{_bindir}/polkit-gnome-example
  122. %{_datadir}/PolicyKit/policy/*.policy
  123. %changelog
  124. * Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.2-2
  125. - rebuilt with rpm-4.8.1 for pkg-config
  126. * Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.2-1
  127. - new upstream release
  128. * Mon Aug 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9-1
  129. - new upstream release
  130. * Wed Jun 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.8-6
  131. - initial build for Vine Linux
  132. * Thu May 1 2008 David Zeuthen <davidz@redhat.com> - 0.8-5%{?dist}
  133. - Rebuild
  134. * Thu May 1 2008 David Zeuthen <davidz@redhat.com> - 0.8-4%{?dist}
  135. - Don't spawn stuff under gdm
  136. * Thu Apr 17 2008 David Zeuthen <davidz@redhat.com> - 0.8-3%{?dist}
  137. - Fix i18n (#442938)
  138. * Thu Apr 17 2008 Matthias Clasen <mclasen@redhat.com> - 0.8-2%{?dist}
  139. - Show the menu item in other desktops too (#442814)
  140. * Wed Apr 16 2008 David Zeuthen <davidz@redhat.com> - 0.8-1%{?dist}
  141. - Upstream release 0.8
  142. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.7-3
  143. - Autorebuild for GCC 4.3
  144. * Tue Dec 18 2007 David Zeuthen <davidz@redhat.com> - 0.7-2%{?dist}
  145. - Avoid crashing when an authorization is blocked for a user without ~/.face
  146. * Thu Dec 6 2007 David Zeuthen <davidz@redhat.com> - 0.7-1%{?dist}
  147. - Update to latest upstream release
  148. * Mon Oct 22 2007 Matthias Clasen <mclasen@redhat.com> - 0.6-2
  149. - Rebuild against new dbus-glib
  150. * Thu Oct 11 2007 David Zeuthen <davidz@redhat.com> - 0.6-1%{?dist}
  151. - Update to latest upstream release
  152. * Tue Sep 25 2007 David Zeuthen <davidz@redhat.com> - 0.6-0.git20070925%{?dist}
  153. - Update to git snapshot
  154. * Mon Sep 3 2007 Matthias Clasen <mclasen@redhat.com> - 0.5-4
  155. - Add gettext BR
  156. * Fri Aug 31 2007 David Zeuthen <davidz@redhat.com> - 0.5-3%{?dist}
  157. - Rebuild
  158. * Fri Aug 31 2007 David Zeuthen <davidz@redhat.com> - 0.5-2%{?dist}
  159. - Require newer PolicyKit release
  160. * Fri Aug 31 2007 David Zeuthen <davidz@redhat.com> - 0.5-1%{?dist}
  161. - Upstream release 0.5
  162. * Tue Jul 31 2007 David Zeuthen <davidz@redhat.com> - 0.5-0.git20070731.4%{?dist}
  163. - Add BR for intltool
  164. * Tue Jul 31 2007 David Zeuthen <davidz@redhat.com> - 0.5-0.git20070731.3%{?dist}
  165. - Add BR for gnome-doc-utils
  166. * Tue Jul 31 2007 David Zeuthen <davidz@redhat.com> - 0.5-0.git20070731.2%{?dist}
  167. - Rebuild
  168. * Tue Jul 31 2007 David Zeuthen <davidz@redhat.com> - 0.5-0.git20070731.1%{?dist}
  169. - Rebuild and require PolicyKit >= 0.5
  170. * Tue Jul 31 2007 David Zeuthen <davidz@redhat.com> - 0.5-0.git20070731%{?dist}
  171. - Update to git snapshot
  172. * Wed Jul 25 2007 David Zeuthen <davidz@redhat.com> - 0.4-1%{?dist}
  173. - Update to 0.4
  174. * Tue Jun 19 2007 David Zeuthen <davidz@redhat.com> - 0.3-1%{?dist}
  175. - Initial build.