OpenImageIO-vl.spec 7.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254
  1. %global subname oiio
  2. Name: OpenImageIO
  3. Version: 1.6.14
  4. Release: 3%{?_dist_release}
  5. Summary: Library for reading and writing images
  6. Group: System Environment/Libraries
  7. License: BSD
  8. URL: https://sites.google.com/site/openimageio/home
  9. Source0: https://github.com/%{name}/%{subname}/archive/Release-%{version}/%{subname}-Release-%{version}.tar.gz
  10. # Images for test suite
  11. #Source1: oiio-images.tar.gz
  12. BuildRequires: cmake
  13. BuildRequires: txt2man
  14. BuildRequires: qt4-devel
  15. BuildRequires: libboost-devel
  16. BuildRequires: libboost-python
  17. BuildRequires: libboost-filesystem
  18. BuildRequires: glew-devel
  19. BuildRequires: OpenEXR-devel ilmbase-devel
  20. BuildRequires: python-devel
  21. BuildRequires: openssl-devel
  22. BuildRequires: libpng-devel libtiff-devel openjpeg-devel giflib-devel
  23. BuildRequires: libwebp-devel
  24. BuildRequires: Field3D-devel
  25. BuildRequires: hdf5-devel
  26. BuildRequires: zlib-devel
  27. BuildRequires: jasper-devel
  28. BuildRequires: LibRaw-devel
  29. BuildRequires: pugixml-devel
  30. # WARNING: OpenColorIO and OpenImageIO are cross dependent.
  31. # If an ABI incompatible update is done in one, the other also needs to be
  32. # rebuilt.
  33. BuildRequires: OpenColorIO-devel
  34. # We don't want to provide private python extension libs
  35. %{?filter_setup:
  36. %filter_provides_in %{python_sitearch}/.*\.so$
  37. %filter_setup
  38. }
  39. %description
  40. OpenImageIO is a library for reading and writing images, and a bunch of related
  41. classes, utilities, and applications. Main features include:
  42. - Extremely simple but powerful ImageInput and ImageOutput APIs for reading and
  43. writing 2D images that is format agnostic.
  44. - Format plugins for TIFF, JPEG/JFIF, OpenEXR, PNG, HDR/RGBE, Targa, JPEG-2000,
  45. DPX, Cineon, FITS, BMP, ICO, RMan Zfile, Softimage PIC, DDS, SGI,
  46. PNM/PPM/PGM/PBM, Field3d.
  47. - An ImageCache class that transparently manages a cache so that it can access
  48. truly vast amounts of image data.
  49. %package -n python-%{name}
  50. Summary: Python 2 bindings for %{name}
  51. Requires: %{name} = %{version}-%{release}
  52. %description -n python-%{name}
  53. Python bindings for %{name}.
  54. %package utils
  55. Summary: Command line utilities for %{name}
  56. Requires: %{name} = %{version}-%{release}
  57. %description utils
  58. Command-line tools to manipulate and get information on images using the
  59. %{name} library.
  60. %package iv
  61. Summary: %{name} based image viewer
  62. Requires: %{name} = %{version}-%{release}
  63. %description iv
  64. A really nice image viewer, iv, based on %{name} classes (and so will work
  65. with any formats for which plugins are available).
  66. %package devel
  67. Summary: Documentation for %{name}
  68. Group: Development/Libraries
  69. Requires: %{name} = %{version}-%{release}
  70. %description devel
  71. Development files for package %{name}
  72. %prep
  73. %setup -q -n oiio-Release-%{version}
  74. # Remove bundled pugixml
  75. rm -f src/include/pugixml.hpp \
  76. src/include/pugiconfig.hpp \
  77. src/libutil/pugixml.cpp
  78. # Remove bundled tbb
  79. rm -rf src/include/tbb
  80. # Install test images
  81. #rm -rf ../oiio-images && mkdir ../oiio-images && pushd ../oiio-images
  82. #tar --strip-components=1 -xzf %{SOURCE1}
  83. %build
  84. rm -rf build/linux && mkdir -p build/linux && pushd build/linux
  85. # CMAKE_SKIP_RPATH is OK here because it is set to FALSE internally and causes
  86. # CMAKE_INSTALL_RPATH to be cleared, which is the desiered result.
  87. %cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo \
  88. -DCMAKE_SKIP_RPATH:BOOL=TRUE \
  89. -DINCLUDE_INSTALL_DIR:PATH=/usr/include/%{name} \
  90. -DPYLIB_INSTALL_DIR:PATH=%{python_sitearch} \
  91. -DINSTALL_DOCS:BOOL=FALSE \
  92. -DINSTALL_FONTS:BOOL=FALSE \
  93. -DUSE_EXTERNAL_PUGIXML:BOOL=TRUE \
  94. -DUSE_TBB:BOOL=FALSE \
  95. %ifarch ppc ppc64
  96. -DNOTHREADS:BOOL=FALSE \
  97. %endif
  98. -DVERBOSE=TRUE \
  99. ../../
  100. make %{?_smp_mflags}
  101. %install
  102. pushd build/linux
  103. make DESTDIR=%{buildroot} install
  104. # Move man pages to the right directory
  105. mkdir -p %{buildroot}%{_mandir}/man1
  106. cp -a src/doc/*.1 %{buildroot}%{_mandir}/man1
  107. %post -p /sbin/ldconfig
  108. %postun -p /sbin/ldconfig
  109. %files
  110. %doc CHANGES LICENSE
  111. %{_libdir}/libOpenImageIO.so.*
  112. %{_libdir}/libOpenImageIO_Util.so.*
  113. %files -n python-%{name}
  114. %{python_sitearch}/OpenImageIO.so
  115. %files utils
  116. %exclude %{_bindir}/iv
  117. %{_bindir}/*
  118. %exclude %{_mandir}/man1/iv.1.gz
  119. %{_mandir}/man1/*.1.gz
  120. %files iv
  121. %{_bindir}/iv
  122. %{_mandir}/man1/iv.1.gz
  123. %files devel
  124. %doc src/doc/*.pdf
  125. %{_libdir}/libOpenImageIO.so
  126. %{_libdir}/libOpenImageIO_Util.so
  127. %{_includedir}/*
  128. %changelog
  129. * Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.14-3
  130. - rebuilt with LibRaw-0.17.2.
  131. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-2
  132. - rebuild with gcc-5.4.0
  133. * Mon Jun 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
  134. - new upstream release
  135. * Fri May 06 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.13-1
  136. - new upstream release
  137. - remove Patch0
  138. - create python-%%{name} subpackage
  139. * Thu Oct 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-2
  140. - rebuild with glew-1.13.0
  141. * Sun Jan 18 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-1
  142. - initial build for Vine Linux
  143. - add Patch0 (oiio-Release-1.4.15-sign-compare.patch)
  144. * Wed Nov 26 2014 Rex Dieter <rdieter@fedoraproject.org> 1.4.15-2
  145. - rebuild (openexr)
  146. * Tue Nov 25 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.15-1
  147. - Update to latest upstream release.
  148. * Fri Nov 14 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.14-1
  149. - Update to latest upstream release.
  150. * Fri Sep 5 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-4
  151. - Rebuild for Field3D 1.4.3.
  152. * Thu Sep 04 2014 Orion Poplawski <orion@cora.nwra.com> - 1.4.12-3
  153. - Rebuild for pugixml 1.4
  154. * Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.12-2
  155. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  156. * Fri Aug 1 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-1
  157. - Update to latest upstream release.
  158. * Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.7-4
  159. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  160. * Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 1.4.7-3
  161. - Rebuild for boost 1.55.0
  162. * Fri May 23 2014 David Tardon <dtardon@redhat.com> - 1.4.7-2
  163. - rebuild for boost 1.55.0
  164. * Mon May 19 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.7-1
  165. - Update to latest upstream release.
  166. * Tue Jan 7 2014 Richard Shaw <hobbes1069@gmail.com> - 1.3.10-1
  167. - Update to latest upstream release.
  168. - Add libgif as build requirement.
  169. * Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> - 1.2.3-3
  170. - rebuild (openexr)
  171. * Mon Nov 18 2013 Dave Airlie <airlied@redhat.com> - 1.2.3-2
  172. - rebuilt for GLEW 1.10
  173. * Wed Nov 6 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.3-1
  174. - Update to latest upstream release.
  175. - Fix ppc builds (BZ#1021977).
  176. - Add conditionals to build requirements for EPEL 6.
  177. * Wed Oct 2 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.2-1
  178. - Update to latest upstream release.
  179. * Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 1.2.1-2
  180. - rebuild (ilmbase/openexr)
  181. * Thu Aug 8 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.1-1
  182. - Update to latest upstream release.
  183. * Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-3
  184. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  185. * Sun Jul 28 2013 Petr Machata <pmachata@redhat.com> - 1.2.0-2
  186. - Rebuild for boost 1.54.0