GraphicsMagick-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368
  1. %define pkg_name GraphicsMagick
  2. %define pkg_version 1.3.24
  3. %define pkg_release 2%{?_dist_release}
  4. %define quant 16
  5. %define perlm 1
  6. Name: %{pkg_name}
  7. Summary: An X application for displaying and manipulating images
  8. Summary(ja): 画像ファイルの表示/処理を行うXのアプリケーション
  9. Version: %{pkg_version}
  10. Release: %{pkg_release}
  11. License: MIT License
  12. Group: Applications/Graphics
  13. URL: http://www.graphicsmagick.org/
  14. Source: ftp://ftp.GraphicsMagick.org/pub/%{name}/%{name}-%{version}.tar.gz
  15. Buildroot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: bzip2-devel
  17. BuildRequires: freetype2-devel >= 2.0.1
  18. BuildRequires: libjpeg-turbo-devel
  19. BuildRequires: libpng-devel >= 1.2.5
  20. BuildRequires: libtiff-devel
  21. BuildRequires: lcms-devel
  22. BuildRequires: xz-devel
  23. BuildRequires: libX11-devel
  24. BuildRequires: libxml2-devel
  25. BuildRequires: zlib-devel
  26. BuildRequires: libtool-ltdl-devel
  27. Requires: bzip2
  28. Requires: freetype2 >= 2.0.1
  29. Requires: libjpeg-turbo
  30. Requires: libpng
  31. Requires: libtiff
  32. Requires: lcms
  33. Requires: libxml2
  34. Requires: xz
  35. Requires: zlib
  36. Vendor: Project Vine
  37. Distribution: Vine Linux
  38. Packager: ara_t
  39. %description
  40. GraphicsMagick(TM) provides a powerful image manipulation and
  41. translation utility. It is capable of displaying still images and
  42. animations using the X Window system, provides a simple interface for
  43. interactively editing images, and is capable of importing selected
  44. windows or the entire desktop. GraphicsMagick can read and write over
  45. 88 image formats, including JPEG, TIFF, WMF, SVG, PNG, PNM, GIF, and
  46. Photo CD. It can resize, rotate, sharpen, color reduce, or add special
  47. effects to the image and save the result to any supported format.
  48. GraphicsMagick may be used to create animated or transparent .gifs,
  49. create composite images, create thumbnail images, and much, much,
  50. more.
  51. GraphicsMagick is one of your choices if you need a program to manipulate
  52. and display images. If you want to develop your own applications
  53. which use GraphicsMagick code or APIs, you need to install
  54. GraphicsMagick-devel as well.
  55. %description -l ja
  56. GraphicsMagick(TM)はXウィンドウシステム用の画像表示/処理ツールです。
  57. GraphicsMagickが読み書き出来る画像形式にはJPEG, TIFF, PNM, GIF, Photo CD
  58. イメージ型式等があります。また画像のリサイズ、回転、シャープ化、減色が
  59. 出来ますし、画像に対してイフェクトをかけることも出来ます、変更した画像は
  60. オリジナルと同じ画像形式ででも、異なる画像形式にでも保存することが出来ます。
  61. またGraphicsMagickにはアニメーションGIFや透過GIFの作成、画像の合成、
  62. サムネール画像の作成等々を行うコマンドラインプログラムも含まれています。
  63. 画像ファイルの表示/処理を行う為の幾多のプログラムが必要ならば、
  64. GraphicsMagickも選択肢の一つとなるでしょう。
  65. また、GraphicsMagickのコードやAPIを使ったアプリケーションを開発したい場合は、
  66. GraphicsMagick-develパッケージも同時にインストールして下さい。
  67. %package devel
  68. Summary: Static libraries and header files for GraphicsMagick app development.
  69. Summary(ja): GraphicsMagickアプリケーション開発用ライブラリ/ヘッダファイル
  70. Group: Development/Libraries
  71. Requires: %{name} = %{version}-%{release}
  72. %description devel
  73. GraphicsMagick-devel contains the static libraries and header files you'll
  74. need to develop GraphicsMagick applications. GraphicsMagick is an image
  75. manipulation program.
  76. If you want to create applications that will use GraphicsMagick code or
  77. APIs, you need to install GraphicsMagick-devel as well as GraphicsMagick.
  78. You do not need to install it if you just want to use GraphicsMagick,
  79. however.
  80. #'
  81. %description devel -l ja
  82. GraphicsMagick-develにはスタティックライブラリとヘッダファイルが収められており、
  83. これらはGraphicsMagickアプリケーションの開発の際に必要となります。
  84. GraphicsMagickは画像処理プログラムです。
  85. GraphicsMagickのコードやAPIを使ったアプリケーションを作りたい場合には、
  86. このGraphicsMagick-develパッケージをGraphicsMagickパッケージと共にインストール
  87. する必要があります。単にGraphicsMagickを使いたいだけならば、
  88. develパッケージはインストールする必要はありません。
  89. %package c++
  90. Summary: GraphicsMagick Magick++ library (C++ bindings)
  91. Summary(ja): GraphicsMagick Magick++ライブラリ (C++バインディング)
  92. Group: System Environment/Libraries
  93. Requires: %{name} = %{version}-%{release}
  94. %description c++
  95. This package contains the Magick++ library, a C++ binding to the GraphicsMagick
  96. graphics manipulation library.
  97. Install GraphicsMagick-c++ if you want to use any applications that use
  98. Magick++.
  99. %description c++
  100. このパッケージにはMagick++ライブラリが収められています。
  101. Magick++とはImageMagickライブラリのC++バインディングです。
  102. Magick++を使ったアプリケーションを利用する際にはImageMagick-c++
  103. パッケージをインストールして下さい。
  104. %package c++-devel
  105. Summary: C++ bindings for the GraphicsMagick library
  106. Summary(ja): GraphicsMagickライブラリのC++バインディング
  107. Group: Development/Libraries
  108. Requires: %{name} = %{version}
  109. Requires: %{name}-c++ = %{version}
  110. Requires: %{name}-devel = %{version}
  111. Requires: bzip2-devel, freetype-devel
  112. Requires: libjpeg-turbo-devel libpng-devel libtiff-devel
  113. Requires: zlib-devel libxml2-devel
  114. %description c++-devel
  115. GraphicsMagick-c++-devel contains the static libraries and header files you'll
  116. need to develop GraphicsMagick applications using the Magick++ C++ bindings.
  117. GraphicsMagick is an image manipulation program.
  118. If you want to create applications that will use Magick++ code or APIs,
  119. you'll need to install GraphicsMagick-c++-devel, GraphicsMagick-devel and
  120. GraphicsMagick. You don't need to install it if you just want to use
  121. GraphicsMagick, or if you want to develop/compile applications using the
  122. GraphicsMagick C interface, however.
  123. #'
  124. %description c++-devel -l ja
  125. GraphicsMagick-c++-devel にはMagick++ C++バインディングを使った
  126. GraphicsMagickアプリケーション開発に必要なスタティックライブラリと
  127. ヘッダファイルが収められています。
  128. GraphicsMagickとは画像処理プログラムです。
  129. Magick++コードやAPIを使ったアプリケーションを開発する場合は、
  130. GraphicsMagick-c++-devel、GraphicsMagick-devel、GraphicsMagickパッケージを
  131. インストールする必要があります。
  132. GraphicsMagickプログラムを使うだけの場合、あるいはGraphicsMagick Cインタフェース
  133. を使ってアプリケーション開発を行う場合は,GraphicsMagick-c++-devel パッケージは
  134. インストールする必要はありません。
  135. %if %{perlm}
  136. %package -n perl-GraphicsMagick
  137. Summary: GraphicsMagick perl bindings
  138. Summary(ja): GraphicsMagickのPerlバインディング
  139. Group: System Environment/Libraries
  140. BuildRequires: perl >= 5.6.0
  141. Requires: %{name} = %{version}-%{release}
  142. Requires: perl >= 5.6.0
  143. %description -n perl-GraphicsMagick
  144. Perl bindings to GraphicsMagick.
  145. Install GraphicsMagick-perl if you want to use any perl scripts that use
  146. GraphicsMagick.
  147. %description -n perl-GraphicsMagick -l ja
  148. このパッケージはGraphicsMagickのPerlバインディングです。
  149. GraphicsMagickを利用するperlスクリプトを使いたい場合は
  150. perl-GraphicsMagickパッケージをインストールして下さい。
  151. %endif
  152. %prep
  153. %{__rm} -rf ${RPM_BUILD_ROOT}
  154. %setup -q
  155. %build
  156. %{configure} \
  157. --enable-silent-rules \
  158. --enable-shared \
  159. --disable-static \
  160. --with-modules \
  161. --with-quantum-depth=%{quant} \
  162. --without-frozenpaths \
  163. --with-x \
  164. --with-magick-plus-plus \
  165. --without-dps \
  166. --without-fpx \
  167. --without-gslib \
  168. --without-jbig \
  169. --without-jp2 \
  170. --without-trio \
  171. --without-webp \
  172. --without-wmf \
  173. --docdir=%{_datadir}/doc/%{name}-%{version} \
  174. %if %{perlm}
  175. --with-perl \
  176. --with-perl-options="INSTALLDIRS=vendor %{?perl_prefix} CC='%__cc -L$PWD/magick/.libs' LDDLFLAGS='-shared -L$PWD/magick/.libs'"
  177. %else
  178. --without-perl \
  179. %endif
  180. %{__make} %{?_smp_mflags}
  181. %if %{perlm}
  182. %{__make} all-perl
  183. %endif
  184. %install
  185. %{make_install}
  186. %if %{perlm}
  187. %{__make} install-exec-perl DESTDIR=${RPM_BUILD_ROOT}
  188. # Remove unpackaged files.
  189. %{__rm} -f `find ${RPM_BUILD_ROOT}%{_libdir}/perl*/ -name perllocal.pod -type f`
  190. %{__rm} -f `find ${RPM_BUILD_ROOT}%{_libdir}/perl*/ -name .packlist -type f`
  191. %endif
  192. %clean
  193. %{__rm} -rf ${RPM_BUILD_ROOT}
  194. %post -p %{_syssbindir}/ldconfig
  195. %postun -p %{_syssbindir}/ldconfig
  196. %post c++ -p %{_syssbindir}/ldconfig
  197. %postun c++ -p %{_syssbindir}/ldconfig
  198. %files
  199. %defattr(-,root,root)
  200. %{_bindir}/gm
  201. %{_libdir}/lib%{name}.so.*
  202. %{_libdir}/lib%{name}Wand.so.*
  203. %{_libdir}/%{name}-%{version}/config/*.mgk
  204. %{_libdir}/%{name}-%{version}/modules-Q%{quant}/*/*.so
  205. %{_libdir}/%{name}-%{version}/modules-Q%{quant}/*/*.la
  206. %{_datadir}/%{name}-%{version}/config/*.mgk
  207. %{_docdir}/%{name}-%{version}/
  208. %{_mandir}/man1/gm.1.gz
  209. %{_mandir}/man4/*gz
  210. %{_mandir}/man5/*gz
  211. %files devel
  212. %defattr(-,root,root)
  213. %{_bindir}/%{name}-config
  214. %{_bindir}/%{name}Wand-config
  215. %{_includedir}/%{name}/wand/
  216. %{_includedir}/%{name}/magick/
  217. %{_libdir}/lib%{name}.*a
  218. %{_libdir}/lib%{name}.so
  219. %{_libdir}/lib%{name}Wand.*a
  220. %{_libdir}/lib%{name}Wand.so
  221. %{_libdir}/pkgconfig/%{name}.pc
  222. %{_libdir}/pkgconfig/%{name}Wand.pc
  223. %{_mandir}/man1/%{name}-config.1.gz
  224. %{_mandir}/man1/%{name}Wand-config.1.gz
  225. %files c++
  226. %defattr(-,root,root)
  227. %{_libdir}/lib%{name}++.so.*
  228. %files c++-devel
  229. %defattr(-,root,root)
  230. %{_bindir}/%{name}++-config
  231. %{_includedir}/%{name}/Magick++.h
  232. %{_includedir}/%{name}/Magick++/
  233. %{_libdir}/lib%{name}++.*a
  234. %{_libdir}/lib%{name}++.so
  235. %{_libdir}/pkgconfig/%{name}++.pc
  236. %{_mandir}/man1/%{name}++-config.1.gz
  237. %if %{perlm}
  238. %files -n perl-GraphicsMagick
  239. %defattr(-,root,root)
  240. %{_libdir}/perl*/vendor_perl/
  241. %{_mandir}/man3/*gz
  242. %endif
  243. %changelog
  244. * Tue Jun 28 2016 Toshiaki Ara <ara_t@384.jp> 1.3.24-2
  245. - rebuild with gcc-5.4.0
  246. * Sun Jun 19 2016 Toshiaki Ara <ara_t@384.jp> 1.3.24-1
  247. - update to 1.3.24
  248. * Mon Apr 11 2016 Toshiaki Ara <ara_t@384.jp> 1.3.23-2
  249. - correct SPEC file
  250. * Wed Mar 16 2016 Toshiaki Ara <ara_t@384.jp> 1.3.23-1
  251. - new package for Vine Linux
  252. * Fri Apr 16 2010 Bob Friesenhahn <bfriesen@graphicsmagick.org> 1.3.13
  253. - Avoided duplicate copies of documentation files. Put documentation
  254. into a versioned directory as used by Red Hat and CentOS. Include
  255. archive libraries in developer package.
  256. * Tue Apr 13 2010 Bob Friesenhahn <bfriesen@graphicsmagick.org> 1.3.13
  257. - Fixed PerlMagick build and install which was broken by Makefile
  258. changes.
  259. * Wed Jan 23 2009 Bob Friesenhahn <bfriesen@graphicsmagick.org> 1.3
  260. - The module .la files need to be installed as part of the base
  261. install or else the modules will fail to load.
  262. * Wed Jan 21 2009 Bob Friesenhahn <bfriesen@graphicsmagick.org> 1.3
  263. - --enable-lzw option is not longer needed
  264. * Tue Nov 11 2008 Giacomo Tenaglia 1.3 <gtenagli at sf . net>.
  265. - The *-config scripts were listed twice.
  266. - Add definition for %{_datadir}/doc directory
  267. * Wed Jun 02 2004 Bob Friesenhahn <bfriesen@graphicsmagick.org> 1.2
  268. - Install *-config scripts with mode 755 rather than default 644.
  269. * Sat Feb 21 2004 Bob Friesenhahn <bfriesen@graphicsmagick.org> 1.1-1
  270. - Added some comments.
  271. - Eliminated DATE variable.
  272. - Support creating RPMs of snapshots packages.
  273. - Don't remove /usr/include/magick or %{_datadir}/%{name} since they
  274. are not created anymore.
  275. - Fixed location of .mgk files.
  276. * Mon Jul 28 2003 Bob Friesenhahn <bfriesen@graphicsmagick.org> 1.1-1
  277. - Changed default quantum depth to 8 bits.
  278. * Mon Jun 28 2003 Troy Edwards <vallimar@sexorcisto.net> 1.1-20030628
  279. - Updated to CVS build, added the GraphicsMagickWand files to the spec.
  280. - Only try to remove the unneeded perl package files if we are using
  281. PerlMagick.
  282. * Mon Jun 09 2003 Troy Edwards <vallimar@sexorcisto.net> 1.0.2-3
  283. - removed libungif as a dependancy
  284. - changed with/without-magick_plus_plus -> with/without-magick-plus-plus
  285. - Use --with-perl-options instead of patching Makefile.in
  286. - Only set a perl prefix if we aren't using perl >= 5.8.0
  287. * Sat Jun 07 2003 Troy Edwards <vallimar@sexorcisto.net> 1.0.2-2
  288. - patch to pass DESTDIR to install-exec-perl since some users
  289. reported problems
  290. * Sat Jun 07 2003 Troy Edwards <vallimar@sexorcisto.net> 1.0.2-1
  291. - updated to 1.0.2
  292. * Tue May 05 2003 Troy Edwards <vallimar@sexorcisto.net> 1.0-1
  293. - updated to 1.0 Final
  294. * Fri Apr 25 2003 Troy Edwards <vallimar@sexorcisto.net> 1.0-Beta1-1
  295. - updated to 1.0-Beta1
  296. * Mon Oct 22 2002 Troy Edwards <vallimar@sexorcisto.net>
  297. - updated to 1.0.0pre