gnome-panel-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717
  1. %define use_eds 1
  2. %define gettext_package gnome-panel-2.0
  3. %define gnome_desktop_version 2.26.0
  4. %define glib2_version 2.20.0
  5. %define gtk2_version 2.16.0
  6. %define libgnome_version 2.26.0
  7. %define libgnomeui_version 2.24.1
  8. %define orbit_version 2.14.0
  9. %define libwnck_version 2.26.0
  10. %define gconf_version 2.26.0
  11. %define gnome_menus_version 2.26.0
  12. %define evolution_data_server_version 2.26.0
  13. %define cairo_version 1.8.6
  14. %define dbus_version 1.2
  15. %define dbus_glib_version 0.73
  16. %define gnome_doc_utils_version 0.3.2
  17. %define libgweather_version 2.26.0
  18. Summary: GNOME panel
  19. Summary(ja): GNOME パネル
  20. Name: gnome-panel
  21. Version: 2.28.0
  22. Release: 3%{_dist_release}
  23. URL: http://www.gnome.org/
  24. License: GPL
  25. Group: User Interface/Desktops
  26. Source0: %{name}-%{version}.tar.bz2
  27. Source1: clock.gnome-2-28.ja.po
  28. Source2: vine-panel-default-setup.entries
  29. Source5: vine-panel-backwards-compat-config.schemas
  30. Source10: add-translations.sh
  31. Source12: gnome-compiler-flags.m4
  32. Patch0: gnome-panel-2.28.0-vendor.patch
  33. Patch1: gnome-panel-2.10.1-speak-to-us-ye-old-wise-fish.patch
  34. Patch2: gnome-panel-2.28.0-about-vine.patch
  35. # the next three patches belong together
  36. # http://bugzilla.gnome.org/show_bug.cgi?id=470966
  37. Patch8: launcher-desktop-files.patch
  38. Patch9: desktop-file-monitoring.patch
  39. Patch10: preferred-apps.patch
  40. # don't pop up an error dialog if an applet from the
  41. # default configuration is missing; we don't want to
  42. # add a hard dependency on e.g. tomboy
  43. Patch11: applet-error.patch
  44. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  45. Requires: gnome-desktop >= %{gnome_desktop_version}
  46. Requires: libwnck >= %{libwnck_version}
  47. Requires: gnome-menus >= %{gnome_menus_version}
  48. Requires: vine-menus >= 1.1
  49. Requires(post,postun): scrollkeeper, gtk2
  50. Requires(post,pre,preun): GConf2
  51. Provides: %{name}-devel = %{version}-%{release}
  52. %if %{use_eds}
  53. Requires: evolution-data-server
  54. %endif
  55. Requires: libSM
  56. BuildRequires: libxml2-python
  57. BuildRequires: intltool
  58. BuildRequires: gettext
  59. BuildRequires: automake
  60. BuildRequires: autoconf
  61. BuildRequires: libtool
  62. BuildRequires: scrollkeeper
  63. BuildRequires: libxslt
  64. BuildRequires: gnome-desktop-devel >= %{gnome_desktop_version}
  65. BuildRequires: gtk2-devel >= %{gtk2_version}
  66. BuildRequires: libgnome-devel >= %{libgnome_version}
  67. BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
  68. BuildRequires: libbonoboui-devel >= %{libbonoboui_version}
  69. BuildRequires: libwnck-devel >= %{libwnck_version}
  70. BuildRequires: GConf2-devel >= %{gconf_version}
  71. BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
  72. BuildRequires: cairo-devel >= %{cairo_version}
  73. BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
  74. BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
  75. BuildRequires: gtk-doc
  76. BuildRequires: pango-devel
  77. BuildRequires: libbonobo-devel
  78. BuildRequires: libX11-devel
  79. BuildRequires: libXau-devel
  80. %if %{use_eds}
  81. BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
  82. BuildRequires: ORBit2-devel >= %{orbit_version}
  83. BuildRequires: dbus-devel >= %{dbus_version}
  84. %endif
  85. BuildRequires: libgweather-devel >= %{libgweather_version}
  86. BuildRequires: librsvg2-devel
  87. BuildRequires: polkit-gnome-devel
  88. BuildRequires: NetworkManager-devel
  89. BuildRequires: libSM-devel
  90. BuildRequires(install): desktop-file-utils
  91. %description
  92. The GNOME panel provides the window list, workspace switcher, menus, and other
  93. features for the GNOME desktop.
  94. %description -l ja
  95. GNOME パネルは、ウィンドウ一覧・ワークスペース切り換え器・メニューその他の
  96. 特徴を GNOME デスクトップに提供します。
  97. %prep
  98. %setup -q
  99. cp -f %{SOURCE1} help/clock/ja/ja.po
  100. cp -f %{SOURCE2} gnome-panel/panel-default-setup.entries
  101. cp -f %{SOURCE12} m4
  102. cp -f %{SOURCE5} gnome-panel/panel-compatibility.schemas
  103. %patch0 -p1 -b .vendor
  104. %patch1 -p1 -b .speak-to-us-ye-old-wise-fish
  105. %patch2 -p1 -b .about-vine
  106. %patch8 -p1 -b .launcher-desktop-files
  107. %patch9 -p1 -b .desktop-file-monitoring
  108. %patch10 -p1 -b .preferred-apps
  109. %patch11 -p1 -b .applet-error
  110. libtoolize --force --copy
  111. . %{SOURCE10}
  112. %build
  113. # gpm-integration patches Makefile.am and configure.in
  114. aclocal -I m4
  115. automake --add-missing
  116. autoheader
  117. autoconf
  118. %configure --disable-scrollkeeper \
  119. --disable-schemas-install \
  120. --disable-gtk-doc \
  121. --with-in-process-applets=clock:fish \
  122. %if %{use_eds}
  123. --enable-eds=yes
  124. %else
  125. --enable-eds=no
  126. %endif
  127. make
  128. %install
  129. rm -rf $RPM_BUILD_ROOT
  130. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  131. %makeinstall
  132. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  133. #
  134. # Create pager and tasklist schemas for compatibility with older
  135. # configurations which reference the old schema names
  136. #
  137. sed -e 's|/schemas/apps/window_list_applet/prefs/|/schemas/apps/tasklist_applet/prefs/|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/window-list.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/tasklist.schemas
  138. sed -e 's|/schemas/apps/workspace_switcher_applet/prefs/|/schemas/apps/pager_applet/prefs/|; s|<default>1</default>|<default>2</default>|' $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/workspace-switcher.schemas > $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/pager.schemas
  139. ## blow away stuff we don't want
  140. /bin/rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
  141. #rmdir --ignore-fail-on-non-empty $RPM_BUILD_ROOT/var
  142. /bin/rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  143. /bin/rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
  144. sed -i -e "s/NoDisplay=True/NoDisplay=true/" $RPM_BUILD_ROOT%{_datadir}/applications/gnome-panel.desktop
  145. desktop-file-install --delete-original \
  146. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  147. $RPM_BUILD_ROOT%{_datadir}/applications/gnome-panel.desktop
  148. %find_lang %{gettext_package} --all-name --with-gnome
  149. #grep -q '/usr/share/locale' %{gettext_package}.lang || exit 1
  150. %clean
  151. rm -rf $RPM_BUILD_ROOT
  152. %post
  153. touch --no-create %{_datadir}/icons/hicolor
  154. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  155. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  156. fi
  157. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  158. #
  159. # Clear out the old defaults
  160. #
  161. gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --recursive-unset /apps/panel > /dev/null || :
  162. gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --recursive-unset /schemas/apps/panel > /dev/null || :
  163. # install schemas
  164. SCHEMAS="clock.schemas fish.schemas pager.schemas \
  165. panel-compatibility.schemas panel-general.schemas \
  166. panel-global.schemas panel-object.schemas panel-toplevel.schemas \
  167. tasklist.schemas window-list.schemas workspace-switcher.schemas"
  168. for S in $SCHEMAS; do
  169. echo %{_sysconfdir}/gconf/schemas/$S ; done \
  170. | xargs gconftool-2 --makefile-install-rule >& /dev/null ||:
  171. #
  172. # Install the default setup into /apps/panel and /apps/panel/default_setup
  173. #
  174. gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --load %{_sysconfdir}/gconf/schemas/panel-default-setup.entries > /dev/null || :
  175. gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --load %{_sysconfdir}/gconf/schemas/panel-default-setup.entries /apps/panel > /dev/null || :
  176. /sbin/ldconfig
  177. scrollkeeper-update > /dev/null 2>&1 || :
  178. %pre
  179. if [ "$1" -gt 1 ]; then
  180. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  181. SCHEMAS="clock.schemas fish.schemas pager.schemas \
  182. panel-compatibility.schemas panel-general.schemas \
  183. panel-global.schemas panel-object.schemas panel-toplevel.schemas \
  184. tasklist.schemas window-list.schemas workspace-switcher.schemas"
  185. for S in $SCHEMAS; do
  186. echo %{_sysconfdir}/gconf/schemas/$S ; done \
  187. | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null ||:
  188. fi
  189. %preun
  190. if [ "$1" -eq 0 ]; then
  191. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  192. SCHEMAS="clock.schemas fish.schemas pager.schemas \
  193. panel-compatibility.schemas panel-general.schemas \
  194. panel-global.schemas panel-object.schemas panel-toplevel.schemas \
  195. tasklist.schemas window-list.schemas workspace-switcher.schemas"
  196. for S in $SCHEMAS; do
  197. echo %{_sysconfdir}/gconf/schemas/$S ; done \
  198. | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null ||:
  199. fi
  200. %postun
  201. /sbin/ldconfig
  202. scrollkeeper-update > /dev/null 2>&1 || :
  203. touch --no-create %{_datadir}/icons/hicolor
  204. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  205. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  206. fi
  207. %files -f %{gettext_package}.lang
  208. %defattr(-,root,root)
  209. %doc AUTHORS COPYING COPYING.LIB COPYING-DOCS NEWS README
  210. %{_datadir}/applications/*.desktop
  211. %{_datadir}/icons/*
  212. %{_datadir}/gnome-panel
  213. %exclude %{_datadir}/gnome-panelrc
  214. %{_datadir}/idl/gnome-panel-2.0
  215. %{_datadir}/gnome-2.0/ui/*
  216. %{_mandir}/man*/*
  217. %{_bindir}/*
  218. %{_libexecdir}/*
  219. %{_libdir}/bonobo/servers/*.server
  220. %{_libdir}/*.so.*
  221. %{_sysconfdir}/gconf/schemas/*.schemas
  222. %{_sysconfdir}/gconf/schemas/*.entries
  223. %{_sysconfdir}/dbus-1/system.d/org.gnome.ClockApplet.Mechanism.conf
  224. %{_datadir}/dbus-1/system-services/org.gnome.ClockApplet.Mechanism.service
  225. %{_datadir}/polkit-1/actions/org.gnome.clockapplet.mechanism.policy
  226. # theoretically a devel package, but just doesn't seem worth it
  227. %{_libdir}/pkgconfig/*.pc
  228. %{_includedir}/panel-2.0
  229. %{_libdir}/*.so
  230. %{_datadir}/gtk-doc
  231. %changelog
  232. * Fri Mar 26 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-3
  233. - add libSM(-devel) to (Build)Requires
  234. - add desktop-file-utils to BuildRequires
  235. * Thu Mar 25 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.0-2
  236. - update translation of clock applet manual
  237. * Sun Nov 1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
  238. - new upstream release
  239. - updated Patch0 and 2
  240. * Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
  241. - new upstream release
  242. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-3
  243. - rebuild with gtk2-2.16.3
  244. * Thu Jun 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
  245. - add empty gconf entries to vine-panel-default-setup.entries
  246. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  247. - new upstream release
  248. * Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
  249. - new upstream release
  250. * Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
  251. - update vine-panel-default-setup.entries again..
  252. * Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
  253. - update vine-panel-default-setup.entries
  254. * Tue Mar 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
  255. - remove mixer applets from default panel setup
  256. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  257. - new upstream release
  258. * Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.3-1
  259. - new upstream release
  260. - added BuildRequires: PolicyKit-gnome-devel
  261. * Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  262. - new upstream release
  263. * Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  264. - new upstream release
  265. * Tue Jun 3 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
  266. - new upstream release
  267. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.3-1
  268. - new upstream release
  269. * Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.2-1vl5
  270. - new upstream release
  271. - removed Patch25,26,27,29 and 30 (merged into upstream)
  272. * Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-2vl5
  273. - added Patches from FC
  274. * Fri Mar 28 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.0-8
  275. - Fix editing of locations in the clock applet
  276. * Fri Mar 28 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.0-7
  277. - Convert the edit and find location windows to dialogs
  278. * Thu Mar 27 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.0-6
  279. - Improve the time settings window
  280. * Thu Mar 27 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.0-5
  281. - Make the find-location window of the clock larger
  282. * Sat Mar 15 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.0-4
  283. - Only save the session when the users wants it
  284. * Fri Mar 14 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.0-3
  285. - Populate the location list before showing the preference window
  286. * Sat Mar 8 2008 Will Woods <wwoods@redhat.com> - 2.21.92-6
  287. - Add "About This Computer" item to System menu if it exists
  288. * Wed Feb 20 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.91-6
  289. - Try harder to avoid resizing the popup
  290. - updated BuildRequires
  291. * Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
  292. - new upstream release
  293. - added BuildRequires: libgweather-devel
  294. * Tue Jan 8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
  295. - new upstream release
  296. - updated %post and %postun section
  297. - added %pre and %preun section
  298. - added Patches from Fedora
  299. * Fri Oct 12 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-4
  300. - Sharper icons
  301. * Wed Oct 3 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-3
  302. - Make it possible to start s-c-d from the clock menu again (#316921)
  303. * Fri Sep 21 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0.1-2
  304. - Don't pop up an error if an applet from the default
  305. configuration is missing
  306. * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-6
  307. - Turns out we need requires for applets in the default config (#293261)
  308. * Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.19.92-5
  309. - Drop the requires for fast-user-switch-applet (#253831)
  310. * Sun Aug 5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
  311. - new upstream release
  312. - dropped Patch22 (merged into upstream)
  313. * Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
  314. - new upstream release
  315. * Mon Oct 30 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl2
  316. - add missing BuildRequires to gnome-menus-devel (<BTS:319>)
  317. * Thu Oct 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl1
  318. - new upstream release
  319. - fix panel-default-setup.entries to change the name of
  320. firefox desktopfile (<BTS:229>)
  321. * Thu Jul 20 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.2-0vl2
  322. - add patch 11 to fix disappearing of recent documents list.
  323. <BTS:VineLinux:81>, http://bugzilla.gnome.org/show_bug.cgi?id=343812
  324. * Sat Jun 3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
  325. - new upstream release
  326. * Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
  327. - new upstream release
  328. * Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
  329. - run gtk-update-icon-cache in %%post script.
  330. * Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
  331. - new upstream release
  332. * Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl2
  333. - update vine-panel-default-setup.entries
  334. - replace mozilla by firefox
  335. - remove nautilus
  336. - add notification area applet on top panel
  337. - add trashbox applet on bottom panel
  338. - cleanup %%post script
  339. * Thu Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.91-0vl1
  340. - new upstream release
  341. * Sun Feb 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
  342. - new upstream release
  343. - added Prereq: scroolkeeper, GConf2
  344. * Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
  345. - new upstream release
  346. * Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
  347. - new upstream release
  348. * Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.91-0vl1
  349. - new upstream release
  350. * Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
  351. - new upstream release
  352. * Thu Jul 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
  353. - new upstream release
  354. * Sat Apr 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
  355. - disable evolution-data-server
  356. * Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
  357. - new upstream release
  358. * Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
  359. - add Patch10 to fix hard-coded desktop file name.
  360. * Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
  361. - new upstream version
  362. * Fri Feb 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl1
  363. - new upstream release
  364. - run scrollkeeper at %post, %postun
  365. * Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
  366. - new upstream release
  367. * Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
  368. - add Patch10 to fix egg-recent-model.c.
  369. save old umask value before create ".recently-used" file.
  370. * Sun Oct 24 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.4.2-0vl2
  371. - fix location of nautilus launcher in panel-default-setup.entries.
  372. - do not add wireless monitor in %%post when no interfaces are available.
  373. - add Japanese summary and description
  374. - add BuildRequires: startup-notification-devel, gcc-c++.
  375. - disable libtoolize: version mismatch is bad
  376. * Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
  377. - new upstream release
  378. * Sat Dec 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
  379. - new upstream release
  380. * Sat Dec 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl3
  381. - rebuilt against new toolchain
  382. * Fri Sep 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
  383. - add --disable-schemas-install option to %%configure
  384. * Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
  385. - new upstream release
  386. * Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl2
  387. - add missing files
  388. - add vine default panel entries
  389. * Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.91-0vl1
  390. - new upstream release
  391. * Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
  392. - new upstream release
  393. * Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.7-0vl1
  394. - new upstream release
  395. * Wed Jun 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl2
  396. - remove vine's panel-per-panel-config.schemas
  397. This should be added again in a future version.
  398. * Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2.1-0vl1
  399. - new upstream release
  400. * Tue Apr 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
  401. - new upstream release
  402. - remove old ja.po
  403. * Sat Feb 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
  404. - new upstream release
  405. * Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
  406. - remove clockaddon, system-tray-applet
  407. * Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  408. - new upstream release
  409. * Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl2
  410. - add patch1 from rawhide package.
  411. * Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90.1-0vl1
  412. - new upstream release
  413. * Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
  414. - add system-tray-applet
  415. - modify default panel menu.
  416. - update ja.po
  417. * Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
  418. - add Requires: vine-menus
  419. * Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
  420. - new upstream release
  421. * Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
  422. - remove redhatize patch.
  423. * Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
  424. - build for Vine Linux
  425. - new upstream release from gnome-2.1.4
  426. * Mon Oct 14 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  427. - fix postun script
  428. * Tue Oct 8 2002 Havoc Pennington <hp@redhat.com>
  429. - 2.0.9 with menu edit stuff
  430. - system-tray-applet 0.15 that doesn't crash all the time
  431. - merge/remove patches as appropriate
  432. * Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
  433. - Fix problem with "hold down print screen" (71432)
  434. * Tue Aug 27 2002 Jonathan Blandford <jrb@redhat.com>
  435. - panel-properties OnlyShowIn=GNOME;
  436. - somehow the po file got screwed up. Works now
  437. - update po files
  438. * Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
  439. - fix from #71762 for clock applet popdown key
  440. - no WIN_POS_MOUSE fixes #72167
  441. - fix for #72540 from George
  442. * Wed Aug 21 2002 Havoc Pennington <hp@redhat.com>
  443. - system tray applet 0.11 with a small memleak fix and a couple translations
  444. * Thu Aug 15 2002 Jonathan Blandford <jrb@redhat.com>
  445. - menu tweaks
  446. * Wed Aug 14 2002 Tim Powers <timp@redhat.com>
  447. - bump release
  448. * Wed Aug 14 2002 Preston Brown <pbrown@redhat.com>
  449. - put battery applet on panel for laptops (#67296)
  450. * Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
  451. - 2.0.6 final from gnome 2.0.1
  452. - remove gnome-panel-screenshot patch now upstream
  453. * Thu Aug 8 2002 Jonathan Blandford <jrb@redhat.com>
  454. - new system-tray-applet version
  455. - Fix gnome-panel-screenshot
  456. * Tue Aug 6 2002 Havoc Pennington <hp@redhat.com>
  457. - 2.0.4
  458. - replace gnome-logo-icon-transparent.png with redhat-main-menu.png
  459. for the foot menu
  460. * Fri Aug 2 2002 Havoc Pennington <hp@redhat.com>
  461. - fix desktop (logout/lock) menu item location
  462. in Alt+F1 and in new menu applets
  463. - remove Screenshot... menu item
  464. * Fri Aug 2 2002 Havoc Pennington <hp@redhat.com>
  465. - move around default applets, remove some of them
  466. - system tray 0.9
  467. - change default menu flags
  468. - blow unpackaged files out of build root
  469. * Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
  470. - 2.0.3
  471. - own libexecdir stuff
  472. * Thu Jul 25 2002 Havoc Pennington <hp@redhat.com>
  473. - new system tray that's prettier and doesn't clip the icon
  474. * Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
  475. - system tray 0.7 that doesn't crash on startup
  476. - get Mozilla desktop file right so we get web browser launcher
  477. * Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
  478. - system tray 0.6 with server file fixed (work dammit)
  479. * Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
  480. - tweak applet positions but I think it's just broken
  481. - system tray 0.5 moved back to libdir not libexecdir
  482. * Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
  483. - remove ltmain.sh hack
  484. - new system-tray-applet that works
  485. * Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
  486. - put office suite stuff on the panel
  487. * Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
  488. - 2.0.2.90 cvs snap
  489. * Wed Jul 10 2002 Havoc Pennington <hp@redhat.com>
  490. - update the clock patch to be a little smarter in a couple ways
  491. * Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
  492. - Fix problem where system tray applet was being looked for in /unst
  493. - Fix a crash in the system tray applet
  494. * Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
  495. - Fix typo in the pt_BR translation that was causing GConf problems
  496. * Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
  497. - add the system tray applet
  498. - add system tray applet by default
  499. - add more launcher by default
  500. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  501. - automated rebuild
  502. * Thu Jun 20 2002 Havoc Pennington <hp@redhat.com>
  503. - use correct gettext package name, and add check for missing translations
  504. * Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
  505. - add the calendar and configuration patch
  506. * Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
  507. - 2.0.0
  508. - add control center desktop file to file list
  509. - add gnome-panelrc to file list
  510. - try fixing panel size (blind, no text box at home)
  511. * Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
  512. - rebuild in different environment
  513. * Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
  514. - updates to default configuration
  515. * Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
  516. - fix schemas installation
  517. * Tue Jun 11 2002 Havoc Pennington <hp@redhat.com>
  518. - unset old panel schemas when installing new ones
  519. - put in a broken panel config to see errors about
  520. - add a patch to give some decent error messages about what's wrong
  521. with the default panel config
  522. * Sun Jun 09 2002 Havoc Pennington <hp@redhat.com>
  523. - rebuild in different environment
  524. * Sun Jun 9 2002 Havoc Pennington <hp@redhat.com>
  525. - don't provide/obsolete gnome-core
  526. * Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
  527. - rebuild in different environment
  528. * Wed Jun 5 2002 Havoc Pennington <hp@redhat.com>
  529. - 1.5.24
  530. - ldconfig
  531. * Mon Jun 03 2002 Havoc Pennington <hp@redhat.com>
  532. - rebuild in different environment
  533. * Fri May 31 2002 Havoc Pennington <hp@redhat.com>
  534. - 1.5.23
  535. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  536. - automated rebuild
  537. * Tue May 21 2002 Havoc Pennington <hp@redhat.com>
  538. - rebuild in different environment
  539. * Tue May 21 2002 Havoc Pennington <hp@redhat.com>
  540. - 1.5.22
  541. - provide gnome-core
  542. - add a bunch of extra build requires so build system
  543. won't get confused
  544. * Fri May 3 2002 Havoc Pennington <hp@redhat.com>
  545. - 1.5.19
  546. * Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
  547. - add the keep-libtool-from-relinking hack so
  548. we get the gen util applet
  549. * Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
  550. - obsoletes gnome-core-devel
  551. - include libdir/*.so
  552. * Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
  553. - get libpanel-applet in the package
  554. * Tue Apr 16 2002 Havoc Pennington <hp@redhat.com>
  555. - Initial build.