ffmpeg-vl.spec 9.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330
  1. #TODO: Build with openjpeg, opencore-amr
  2. #TODO: add make test to %%check section
  3. #% define svndate 20100625
  4. ## available for v0.6 or lower
  5. %define with_libfaad 1
  6. %define with_faac 1
  7. %define with_vaapi 1
  8. %define with_libvpx 1
  9. Summary: Digital VCR and streaming server
  10. Name: ffmpeg
  11. Version: 0.6.3
  12. Release: 2%{?svndate:.%svndate}%{?_dist_release}
  13. Source: http://ffmpeg.org/releases/%{name}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
  14. Source1: %{name}-snapshot.sh
  15. # pre-built man files
  16. Source90: ffmpeg.1.gz
  17. Source91: ffplay.1.gz
  18. Source92: ffserver.1.gz
  19. Source93: ffprobe.1.gz
  20. License: GPLv2+
  21. Group: Applications/Multimedia
  22. URL: http://ffmpeg.org/
  23. BuildRequires: bzip2-devel
  24. ##BuildRequires: dirac-devel
  25. BuildRequires: gsm-devel
  26. BuildRequires: imlib2-devel
  27. BuildRequires: libdc1394-devel
  28. BuildRequires: libraw1394-devel
  29. BuildRequires: librtmp-devel >= 2.3
  30. BuildRequires: libtheora-devel
  31. %{?with_vaapi:BuildRequires:libva-devel >= 0.31.0}
  32. BuildRequires: libvdpau-devel
  33. BuildRequires: libvorbis-devel
  34. %{?with_libvpx:BuildRequires: libvpx-devel >= 0.9.1}
  35. %{?_with_opencore_amr:BuildRequires: opencore-amr-devel}
  36. ##BuildRequires: openjpeg-devel
  37. ##BuildRequires: schroedinger-devel
  38. BuildRequires: SDL-devel
  39. BuildRequires: speex-devel
  40. ##BuildRequires: texi2html
  41. BuildRequires: zlib-devel
  42. BuildRequires: libogg-devel
  43. BuildRequires: yasm
  44. # *-devel packages provided by other self-build-* should only be listed
  45. # in self-build-%{name}.spec as PreReq.
  46. #BuildRequires: a52dec-devel
  47. #BuildRequires: faac-devel
  48. #BuildRequires: lame-devel
  49. #BuildRequires: libdca-devel
  50. #BuildRequires: faad2-devel
  51. #BuildRequires: x264-devel >= 0.0.0-15.20110322
  52. #BuildRequires: xvidcore-devel
  53. Requires: %{name}-libs = %{version}-%{release}
  54. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  55. %description
  56. FFMpeg is a complete and free Internet live audio and video
  57. broadcasting solution for Linux/Unix. It also includes a digital
  58. VCR. It can encode in real time in many formats including MPEG1 audio
  59. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  60. %package libs
  61. Summary: Libraries for %{name}
  62. Group: System Environment/Libraries
  63. %description libs
  64. FFMpeg is a complete and free Internet live audio and video
  65. broadcasting solution for Linux/Unix. It also includes a digital
  66. VCR. It can encode in real time in many formats including MPEG1 audio
  67. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  68. This package contains the libraries for %{name}.
  69. %package devel
  70. Summary: Development package for %{name}
  71. Group: Development/Libraries
  72. Requires: %{name}-libs = %{version}-%{release}
  73. Requires: pkgconfig
  74. %description devel
  75. FFMpeg is a complete and free Internet live audio and video
  76. broadcasting solution for Linux/Unix. It also includes a digital
  77. VCR. It can encode in real time in many formats including MPEG1 audio
  78. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  79. This package contains development files for %{name}.
  80. %prep
  81. %setup -q -n %{name}-%{?svndate:%svndate}%{!?svndate:%version}
  82. #% setup -q
  83. #%patch0 -p1 -b .textrel
  84. %build
  85. %ifarch ppc
  86. # compile with -mlongcall on ppc/ppc64 (rf804)
  87. export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
  88. %endif
  89. ./configure \
  90. --prefix=%{_prefix} \
  91. --incdir=%{_includedir}/%{name} \
  92. --shlibdir=%{_libdir} \
  93. --libdir=%{_libdir} \
  94. --mandir=%{_mandir} \
  95. --arch=%{_target_cpu} \
  96. %ifarch %{ix86}
  97. --cpu=%{_target_cpu} \
  98. %endif
  99. %ifarch ppc
  100. --cpu=g3 \
  101. --enable-pic \
  102. %endif
  103. --enable-runtime-cpudetect \
  104. --extra-cflags="$RPM_OPT_FLAGS" \
  105. %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3} \
  106. --enable-bzlib \
  107. --enable-zlib \
  108. --enable-libdc1394 \
  109. %{?_with_libdirac:--enable-libdirac} \
  110. %{?with_faac:--enable-libfaac --enable-nonfree} \
  111. %{?with_libfaad:--enable-libfaad} \
  112. --enable-libgsm \
  113. --enable-libmp3lame \
  114. %{?_with_openjpeg:--enable-libopenjpeg} \
  115. --enable-librtmp \
  116. --enable-libspeex \
  117. --enable-libtheora \
  118. --enable-libvorbis \
  119. %{?with_libvpx:--enable-libvpx} \
  120. --enable-libx264 \
  121. --enable-libxvid \
  122. \
  123. --enable-x11grab \
  124. --enable-avfilter \
  125. --enable-postproc \
  126. --enable-pthreads \
  127. --disable-static \
  128. --enable-shared \
  129. --enable-gpl \
  130. --disable-doc \
  131. --disable-debug \
  132. --disable-stripping \
  133. ;
  134. %{__make} %{?_smp_mflags}
  135. #% {__make}
  136. #%{__make} documentation
  137. %install
  138. %__make install DESTDIR=$RPM_BUILD_ROOT
  139. # ## install tool/qt-faststart
  140. # %__install -pm755 tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
  141. ## install man
  142. %__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
  143. %__install %{SOURCE90} %{SOURCE91} %{SOURCE92} %{SOURCE93} \
  144. $RPM_BUILD_ROOT%{_mandir}/man1/
  145. %clean
  146. %{__rm} -rf $RPM_BUILD_ROOT
  147. %post libs -p /sbin/ldconfig
  148. %postun libs -p /sbin/ldconfig
  149. %files
  150. %defattr(-,root,root,-)
  151. %doc COPYING.* CREDITS Changelog README doc/ffserver.conf
  152. %{_bindir}/ffmpeg
  153. %{_bindir}/ffplay
  154. %{_bindir}/ffprobe
  155. %{_bindir}/ffserver
  156. #%{_bindir}/qt-faststart
  157. %{_mandir}/man1/ffmpeg.1*
  158. %{_mandir}/man1/ffplay.1*
  159. %{_mandir}/man1/ffprobe.1*
  160. %{_mandir}/man1/ffserver.1*
  161. %{_datadir}/ffmpeg
  162. %files libs
  163. %defattr(-,root,root,-)
  164. %{_libdir}/lib*.so.*
  165. %files devel
  166. %defattr(-,root,root,-)
  167. %doc MAINTAINERS doc/APIchanges doc/TODO doc/*.txt
  168. %{_includedir}/ffmpeg
  169. %{_libdir}/pkgconfig/lib*.pc
  170. %{_libdir}/lib*.so
  171. %changelog
  172. * Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
  173. - change release to sync with self-build-ffmpeg-vl.spec
  174. * Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
  175. - new upstream release
  176. * Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
  177. - new upstream release
  178. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
  179. - required latest x264 build
  180. - added BuildRequires: librtmp-devel >= 2.3
  181. - build PIC objects on PPC
  182. #- add qt-faststart tool
  183. * Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
  184. - new upstream release
  185. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
  186. - change release to sync with self-build-ffmpeg-vl.spec
  187. * Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
  188. - added BuildRequires: libvpx-devel >= 0.9.1
  189. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
  190. - new upstream release
  191. * Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
  192. - bumped version to pre-0.6
  193. * Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-13.20100410
  194. - updated source snapshot 20100410
  195. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
  196. - change release to sync with self-build-ffmpeg-vl.spec
  197. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
  198. - change release to sync with self-build-ffmpeg-vl.spec
  199. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
  200. - updated source snapshot 20100401
  201. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-9.20100216
  202. - updated source snapshot 20100326
  203. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
  204. - change release to sync with self-build-ffmpeg
  205. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
  206. - updated source snapshot 20100216
  207. - rebuild with recent x264-devel
  208. - updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
  209. - added BuildRequires: libvdpau-devel
  210. * Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
  211. - change release to sync with self-build-ffmpeg
  212. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
  213. - change release to sync with self-build-ffmpeg
  214. * Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
  215. - applied ffmpeg-0.5-disable-texi2html.patch
  216. - dropped BuildRequires: texi2html
  217. * Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
  218. - change release to sync with self-build-ffmpeg
  219. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
  220. - corrected release number
  221. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
  222. - new upstream release
  223. - added BuildRequires:
  224. - speex-devel
  225. - bzip2-devel
  226. * Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
  227. - 20090227 snapshot
  228. * Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
  229. - added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
  230. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
  231. - changed to PreReq: self-build-faad2 >= 2.0 from faad2-devel
  232. - dropped Requires: a52dec, faad2 in ffmpeg-libs
  233. * Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
  234. - 20090202 snapshot
  235. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
  236. - 20090110 snapshot
  237. - dropped some patches
  238. * Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
  239. - source updated (r15488)
  240. - fixed License: GPLv2+
  241. - added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
  242. - added BuildRequires: yasm (only %%ix86)
  243. - applied ffmpeg-cpu.patch (merged from RPM Fusion)
  244. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
  245. - spec in utf8
  246. * Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
  247. - change release to sync with self-build-ffmpeg
  248. * Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
  249. - drop "Patch100: ffmpeg-vine.patch".
  250. * Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
  251. - build with new versioning policy
  252. - change to use svn export from svn checkout on post install
  253. - fix ffmpeg-vine.patch for libswscale/swscale.c.rej
  254. * Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
  255. - [self-build-ffmpeg.spec]
  256. For all pre-required package that is provied by self-build,
  257. changed to its self-build package
  258. * Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
  259. - initial build for Vine Linux 4.2
  260. - snapshot 2008/01/28 + some Rev.11662 2008/01/29
  261. ### end of file