cfitsio-vl.spec 8.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270
  1. Name: cfitsio
  2. Summary: Library for manipulating FITS data files
  3. Summary(ja): FITS データファイルを処理するためのライブラリ
  4. Version: 3.280
  5. Release: 1%{?_dist_release}
  6. Group: System Environment/Libraries
  7. License: MIT
  8. URL: http://heasarc.gsfc.nasa.gov/docs/software/fitsio/fitsio.html
  9. Source0: ftp://heasarc.gsfc.nasa.gov/software/fitsio/c/cfitsio3280.tar.gz
  10. Patch0: cfitsio.patch
  11. Patch1: cfitsio-pkgconfig.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: gcc-gfortran
  14. Requires(post): /sbin/ldconfig
  15. Requires(postun): /sbin/ldconfig
  16. %description
  17. CFITSIO is a library of C and FORTRAN subroutines for reading and writing
  18. data files in FITS (Flexible Image Transport System) data format. CFITSIO
  19. simplifies the task of writing software that deals with FITS files by
  20. providing an easy to use set of high-level routines that insulate the
  21. programmer from the internal complexities of the FITS file format. At the
  22. same time, CFITSIO provides many advanced features that have made it the
  23. most widely used FITS file programming interface in the astronomical
  24. community.
  25. %package devel
  26. Summary: Headers required when building programs against cfitsio
  27. Group: Development/Libraries
  28. Requires: %{name} = %{version}-%{release}
  29. Requires: pkgconfig
  30. %description devel
  31. Headers required when building a program against the cfitsio library.
  32. %package static
  33. Summary: Static cfitsio library
  34. Group: Development/Libraries
  35. Requires: %{name}-devel = %{version}-%{release}
  36. %description static
  37. Static cfitsio library; avoid use if possible.
  38. %package docs
  39. Summary: Documentation for cfitsio
  40. Group: Development/Libraries
  41. BuildArch: noarch
  42. %description docs
  43. Stand-alone documentation for cfitsio.
  44. %prep
  45. %setup -q -n cfitsio
  46. %patch0 -p1
  47. %patch1 -p1
  48. %build
  49. FC=f95
  50. export FC
  51. export CC=gcc # fixes -O*, -g
  52. %configure
  53. make shared %{?_smp_mflags}
  54. ln -s libcfitsio.so.0 libcfitsio.so
  55. make fpack %{?_smp_mflags}
  56. make funpack %{?_smp_mflags}
  57. unset FC
  58. # Manually fix pkgconfig .pc file (BZ 436539, BZ 618291)
  59. sed 's|/usr/include|/usr/include/%{name}|' cfitsio.pc >cfitsio.pc.new
  60. mv cfitsio.pc.new cfitsio.pc
  61. %check
  62. make testprog
  63. LD_LIBRARY_PATH=. ./testprog > testprog.lis
  64. cmp -s testprog.lis testprog.out
  65. cmp -s testprog.fit testprog.std
  66. %install
  67. rm -rf %{buildroot}
  68. mkdir -p %{buildroot}
  69. mkdir -p %{buildroot}%{_libdir}
  70. mkdir -p %{buildroot}%{_includedir}/%{name}
  71. make LIBDIR=%{_lib} INCLUDEDIR=include/%{name} CFITSIO_LIB=%{buildroot}%{_libdir} \
  72. CFITSIO_INCLUDE=%{buildroot}%{_includedir}/%{name} install
  73. pushd %{buildroot}%{_libdir}
  74. ln -s libcfitsio.so.0 libcfitsio.so
  75. popd
  76. %clean
  77. rm -rf %{buildroot}
  78. %post -p /sbin/ldconfig
  79. %postun -p /sbin/ldconfig
  80. %files
  81. %defattr(-,root,root,-)
  82. %doc README License.txt changes.txt
  83. %{_libdir}/libcfitsio.so.*
  84. %files devel
  85. %defattr(-,root,root,-)
  86. %{_includedir}/%{name}
  87. %{_libdir}/libcfitsio.so
  88. %{_libdir}/pkgconfig/cfitsio.pc
  89. %files static
  90. %defattr(-,root,root,-)
  91. %{_libdir}/libcfitsio.a
  92. %files docs
  93. %defattr(-,root,root,-)
  94. %doc fitsio.doc fitsio.ps cfitsio.doc cfitsio.ps
  95. %changelog
  96. * Sat Sep 3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.280-1
  97. - new upstream release
  98. - added Patch1
  99. * Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 3.240-2
  100. - rebuilt with rpm-4.8.1 for pkg-config
  101. * Thu Apr 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.240-1
  102. - new upstream release
  103. * Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.140-3
  104. - Initial build for Vine Linux
  105. * Fri Jul 24 2009 Matthew Truch <matt at truch.net> - 3.140-2
  106. - Bump to include proper tarball.
  107. * Tue Jul 21 2009 Matthew Truch <matt at truch.net> - 3.140-1
  108. - Update to upstream 3.140 release.
  109. - Bump for mass rebuild.
  110. * Wed Jun 17 2009 Matthew Truch <matt at truch.net> - 3.130-5
  111. - Separate -docs noarch subpackage as per BZ 492438.
  112. - Explicitly set file attributes correctly.
  113. * Tue Mar 10 2009 Matthew Truch <matt at truch.net> - 3.130-4
  114. - Set correct version in pkgconfig .pc file.
  115. * Sun Feb 22 2009 Matthew Truch <matt at truch.net> - 3.130-3
  116. - Re-check testprogram output.
  117. - Build for koji, rpm, gcc upgrade.
  118. * Thu Feb 5 2009 Matthew Truch <matt at truch.net> - 3.130-2
  119. - Fix source file naming typo.
  120. * Wed Feb 4 2009 Matthew Truch <matt at truch.net> - 3.130-1
  121. - Update to 3.130 upstream.
  122. * Sat Sep 20 2008 Matthew Truch <matt at truch.net> - 3.100-2
  123. - Test library with included test-suite.
  124. * Fri Sep 19 2008 Matthew Truch <matt at truch.net> - 3.100-1
  125. - Update to 3.100 upstream.
  126. Includes bugfixes and new compression scheme.
  127. * Fri Mar 7 2008 Matthew Truch <matt at truch.net> - 3.060-3
  128. - Properly indicated include and lib directories in .pc file
  129. (BZ 436539)
  130. - Fix typo in -static descrition.
  131. * Mon Feb 11 2008 Matthew Truch <matt at truch.net> - 3.060-2
  132. - Bump release for rebuild.
  133. * Fri Nov 9 2007 Matthew Truch <matt at truch.net> - 3.060-1
  134. - Update to 3.060 bugfix release.
  135. - Add static package (BZ 372801)
  136. * Tue Aug 21 2007 Matthew Truch <matt at truch.net> - 3.040-3
  137. - Bump release for rebuild (build-id etc.)
  138. * Thu Aug 2 2007 Matthew Truch <matt at truch.net> - 3.040-2
  139. - Update License tag
  140. * Mon Jul 9 2007 Matthew Truch <matt at truch.net> - 3.040-1
  141. - Upgrade to version 3.040 of cfitsio.
  142. * Fri Feb 16 2007 Matthew Truch <matt at truch.net> - 3.030-2
  143. - Require pkgconfig for -devel.
  144. - export CC=gcc so we don't clobber $RPM_OPT_FLAGS, thereby
  145. ruining any -debuginfo packages.
  146. See RedHat Bugzilla 229041.
  147. * Fri Jan 5 2007 Matthew Truch <matt at truch.net> - 3.030-1
  148. - Upgrade to version 3.020 of cfitsio.
  149. * Fri Dec 8 2006 Matthew Truch <matt at truch.net> - 3.020-3
  150. - Commit correct patch to configure and Makefiles.
  151. * Fri Dec 8 2006 Matthew Truch <matt at truch.net> - 3.020-2
  152. - Modify spec file to install to correct directories.
  153. - Package cfitsio.pc file in -devel package.
  154. * Wed Dec 6 2006 Matthew Truch <matt at truch.net> - 3.020-1
  155. - Upgrade to revision 3.020 of cfitsio.
  156. * Mon Aug 28 2006 Matthew Truch <matt at truch.net> - 3.006-6
  157. - Bump release for rebuild in prep. for FC6.
  158. * Thu Mar 30 2006 Matthew Truch <matt at truch.net> - 3.006-5
  159. - Include defattr() for devel package as well - bug 187366
  160. * Sun Mar 19 2006 Matthew Truch <matt at truch.net> - 3.006-4
  161. - Don't use macro {buildroot} in build, only in install as per
  162. appended comments to Bugzilla bug 172042
  163. * Fri Mar 10 2006 Matthew Truch <matt at truch.net> - 3.006-3
  164. - Point to f95 instead of g95 as per bugzilla bug 185107
  165. * Tue Feb 28 2006 Matthew Truch <matt at truch.net> - 3.006-2
  166. - Fix spelling typo in name of License.txt file.
  167. * Tue Feb 28 2006 Matthew Truch <matt at truch.net> - 3.006-1
  168. - Use new 3.006 fully official stable (non-beta) upstream package.
  169. * Tue Feb 28 2006 Matthew Truch <matt at truch.net> - 3.005-0.2.beta
  170. - Bump release for FC5 extras rebuild.
  171. * Fri Dec 23 2005 Matthew Truch <matt at truch.net> - 3.005-0.1.beta
  172. - Update to 3.005beta release.
  173. * Mon Nov 14 2005 Matthew Truch <matt at truch.net> - 3.004-0.12.b
  174. - Put in proper URL and Source addresses.
  175. - Sync up spec files.
  176. * Sun Nov 13 2005 Matthew Truch <matt at truch.net> - 3.004-0.11.b
  177. - Clean up unused code in spec file.
  178. * Sun Nov 13 2005 Matthew Truch <matt at truch.net> - 3.004-0.10.b
  179. - Set environment variables correctly.
  180. - Include patch so Makefile will put things where they belong.
  181. * Sun Nov 13 2005 Matthew Truch <matt at truch.net> - 3.004-0.9.b
  182. - Set libdir and includedir correctly for build process.
  183. * Sat Nov 12 2005 Matthew Truch <matt at truch.net> - 3.004-0.8.b
  184. - unset FC once we are done with the build
  185. * Sat Nov 12 2005 Ed Hill <ed@eh3.com> - 3.004-0.7.b
  186. - shared libs and small cleanups
  187. * Sun Nov 06 2005 Matthew Truch <matt at truch.net> - 3.004-0.6.b
  188. - Own include directory created by the devel package.
  189. * Sun Nov 06 2005 Matthew Truch <matt at truch.net> - 3.004-0.5.b
  190. - Shorten summary.
  191. - Improve specfile post and postun syntax.
  192. - Install headers in cfitsio include subdir.
  193. - Include more documentation provided in tarball.
  194. * Sun Nov 06 2005 Matthew Truch <matt at truch.net> - 3.004-0.4.b
  195. - Require cfitsio for cfitsio-devel
  196. * Sat Nov 05 2005 Matthew Truch <matt at truch.net> - 3.004-0.3.b
  197. - Use proper virgin tarball from upstream.
  198. * Sun Oct 30 2005 Matthew Truch <matt at truch.net> - 3.004-0.2.b
  199. - Include gcc-gfortran build requirment and make sure it gets used.
  200. - Use macros instead of hard coded paths.
  201. - Include home page in description
  202. * Sat Oct 29 2005 Matthew Truch <matt at truch.net> - 3.004-0.1.b
  203. - Initial spec file for Fedora Extras.