cryptsetup-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407
  1. %define _root_sbindir /sbin
  2. %define upstream_version %{version}
  3. Summary: A utility for setting up encrypted disks
  4. Summary(ja): 暗号化ファイルシステム設定用ユーティリティ
  5. Name: cryptsetup
  6. Version: 1.4.1
  7. Release: 3%{?_dist_release}
  8. License: GPLv2 and LGPLv2+
  9. Group: Applications/System
  10. URL: http://cryptsetup.googlecode.com/
  11. BuildRequires: libgcrypt-devel, popt-devel, device-mapper-devel
  12. BuildRequires: libgpg-error-devel, libuuid-devel
  13. BuildRequires: python-devel
  14. Provides: cryptsetup-luks = %{version}-%{release}
  15. Obsoletes: cryptsetup-luks < 1.4.0
  16. Requires: cryptsetup-libs = %{version}-%{release}
  17. Source0: http://cryptsetup.googlecode.com/files/cryptsetup-%{upstream_version}.tar.bz2
  18. %description
  19. The cryptsetup package contains a utility for setting up
  20. disk encryption using dm-crypt kernel module.
  21. %description -l ja
  22. cryptsetup パッケージには、dm-crypt カーネルモジュールを使って
  23. ディスクの暗号化を設定するユーティリティが収録されています。
  24. %package devel
  25. Group: Development/Libraries
  26. Requires: %{name} = %{version}-%{release}
  27. Requires: libgcrypt-devel > 1.1.42, device-mapper-devel, libuuid-devel
  28. Requires: pkgconfig
  29. Summary: Headers and libraries for using encrypted file systems
  30. Summary(ja): 暗号化ファイルシステムを使うためのヘッダとライブラリ
  31. Provides: cryptsetup-luks-devel = %{version}-%{release}
  32. Obsoletes: cryptsetup-luks-devel < 1.4.0
  33. %description devel
  34. The cryptsetup-devel package contains libraries and header files
  35. used for writing code that makes use of disk encryption.
  36. %description devel -l ja
  37. cryptsetup-devel パッケージには、ディスクの暗号化を使うコードを
  38. 書くのに使われるライブラリとヘッダファイルが収録されています。
  39. %package libs
  40. Group: System Environment/Libraries
  41. Summary: Cryptsetup shared library
  42. Summary(ja): Cryptsetup 共有ライブラリ
  43. Provides: cryptsetup-luks-libs = %{version}-%{release}
  44. Obsoletes: cryptsetup-luks-libs < 1.4.0
  45. %description libs
  46. This package contains the cryptsetup shared library, libcryptsetup.
  47. %description libs -l ja
  48. このパッケージには、cryptsetup の共有ライブラリ、libcryptsetup が
  49. 収録されています。
  50. %package python
  51. Group: System Environment/Libraries
  52. Summary: Python bindings for libcryptsetup
  53. Summary(ja): libcryptsetup の Python バインディング
  54. Requires: %{name}-libs = %{version}-%{release}
  55. Provides: python-cryptsetup = %{version}-%{release}
  56. Obsoletes: python-cryptsetup < 1.4.0
  57. %description python
  58. This package provides Python bindings for libcryptsetup, a library
  59. for setting up disk encryption using dm-crypt kernel module.
  60. %description python -l ja
  61. このパッケージには、dm-crypt カーネルモジュールを使って
  62. ディスクの暗号化を設定するライブラリ libcryptsetup の
  63. Python バインディングが収録されています。
  64. %prep
  65. %setup -q -n cryptsetup-%{upstream_version}
  66. chmod -x python/pycryptsetup-test.py
  67. %build
  68. %configure --sbindir=%{_root_sbindir} --libdir=/%{_lib} \
  69. --enable-python \
  70. --disable-selinux
  71. # remove rpath
  72. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  73. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  74. make %{?_smp_mflags}
  75. %install
  76. rm -rf %{buildroot}
  77. make install DESTDIR=%{buildroot}
  78. rm -rf %{buildroot}/%{_lib}/*.la %{buildroot}/%{_lib}/cryptsetup
  79. # move libcryptsetup.so to %%{_libdir}
  80. pushd %{buildroot}/%{_lib}
  81. rm libcryptsetup.so
  82. mkdir -p %{buildroot}/%{_libdir}
  83. ln -s ../../%{_lib}/$(ls libcryptsetup.so.?.?.?) %{buildroot}/%{_libdir}/libcryptsetup.so
  84. mv %{buildroot}/%{_lib}/pkgconfig %{buildroot}/%{_libdir}
  85. popd
  86. %find_lang cryptsetup
  87. %post -n cryptsetup-libs -p /sbin/ldconfig
  88. %postun -n cryptsetup-libs -p /sbin/ldconfig
  89. %files -f cryptsetup.lang
  90. %doc COPYING ChangeLog AUTHORS TODO FAQ
  91. %{_mandir}/man8/cryptsetup.8.gz
  92. %{_root_sbindir}/cryptsetup
  93. %files devel
  94. %doc docs/examples/*
  95. %{_includedir}/libcryptsetup.h
  96. %{_libdir}/libcryptsetup.so
  97. %{_libdir}/pkgconfig/libcryptsetup.pc
  98. %files libs
  99. %doc COPYING
  100. /%{_lib}/libcryptsetup.so.*
  101. %files python
  102. %doc COPYING.LGPL python/pycryptsetup-test.py
  103. %exclude %{python_sitearch}/pycryptsetup.la
  104. %{python_sitearch}/pycryptsetup.so
  105. %clean
  106. rm -rf %{buildroot}
  107. %changelog
  108. * Fri Mar 23 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.1-3
  109. - updated to 1.4.1; spec revamp; Japanese summary & description
  110. - Sun Sep 21 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.5-8vl5
  111. - applied new versioning policy
  112. - Sun Dec 9 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.5-7vl1
  113. - initial build for VineSeed
  114. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.1-2
  115. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  116. * Wed Nov 09 2011 Milan Broz <mbroz@redhat.com> - 1.4.1-1
  117. - Update to cryptsetup 1.4.1.
  118. - Add Python cryptsetup bindings.
  119. - Obsolete separate python-cryptsetup package.
  120. * Wed Oct 26 2011 Milan Broz <mbroz@redhat.com> - 1.4.0-1
  121. - Update to cryptsetup 1.4.0.
  122. * Mon Oct 10 2011 Milan Broz <mbroz@redhat.com> - 1.4.0-0.1
  123. - Update to cryptsetup 1.4.0-rc1.
  124. - Rename package back from cryptsetup-luks to cryptsetup.
  125. * Wed Jun 22 2011 Milan Broz <mbroz@redhat.com> - 1.3.1-2
  126. - Fix return code for status command when device doesn't exist.
  127. * Tue May 24 2011 Milan Broz <mbroz@redhat.com> - 1.3.1-1
  128. - Update to cryptsetup 1.3.1.
  129. * Tue Apr 05 2011 Milan Broz <mbroz@redhat.com> - 1.3.0-1
  130. - Update to cryptsetup 1.3.0.
  131. * Tue Mar 22 2011 Milan Broz <mbroz@redhat.com> - 1.3.0-0.2
  132. - Update to cryptsetup 1.3.0-rc2
  133. * Mon Mar 14 2011 Milan Broz <mbroz@redhat.com> - 1.3.0-0.1
  134. - Update to cryptsetup 1.3.0-rc1
  135. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-2
  136. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  137. * Mon Dec 20 2010 Milan Broz <mbroz@redhat.com> - 1.2.0-1
  138. - Update to cryptsetup 1.2.0
  139. * Thu Nov 25 2010 Milan Broz <mbroz@redhat.com> - 1.2.0-0.2
  140. - Fix crypt_activate_by_keyfile() to work with PLAIN devices.
  141. * Tue Nov 16 2010 Milan Broz <mbroz@redhat.com> - 1.2.0-0.1
  142. - Add FAQ to documentation.
  143. - Update to cryptsetup 1.2.0-rc1
  144. * Sat Jul 03 2010 Milan Broz <mbroz@redhat.com> - 1.1.3-1
  145. - Update to cryptsetup 1.1.3
  146. * Mon Jun 07 2010 Milan Broz <mbroz@redhat.com> - 1.1.2-2
  147. - Fix alignment ioctl use.
  148. - Fix API activation calls to handle NULL device name.
  149. * Sun May 30 2010 Milan Broz <mbroz@redhat.com> - 1.1.2-1
  150. - Update to cryptsetup 1.1.2
  151. - Fix luksOpen handling of new line char on stdin.
  152. * Sun May 23 2010 Milan Broz <mbroz@redhat.com> - 1.1.1-1
  153. - Update to cryptsetup 1.1.1
  154. - Fix luksClose for stacked LUKS/LVM devices.
  155. * Mon May 03 2010 Milan Broz <mbroz@redhat.com> - 1.1.1-0.2
  156. - Update to cryptsetup 1.1.1-rc2.
  157. * Sat May 01 2010 Milan Broz <mbroz@redhat.com> - 1.1.1-0.1
  158. - Update to cryptsetup 1.1.1-rc1.
  159. * Sun Jan 17 2010 Milan Broz <mbroz@redhat.com> - 1.1.0-1
  160. - Update to cryptsetup 1.1.0.
  161. * Fri Jan 15 2010 Milan Broz <mbroz@redhat.com> - 1.1.0-0.6
  162. - Fix gcrypt initialisation.
  163. - Fix backward compatibility for hash algorithm (uppercase).
  164. * Wed Dec 30 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.5
  165. - Update to cryptsetup 1.1.0-rc4
  166. * Mon Nov 16 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.4
  167. - Update to cryptsetup 1.1.0-rc3
  168. * Thu Oct 01 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.3
  169. - Update to cryptsetup 1.1.0-rc2
  170. - Fix libcryptsetup to properly export only versioned symbols.
  171. * Tue Sep 29 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.2
  172. - Update to cryptsetup 1.1.0-rc1
  173. - Add luksHeaderBackup and luksHeaderRestore commands.
  174. * Thu Sep 11 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.1
  175. - Update to new upstream testing version with new API interface.
  176. - Add luksSuspend and luksResume commands.
  177. - Introduce pkgconfig.
  178. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.7-2
  179. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  180. * Wed Jul 22 2009 Milan Broz <mbroz@redhat.com> - 1.0.7-1
  181. - Update to upstream final release.
  182. - Split libs subpackage.
  183. - Remove rpath setting from cryptsetup binary.
  184. * Wed Jul 15 2009 Till Maas <opensource@till.name> - 1.0.7-0.2
  185. - update BR because of libuuid splitout from e2fsprogs
  186. * Mon Jun 22 2009 Milan Broz <mbroz@redhat.com> - 1.0.7-0.1
  187. - Update to new upstream 1.0.7-rc1.
  188. - Wipe old fs headers to not confuse blkid (#468062)
  189. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.6-7
  190. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  191. * Thu Oct 30 2008 Milan Broz <mbroz@redhat.com> - 1.0.6-6
  192. - Wipe old fs headers to not confuse blkid (#468062)
  193. * Tue Sep 23 2008 Milan Broz <mbroz@redhat.com> - 1.0.6-5
  194. - Change new project home page.
  195. - Print more descriptive messages for initialization errors.
  196. - Refresh patches to versions commited upstream.
  197. * Sat Sep 06 2008 Milan Broz <mbroz@redhat.com> - 1.0.6-4
  198. - Fix close of zero decriptor.
  199. - Fix udevsettle delays - use temporary crypt device remapping.
  200. * Wed May 28 2008 Till Maas <opensource till name> - 1.0.6-3
  201. - remove a duplicate sentence from the manpage (RH #448705)
  202. - add patch metadata about upstream status
  203. * Tue Apr 15 2008 Bill Nottinghm <notting@redhat.com> - 1.0.6-2
  204. - Add the device to the luksOpen prompt (#433406)
  205. - Use iconv, not recode (#442574)
  206. * Thu Mar 13 2008 Till Maas <opensource till name> - 1.0.6-1
  207. - Update to latest version
  208. - remove patches that have been merged upstream
  209. * Mon Mar 03 2008 Till Maas <opensource till name> - 1.0.6-0.1.pre2
  210. - Update to new version with several bugfixes
  211. - remove patches that have been merged upstream
  212. - add patch from cryptsetup newsgroup
  213. - fix typo / missing luksRemoveKey in manpage (patch)
  214. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.5-9
  215. - Autorebuild for GCC 4.3
  216. * Sat Jan 19 2008 Peter Jones <pjones@redhat.com> - 1.0.5-8
  217. - Rebuild for broken deps.
  218. * Thu Aug 30 2007 Till Maas <opensource till name> - 1.0.5-7
  219. - update URL
  220. - update license tag
  221. - recode ChangeLog from latin1 to uf8
  222. - add smp_mflags to make
  223. * Fri Aug 24 2007 Till Maas <opensource till name> - 1.0.5-6
  224. - cleanup BuildRequires:
  225. - removed versions, packages in Fedora are new enough
  226. - changed popt to popt-devel
  227. * Thu Aug 23 2007 Till Maas <opensource till name> - 1.0.5-5
  228. - fix devel subpackage requires
  229. - remove empty NEWS README
  230. - remove uneeded INSTALL
  231. - remove uneeded ldconfig requires
  232. - add readonly detection patch
  233. * Wed Aug 08 2007 Till Maas <opensource till name> - 1.0.5-4
  234. - disable patch2, libsepol is now detected by configure
  235. - move libcryptsetup.so to %%{_libdir} instead of /%%{_lib}
  236. * Fri Jul 27 2007 Till Maas <opensource till name> - 1.0.5-3
  237. - Use /%%{_lib} instead of /lib to use /lib64 on 64bit archs
  238. * Thu Jul 26 2007 Till Maas <opensource till name> - 1.0.5-2
  239. - Use /lib as libdir (#243228)
  240. - sync header and library (#215349)
  241. - do not use %%makeinstall (recommended by PackageGuidelines)
  242. - select sbindir with %%configure instead with make
  243. - add TODO
  244. * Wed Jun 13 2007 Jeremy Katz <katzj@redhat.com> - 1.0.5-1
  245. - update to 1.0.5
  246. * Mon Jun 04 2007 Peter Jones <pjones@redhat.com> - 1.0.3-5
  247. - Don't build static any more.
  248. * Mon Feb 05 2007 Alasdair Kergon <agk@redhat.com> - 1.0.3-4
  249. - Add build dependency on new device-mapper-devel package.
  250. - Add preun and post ldconfig requirements.
  251. - Update BuildRoot.
  252. * Wed Nov 1 2006 Peter Jones <pjones@redhat.com> - 1.0.3-3
  253. - Require newer libselinux (#213414)
  254. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0.3-2.1
  255. - rebuild
  256. * Wed Jun 7 2006 Jeremy Katz <katzj@redhat.com> - 1.0.3-2
  257. - put shared libs in the right subpackages
  258. * Fri Apr 7 2006 Bill Nottingham <notting@redhat.com> 1.0.3-1
  259. - update to final 1.0.3
  260. * Wed Feb 27 2006 Bill Nottingham <notting@redhat.com> 1.0.3-0.rc2
  261. - update to 1.0.3rc2, fixes bug with HAL & encrypted devices (#182658)
  262. * Wed Feb 22 2006 Bill Nottingham <notting@redhat.com> 1.0.3-0.rc1
  263. - update to 1.0.3rc1, reverts changes to default encryption type
  264. * Tue Feb 21 2006 Bill Nottingham <notting@redhat.com> 1.0.2-1
  265. - update to 1.0.2, fix incompatiblity with old cryptsetup (#176726)
  266. * Mon Feb 20 2006 Karsten Hopp <karsten@redhat.de> 1.0.1-5
  267. - BuildRequires: libselinux-devel
  268. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-4.2.1
  269. - bump again for double-long bug on ppc(64)
  270. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-4.2
  271. - rebuilt for new gcc4.1 snapshot and glibc changes
  272. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  273. - rebuilt
  274. * Mon Dec 5 2005 Bill Nottingham <notting@redhat.com> 1.0.1-4
  275. - rebuild against new libdevmapper
  276. * Thu Oct 13 2005 Florian La Roche <laroche@redhat.com>
  277. - add -lsepol to rebuild on current fc5
  278. * Mon Aug 22 2005 Karel Zak <kzak@redhat.com> 1.0.1-2
  279. - fix cryptsetup help for isLuks action
  280. * Fri Jul 1 2005 Bill Nottingham <notting@redhat.com> 1.0.1-1
  281. - update to 1.0.1 - fixes incompatiblity with previous cryptsetup for
  282. piped passwords
  283. * Thu Jun 16 2005 Bill Nottingham <notting@redhat.com> 1.0-2
  284. - add patch for 32/64 bit compatibility (#160445, <redhat@paukstadt.de>)
  285. * Tue Mar 29 2005 Bill Nottingham <notting@redhat.com> 1.0-1
  286. - update to 1.0
  287. * Thu Mar 10 2005 Bill Nottingham <notting@redhat.com> 0.993-1
  288. - switch to cryptsetup-luks, for LUKS support
  289. * Tue Oct 12 2004 Bill Nottingham <notting@redhat.com> 0.1-4
  290. - oops, make that *everything* static (#129926)
  291. * Tue Aug 31 2004 Bill Nottingham <notting@redhat.com> 0.1-3
  292. - link some things static, move to /sbin (#129926)
  293. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  294. - rebuilt
  295. * Fri Apr 16 2004 Bill Nottingham <notting@redhat.com> 0.1-1
  296. - initial packaging