bash-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543
  1. %define bashversion 4.2
  2. %define patchlevel 20
  3. Summary: The GNU Bourne Again shell (bash).
  4. Summary(ja): GNU Bourne Again シェル (bash).
  5. Name: bash
  6. Version: %{bashversion}.%{patchlevel}
  7. Release: 1%{?_dist_release}
  8. Group: System Environment/Shells
  9. License: GPLv3+
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Packager: daisuke
  13. Source0: ftp://ftp.gnu.org/pub/gnu/bash/bash-%{bashversion}.tar.gz
  14. Source10: bashrc-vine
  15. # Official upstream patches
  16. Patch1: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-001
  17. Patch2: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-002
  18. Patch3: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-003
  19. Patch4: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-004
  20. Patch5: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-005
  21. Patch6: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-006
  22. Patch7: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-007
  23. Patch8: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-008
  24. Patch9: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-009
  25. Patch10: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-010
  26. Patch11: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-011
  27. Patch12: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-012
  28. Patch13: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-013
  29. Patch14: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-014
  30. Patch15: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-015
  31. Patch16: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-016
  32. Patch17: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-017
  33. Patch18: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-018
  34. Patch19: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-019
  35. Patch20: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-020
  36. # Other patches
  37. Patch101: bash-2.02-security.patch
  38. Patch102: bash-2.03-paths.patch
  39. Patch103: bash-2.03-profile.patch
  40. Patch104: bash-2.05a-interpreter.patch
  41. Patch105: bash-2.05b-debuginfo.patch
  42. Patch106: bash-2.05b-manso.patch
  43. Patch107: bash-2.05b-pgrp_sync.patch
  44. Patch108: bash-2.05b-readline-oom.patch
  45. Patch109: bash-2.05b-xcc.patch
  46. Patch110: bash-3.2-audit.patch
  47. Patch111: bash-3.2-ssh_source_bash.patch
  48. Patch112: bash-bashbug.patch
  49. Patch113: bash-infotags.patch
  50. Patch114: bash-requires.patch
  51. Patch115: bash-setlocale.patch
  52. Patch116: bash-tty-tests.patch
  53. # 484809, check if interp section is NOBITS
  54. Patch117: bash-4.0-nobits.patch
  55. # Do the same CFLAGS in generated Makefile in examples
  56. Patch118: bash-4.1-examples.patch
  57. # Builtins like echo and printf won't report errors
  58. # when output does not succeed due to EPIPE
  59. Patch119: bash-4.1-broken_pipe.patch
  60. # Enable system-wide .bash_logout for login shells
  61. Patch120: bash-4.2-rc2-logout.patch
  62. # Static analyzis shows some issues in bash-2.05a-interpreter.patch
  63. Patch121: bash-4.2-coverity.patch
  64. Buildroot: %{_tmppath}/%{name}-%{version}-root
  65. BuildRequires: texinfo, bison, ncurses-devel, autoconf, gettext
  66. Obsoletes: bash <= 1.14.7
  67. Obsoletes: bash2
  68. %description
  69. Bash is a GNU project sh-compatible shell or command language
  70. interpreter. Bash (Bourne Again shell) incorporates useful features
  71. from the Korn shell (ksh) and the C shell (csh). Most sh scripts
  72. can be run by bash without modification.
  73. Bash offers several improvements over sh, including command line
  74. editing, unlimited size command history, job control, shell
  75. functions and aliases, indexed arrays of unlimited size and
  76. integer arithmetic in any base from two to 64. Bash is ultimately
  77. intended to conform to the IEEE POSIX P1003.2/ISO 9945.2 Shell and
  78. Tools standard.
  79. %package doc
  80. Summary: Documentation for the GNU Bourne Again shell (bash).
  81. Summary: GNU Bourne Again シェル向けドキュメント
  82. Group: Applications/Documentation
  83. Requires: %{name} = %{version}-%{release}
  84. Obsoletes: bash2-doc
  85. %description doc
  86. This is a separate documentation package for the GNU Bourne
  87. Again shell.
  88. %prep
  89. %setup -q -n %{name}-%{bashversion}
  90. # Official upstream patches
  91. %patch1 -p0 -b .001
  92. %patch2 -p0 -b .002
  93. %patch3 -p0 -b .003
  94. %patch4 -p0 -b .004
  95. %patch5 -p0 -b .005
  96. %patch6 -p0 -b .006
  97. %patch7 -p0 -b .007
  98. %patch8 -p0 -b .008
  99. %patch9 -p0 -b .009
  100. %patch10 -p0 -b .010
  101. %patch11 -p0 -b .011
  102. %patch12 -p0 -b .012
  103. %patch13 -p0 -b .013
  104. %patch14 -p0 -b .014
  105. %patch15 -p0 -b .015
  106. %patch16 -p0 -b .016
  107. %patch17 -p0 -b .017
  108. %patch18 -p0 -b .018
  109. %patch19 -p0 -b .019
  110. %patch20 -p0 -b .020
  111. # Other patches
  112. %patch101 -p1 -b .security
  113. %patch102 -p1 -b .paths
  114. %patch103 -p1 -b .profile
  115. %patch104 -p1 -b .interpreter
  116. %patch105 -p1 -b .debuginfo
  117. %patch106 -p1 -b .manso
  118. %patch107 -p1 -b .pgrp_sync
  119. %patch108 -p1 -b .readline_oom
  120. %patch109 -p1 -b .xcc
  121. %patch110 -p1 -b .audit
  122. %patch111 -p1 -b .ssh_source_bash
  123. %patch112 -p1 -b .bashbug
  124. %patch113 -p1 -b .infotags
  125. %patch114 -p1 -b .requires
  126. %patch115 -p1 -b .setlocale
  127. %patch116 -p1 -b .tty_tests
  128. %patch117 -p1 -b .nobits
  129. %patch118 -p1 -b .examples
  130. %patch119 -p1 -b .broken_pipe
  131. %patch120 -p1 -b .logout
  132. %patch121 -p1 -b .coverity
  133. echo %{version} > _distribution
  134. echo %{release} |sed 's/vl.*//' > _patchlevel
  135. %build
  136. %configure --with-bash-malloc=no
  137. make CPPFLAGS="-D_GNU_SOURCE -DRECYCLES_PIDS `getconf LFS_CFLAGS`"
  138. %install
  139. rm -rf %{buildroot}
  140. # Fix bug #83776
  141. perl -pi -e 's,bashref\.info,bash.info,' doc/bashref.info
  142. make DESTDIR=$RPM_BUILD_ROOT install
  143. pushd $RPM_BUILD_ROOT
  144. mkdir ./bin
  145. mv ./usr/bin/bash ./bin/bash
  146. ln -s bash ./bin/sh
  147. rm -f .%{_infodir}/dir
  148. popd
  149. ln -s bash.1 %{buildroot}%{_mandir}/man1/sh.1
  150. # make manpages for bash builtins as per suggestion in DOC/README
  151. pushd doc
  152. sed -e '
  153. /^\.SH NAME/, /\\- bash built-in commands, see \\fBbash\\fR(1)$/{
  154. /^\.SH NAME/d
  155. s/^bash, //
  156. s/\\- bash built-in commands, see \\fBbash\\fR(1)$//
  157. s/,//g
  158. b
  159. }
  160. d
  161. ' builtins.1 > man.pages
  162. for i in echo pwd test kill; do
  163. perl -pi -e "s,$i,,g" man.pages
  164. perl -pi -e "s, , ,g" man.pages
  165. done
  166. install -c -m 644 builtins.1 %{buildroot}%{_mandir}/man1/builtins.1
  167. for i in `cat man.pages` ; do
  168. echo .so man1/builtins.1 > %{buildroot}%{_mandir}/man1/$i.1
  169. chmod 0644 ${RPM_BUILD_ROOT}%{_mandir}/man1/$i.1
  170. done
  171. mkdir -p $RPM_BUILD_ROOT/etc/profile.d/
  172. install -m 644 %{SOURCE10} $RPM_BUILD_ROOT/etc/bashrc
  173. # Not for printf, false and true (conflict with coreutils)
  174. rm -f $RPM_BUILD_ROOT%{_mandir}/man1/printf.1
  175. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/true.1
  176. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/false.1
  177. popd
  178. %find_lang %{name}
  179. %clean
  180. rm -rf %{buildroot}
  181. # ***** bash doesn't use install-info. It's always listed in %{_infodir}/dir
  182. # to prevent prereq loops
  183. # post is in lua so that we can run it without any external deps. Helps
  184. # for bootstrapping a new install.
  185. # Jesse Keating 2009-01-29 (code from Ignacio Vazquez-Abrams)
  186. %post -p <lua>
  187. bashfound = false;
  188. shfound = false;
  189. f = io.open("/etc/shells", "r");
  190. if f == nil
  191. then
  192. f = io.open("/etc/shells", "w");
  193. else
  194. repeat
  195. t = f:read();
  196. if t == "/bin/bash"
  197. then
  198. bashfound = true;
  199. end
  200. if t == "/bin/sh"
  201. then
  202. shfound = true;
  203. end
  204. until t == nil;
  205. end
  206. f:close()
  207. f = io.open("/etc/shells", "a");
  208. if not bashfound
  209. then
  210. f:write("/bin/bash\n")
  211. end
  212. if not shfound
  213. then
  214. f:write("/bin/sh\n")
  215. end
  216. f:close()
  217. %postun -p <lua>
  218. t={}
  219. for line in io.lines("/etc/shells")
  220. do
  221. if line ~= "/bin/bash" and line ~= "/bin/sh"
  222. then
  223. table.insert(t,line)
  224. end
  225. end
  226. f = io.open("/etc/shells", "w+")
  227. for n,line in pairs(t)
  228. do
  229. f:write(line.."\n")
  230. end
  231. %files -f %{name}.lang
  232. %defattr(-,root,root)
  233. %doc CHANGES COPYING
  234. %doc examples
  235. %config(noreplace) /etc/bashrc
  236. /bin/bash
  237. /bin/sh
  238. %{_infodir}/bash.info*
  239. %{_mandir}/*/*
  240. %{_mandir}/*/..1*
  241. %{_bindir}/bashbug
  242. %files doc
  243. %defattr(-,root,root)
  244. %doc COMPAT NEWS NOTES POSIX RBASH
  245. %doc examples/bashdb/ examples/functions/ examples/misc/
  246. %doc examples/scripts.noah/ examples/scripts.v2/ examples/scripts/
  247. %doc examples/startup-files/ examples/complete/ examples/loadables/
  248. %doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
  249. %doc doc/FAQ doc/INTRO doc/article.ms doc/README
  250. %changelog
  251. * Fri Feb 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.20-1
  252. - update to 4.2 patch level 20
  253. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.8-1
  254. - update to 4.2 patch level 8
  255. - use lua script in post/postun
  256. - update patches from fedora
  257. * Fri Sep 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-1
  258. - update to 4.1 patch level 7
  259. * Fri Mar 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-9
  260. - check if /bin/grep exists on %%post script
  261. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-8
  262. - rebuilt with gcc-4.4.3-3 on ppc
  263. * Tue Feb 2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-7
  264. - rebuilt with new toolchain
  265. * Fri Dec 4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-6
  266. - revert changes on 3.2-5 (avoid a nasty dependency loop on bootstrapping)
  267. * Fri Dec 4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-5
  268. - add Requires(post): grep
  269. * Sat Oct 24 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-4
  270. - remove obsolete /bin/bash2 entry from /etc/shells
  271. * Mon Apr 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-3
  272. - add Requires(post): ncurses (should be added by find-requires..)
  273. * Mon Mar 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-2
  274. - add upstream patch (from 040 to 048)
  275. - build against ncurses-devel (libtinfo)
  276. - spec in utf-8
  277. * Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2-1vl5
  278. - added upstream patch (from 026 to 039)
  279. - added Japanese summary
  280. - applied new versioning policy
  281. * Fri Jan 18 2008 Shu KONNO <owa@bg.wakwak.com> 3.2-0vl2
  282. - rebuilt with libtermcap-devel
  283. * Fri Oct 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-0vl1
  284. - new upstream release
  285. - add upstream patch (from 001 to 025)
  286. - remove Provides: bash2
  287. * Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.05b-0vl4
  288. - rebuilt with new toolchain
  289. * Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.05b-0vl3
  290. - change doc Group to Applications/Documentation. <BTS:VineLinux:163>
  291. - quote CPPFLAGS to avoid configure error. <BTS:VineLinux:173>
  292. * Mon Jun 28 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05b-0vl2
  293. - Don't read /etc/profile.d/*.sh in /etc/bashrc; done in /etc/profile
  294. * Wed Mar 10 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.05b-0vl1
  295. - update to 2.05b
  296. - rebuild with new toolchains
  297. - add make check
  298. - add %postun script based on Fedora development
  299. - README file moved doc package
  300. - update Patch5 and Patch8 from Fedora development
  301. - change Patch6
  302. - remove Patch2 and Patch100 (bash-2.05b supports multibyte string)
  303. - add Patch11--39 from Fedora development 2.05b-36
  304. * Tim Waugh <twaugh@redhat.com>
  305. - Fix parameter expansion in multibyte locales (bug #112657).
  306. - Speed up UTF-8 command-line redrawing in the common case (bug #102353,
  307. bug #110777).
  308. - Apply upstream patches (bug #109269 among others).
  309. - Fix bash.info (bug #83776).
  310. - Add bash205b-007 patch to fix bug #106876.
  311. - Avoid crashing on multibyte input when locale is set incorrectly
  312. (bug #74266).
  313. - LFS support (bug #103627).
  314. - Fix completion display when multibyte or control characters are to be
  315. shown (bug #90201).
  316. - Fix a warning message (bug #79629).
  317. - Don't build with AFS support (bug #86514).
  318. - Don't explicitly strip binaries (bug #85995).
  319. - Really fix bug #83331 for good.
  320. - Fix builtins.1.
  321. - Actually apply the patch (bug #83331).
  322. - Fix history/UTF-8 bug (bug #83331).
  323. - More tab-completion fixing (bug #72512).
  324. - Force pgrp synchronization (bug #81653).
  325. - Prevent prompt overwriting output (bug #74383).
  326. - Fix '-rbash' (bug #78455).
  327. - Add readline-init patch (bug #74925).
  328. - Add the (4) patches from ftp.gnu.org (bug #75888, bug #72512).
  329. - Ship '.' man page, which doesn't get picked up by glob.
  330. - Locale shell variables fix (bug #74701).
  331. * Elliot Lee <sopwith@redhat.com>
  332. - (patch26) Don't call 'size' in makefile. Pointless, and interferes with
  333. cross compiles.
  334. * Wed Oct 9 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05-0vl1
  335. - update to 2.05
  336. - add README.jpatch to %doc
  337. - remove patch4 (bash2): revert command name in man pages to "bash"
  338. - fix perl command to remove man pages conflict with sh-utils
  339. - remove section of config.h.in from patch0 to prevent remake of configure
  340. - change patch9: define in config-top.h to avoid conflict with patch100
  341. - remove patches 7, 10 & 101
  342. * Mon Apr 8 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.04-1vl14
  343. - made a link for man sh
  344. * Thu Nov 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.04-1vl13
  345. - added missing %%post and %%triggerpostun section
  346. * Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  347. - 2.04-1vl12
  348. - now bash2 is finally bash
  349. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.04-1vl11
  350. - build for Playstation2
  351. * Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  352. - 2.04-1vl10
  353. - Provides: bash = %%{version}
  354. * Thu Jun 07 2001 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl9
  355. - added Provides: bash
  356. * Thu Jun 07 2001 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl8
  357. - Obsoletes: bash
  358. - changed Copyright to License
  359. * Fri Dec 29 2000 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
  360. - 2.04-1vl7
  361. - deleted: /etc/profile.d/alias.sh (which we have in /etc/skel/.bashrc)
  362. - corrected: bashrc-vine -> bashrc
  363. * Sat Dec 16 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl6
  364. - combined bash-1.x and bash-2.x packages
  365. - added some patches from bash-2.04-13mdk
  366. * Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org> 2.04-1vl5
  367. - fix spec macros
  368. - added tests
  369. * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl5
  370. - build with gcc-2.95.3
  371. - partially used rpmmacros
  372. * Fri Sep 8 2000 Jun Nishii <jun@vinelinux.org>
  373. - minor bug fix in spec file
  374. * Sun Aug 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  375. - 2.04-1vl3
  376. - modified %install and %files section to handle compressed man page(s)
  377. * Thu Mar 23 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  378. - added pcomplete patch to fix complete if the candidate list is NULL.
  379. * Wed Mar 22 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  380. - updated to 2.04
  381. * Fri Sep 14 1999 Dale Lovelace <dale@redhat.com>
  382. - Remove annoying ^H's from documentation
  383. * Fri Jul 16 1999 Ken Estes <kestes@staff.mail.com>
  384. - patch to detect what executables are required by a script.
  385. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  386. - auto rebuild in the new build environment (release 4)
  387. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  388. - strip binaries.
  389. - include bash-doc correctly.
  390. * Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
  391. - fixed post/postun /etc/shells work.
  392. * Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
  393. - updated again text in the spec file
  394. * Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
  395. - updated text in spec file.
  396. - update to 2.03.
  397. * Fri Feb 12 1999 Cristian Gafton <gafton@redhat.com>
  398. - build it as bash2 instead of bash
  399. * Tue Feb 9 1999 Bill Nottingham <notting@redhat.com>
  400. - set 'NON_INTERACTIVE_LOGIN_SHELLS' so profile gets read
  401. * Thu Jan 14 1999 Jeff Johnson <jbj@redhat.com>
  402. - rename man pages in bash-doc to avoid packaging conflicts (#606).
  403. * Wed Dec 02 1998 Cristian Gafton <gafton@redhat.com>
  404. - patch for the arm
  405. - use $RPM_ARCH-redhat-linux as the build target
  406. * Tue Oct 6 1998 Bill Nottingham <notting@redhat.com>
  407. - rewrite %pre, axe %postun (to avoid prereq loops)
  408. * Wed Aug 19 1998 Jeff Johnson <jbj@redhat.com>
  409. - resurrect for RH 6.0.
  410. * Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
  411. - update to 2.02.1
  412. * Thu Jun 11 1998 Jeff Johnson <jbj@redhat.com>
  413. - Package for 5.2.
  414. * Mon Apr 20 1998 Ian Macdonald <ianmacd@xs4all.nl>
  415. - added POSIX.NOTES doc file
  416. - some extraneous doc files removed
  417. - minor .spec file changes
  418. * Sun Apr 19 1998 Ian Macdonald <ianmacd@xs4all.nl>
  419. - upgraded to version 2.02
  420. - Alpha, MIPS & Sparc patches removed due to lack of test platforms
  421. - glibc & signal patches no longer required
  422. - added documentation subpackage (doc)
  423. * Fri Nov 07 1997 Donnie Barnes <djb@redhat.com>
  424. - added signal handling patch from Dean Gaudet <dgaudet@arctic.org> that
  425. is based on a change made in bash 2.0. Should fix some early exit
  426. problems with suspends and fg.
  427. * Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
  428. - added %clean
  429. * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
  430. - added comment explaining why install-info isn't used
  431. - added mips patch
  432. * Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
  433. - added BuildRoot
  434. * Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
  435. - built against glibc