yatex-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370
  1. %define _noVersionedDependencies 1
  2. #% define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %if %{?_dist_release} <= "vl5"
  4. exit 1
  5. %endif
  6. Name: yatex
  7. Version: 1.76
  8. Release: 2%{?_dist_release}
  9. License: Distributable
  10. Source0: http://www.yatex.org/yatex%{version}.tar.gz
  11. #Source0: http://www.gentei.org/~yuuji/tmp/yatex11205111805.tar.gz
  12. Source1: %{name}-install.sh
  13. Source2: %{name}-remove.sh
  14. Source3: %{name}-init.el
  15. Source4: vine-default-%{name}.el
  16. Source5: vine-default-yahtml.el
  17. ## Vine Patch(es)
  18. Patch1: yatexhlp-emacs.diff
  19. Patch2: yatex-make.diff
  20. # based on a patch at http://www.nekolinux.2y.net/nekomemo/yahtml01.html
  21. # and modified to suit 1.70 release
  22. Patch3: yahtml-1.70-timestamp.patch
  23. Patch10: yatex-1.76-vine-vl7.patch
  24. Patch11: yatex-1.76-vine-vl6.patch
  25. URL: http://www.yatex.org/
  26. Group: Applications/Editors/Emacs
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  28. Summary: YaTeX - Yet Another TeX mode for Emacs
  29. Summary(ja): 野鳥(YaTeX) - Yet Another TeX mode for Emacs
  30. BuildArch: noarch
  31. Requires(post): emacsen
  32. Requires(post): emacsen-common
  33. Requires(post): make
  34. BuildRequires: emacsen-common
  35. BuildRequires: nkf perl
  36. Obsoletes: yatex-xemacs
  37. Distribution: Vine Linux
  38. Vendor: Project Vine
  39. Packager: munepi
  40. %description
  41. YaTeX is an intelligent, acquisitive and integrated package which reduces
  42. your efforts of composing LaTeX source on GNU Emacs.
  43. If you are YaTeX user and you install both yatex and auctex on your system,
  44. you may add the following configure in your emacs init file
  45. ~/.emacs.d/emacsXX-vine-default.el (XX: emacs major version):
  46. ;; I am a YaTeX user!!!
  47. (setq vine-default-auctex nil
  48. vine-default-preview-latex nil)
  49. %description -l ja
  50. YaTeX(野鳥)とは、EmacsでLaTeXソースを書くときに生ずる手間を軽減
  51. してくれる、LaTeX 入力支援環境です。
  52. yatex と auctex パッケージの両方をインストールする場合、
  53. ~/.emacs.d/emacsXX-vine-default.el (XX: emacs のメジャーバージョン)
  54. に以下の設定を追加するとよいでしょう。
  55. ;; YaTeX ユーザです!!!
  56. (setq vine-default-auctex nil
  57. vine-default-preview-latex nil)
  58. %prep
  59. %setup -n yatex%{version}
  60. %patch1 -p1
  61. %patch2 -p1
  62. %patch3 -p1
  63. %if %{?_dist_release} == "vl7"
  64. %patch10 -p1 -b .vine
  65. %elseif %{?_dist_release} == "vl6"
  66. %patch11 -p1 -b .vine
  67. %endif
  68. (cd docs
  69. # change permissions
  70. chmod 644 *
  71. # encode as utf-8 (LF)
  72. # NOTE: This changes needs to entry info files to Info DIR
  73. for i in yatexj yatexe yahtmlj yahtmle; do nkf --unix -w --overwrite $i; done
  74. )
  75. %build
  76. %install
  77. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  78. %__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
  79. %__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
  80. %__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
  81. %__mkdir_p ${RPM_BUILD_ROOT}%{_infodir}
  82. #
  83. # install el files
  84. #
  85. %__cp -a *.el makefile help \
  86. ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}
  87. %__cp -a %{SOURCE3} %{SOURCE4} %{SOURCE5} \
  88. ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
  89. #
  90. # install info files
  91. #
  92. %__install -m 644 docs/{yahtmle,yahtmlj,yatexe,yatexj} \
  93. ${RPM_BUILD_ROOT}%{_infodir}
  94. #
  95. # install script (bytecompile el and install elc, remove)
  96. #
  97. %_installemacsenscript %{name} %{SOURCE1}
  98. %_removeemacsenscript %{name} %{SOURCE2}
  99. %clean
  100. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  101. %post
  102. #
  103. # bytecompile and install
  104. #
  105. if [ "$1" = 2 ] ; then
  106. %_emacsenPackageRemove %{name}
  107. fi
  108. %_addemacsenlist %{name}
  109. %_emacsenPackageInstall %{name}
  110. for i in yatexe yatexj yahtmle yahtmlj; do
  111. /sbin/install-info --dir-file %{_infodir}/dir --section="Emacs" \
  112. %{_infodir}/${i}.gz
  113. done
  114. %preun
  115. if [ "$1" = 0 ]; then
  116. %_emacsenPackageRemove %{name}
  117. %_removeemacsenlist %{name}
  118. for i in yatexe yatexj yahtmle yahtmlj; do
  119. /sbin/install-info --delete --dir-file %{_infodir}/dir --section="Emacs" \
  120. %{_infodir}/${i}.gz
  121. done
  122. fi
  123. %files
  124. %defattr(-,root,root)
  125. %doc 00readme install manifest yatex.new
  126. %doc docs
  127. %{_datadir}/emacs/site-lisp/yatex/
  128. %{_infodir}/yahtmle*
  129. %{_infodir}/yahtmlj*
  130. %{_infodir}/yatexe*
  131. %{_infodir}/yatexj*
  132. %{emacsen_pkgdir}/install/%{name}
  133. %{emacsen_pkgdir}/remove/%{name}
  134. %changelog
  135. * Tue May 22 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.76-2
  136. - new upstream release
  137. - updated yatex-1.76-vine-vl{6,7}.patch
  138. * Sat May 12 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.76-1.20120511
  139. - source snapshot 20120511: testing version 1.76 development
  140. - dropped obsoleted/upstreamed patches
  141. - applied yatex-1.76-vine-vl{6,7}.patch
  142. * Fri May 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-3
  143. - added BuildRequires: nkf perl
  144. - updated yatex-1.74-vine.patch as yatex-1.75-vine-vl{6,7}.patch
  145. - dropped pre-formatted info files
  146. - use original info files
  147. - encode info files as utf-8
  148. - add INFO-DIR-ENTRY
  149. * Thu May 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-2
  150. - fixed vine-default-yatex.el
  151. - applied yatex-1.74-vine.patch for vl6
  152. - updated yatex-1.74-vine.patch: support some extensions for \includegraphics
  153. * Thu Feb 9 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-1
  154. - new upstream release
  155. - updated vine-default-yatex.el
  156. * Sat Dec 3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-9
  157. - support TeX Live 2011
  158. - applied yatex-1.74-vine-vl7.patch
  159. - updated vine-default-yatex.el
  160. * Thu Aug 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-8
  161. - added Requires(post): make
  162. * Sat Apr 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-7
  163. - updated vine-default-yatex.el
  164. - check 'YaTeX-inhibit-prefix-letter
  165. - used "pbibtex -kanji=utf8" as default bibtex-command
  166. - used "mendex -U" as default makeindex-command
  167. * Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-6
  168. - updated vine-default-{yatex,yahtml}.el
  169. - revived auto-fill-mode on {yatex,yahtml}-mode
  170. * Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-5
  171. - updated yatex-init.el
  172. - dropped all pathes of auctex and preview-latex from load-path
  173. * Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-4
  174. - updated vine-default-yatex.el
  175. - added (setq YaTeX-inhibit-prefix-letter t) [yatex:04567]
  176. - supported TeX Live
  177. - used "eplatex", "pxdvi", "pdvips" as default commands
  178. - updated yatex-init.el
  179. - output "Loading vine-default-yatex ..." to the buffer *Messages*
  180. - defined vine-default-yahtml
  181. - added vine-default-yahtml.el
  182. * Tue Jan 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-3
  183. - updated vine-default-yatex.el
  184. - added bbl extension in auto-mode-alist to run yatex-mode
  185. * Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-2
  186. - updated vine-default-yatex.el
  187. - supported new vine-default
  188. * Mon Jan 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-1
  189. - new upstream release
  190. * Sun Oct 18 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.73-7
  191. - updated vine-default-yatex.el
  192. - dropped (setq YaTeX-no-begend-shortcut t)
  193. - use %{emacsen_pkgdir}
  194. * Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-6
  195. - updated vine-default-yatex.el
  196. - (setq tex-command "platex -kanji=utf8 -src-specials") [VineSeed:17572]
  197. * Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-5
  198. - updated yatex-install.sh
  199. - *-init.el: changed from hard copy to symbolic link
  200. on /etc/emacs-XX.YY/site-start.d
  201. * Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-4
  202. - fixed yatex-init.el
  203. * Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-3
  204. - added yatex-init.el, vine-default-yatex.el
  205. - updated yatex-install.sh, yatex-remove.sh for vine-default-yatex.el
  206. * Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-2
  207. - spec in utf8
  208. * Sat Jun 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.73-1
  209. - applied new versioning policy
  210. * Wed Aug 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.73-0vl1
  211. - new upstream release
  212. * Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.72-0vl2
  213. - s/Copyright/License/
  214. - changed Group to Applications/Editors/Emacs <BTS:VineLinux:163>
  215. * Sun Feb 01 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.72-0vl1
  216. - update yatex-1.72
  217. * Wed May 07 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.71-0vl1
  218. - update yatex-1.71
  219. * Fri Jul 17 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.70-0vl2
  220. - added Patch3 to add hhmts timestamp feature
  221. * Tue May 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.70-0vl1
  222. - update yatex-1.70
  223. * Tue May 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.69-0vl0.1
  224. - update yatex10203151806
  225. * Wed Mar 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.68-0vl4
  226. - fixed: bytecompile yatex19
  227. * Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.68-0vl3
  228. - now emacsen-common aware
  229. - FIXME: newer upstream 1.69.2 do not work fine with xemacs-21.1.14
  230. * Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
  231. - 1.68-0vl2
  232. - no kanji code conversion of documents
  233. * Tue Sep 19 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
  234. - 1.68-0vl1
  235. - update to 1.68
  236. * Wed Jul 05 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  237. - 1.67-6vl5
  238. - YATEXHLP.{jp,eng} moved to appropriate dir
  239. * Thu Jun 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  240. - 1.67-6vl3
  241. - rebuilt for emacs-20.7
  242. * Thu May 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  243. - 1.67-6vl2
  244. - oops ... fixed target dir for help files
  245. * Tue May 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  246. - 1.67-6vl1
  247. - rebuilt for emacs-20.6
  248. * Tue Jan 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  249. - 1.67-6
  250. - included forgotten info file for YaHTML
  251. * Fri Jan 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  252. - 1.67-5
  253. - updated for emacs-20.5a release
  254. * Wed Dec 1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  255. - 1.67-4
  256. - change Group to Applications/Editors/EmacsLisp
  257. * Sun Nov 28 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  258. - 1.67-3
  259. - %post and %preun section modified
  260. * Thu Sep 23 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  261. - 1.67-2
  262. - fixed minor problem in the %files section
  263. * Sat Sep 18 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  264. - 1.67-1
  265. - updated to 1.67 release
  266. - rebuilt for emacs-20.4 on Vine Linux 1.9
  267. - updated URL for the new web site of YaTeX
  268. - some typo fix
  269. * Tue May 4 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
  270. - Initial Release