cantor-vl.spec 5.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205
  1. Name: cantor
  2. Summary: Interface for mathematical applications
  3. Version: 4.12.2
  4. Release: 1%{?_dist_release}
  5. License: GPLv2+
  6. Group: Applications/Edutainment
  7. URL: http://edu.kde.org/cantor/
  8. Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.xz
  9. ## upstream patches
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: desktop-file-utils
  12. BuildRequires: gcc-gfortran
  13. BuildRequires: kdelibs-devel >= %{version}
  14. BuildRequires: libspectre-devel
  15. BuildRequires: R libRmath-devel
  16. BuildRequires: soprano-devel
  17. BuildRequires: libqalculate-devel
  18. BuildRequires: analitza-devel
  19. Requires: kdebase-runtime%{?_kde4_version: >= %{_kde4_version}}
  20. Conflicts: kdeedu4 < 4.6.50
  21. Vendor: Project Vine
  22. Distribution: Vine Linux
  23. %description
  24. Cantor is an application to allow you to you use your favorite mathematical applications from within an elegant KDE-integrated worksheet interface. It provides dialogs to assist with common tasks and allows you to share your worksheets with others.
  25. Cantor supports various mathematical applications as backends (provided in external packages):
  26. * KAlgebra
  27. * Maxima Computer Algebra System
  28. * R Project for Statistical Computing (cantor-backend-R)
  29. * Sage Mathematics Software
  30. * Octave
  31. This package is part of the KDE education module.
  32. %package backend-R
  33. Summary: R backend for Cantor
  34. Summary(ja): Cantor の R バックエンド
  35. Group: Applications/Edutainment
  36. Requires: %{name} = %{version}-%{release}
  37. %description backend-R
  38. %{summary}.
  39. %package libs
  40. Summary: Runtime libraries for %{name}
  41. Summary(ja): %{name} のランタイムライブラリ
  42. Group: System Environment/Libraries
  43. Conflicts: kdeedu4-math-libs < 4.6.50
  44. %description libs
  45. %{summary}.
  46. %package devel
  47. Summary: Development files for %{name}
  48. Summary(ja): %{name} の開発用ファイル
  49. Group: Development/Libraries
  50. Requires: %{name}-libs = %{version}-%{release}
  51. Conflicts: kdeedu4-devel < 4.6.50
  52. %description devel
  53. Header files for developing applications using %{name}.
  54. %prep
  55. %setup -q
  56. %build
  57. mkdir -p %{_target_platform}
  58. pushd %{_target_platform}
  59. %cmake \
  60. -DCMAKE_BUILD_TYPE=release \
  61. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  62. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  63. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  64. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  65. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  66. ..
  67. popd
  68. make %{?_smp_mflags} -C %{_target_platform}
  69. %install
  70. rm -rf $RPM_BUILD_ROOT
  71. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  72. %clean
  73. rm -rf $RPM_BUILD_ROOT
  74. %check
  75. for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
  76. desktop-file-validate $f
  77. done
  78. %post
  79. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  80. %posttrans
  81. update-desktop-database -q &> /dev/null ||:
  82. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  83. %postun
  84. if [ $1 -eq 0 ] ; then
  85. update-desktop-database -q &> /dev/null ||:
  86. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  87. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  88. fi
  89. %post backend-R
  90. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  91. %posttrans backend-R
  92. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  93. %postun backend-R
  94. if [ $1 -eq 0 ] ; then
  95. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  96. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  97. fi
  98. %post libs -p /sbin/ldconfig
  99. %postun libs -p /sbin/ldconfig
  100. %files
  101. %defattr(-,root,root)
  102. %doc COPYING COPYING.DOC
  103. %{_bindir}/cantor
  104. %{_libdir}/libcantor_config.so
  105. %{_libdir}/kde4/*.so
  106. %exclude %{_libdir}/kde4/cantor_rbackend.so
  107. %{_datadir}/applications/kde4/cantor.desktop
  108. %{_datadir}/config/*.knsrc
  109. %exclude %{_datadir}/config/cantor_r.knsrc
  110. %{_datadir}/config.kcfg/*.kcfg
  111. %exclude %{_datadir}/config.kcfg/rserver.kcfg
  112. %{_datadir}/icons/hicolor/*/*/*
  113. %exclude %{_datadir}/icons/hicolor/*/*/rbackend.*
  114. %{_datadir}/kde4/apps/cantor
  115. %{_datadir}/kde4/services/cantor/*.desktop
  116. %exclude %{_datadir}/kde4/services/cantor/rbackend.desktop
  117. %{_datadir}/kde4/servicetypes/cantor_*.desktop
  118. %doc %{_docdir}/HTML/en/cantor/
  119. %files backend-R
  120. %defattr(-,root,root,-)
  121. %{_bindir}/cantor_rserver
  122. %{_libdir}/kde4/cantor_rbackend.so
  123. %{_datadir}/config/cantor_r.knsrc
  124. %{_datadir}/config.kcfg/rserver.kcfg
  125. %{_datadir}/icons/hicolor/*/*/rbackend.*
  126. %{_datadir}/kde4/services/cantor/rbackend.desktop
  127. %files libs
  128. %defattr(-,root,root)
  129. %{_libdir}/libcantorlibs.so.*
  130. %files devel
  131. %defattr(-,root,root)
  132. %{_includedir}/kde4/cantor
  133. %{_libdir}/libcantorlibs.so
  134. %changelog
  135. * Sun Feb 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.2-1
  136. - new upstream release
  137. * Wed Dec 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.4-1
  138. - new upstream release
  139. * Sun Sep 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.1-1
  140. - new upstream release
  141. * Sat Jul 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.5-1
  142. - new upstream release
  143. * Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.5-1
  144. - new upstream release
  145. * Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.3-1
  146. - new upstream release
  147. * Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
  148. - new upstream release
  149. * Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
  150. - new upstream release
  151. * Mon Aug 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
  152. - new upstream release
  153. - add BuildRequires: libqalculate-devel, analitza-devel
  154. * Thu Sep 8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
  155. - split from kdeedu