rust-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860861862863864865866867868869870871872873874875876877878879880881882883884885886887888889890891892893894895896
  1. %bcond_with bootstrap
  2. %bcond_with test
  3. %bcond_with newrpm
  4. %bcond_without clang
  5. %bcond_without bundled_libgit2
  6. %bcond_without bundled_libssh2
  7. # Some sub-packages are versioned independently of the rust compiler and runtime itself.
  8. # Also beware that if any of these are not changed in a version bump, then the release
  9. # number should still increase, not be reset to 1!
  10. %global rustc_version 1.49.0
  11. %global cargo_version %{rustc_version}
  12. %global rustfmt_version %{rustc_version}
  13. %global rls_version %{rustc_version}
  14. %global clippy_version %{rustc_version}
  15. # The channel can be stable, beta, or nightly
  16. %{!?channel: %global channel stable}
  17. # Only x86_64 and i686 are Tier 1 platforms at this time.
  18. # https://forge.rust-lang.org/platform-support.html
  19. %global rust_arches x86_64 i686
  20. # To bootstrap from scratch, set the channel and date from src/stage0.txt
  21. # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
  22. # or nightly wants some beta-YYYY-MM-DD
  23. %global bootstrap_rust 1.46.0
  24. %global bootstrap_cargo 1.46.0
  25. %global bootstrap_channel %{bootstrap_rust}
  26. # Only the specified arches will use bootstrap binaries.
  27. %if %{with bootstrap}
  28. %global bootstrap_arches %%{rust_arches}
  29. %endif
  30. # We generally don't want llvm-static present at all, since llvm-config will
  31. # make us link statically. But we can opt in, e.g. to aid LLVM rebases.
  32. # FIXME: LLVM 3.9 prefers shared linking now! Which is good, but next time we
  33. # *want* static we'll have to force it with "llvm-config --link-static".
  34. # See also https://github.com/rust-lang/rust/issues/36854
  35. # The new rustbuild accepts `--enable-llvm-link-shared`, else links static.
  36. %bcond_with llvm_static
  37. # We can also choose to just use Rust's bundled LLVM, in case the system LLVM
  38. # is insufficient. Rust currently requires LLVM 3.7+.
  39. %bcond_with bundled_llvm
  40. # LLDB only works on some architectures
  41. %ifarch %{arm} aarch64 %{ix86} x86_64
  42. # LLDB isn't available everywhere...
  43. %bcond_without lldb
  44. %else
  45. %bcond_with lldb
  46. %endif
  47. Summary: The Rust Programming Language
  48. Name: rust
  49. Version: %{rustc_version}
  50. Release: 1%{?_dist_release}
  51. Group: programming
  52. Vendor: Project Vine
  53. Distribution: Vine Linux
  54. License: (ASL 2.0 or MIT) and (BSD and ISC and MIT)
  55. # ^ written as: (rust itself) and (bundled libraries)
  56. URL: https://www.rust-lang.org
  57. ExclusiveArch: %{rust_arches}
  58. %if "%{channel}" == "stable"
  59. %global rustc_package rustc-%{version}-src
  60. %else
  61. %global rustc_package rustc-%{channel}-src
  62. %endif
  63. Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.gz
  64. # Get the Rust triple for any arch.
  65. %{lua: function rust_triple(arch)
  66. local abi = "gnu"
  67. if arch == "armv7hl" then
  68. arch = "armv7"
  69. abi = "gnueabihf"
  70. elseif arch == "ppc64" then
  71. arch = "powerpc64"
  72. elseif arch == "ppc64le" then
  73. arch = "powerpc64le"
  74. end
  75. return arch.."-unknown-linux-"..abi
  76. end}
  77. %global rust_triple %{lua: print(rust_triple(rpm.expand("%{_target_cpu}")))}
  78. %if %defined bootstrap_arches
  79. # For each bootstrap arch, add an additional binary Source.
  80. # Also define bootstrap_source just for the current target.
  81. %{lua: do
  82. local bootstrap_arches = {}
  83. for arch in string.gmatch(rpm.expand("%{bootstrap_arches}"), "%S+") do
  84. table.insert(bootstrap_arches, arch)
  85. end
  86. local base = rpm.expand("https://static.rust-lang.org/dist"
  87. .."/rust-%{bootstrap_channel}")
  88. local target_arch = rpm.expand("%{_target_cpu}")
  89. for i, arch in ipairs(bootstrap_arches) do
  90. print(string.format("Source%d: %s-%s.tar.gz\n",
  91. i, base, rust_triple(arch)))
  92. if arch == target_arch then
  93. rpm.define("bootstrap_source "..i)
  94. end
  95. end
  96. end}
  97. %endif
  98. %ifarch %{bootstrap_arches}
  99. %global bootstrap_root rust-%{bootstrap_channel}-%{rust_triple}
  100. %global local_rust_root %{_builddir}/%{bootstrap_root}/usr
  101. Provides: bundled(%{name}-bootstrap) = %{bootstrap_rust}
  102. %else
  103. BuildRequires: cargo >= %{bootstrap_cargo}
  104. BuildRequires: %{name} >= %{bootstrap_rust}
  105. BuildConflicts: %{name} > %{version}
  106. %global local_rust_root %{_prefix}
  107. %endif
  108. BuildRequires: cmake
  109. BuildRequires: make
  110. %if %{with clang}
  111. BuildRequires: clang
  112. BuildRequires: lld
  113. %else
  114. BuildRequires: gcc
  115. BuildRequires: gcc-c++
  116. %endif
  117. %if %{without bundled_libgit2}
  118. BuildRequires: libgit2-devel
  119. %endif
  120. %if %{without bundled_libssh2}
  121. BuildRequires: libssh2-devel
  122. %endif
  123. BuildRequires: ncurses-devel
  124. BuildRequires: openssl-devel
  125. BuildRequires: zlib-devel
  126. BuildRequires: python3
  127. BuildRequires: python3-rpm-macros
  128. BuildRequires: curl
  129. BuildRequires: curl-devel
  130. BuildRequires: xz-devel
  131. %if %{with bundled_llvm}
  132. BuildRequires: cmake
  133. BuildRequires: git
  134. Provides: bundled(llvm) = 6.0
  135. %else
  136. BuildRequires: cmake
  137. %if %defined llvm
  138. %global llvm_root %{_libdir}/%{llvm}
  139. %else
  140. %global llvm llvm
  141. %global llvm_root %{_prefix}
  142. %global llvm_has_filecheck 1
  143. %endif
  144. BuildRequires: %{llvm}-devel >= 11.0.0
  145. %if %{with llvm_static}
  146. BuildRequires: %{llvm}-static
  147. BuildRequires: libffi-devel
  148. %else
  149. BuildConflicts: %{llvm}-static
  150. %endif
  151. %endif
  152. # make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
  153. BuildRequires: procps
  154. # debuginfo-gdb tests need gdb
  155. BuildRequires: gdb
  156. # TODO: work on unbundling these!
  157. Provides: bundled(jquery) = 2.1.4
  158. Provides: bundled(miniz) = 1.14
  159. # Virtual provides for folks who attempt "dnf install rustc"
  160. Provides: rustc = %{version}-%{release}
  161. Provides: rustc%{?_isa} = %{version}-%{release}
  162. # Always require our exact standard library
  163. Requires: %{name}-std-static%{?_isa} = %{version}-%{release}
  164. # The C compiler is needed at runtime just for linking. Someday rustc might
  165. # invoke the linker directly, and then we'll only need binutils.
  166. # https://github.com/rust-lang/rust/issues/11937
  167. Requires: /usr/bin/cc
  168. # ALL Rust libraries are private, because they don't keep an ABI.
  169. %global _privatelibs lib(.*-[[:xdigit:]]{16}*|rustc.*)[.]so.*
  170. %global __provides_exclude ^(%{_privatelibs})$
  171. %global __requires_exclude ^(%{_privatelibs})$
  172. %global __provides_exclude_from ^(%{_docdir}|%{rustlibdir}/src)/.*$
  173. %global __requires_exclude_from ^(%{_docdir}|%{rustlibdir}/src)/.*$
  174. %if !%{with newrpm}
  175. # eu-strip is very eager by default, so we have to limit it to -g, only debugging symbols.
  176. %global _find_debuginfo_opts -g
  177. %undefine _include_minidebuginfo
  178. %else
  179. # Newer find-debuginfo.sh supports --keep-section, which is preferable. rhbz1465997
  180. %global _find_debuginfo_opts --keep-section .rustc
  181. %endif
  182. # Use hardening ldflags.
  183. %global rustflags -Clink-arg=-Wl,-z,relro,-z,now
  184. %if %{without bundled_llvm} && "%{llvm_root}" != "%{_prefix}"
  185. # https://github.com/rust-lang/rust/issues/40717
  186. %global library_path $(%{llvm_root}/bin/llvm-config --libdir)
  187. %endif
  188. %description
  189. Rust is a systems programming language that runs blazingly fast, prevents
  190. segfaults, and guarantees thread safety.
  191. This package includes the Rust compiler and documentation generator.
  192. %package std-static
  193. Summary: Standard library for Rust
  194. Group: programming
  195. %description std-static
  196. This package includes the standard libraries for building applications
  197. written in Rust.
  198. %package debugger-common
  199. Summary: Common debugger pretty printers for Rust
  200. Group: programming
  201. BuildArch: noarch
  202. %description debugger-common
  203. This package includes the common functionality for %{name}-gdb and %{name}-lldb.
  204. %package gdb
  205. Summary: GDB pretty printers for Rust
  206. Group: programming
  207. BuildArch: noarch
  208. Requires: gdb
  209. Requires: %{name}-debugger-common = %{version}-%{release}
  210. %description gdb
  211. This package includes the rust-gdb script, which allows easier debugging of Rust
  212. programs.
  213. %if %{with lldb}
  214. %package lldb
  215. Summary: LLDB pretty printers for Rust
  216. Group: programming
  217. # It could be noarch, but lldb has limited availability
  218. #BuildArch: noarch
  219. Requires: lldb
  220. Requires: python3-lldb
  221. Requires: %{name}-debugger-common = %{version}-%{release}
  222. %description lldb
  223. This package includes the rust-lldb script, which allows easier debugging of Rust
  224. programs.
  225. %endif
  226. %package doc
  227. Summary: Documentation for Rust
  228. Group: documentation
  229. # NOT BuildArch: noarch
  230. # Note, while docs are mostly noarch, some things do vary by target_arch.
  231. # Koji will fail the build in rpmdiff if two architectures build a noarch
  232. # subpackage differently, so instead we have to keep its arch.
  233. %description doc
  234. This package includes HTML documentation for the Rust programming language and
  235. its standard library.
  236. %package -n cargo
  237. Summary: Rust's package manager and build tool
  238. Version: %{cargo_version}
  239. Group: programming
  240. # For tests:
  241. BuildRequires: git
  242. # Cargo is not much use without Rust
  243. Requires: rust
  244. %description -n cargo
  245. Cargo is a tool that allows Rust projects to declare their various dependencies
  246. and ensure that you'll always get a repeatable build.
  247. %package -n cargo-doc
  248. Summary: Documentation for Cargo
  249. Version: %{cargo_version}
  250. Group: programming
  251. BuildArch: noarch
  252. # Cargo no longer builds its own documentation
  253. # https://github.com/rust-lang/cargo/pull/4904
  254. Requires: rust-doc = %{rustc_version}-%{release}
  255. %description -n cargo-doc
  256. This package includes HTML documentation for Cargo.
  257. %package -n rustfmt
  258. Summary: Tool to find and fix Rust formatting issues
  259. Version: %{rustfmt_version}
  260. Group: programming
  261. Requires: cargo
  262. Obsoletes: rustfmt-preview < 1.0.0
  263. %description -n rustfmt
  264. A tool for formatting Rust code according to style guidelines.
  265. %package -n rls
  266. Summary: Rust Language Server for IDE integration
  267. Version: %{rls_version}
  268. Group: programming
  269. Requires: rust-analysis
  270. # /usr/bin/rls is dynamically linked against internal rustc libs
  271. Requires: %{name} = %{rustc_version}-%{release}
  272. Obsoletes: rls-preview < 1.0.0
  273. %description -n rls
  274. The Rust Language Server provides a server that runs in the background,
  275. providing IDEs, editors, and other tools with information about Rust programs.
  276. It supports functionality such as 'goto definition', symbol search,
  277. reformatting, and code completion, and enables renaming and refactorings.
  278. %package -n clippy
  279. Summary: Lints to catch common mistakes and improve your Rust code
  280. Version: %{clippy_version}
  281. Group: programming
  282. License: MPLv2.0
  283. Requires: cargo
  284. # /usr/bin/clippy-driver is dynamically linked against internal rustc libs
  285. Requires: %{name} = %{rustc_version}-%{release}
  286. Obsoletes: clippy-preview < 1.0.0
  287. %description -n clippy
  288. A collection of lints to catch common mistakes and improve your Rust code.
  289. %package src
  290. Summary: Sources for the Rust standard library
  291. Group: programming
  292. BuildArch: noarch
  293. %description src
  294. This package includes source files for the Rust standard library. It may be
  295. useful as a reference for code completion tools in various editors.
  296. %package analysis
  297. Summary: Compiler analysis data for the Rust standard library
  298. Group: programming
  299. Requires: rust-std-static = %{rustc_version}-%{release}
  300. %description analysis
  301. This package contains analysis data files produced with rustc's -Zsave-analysis
  302. feature for the Rust standard library. The RLS (Rust Language Server) uses this
  303. data to provide information about the Rust standard library.
  304. %package miri
  305. Summary: An interpreter for Rust's mid-level intermediate representation
  306. Group: programming
  307. Requires: rust = %{rustc_version}-%{release}
  308. %description miri
  309. An experimental interpreter for Rust's mid-level intermediate representation
  310. (MIR). It can run binaries and test suites of cargo projects and detect certain
  311. classes of undefined behavior.
  312. %debug_package
  313. %prep
  314. %ifarch %{bootstrap_arches}
  315. %setup -q -n %{bootstrap_root} -T -b %{bootstrap_source}
  316. ./install.sh --components=cargo,rustc,rust-std-%{rust_triple} \
  317. --prefix=%{local_rust_root} --disable-ldconfig
  318. test -f '%{local_rust_root}/bin/cargo'
  319. test -f '%{local_rust_root}/bin/rustc'
  320. %endif
  321. %setup -q -n %{rustc_package}
  322. sed -i.try-py3 -e '/try python2.7/i try python3 "$@"' ./configure
  323. %if %without bundled_llvm
  324. rm -rf src/llvm-project/
  325. mkdir -p src/llvm-project/libunwind/
  326. %endif
  327. # We never enable emscripten.
  328. rm -rf src/llvm-emscripten/
  329. # Remove other unused vendored libraries
  330. #rm -rf vendor/curl-sys/curl/
  331. rm -rf vendor/jemalloc-sys/jemalloc/
  332. rm -rf vendor/libz-sys/src/zlib/
  333. rm -rf vendor/lzma-sys/xz-*/
  334. rm -rf vendor/openssl-src/openssl/
  335. %if %{without bundled_libgit2}
  336. rm -rf vendor/libgit2-sys/libgit2/
  337. %endif
  338. %if %{without bundled_libssh2}
  339. rm -rf vendor/libssh2-sys/libssh2/
  340. %endif
  341. # This only affects the transient rust-installer, but let it use our dynamic xz-libs
  342. sed -i.lzma -e '/LZMA_API_STATIC/d' src/bootstrap/tool.rs
  343. # rename bundled license for packaging
  344. if [ -e vendor/backtrace-sys/src/libbacktrace/LICENSE ]; then
  345. cp -a vendor/backtrace-sys/src/libbacktrace/LICENSE{,-libbacktrace}
  346. fi
  347. %if %{with bundled_llvm} && 0%{?epel}
  348. mkdir -p cmake-bin
  349. ln -s /usr/bin/cmake cmake-bin/cmake
  350. %global cmake_path $PWD/cmake-bin
  351. %endif
  352. %if %{without bundled_llvm} && %{with llvm_static}
  353. # Static linking to distro LLVM needs to add -lffi
  354. # https://github.com/rust-lang/rust/issues/34486
  355. sed -i.ffi -e '$a #[link(name = "ffi")] extern {}' \
  356. src/librustc_llvm/lib.rs
  357. %endif
  358. # The configure macro will modify some autoconf-related files, which upsets
  359. # cargo when it tries to verify checksums in those files. If we just truncate
  360. # that file list, cargo won't have anything to complain about.
  361. find vendor -name .cargo-checksum.json \
  362. -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
  363. %build
  364. %if %{without bundled_libgit2}
  365. export LIBGIT2_SYS_USE_PKG_CONFIG=1
  366. %endif
  367. %if %{without bundled_libssh2}
  368. export LIBSSH2_SYS_USE_PKG_CONFIG=1
  369. %endif
  370. %{?cmake_path:export PATH=%{cmake_path}:$PATH}
  371. %{?library_path:export LIBRARY_PATH="%{library_path}"}
  372. %{?rustflags:export RUSTFLAGS="%{rustflags}"}
  373. # We're going to override --libdir when configuring to get rustlib into a
  374. # common path, but we'll fix the shared libraries during install.
  375. %global common_libdir %{_prefix}/lib
  376. %global rustlibdir %{common_libdir}/rustlib
  377. %ifarch x86_64
  378. %if %{with newrpm}
  379. %define enable_debuginfo --debuginfo-level=0 --debuginfo-level-std=2
  380. %else
  381. %define enable_debuginfo --debuginfo-level=0
  382. %global debug_package %{nil}
  383. %endif
  384. %else
  385. %define enable_debuginfo --debuginfo-level=0
  386. %global debug_package %{nil}
  387. %endif
  388. # Some builders have relatively little memory for their CPU count.
  389. # At least 2GB per CPU is a good rule of thumb for building rustc.
  390. ncpus=$(/usr/bin/getconf _NPROCESSORS_ONLN)
  391. max_cpus=$(( ($(LANG=C free -g | awk '/^Mem:/{print $2}') + 1) / 2 ))
  392. if [ "$max_cpus" -ge 1 -a "$max_cpus" -lt "$ncpus" ]; then
  393. ncpus="$max_cpus"
  394. fi
  395. %if %{with clang}
  396. export CC=clang
  397. export CXX=clang++
  398. export LDFLAGS="$LDFLAGS -fuse-ld=lld"
  399. export RUSTFLAGS="$RUSTFLAGS -C linker=clang -C link-arg=-fuse-ld=lld"
  400. %endif
  401. # workaround for https://github.com/rust-lang/rust/issues/69953
  402. # --set rust.deny-warnings=false
  403. %configure \
  404. --disable-option-checking \
  405. --libdir=%{common_libdir} \
  406. --build=%{rust_triple} --host=%{rust_triple} --target=%{rust_triple} \
  407. --enable-local-rust --local-rust-root=%{local_rust_root} \
  408. %{!?with_bundled_llvm: --llvm-root=%{llvm_root} \
  409. %{!?llvm_has_filecheck: --disable-codegen-tests} \
  410. %{!?with_llvm_static: --enable-llvm-link-shared } } \
  411. --disable-rpath \
  412. %{enable_debuginfo} \
  413. --enable-extended \
  414. --enable-vendor \
  415. --enable-verbose-tests \
  416. --set rust.codegen-units-std=1 \
  417. --release-channel=%{channel} \
  418. --set rust.deny-warnings=false \
  419. %{nil}
  420. RUST_BACKTRACE=1 %{__python3} ./x.py build -j "$ncpus" --stage 2
  421. %{__python3} ./x.py doc --stage 2
  422. %install
  423. rm -rf %{buildroot}
  424. %{?cmake_path:export PATH=%{cmake_path}:$PATH}
  425. %{?library_path:export LIBRARY_PATH="%{library_path}"}
  426. %{?rustflags:export RUSTFLAGS="%{rustflags}"}
  427. %if %{with clang}
  428. export CC=clang
  429. export CXX=clang++
  430. export RUSTFLAGS="$RUSTFLAGS -C linker=clang -C link-arg=-fuse-ld=lld"
  431. %endif
  432. DESTDIR=%{buildroot} ./x.py install
  433. #DESTDIR=%{buildroot} ./x.py install src
  434. # Make sure the shared libraries are in the proper libdir
  435. %if "%{_libdir}" != "%{common_libdir}"
  436. mkdir -p %{buildroot}%{_libdir}
  437. find %{buildroot}%{common_libdir} -maxdepth 1 -type f -name '*.so' \
  438. -exec mv -v -t %{buildroot}%{_libdir} '{}' '+'
  439. %endif
  440. # The shared libraries should be executable for debuginfo extraction.
  441. find %{buildroot}%{_libdir} -maxdepth 1 -type f -name '*.so' \
  442. -exec chmod -v +x '{}' '+'
  443. # The libdir libraries are identical to those under rustlib/. It's easier on
  444. # library loading if we keep them in libdir, but we do need them in rustlib/
  445. # to support dynamic linking for compiler plugins, so we'll symlink.
  446. (cd "%{buildroot}%{rustlibdir}/%{rust_triple}/lib" &&
  447. find ../../../../%{_lib} -maxdepth 1 -name '*.so' |
  448. while read lib; do
  449. if [ -f "${lib##*/}" ]; then
  450. # make sure they're actually identical!
  451. cmp "$lib" "${lib##*/}"
  452. ln -v -f -s -t . "$lib"
  453. fi
  454. done)
  455. # Remove installer artifacts (manifests, uninstall scripts, etc.)
  456. find %{buildroot}%{rustlibdir} -maxdepth 1 -type f -exec rm -v '{}' '+'
  457. # Remove backup files from %%configure munging
  458. find %{buildroot}%{rustlibdir} -type f -name '*.orig' -exec rm -v '{}' '+'
  459. # https://fedoraproject.org/wiki/Changes/Make_ambiguous_python_shebangs_error
  460. # We don't actually need to ship any of those python scripts in rust-src anyway.
  461. find %{buildroot}%{rustlibdir}/src -type f -name '*.py' -exec rm -v '{}' '+'
  462. # FIXME: __os_install_post will strip the rlibs
  463. # -- should we find a way to preserve debuginfo?
  464. # Remove unwanted documentation files (we already package them)
  465. # Remove unwanted documentation files (we already package them)
  466. rm -f %{buildroot}%{_docdir}/%{name}/README.md
  467. rm -f %{buildroot}%{_docdir}/%{name}/COPYRIGHT
  468. rm -f %{buildroot}%{_docdir}/%{name}/LICENSE
  469. rm -f %{buildroot}%{_docdir}/%{name}/LICENSE-APACHE
  470. rm -f %{buildroot}%{_docdir}/%{name}/LICENSE-MIT
  471. rm -f %{buildroot}%{_docdir}/%{name}/LICENSE-THIRD-PARTY
  472. rm -f %{buildroot}%{_docdir}/%{name}/*.old
  473. # Sanitize the HTML documentation
  474. find %{buildroot}%{_docdir}/%{name}/html -empty -delete
  475. find %{buildroot}%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
  476. # Create the path for crate-devel packages
  477. mkdir -p %{buildroot}%{_datadir}/cargo/registry
  478. # Cargo no longer builds its own documentation
  479. # https://github.com/rust-lang/cargo/pull/4904
  480. mkdir -p %{buildroot}%{_docdir}/cargo
  481. ln -sT ../rust/html/cargo/ %{buildroot}%{_docdir}/cargo/html
  482. %if %{without lldb}
  483. rm -f %{buildroot}%{_bindir}/rust-lldb
  484. rm -f %{buildroot}%{rustlibdir}/etc/lldb_*.py*
  485. rm -f %{buildroot}%{rustlibdir}/etc/lldb_commands
  486. %endif
  487. %if %{with bundled_llvm}
  488. rm -rf %{buildroot}/home
  489. %endif
  490. %check
  491. %if %{with test}
  492. %{?cmake_path:export PATH=%{cmake_path}:$PATH}
  493. %{?library_path:export LIBRARY_PATH="%{library_path}"}
  494. %{?rustflags:export RUSTFLAGS="%{rustflags}"}
  495. %if %{with clang}
  496. export CC=clang
  497. export CXX=clang++
  498. export LD=ld.lld
  499. export RUSTFLAGS="$RUSTFLAGS -C linker=ld.lld -C link-arg=-fuse-ld=lld"
  500. %endif
  501. # The results are not stable on koji, so mask errors and just log it.
  502. %{__python3} ./x.py test --no-fail-fast || :
  503. %{__python3} ./x.py test --no-fail-fast cargo || :
  504. %{__python3} ./x.py test --no-fail-fast clippy || :
  505. %{__python3} ./x.py test --no-fail-fast rls || :
  506. %{__python3} ./x.py test --no-fail-fast rustfmt || :
  507. %endif
  508. %post -p /sbin/ldconfig
  509. %postun -p /sbin/ldconfig
  510. %files
  511. %license COPYRIGHT LICENSE-APACHE LICENSE-MIT
  512. #license src/libbacktrace/LICENSE-libbacktrace
  513. %doc README.md
  514. %{_bindir}/rustc
  515. %{_bindir}/rustdoc
  516. %{_libdir}/*.so
  517. %{_mandir}/man1/rustc.1*
  518. %{_mandir}/man1/rustdoc.1*
  519. %dir %{rustlibdir}
  520. %dir %{rustlibdir}/%{rust_triple}
  521. %dir %{rustlibdir}/%{rust_triple}/lib
  522. %{rustlibdir}/%{rust_triple}/lib/*.so
  523. %files std-static
  524. %dir %{rustlibdir}
  525. %dir %{rustlibdir}/%{rust_triple}
  526. %dir %{rustlibdir}/%{rust_triple}/lib
  527. %{rustlibdir}/%{rust_triple}/lib/*.rlib
  528. %files debugger-common
  529. %dir %{rustlibdir}
  530. %dir %{rustlibdir}/etc
  531. %{rustlibdir}/etc/rust_types.py*
  532. %files gdb
  533. %{_bindir}/rust-gdb
  534. %{rustlibdir}/etc/gdb_*.py*
  535. %exclude %{_bindir}/rust-gdbgui
  536. %if %with lldb
  537. %files lldb
  538. %{_bindir}/rust-lldb
  539. %{rustlibdir}/etc/lldb_*.py*
  540. %{rustlibdir}/etc/lldb_commands
  541. %endif
  542. %files doc
  543. %docdir %{_docdir}/%{name}
  544. %dir %{_docdir}/%{name}
  545. %dir %{_docdir}/%{name}/html
  546. %{_docdir}/%{name}/html/*/
  547. %{_docdir}/%{name}/html/*.html
  548. %{_docdir}/%{name}/html/*.css
  549. %{_docdir}/%{name}/html/*.js
  550. %{_docdir}/%{name}/html/*.png
  551. %{_docdir}/%{name}/html/*.svg
  552. %{_docdir}/%{name}/html/*.woff
  553. %license %{_docdir}/%{name}/html/*.txt
  554. %license %{_docdir}/%{name}/html/*.md
  555. %files -n cargo
  556. %license src/tools/cargo/LICENSE-APACHE src/tools/cargo/LICENSE-MIT src/tools/cargo/LICENSE-THIRD-PARTY
  557. %doc src/tools/cargo/README.md
  558. %{_bindir}/cargo
  559. %{_mandir}/man1/cargo*.1*
  560. %dir %{_sysconfdir}/bash_completion.d
  561. %{_sysconfdir}/bash_completion.d/cargo
  562. %dir %{_datadir}/zsh
  563. %dir %{_datadir}/zsh/site-functions
  564. %{_datadir}/zsh/site-functions/_cargo
  565. %dir %{_datadir}/cargo
  566. %dir %{_datadir}/cargo/registry
  567. %files -n cargo-doc
  568. %docdir %{_docdir}/cargo
  569. %dir %{_docdir}/cargo
  570. %{_docdir}/cargo/html
  571. %files -n rustfmt
  572. %{_bindir}/rustfmt
  573. %{_bindir}/cargo-fmt
  574. %doc src/tools/rustfmt/{README,CHANGELOG,Configurations}.md
  575. %license src/tools/rustfmt/LICENSE-{APACHE,MIT}
  576. %files -n rls
  577. %{_bindir}/rls
  578. %doc src/tools/rls/{README.md,COPYRIGHT,debugging.md}
  579. %license src/tools/rls/LICENSE-{APACHE,MIT}
  580. %files -n clippy
  581. %{_bindir}/cargo-clippy
  582. %{_bindir}/clippy-driver
  583. %doc src/tools/clippy/{README.md,CHANGELOG.md}
  584. %license src/tools/clippy/LICENSE*
  585. %files src
  586. %dir %{rustlibdir}
  587. %{rustlibdir}/src
  588. %files analysis
  589. %{_bindir}/rust-analyzer
  590. %{rustlibdir}/%{rust_triple}/analysis/
  591. %files miri
  592. %{_bindir}/miri
  593. %{_bindir}/cargo-miri
  594. %changelog
  595. * Wed Jan 27 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.49.0-1
  596. - new upstream release.
  597. * Sat Dec 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.48.0-1
  598. - new upstream release.
  599. * Fri Oct 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.47.0-1
  600. - new upstream release.
  601. * Thu Sep 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.46.0-1
  602. - new upstream release.
  603. * Thu Mar 26 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.42.0-1
  604. - new upstream release.
  605. - separated debuginfo.
  606. * Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.40.0-1
  607. - new upstream release.
  608. * Sat Sep 28 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.38.0-1
  609. - new upstream release.
  610. - erased "-preview" from the name of subpackages.
  611. * Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.30.1-1
  612. - new upstream release.
  613. - dropped Patch1.
  614. - added subpackages cargo, cargo-doc, rustformat-preview, rls-preview, clippy-preview and rust-analysis.
  615. * Fri Jan 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.23.0-1
  616. - Update to 1.23.0 (stable).
  617. * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.23.0-0.beta1
  618. - initial build for Vine Linux.
  619. - Update to 1.23.0-beta.
  620. - built a bootstrap rpm.
  621. * Thu Nov 23 2017 Josh Stone <jistone@redhat.com> - 1.22.1-1
  622. - Update to 1.22.1.
  623. * Thu Oct 12 2017 Josh Stone <jistone@redhat.com> - 1.21.0-1
  624. - Update to 1.21.0.
  625. * Mon Sep 11 2017 Josh Stone <jistone@redhat.com> - 1.20.0-2
  626. - ABI fixes for ppc64 and s390x.
  627. * Thu Aug 31 2017 Josh Stone <jistone@redhat.com> - 1.20.0-1
  628. - Update to 1.20.0.
  629. - Add a rust-src subpackage.
  630. * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.19.0-4
  631. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  632. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.19.0-3
  633. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  634. * Mon Jul 24 2017 Josh Stone <jistone@redhat.com> - 1.19.0-2
  635. - Use find-debuginfo.sh --keep-section .rustc
  636. * Thu Jul 20 2017 Josh Stone <jistone@redhat.com> - 1.19.0-1
  637. - Update to 1.19.0.
  638. * Thu Jun 08 2017 Josh Stone <jistone@redhat.com> - 1.18.0-1
  639. - Update to 1.18.0.
  640. * Mon May 08 2017 Josh Stone <jistone@redhat.com> - 1.17.0-2
  641. - Move shared libraries back to libdir and symlink in rustlib
  642. * Thu Apr 27 2017 Josh Stone <jistone@redhat.com> - 1.17.0-1
  643. - Update to 1.17.0.
  644. * Mon Mar 20 2017 Josh Stone <jistone@redhat.com> - 1.16.0-3
  645. - Make rust-lldb arch-specific to deal with lldb deps
  646. * Fri Mar 17 2017 Josh Stone <jistone@redhat.com> - 1.16.0-2
  647. - Limit rust-lldb arches
  648. * Thu Mar 16 2017 Josh Stone <jistone@redhat.com> - 1.16.0-1
  649. - Update to 1.16.0.
  650. - Use rustbuild instead of the old makefiles.
  651. - Update bootstrapping to include rust-std and cargo.
  652. - Add a rust-lldb subpackage.
  653. * Thu Feb 09 2017 Josh Stone <jistone@redhat.com> - 1.15.1-1
  654. - Update to 1.15.1.
  655. - Require rust-rpm-macros for new crate packaging.
  656. - Keep shared libraries under rustlib/, only debug-stripped.
  657. - Merge and clean up conditionals for epel7.
  658. * Fri Dec 23 2016 Josh Stone <jistone@redhat.com> - 1.14.0-2
  659. - Rebuild without bootstrap binaries.
  660. * Thu Dec 22 2016 Josh Stone <jistone@redhat.com> - 1.14.0-1
  661. - Update to 1.14.0.
  662. - Rewrite bootstrap logic to target specific arches.
  663. - Bootstrap ppc64, ppc64le, s390x. (thanks to Sinny Kumari for testing!)
  664. * Thu Nov 10 2016 Josh Stone <jistone@redhat.com> - 1.13.0-1
  665. - Update to 1.13.0.
  666. - Use hardening flags for linking.
  667. - Split the standard library into its own package
  668. - Centralize rustlib/ under /usr/lib/ for multilib integration.
  669. * Thu Oct 20 2016 Josh Stone <jistone@redhat.com> - 1.12.1-1
  670. - Update to 1.12.1.
  671. * Fri Oct 14 2016 Josh Stone <jistone@redhat.com> - 1.12.0-7
  672. - Rebuild with LLVM 3.9.
  673. - Add ncurses-devel for llvm-config's -ltinfo.
  674. * Thu Oct 13 2016 Josh Stone <jistone@redhat.com> - 1.12.0-6
  675. - Rebuild with llvm-static, preparing for 3.9
  676. * Fri Oct 07 2016 Josh Stone <jistone@redhat.com> - 1.12.0-5
  677. - Rebuild with fixed eu-strip (rhbz1380961)
  678. * Fri Oct 07 2016 Josh Stone <jistone@redhat.com> - 1.12.0-4
  679. - Rebuild without bootstrap binaries.
  680. * Thu Oct 06 2016 Josh Stone <jistone@redhat.com> - 1.12.0-3
  681. - Bootstrap aarch64.
  682. - Use jemalloc's MALLOC_CONF to work around #36944.
  683. - Apply pr36933 to really disable armv7hl NEON.
  684. * Sat Oct 01 2016 Josh Stone <jistone@redhat.com> - 1.12.0-2
  685. - Protect .rustc from rpm stripping.
  686. * Fri Sep 30 2016 Josh Stone <jistone@redhat.com> - 1.12.0-1
  687. - Update to 1.12.0.
  688. - Always use --local-rust-root, even for bootstrap binaries.
  689. - Remove the rebuild conditional - the build system now figures it out.
  690. - Let minidebuginfo do its thing, since metadata is no longer a note.
  691. - Let rust build its own compiler-rt builtins again.
  692. * Sat Sep 03 2016 Josh Stone <jistone@redhat.com> - 1.11.0-3
  693. - Rebuild without bootstrap binaries.
  694. * Fri Sep 02 2016 Josh Stone <jistone@redhat.com> - 1.11.0-2
  695. - Bootstrap armv7hl, with backported no-neon patch.
  696. * Wed Aug 24 2016 Josh Stone <jistone@redhat.com> - 1.11.0-1
  697. - Update to 1.11.0.
  698. - Drop the backported patches.
  699. - Patch get-stage0.py to trust existing bootstrap binaries.
  700. - Use libclang_rt.builtins from compiler-rt, dodging llvm-static issues.
  701. - Use --local-rust-root to make sure the right bootstrap is used.
  702. * Sat Aug 13 2016 Josh Stone <jistone@redhat.com> 1.10.0-4
  703. - Rebuild without bootstrap binaries.
  704. * Fri Aug 12 2016 Josh Stone <jistone@redhat.com> - 1.10.0-3
  705. - Initial import into Fedora (#1356907), bootstrapped
  706. - Format license text as suggested in review.
  707. - Note how the tests already run in parallel.
  708. - Undefine _include_minidebuginfo, because it duplicates ".note.rustc".
  709. - Don't let checks fail the whole build.
  710. - Note that -doc can't be noarch, as rpmdiff doesn't allow variations.
  711. * Tue Jul 26 2016 Josh Stone <jistone@redhat.com> - 1.10.0-2
  712. - Update -doc directory ownership, and mark its licenses.
  713. - Package and declare licenses for libbacktrace and hoedown.
  714. - Set bootstrap_base as a global.
  715. - Explicitly require python2.
  716. * Thu Jul 14 2016 Josh Stone <jistone@fedoraproject.org> - 1.10.0-1
  717. - Initial package, bootstrapped