nsd-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440
  1. %bcond_with systemd
  2. Summary: Fast and lean authoritative DNS Name Server
  3. Summary(ja): 高速で最小限のAuthoritative専用DNSネームサーバ
  4. Name: nsd
  5. Version: 4.3.5
  6. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  7. Group: servers
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: BSD
  11. Url: http://www.nlnetlabs.nl/%{name}/
  12. Source: https://www.nlnetlabs.nl/downloads/%{name}/%{name}-%{version}.tar.gz
  13. Source1: nsd.init
  14. Source3: nsd.sysconfig
  15. Source10: nsd.service
  16. Source11: nsd-keygen.service
  17. Source12: tmpfiles-nsd.conf
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  19. BuildRequires: flex, libevent-devel, openssl-devel
  20. Requires(pre): shadow-utils
  21. %if %{with systemd}
  22. %global piddir /run/%{name}
  23. BuildRequires: systemd-devel
  24. %{?systemd_requires}
  25. %else
  26. %global piddir %{_localstatedir}/run/%{name}
  27. Requires(post): /sbin/chkconfig
  28. Requires(preun): /sbin/chkconfig
  29. Requires(preun): /sbin/service
  30. Requires(postun): /sbin/service
  31. %endif
  32. %description
  33. NSD is a complete implementation of an authoritative DNS name server.
  34. For further information about what NSD is and what NSD is not please
  35. consult the REQUIREMENTS document which is a part of this distribution
  36. %description -l ja
  37. NSD は Authoritative DNSネームサーバの完全な実装です。
  38. NSD に関する詳しい情報は REQUIREMENTS ドキュメントを参照してください。
  39. %debug_package
  40. %prep
  41. %setup -q
  42. autoreconf
  43. %build
  44. %configure \
  45. --with-configdir=%{_sysconfdir}/nsd \
  46. --with-nsd_conf_file=%{_sysconfdir}/nsd/nsd.conf \
  47. --with-zonesdir=%{_sysconfdir}/nsd \
  48. --with-pidfile=%{piddir}/%{name}/%{name}.pid \
  49. --with-zonelistfile=%{_sharedstatedir}/nsd/zone.list \
  50. --with-ssl \
  51. --with-user=nsd \
  52. --with-xfrdfile=%{_localstatedir}/lib/%{name}/ixfr.state \
  53. --with-max-ips=1024 \
  54. --with-dbfile="" \
  55. --enable-bind8-stats \
  56. --enable-zone-stats \
  57. --enable-checking \
  58. --enable-mmap \
  59. --enable-nsec3 \
  60. --enable-ratelimit \
  61. --enable-pie \
  62. --enable-relro-now \
  63. --enable-recvmmsg \
  64. --enable-packed \
  65. --enable-memclean \
  66. %if %{with systemd}
  67. --enable-systemd \
  68. %endif
  69. %{nil}
  70. %{__make} %{?_smp_mflags}
  71. #convert to utf8
  72. iconv -f iso8859-1 -t utf-8 doc/RELNOTES > doc/RELNOTES.utf8
  73. iconv -f iso8859-1 -t utf-8 doc/CREDITS > doc/CREDITS.utf8
  74. mv -f doc/RELNOTES.utf8 doc/RELNOTES
  75. mv -f doc/CREDITS.utf8 doc/CREDITS
  76. %install
  77. rm -rf %{buildroot}
  78. %{__make} DESTDIR=%{buildroot} install
  79. install -d -m 0700 %{buildroot}%{_localstatedir}/run/%{name}
  80. install -d -m 0700 %{buildroot}%{_localstatedir}/lib/%{name}
  81. %if %{with systemd}
  82. mkdir -p %{buildroot}%{_unitdir}
  83. install -m 0644 %{SOURCE10} %{SOURCE11} %{buildroot}%{_unitdir}
  84. mkdir -p %{buildroot}%{_tmpfilesdir}
  85. install -m 0644 %{SOURCE12} %{buildroot}%{_tmpfilesdir}/nsd.conf
  86. %else
  87. install -d -m 0755 %{buildroot}%{_initrddir}
  88. install -m 0755 %{SOURCE1} %{buildroot}/%{_initrddir}/nsd
  89. install -d -m 0755 %{buildroot}%{_sysconfdir}/sysconfig
  90. install -m 0755 %{SOURCE3} %{buildroot}/%{_sysconfdir}/sysconfig/%{name}
  91. %endif
  92. # change .sample to normal config files
  93. mv %{buildroot}%{_sysconfdir}/nsd/nsd.conf.sample %{buildroot}%{_sysconfdir}/nsd/nsd.conf
  94. sed -i \
  95. -e 's/# database:.*$/database: ""/' \
  96. -e 's/# round-robin:.*$/round-robin: yes/' \
  97. -e 's/# minimal-responses:.*$/minimal-responses: yes/' \
  98. -e 's/# refuse-any:.*$/refuse-any: yes/' \
  99. -e 's/# control-enable:.*$/control-enable: yes/' \
  100. -e 's|# control-interface: ::1|control-interface: %{piddir}/nsd.ctl|' \
  101. %{buildroot}%{_sysconfdir}/nsd/nsd.conf
  102. %clean
  103. rm -rf ${RPM_BUILD_ROOT}
  104. %files
  105. %defattr(-,root,root,-)
  106. %doc doc/*
  107. %doc contrib/nsd.zones2nsd.conf
  108. %dir %{_sysconfdir}/nsd/
  109. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/nsd/nsd.conf
  110. #%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/nsd/nsd.zones
  111. %if %{with systemd}
  112. %attr(0644,root,root) %{_unitdir}/nsd.service
  113. %attr(0644,root,root) %{_unitdir}/nsd-keygen.service
  114. %attr(0644,root,root) %{_tmpfilesdir}/nsd.conf
  115. %else
  116. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/nsd
  117. %attr(0755,root,root) %{_initrddir}/%{name}
  118. %endif
  119. %ghost %attr(0755,%{name},%{name}) %dir %{_localstatedir}/run/%{name}
  120. %attr(0755,%{name},%{name}) %dir %{_localstatedir}/lib/%{name}
  121. %{_sbindir}/*
  122. %{_mandir}/*/*
  123. %pre
  124. getent group nsd >/dev/null || groupadd -r nsd
  125. getent passwd nsd >/dev/null || \
  126. useradd -r -g nsd -d /etc/nsd -s /sbin/nologin \
  127. -c "nsd daemon account" nsd
  128. exit 0
  129. %post
  130. chown -R nsd.nsd %{_localstatedir}/lib/nsd 2>/dev/null ||:
  131. chown -R nsd.nsd %{_localstatedir}/run/nsd 2>/dev/null ||:
  132. %if %{with systemd}
  133. %systemd_post nsd.service
  134. %systemd_post nsd-keygen.service
  135. %else
  136. /sbin/chkconfig --add %{name}
  137. if [ ! -f %{_sysconfdir}/nsd/nsd_control.pem ]; then
  138. /usr/sbin/nsd-control-setup
  139. fi
  140. %endif
  141. %preun
  142. %if %{with systemd}
  143. %systemd_preun nsd.service
  144. %systemd_preun nsd-keygen.service
  145. %else
  146. if [ $1 -eq 0 -o -x /bin/systemctl ]; then
  147. /sbin/service %{name} stop
  148. /sbin/chkconfig --del %{name}
  149. fi
  150. %endif
  151. %postun
  152. %if %{with systemd}
  153. %systemd_postun_with_restart nsd.service
  154. %systemd_postun nsd-keygen.service
  155. %else
  156. if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
  157. /sbin/service %{name} condrestart
  158. fi
  159. %endif
  160. %changelog
  161. * Tue Jan 26 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.5-1
  162. - new upstream release.
  163. * Wed Dec 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.4-1
  164. - new upstream release.
  165. * Thu Oct 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.3-1
  166. - new upstream release.
  167. * Wed Jul 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.2-1
  168. - new upstream release.
  169. * Tue May 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.1-1
  170. - new upstream release.
  171. * Tue Apr 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.0-3
  172. - rebuilt with libevent-2.1.11.
  173. * Tue Apr 07 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.0-2
  174. - fixed nsd-keygen.service.
  175. - updated nsd.conf.
  176. * Mon Apr 06 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.0-1
  177. - new upstream release.
  178. - dropped Patch0.
  179. - added systemd support (disabled as default).
  180. * Mon Dec 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.2.4-1
  181. - new upstream release.
  182. * Sat Aug 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.2.2-1
  183. - new upstream release.
  184. * Sun Nov 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.25-1
  185. - new upstream release.
  186. - rebuilt with openssl-1.1.1 and libevent-2.1.8.
  187. * Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.19-1
  188. - new upstream release.
  189. * Wed Mar 8 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.15-1
  190. - new upstream release.
  191. * Thu Jun 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.10-1
  192. - new upstream release.
  193. * Wed Mar 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.9-1
  194. - new upstream release.
  195. * Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.8-2
  196. - rebuilt with openssl-1.0.2g.
  197. * Sat Mar 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.8-1
  198. - new upstream release.
  199. * Thu Dec 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.7-1
  200. - new upstream release.
  201. * Tue Nov 3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.6-1
  202. - new upstream release.
  203. * Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.3-1
  204. - new upstream release.
  205. - dropped Source2 (no longer needed).
  206. * Sat Feb 23 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.15-1
  207. - new upstream release
  208. * Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.12-1
  209. - new upstream release
  210. * Wed Feb 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.10-1
  211. - new upstream release
  212. * Fri Mar 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.8-1
  213. - new upstream release
  214. * Sat May 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.4-1
  215. - initial build for Vine Linux
  216. * Wed Jan 06 2010 Paul Wouters <paul@xelerance.com> - 3.2.4-1
  217. - Updated to nsd 3.2.4
  218. * Tue Jan 05 2010 Paul Wouters <paul@xelerance.com> - 3.2.3-4
  219. - Incorporated Ville Mattila's fixes to nsd.cron
  220. - Support for NSD_AUTOREBUILD in /etc/sysconfig/nsd [Ville]
  221. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 3.2.3-3
  222. - rebuilt with new openssl
  223. * Thu Aug 20 2009 Ville Mattila <vmattila@csc.fi> - 3.2.3-2
  224. - The 'nsdc patch' and 'nsdc rebuild' commands wrote a %%1 file by mistake
  225. * Mon Aug 17 2009 Paul Wouters <paul@xelerance.com> - 3.2.3-1
  226. -Updated to version 3.2.3
  227. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.2-4
  228. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  229. * Sat Jun 06 2009 Paul Wouters <paul@xelerance.com> - 3.2.2-3
  230. - Fixed /dev/nul which cause a file \%%1 to be written by cron
  231. - Bump for EVR.
  232. * Mon May 18 2009 Paul Wouters <paul@xelerance.com> - 3.2.2-1
  233. - Upgraded to 3.2.2 security release
  234. http://www.nlnetlabs.nl/publications/NSD_vulnerability_announcement.html
  235. * Thu Apr 09 2009 Ville Mattila <vmattila@csc.fi> - 3.2.1-6
  236. - Make various file paths used by the nsd.init script configurable
  237. from /etc/sysconfig/nsd.
  238. - Add template /etc/sysconfig/nsd.
  239. * Sun Mar 08 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-5
  240. - nsd used the 'named' subsystem in one call in the init script
  241. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-4
  242. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  243. * Mon Jan 26 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-3
  244. - Fix init script 'unary operator' error.
  245. * Mon Jan 26 2009 Paul Wouters <paul@xelerance.com> - 3.2.1-1
  246. - Updated to new version 3.2.1
  247. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 3.2.0-4
  248. - rebuild with new openssl
  249. * Mon Nov 24 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-3
  250. - Updates summary as per Richard Hughes guidelines
  251. * Mon Nov 10 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-2
  252. - Bump version after pre-release version correction.
  253. * Mon Nov 10 2008 Paul Wouters <paul@xelerance.com> - 3.2.0-1
  254. - 3.2.0-1
  255. * Thu Oct 9 2008 Paul Wouters <paul@xelerance.com> - 3.1.1-1
  256. - updated to 3.1.1
  257. * Mon Aug 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 3.1.0-2
  258. - fix license tag
  259. - fix static user creation
  260. * Mon Jun 30 2008 Paul Wouters <paul@xelerance.com> - 3.1.0-1
  261. - Updated to 3.1.0
  262. * Tue May 6 2008 Paul Wouters <paul@xelerance.com> - 3.0.8-2
  263. - Fix /dev/null redirection [Venkatesh Krishnamurthi]
  264. * Tue May 6 2008 Paul Wouters <paul@xelerance.com> - 3.0.8-1
  265. - Updated to 3.0.8
  266. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.0.7-3
  267. - Autorebuild for GCC 4.3
  268. * Wed Dec 5 2007 Paul Wouters <paul@xelerance.com> - 3.0.7-2
  269. - Rebuild for new libcrypto
  270. * Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 3.0.7-1
  271. - Updated to new version
  272. - fix RELNOTES/README to be utf8
  273. - Fix path to nsd.db in cron job.
  274. * Thu Nov 8 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-7
  275. - Modified cron to only rebuild/reload when zone updates
  276. have been received
  277. * Wed Nov 7 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-6
  278. - Added hourly cron job to do various maintenance tasks
  279. - Added nsd rebuild to create the proper nsd.db file on startup
  280. - Added nsd patch on shutdown to ensure zonefiles are up to date
  281. * Tue Oct 2 2007 Paul Wouters <paul@xelerance.com> - 3.0.6-5
  282. - nsdc update and nsdc notify are no longer needed in initscript.
  283. * Mon Sep 24 2007 Jesse Keating <jkeating@redhat.com> - 3.0.6-4
  284. - Bump release for upgrade path.
  285. * Fri Sep 14 2007 Paul Wouters <paul@xelerance.com> 3.0.6-3
  286. - Do not include examples from nsd.conf.sample that causes
  287. bogus network traffic.
  288. * Fri Sep 14 2007 Paul Wouters <paul@xelerance.com> 3.0.6-2
  289. - Change locations of ixfr.db and xfrd.state to /var/lib/nsd
  290. - Enable NSEC3
  291. - Delay running nsdc update until after nsd has started
  292. - Delete xfrd.state on nsd stop
  293. - Run nsdc notify in the background, since it can take
  294. a very long time when remote servers are unavailable.
  295. * Tue Sep 11 2007 Paul Wouters <paul@xelerance.com> 3.0.6-1
  296. - Upgraded to 3.0.6
  297. - Do not include bind2nsd, since it didn't compile for me
  298. * Fri Jul 13 2007 Paul Wouters <paul@xelerance.com> 3.0.5-2
  299. - Fix init script, bug #245546
  300. * Fri Mar 23 2007 Paul Wouters <paul@xelerance.com> 3.0.5-1
  301. - Upgraded to 3.0.5
  302. * Thu Dec 7 2006 Paul Wouters <paul@xelerance.com> 3.0.3-1
  303. - Upgraded to 3.0.3
  304. * Mon Nov 27 2006 Paul Wouters <paul@xelerance.com> 3.0.2-1
  305. - Upgraded to 3.0.2.
  306. - Use new configuration file nsd.conf. Still needs migration script.
  307. patch from Farkas Levente <lfarkas@bppiac.hu>
  308. * Mon Oct 16 2006 Paul Wouters <paul@xelerance.com> 2.3.6-2
  309. - Bump version for upgrade path
  310. * Thu Oct 12 2006 Paul Wouters <paul@xelerance.com> 2.3.6-1
  311. - Upgraded to 2.3.6
  312. - Removed obsolete workaround in nsd.init
  313. - Fixed spec file so daemon gets properly restarted on upgrade
  314. * Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 2.3.5-4
  315. - Rebuild requested for PT_GNU_HASH support from gcc
  316. - Removed dbaccess.c from doc section
  317. * Mon Jun 26 2006 Paul Wouters <paul@xelerance.com> - 2.3.5-3
  318. - Bump version for FC-x upgrade path
  319. * Mon Jun 26 2006 Paul Wouters <paul@xelerance.com> - 2.3.5-1
  320. - Upgraded to nsd-2.3.5
  321. * Sun May 7 2006 Paul Wouters <paul@xelerance.com> - 2.3.4-3
  322. - Upgraded to nsd-2.3.4.
  323. - Removed manual install targets because DESTDIR is now supported
  324. - Re-enabled --checking, checking patch no longer needed and removed.
  325. - Work around in nsd.init for nsd failing to start when there is no ipv6
  326. * Thu Dec 15 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-7
  327. - chkconfig and attribute changes as proposed by Dmitry Butskoy
  328. * Thu Dec 15 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-6
  329. - Moved pid file to /var/run/nsd/nsd.pid.
  330. - Use _localstatedir instead of "/var"
  331. * Tue Dec 13 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-5
  332. - Added BuildRequires for openssl-devel, removed Requires for openssl.
  333. * Mon Dec 12 2005 Paul Wouters <paul@xelerance.com> - 2.3.3-4
  334. - upgraded to nsd-2.3.3
  335. * Wed Dec 7 2005 Tom "spot" Callaway <tcallawa@redhat.com> - 2.3.2-2
  336. - minor cleanups
  337. * Mon Dec 5 2005 Paul Wouters <paul@xelerance.com> - 2.3.2-1
  338. - Upgraded to 2.3.2. Changed post scripts to comply to Fedora
  339. Extras policies (eg do not start daemon on fresh install)
  340. * Tue Oct 4 2005 Paul Wouters <paul@xelerance.com> - 2.3.1-1
  341. - Initial version