djvulibre-vl.spec 8.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235
  1. Summary: DjVu viewers, encoders and utilities.
  2. Summary(ja): DjVu 画像形式ファイル操作用ライブラリ、ツール
  3. Name: djvulibre
  4. Version: 3.5.27
  5. Release: 1%{?_dist_release}
  6. Distribution: Project Vine
  7. Vendor: Vine Linux
  8. Packager: owa
  9. License: GPLv2
  10. URL: http://djvu.sourceforge.net
  11. Source0: http://prdownloads.sourceforge.net/djvu/djvulibre-%{version}.tar.gz
  12. Patch0: djvulibre-3.5.22-cdefs.patch
  13. Patch2: djvulibre-3.5.27-buffer-overflow.patch
  14. Patch3: djvulibre-3.5.27-infinite-loop.patch
  15. Patch4: djvulibre-3.5.27-stack-overflow.patch
  16. Patch5: djvulibre-3.5.27-zero-bytes-check.patch
  17. Patch6: djvulibre-3.5.27-export-file.patch
  18. Patch7: djvulibre-3.5.27-null-dereference.patch
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. BuildRequires: libtiff-devel
  21. BuildRequires: libjpeg-devel
  22. BuildRequires: glibc-devel
  23. BuildRequires: inkscape
  24. BuildRequires: xdg-utils chrpath
  25. BuildRequires: hicolor-icon-theme
  26. %description
  27. DjVu is a web-centric format and software platform for distributing documents
  28. and images. DjVu content downloads faster, displays and renders faster, looks
  29. nicer on a screen, and consume less client resources than competing formats.
  30. DjVu was originally developed at AT&T Labs-Research by Leon Bottou, Yann
  31. LeCun, Patrick Haffner, and many others. In March 2000, AT&T sold DjVu to
  32. LizardTech Inc. who now distributes Windows/Mac plug-ins, and commercial
  33. encoders (mostly on Windows)
  34. In an effort to promote DjVu as a Web standard, the LizardTech management was
  35. enlightened enough to release the reference implementation of DjVu under the
  36. GNU GPL in October 2000. DjVuLibre (which means free DjVu), is an enhanced
  37. version of that code maintained by the original inventors of DjVu. It is
  38. compatible with version 3.5 of the LizardTech DjVu software suite.
  39. DjVulibre-3.5 contains:
  40. - a standalone DjVu viewer based on the Qt library.
  41. - A browser plugin that works with most Unix browsers.
  42. - A full-fledged wavelet-based compressor for pictures.
  43. - A simple compressor for bitonal (black and white) scanned pages.
  44. - A compressor for palettized images (a la GIF/PNG).
  45. - A set of utilities to manipulate and assemble DjVu images and documents.
  46. - A set of decoders to convert DjVu to a number of other formats.
  47. - An up-to-date version of the C++ DjVu Reference Library.
  48. %package devel
  49. Summary: The libraries and header files needed for djvulibre development.
  50. Group: Development/Libraries
  51. Requires: %{name} = %{version}-%{release}
  52. %description devel
  53. DjVulibre libraries and header files for development.
  54. %prep
  55. %setup -q -n %{name}-%{version}
  56. %autopatch -p1
  57. %build
  58. %configure --enable-threads
  59. make %{?_smp_mflags} V=1
  60. %install
  61. rm -rf %{buildroot}
  62. make DESTDIR=%{buildroot} install
  63. # fix to stop ldconfig from complaining
  64. find %{buildroot}%{_libdir} -name "*.so*" -exec chmod 755 {} \;
  65. # Remove rpath
  66. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvutoxml
  67. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvused
  68. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/cjb2
  69. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/csepdjvu
  70. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvuserve
  71. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvm
  72. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvuxmlparser
  73. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvutxt
  74. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/ddjvu
  75. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvumake
  76. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/cpaldjvu
  77. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvuextract
  78. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/c44
  79. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvups
  80. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvudump
  81. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/djvmcvt
  82. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/bzz
  83. # This XML file does not differentiate between DjVu Image and DjVu Document
  84. # MIME types, the default one in shared-mime-info does.
  85. rm -f $RPM_BUILD_ROOT%{_datadir}/mime/packages/djvulibre-mime.xml
  86. # MIME types (icons and desktop file) - this installs icon files under
  87. # /usr/share/icons/hicolor/ and an xml file under /usr/share/mime/image/
  88. # Taken from {_datadir}/djvu/osi/desktop/register-djvu-mime install
  89. # See also the README file in the desktopfiles directory of the source distribution
  90. pushd desktopfiles
  91. for i in 22 32 48 64 ; do
  92. install -d $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/${i}x${i}/mimetypes/
  93. cp -a ./prebuilt-hi${i}-djvu.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/${i}x${i}/mimetypes/image-vnd.djvu.mime.png
  94. # cp -a ./hi${i}-djvu.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/${i}x${i}/mimetypes/gnome-mime-image-vnd.djvu.png
  95. done
  96. popd
  97. %preun -p /sbin/ldconfig
  98. %postun -p /sbin/ldconfig
  99. %clean
  100. rm -rf %{buildroot}
  101. %files
  102. %defattr(-, root, root)
  103. %license COPYRIGHT COPYING
  104. %doc README NEWS doc
  105. %{_bindir}
  106. %{_libdir}/lib*.so.*
  107. %exclude %{_libdir}/libdjvulibre.la
  108. %exclude %{_datadir}/djvu/osi/de/*
  109. %exclude %{_datadir}/djvu/osi/fr/*
  110. %exclude %{_datadir}/djvu/osi/zh/*
  111. %dir %{_datadir}/djvu
  112. %{_datadir}/djvu/pubtext
  113. %dir %{_datadir}/djvu/osi
  114. %{_datadir}/djvu/osi/languages.xml
  115. %{_datadir}/djvu/osi/en
  116. %{_datadir}/djvu/osi/cs
  117. %lang(ja) %{_datadir}/djvu/osi/ja*
  118. %{_datadir}/icons/hicolor/*/mimetypes/*
  119. %{_mandir}/man?
  120. %files devel
  121. %defattr(-, root, root)
  122. %{_includedir}/libdjvu
  123. %{_libdir}/lib*.so
  124. %{_libdir}/pkgconfig/ddjvuapi.pc
  125. %changelog
  126. * Tue Aug 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.27-1
  127. - new upstream release.
  128. * Fri Jul 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.25.3-3
  129. - rebuilt with new toolchain.
  130. * Thu Feb 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.25.3-2
  131. - rebuilt on current VineSeed
  132. - moved %{_libdir}/lib*.so to devel subpackage
  133. * Sun Jul 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.25.3-1
  134. - update to 3.5.25.3
  135. - remove BuildRequires: qt-devel
  136. - add BuildRequires: inkscape
  137. * Sun May 01 2011 Shu KONNO <owa@bg.wakwak.com> 3.5.24-1
  138. - updated djvulibre to 3.5.24
  139. - obsoletes djvulibre-plugin (new is djview-plugin)
  140. * Sat Apr 30 2011 Shu KONNO <owa@bg.wakwak.com> 3.5.22-4
  141. - installed djview3.png
  142. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 3.5.22-3
  143. - rebuilt with rpm-4.8.1 for pkg-config
  144. * Wed Jul 01 2009 Shu KONNO <owa@bg.wakwak.com> 3.5.22-2
  145. - rebuilt with new toolchain
  146. * Wed Jul 01 2009 Shu KONNO <owa@bg.wakwak.com> 3.5.22-1
  147. - updated djvulibre to 3.5.22
  148. * Tue Dec 30 2008 Shu KONNO <owa@bg.wakwak.com> 3.5.21-1
  149. - initial build for VineSeed
  150. - spec in utf-8, and applied vine versioning policy
  151. - updated djvulibre to 3.5.21
  152. - added CXXFLAG="-march=i686" if i386
  153. - added djview desktop file
  154. * Tue Apr 03 2007 Shu KONNO <owa@bg.wakwak.com> 3.5.19-uvl1
  155. - updated djvulibre to 3.5.19
  156. - added scripts to alternative djview at %%post, %%preun
  157. * Thu Dec 01 2005 Shu KONNO <owa@bg.wakwak.com> 3.5.16-uvl1
  158. - updated djvulibre to 3.5.16
  159. - changed suffix
  160. - divided into djvulibre, djvulibre-devel, djvulibre-plugin
  161. * Tue Nov 09 2004 Shu KONNO <owa@bg.wakwak.com> 3.5.14-uvl2
  162. - updated djvulibre to 3.5.14 (realese 2)
  163. * Thu Jun 17 2004 Leon Bottou <leon@bottou.org> 3.5.13-4
  164. - changed runtime generation of file list.
  165. * Mon May 31 2004 Leon Bottou <leon@bottou.org> 3.5.13-3
  166. - removed 'make install-desktop-files'
  167. * Wed May 5 2004 Leon Bottou <leon@bottou.org> 3.5.13-2
  168. * Fri Apr 9 2004 Leon Bottou <leon@bottou.org> 3.5.13-1
  169. - added runtime generation of file list.
  170. - using DESTDIR instead of %makeinstall.
  171. - added 'make install-desktop-files'
  172. * Wed Nov 5 2003 Leon Bottou <leon@bottou.org> 3.5.12-3
  173. - added support for i18n
  174. - renamed symlink in mozilla plugin dirs.
  175. * Mon Jul 7 2003 Leon Bottou <leon@bottou.org> 3.5.12-1
  176. * Thu Apr 24 2003 Leon Bottou <leon@bottou.org> 3.5.11-1
  177. * Thu Feb 6 2003 Leon Bottou <leon@bottou.org> 3.5.10-2
  178. * Fri Jan 24 2003 Leon Bottou <leon@bottou.org> 3.5.10-1
  179. * Wed Oct 9 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.9-2
  180. - fixed logic for uninstalling nsdejavu links.
  181. - learned a few tricks from the freshrpms spec file.
  182. * Sun Oct 6 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.9-1
  183. - added logic to install nsdejavu for mozilla.
  184. * Wed May 29 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.6-1
  185. * Mon Apr 1 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.5-2
  186. - changed group to Applications/Publishing.
  187. * Mon Mar 25 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.5-2
  188. * Tue Jan 22 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.4-2
  189. - added macros to locate man directory.
  190. * Wed Jan 16 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.3-1
  191. * Fri Dec 7 2001 Leon Bottou <leonb@users.sourceforge.net> 3.5.2-1
  192. * Wed Dec 5 2001 Leon Bottou <leonb@users.sourceforge.net> 3.5.1-1
  193. - created initial file.