openbabel-vl.spec 7.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260
  1. %define perl_vendorarch %(eval "`perl -V:installvendorarch`"; echo $installvendorarch)
  2. %define perl_archlib %(eval "`perl -V:archlib`"; echo $archlib)
  3. Name: openbabel
  4. Version: 2.3.2
  5. Release: 1%{?_dist_release}
  6. Summary: Chemistry software file format converter
  7. Summary(ja): 化学ソフトデータファイル変換プログラム
  8. License: GPL
  9. Group: Applications/Edutainment
  10. URL: http://openbabel.sourceforge.net/
  11. Source: http://dl.sourceforge.net/sourceforge/openbabel/%{name}-%{version}.tar.gz
  12. # fron fedora
  13. Patch0: openbabel-2.3.1-gcc47-darwin.patch
  14. Patch1: openbabel-rpm.patch
  15. Patch2: openbabel-2.3.2-cmake.patch
  16. Patch3: openbabel-2.3.1-ruby19-vendorarch.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. BuildRequires: inchi-devel
  19. BuildRequires: libtool
  20. BuildRequires: libxml2-devel
  21. BuildRequires: perl
  22. BuildRequires: python
  23. BuildRequires: python-devel
  24. BuildRequires: ruby
  25. BuildRequires: ruby-devel
  26. BuildRequires: swig
  27. #TODO: enable when GUI is functional
  28. #BuildRequires: wxGTK-devel
  29. BuildRequires: zlib-devel
  30. BuildRequires: cmake
  31. Distribution: Vine Linux
  32. Vendor: Project Vine
  33. Packager: inagaki
  34. %description
  35. Open Babel is a free, open-source version of the Babel chemistry file
  36. translation program. Open Babel is a project designed to pick up where
  37. Babel left off, as a cross-platform program and library designed to
  38. interconvert between many file formats used in molecular modeling,
  39. computational chemistry, and many related areas.
  40. Open Babel includes two components, a command-line utility and a C++
  41. library. The command-line utility is intended to be used as a replacement
  42. for the original babel program, to translate between various chemical file
  43. formats. The C++ library includes all of the file-translation code as well
  44. as a wide variety of utilities to foster development of other open source
  45. scientific software.
  46. %package devel
  47. Summary: Development tools for programs which will use the Open Babel library
  48. Summary(ja): %{name}の開発用ヘッダファイル
  49. Group: Development/Libraries
  50. Requires: %{name} = %{version}-%{release}
  51. Requires: pkgconfig
  52. %description devel
  53. The %{name}-devel package includes the header files and libraries
  54. necessary for developing programs using the Open Babel library.
  55. If you are going to develop programs which will use this library
  56. you should install %{name}-devel. You'll also need to have the
  57. %{name} package installed.
  58. %description devel -l ja
  59. %{name}の開発用ヘッダファイル
  60. %package -n perl-%{name}
  61. Summary: Perl wrapper for the Open Babel library
  62. Summary(ja): Open Babel ライブラリの Perl ラッパー
  63. Group: Development/Libraries
  64. Requires: perl > %(eval "`%{__perl} -V:version`"; echo $version)
  65. Obsoletes: %{name}-perl < 2.2.0
  66. Provides: %{name}-perl = %{version}-%{release}
  67. %description -n perl-%{name}
  68. Perl wrapper for the Open Babel library.
  69. %description -n perl-%{name} -l ja
  70. Open Babel ライブラリの Perl ラッパーです.
  71. %package -n python-%{name}
  72. Group: Development/Libraries
  73. Summary: Python wrapper for the Open Babel library
  74. Summary(ja): Open Babel ライブラリの Python ラッパー
  75. Obsoletes: %{name}-python < 2.2.0
  76. Provides: %{name}-python = %{version}-%{release}
  77. %description -n python-%{name}
  78. Python wrapper for the Open Babel library.
  79. %description -n python-%{name} -l ja
  80. Open Babel ライブラリの Python ラッパー
  81. %package -n ruby-%{name}
  82. Summary: Ruby wrapper for the Open Babel library
  83. Summary(ja): Open Babel ライブラリの Ruby ラッパー
  84. Group: Development/Libraries
  85. Requires: ruby >= 1.8
  86. Requires: %{name} = %{version}-%{release}
  87. %description -n ruby-%{name}
  88. Open Babel ライブラリの Ruby ラッパー
  89. %prep
  90. %setup -q
  91. %patch0 -p1 -b .gcc47
  92. %patch1 -p1 -b .rpm
  93. %patch2 -p1 -b .cmake
  94. %patch3 -p1 -b .ruby_vendor
  95. chmod 644 src/formats/{mmcif,fchk}format.cpp
  96. %build
  97. %cmake \
  98. -DOPENBABEL_USE_SYSTEM_INCHI=true \
  99. -DPYTHON_BINDINGS:BOOL=ON \
  100. -DRUBY_BINDINGS:BOOL=ON \
  101. -DPERL_BINDINGS:BOOL=ON \
  102. .
  103. make %{?_smp_mflags}
  104. %install
  105. rm -rf $RPM_BUILD_ROOT
  106. make install DESTDIR=$RPM_BUILD_ROOT
  107. rm -f $RPM_BUILD_ROOT%{_libdir}{,/%{name}}/*.la
  108. mkdir -p $RPM_BUILD_ROOT%{python_sitearch}
  109. mv $RPM_BUILD_ROOT%{_libdir}/_openbabel.so \
  110. $RPM_BUILD_ROOT%{_libdir}/openbabel.py \
  111. $RPM_BUILD_ROOT%{_libdir}/pybel.py \
  112. $RPM_BUILD_ROOT%{python_sitearch}
  113. rm -rf $RPM_BUILD_ROOT%{_libdir}/cmake/openbabel2
  114. rm -f $RPM_BUILD_ROOT%{_libdir}/perl5/*/*/perllocal.pod
  115. rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Chemistry/OpenBabel/.packlist
  116. rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Chemistry/OpenBabel/OpenBabel.bs
  117. %clean
  118. rm -rf $RPM_BUILD_ROOT
  119. %post -p /sbin/ldconfig
  120. %postun -p /sbin/ldconfig
  121. %files
  122. %defattr(-,root,root,-)
  123. %doc AUTHORS COPYING ChangeLog README THANKS
  124. %doc doc/*.html
  125. %doc doc/README* doc/babel*.inc doc/dioxin.*
  126. %{_bindir}/*
  127. %{_mandir}/man1/*
  128. %{_datadir}/%{name}
  129. %{_libdir}/libopenbabel.so.*
  130. %{_libdir}/%{name}
  131. %files devel
  132. %defattr(-,root,root,-)
  133. %{_includedir}/%{name}-2.0
  134. %{_libdir}/libopenbabel.so
  135. %{_libdir}/pkgconfig/*.pc
  136. %files -n perl-%{name}
  137. %defattr(-,root,root,-)
  138. %{perl_vendorarch}/Chemistry/OpenBabel.pm
  139. %dir %{perl_vendorarch}/*/Chemistry/OpenBabel
  140. %{perl_vendorarch}/*/Chemistry/OpenBabel/OpenBabel.so
  141. %files -n python-%{name}
  142. %defattr(-,root,root,-)
  143. %{python_sitearch}/_openbabel.so
  144. %{python_sitearch}/openbabel.py*
  145. %{python_sitearch}/pybel.py*
  146. %files -n ruby-%{name}
  147. %defattr(-,root,root,-)
  148. %{ruby_vendorarchdir}/openbabel.so
  149. %changelog
  150. * Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3.2-1
  151. - new upstream release
  152. - add BuildRequires: cmake
  153. - add Patch0,1,2,3 from fedora
  154. * Sat Oct 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.2.3-4
  155. - rebuilt with rpm-4.8.1 for pkg-config
  156. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.2.3-3
  157. - rebuild with python-2.6
  158. * Fri Nov 13 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.3-2
  159. - <BTS:0789> ruby binding install path changed to Config::CONFIG["archdir"]
  160. * Wed Aug 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-1
  161. - applied new versioning policy, spec in UTF-8
  162. - using system inchi package
  163. - added ruby-%{name} package
  164. * Mon May 14 2007 Susumu Tanimura <arumiant@gmail.com> 2.1.0-0vl1
  165. - Updated to 2.1.0
  166. * Tue May 1 2007 Susumu Tanimura <arumiant@gmail.com> 2.0.2-5vl1
  167. - built for VineLinux
  168. * Tue Oct 03 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-5
  169. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  170. * Wed Sep 20 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-4
  171. - .pyo files no longer ghosted
  172. - fix chicken-and-egg problem when building perl and python bindings
  173. * Tue Aug 29 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-3
  174. - simplified autotools invocation
  175. - mass rebuild
  176. * Mon Aug 07 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-2
  177. - simplified file lists and permissions
  178. - removed weird character from inchi summary and description
  179. - added missing pkgconfig Req: for -devel
  180. * Sat Aug 05 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-1
  181. - updated to 2.0.2
  182. - dropped GCC4 fix (upstream'd)
  183. - split off inchi package
  184. - added python and perl bindings packages
  185. * Sat Jan 07 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.0-1
  186. - updated to 2.0.0
  187. - fix compilation with GCC4
  188. - FE compliance
  189. * Thu Feb 10 2005 Dominik Mierzejewski <rpm@greysector.net> 1.100.2-1
  190. - rebuilt for Fedora 3
  191. * Tue Jan 18 2005 ALT QA Team Robot <qa-robot@altlinux.org> 1.100.2-alt1.1
  192. - Rebuilt with libstdc++.so.6.
  193. * Wed Mar 03 2004 Michael Shigorin <mike@altlinux.ru> 1.100.2-alt1
  194. - 1.100.2
  195. * Wed Dec 17 2003 Michael Shigorin <mike@altlinux.ru> 1.100.1-alt2
  196. - removed *.la
  197. - don't package static library by default
  198. * Mon Sep 22 2003 Michael Shigorin <mike@altlinux.ru> 1.100.1-alt1
  199. - 1.100.1
  200. - #2994 fixed; thanks to Alex Ott (ott@) for a pointer
  201. - spec cleanup (underlibification fixup)
  202. * Mon Jun 30 2003 Michael Shigorin <mike@altlinux.ru> 1.100.0-alt1
  203. - built for ALT Linux
  204. - based on Mandrake Cooker spec by:
  205. * Lenny Cartier <lenny@mandrakesoft.com>
  206. * Austin Acton <aacton@yorku.ca>
  207. - spec cleanup