kdevplatform-vl.spec 5.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211
  1. %define kde KDE4
  2. Name: kdevplatform
  3. Summary: Libraries for use by %{kde} development tools
  4. Summary(ja): %{kde} 開発ツールが使用するライブラリ
  5. Version: 1.4.1
  6. Release: 2%{?_dist_release}
  7. Group: Development/Tools
  8. License: GPLv2
  9. URL: http://www.kdevelop.org/
  10. Source0: ftp://ftp.kde.org/pub/kde/stable/kdevelop/4.4.0/src/kdevplatform-%{version}.tar.bz2
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: libboost-devel
  13. BuildRequires: gettext
  14. BuildRequires: kdelibs-devel >= 4.6
  15. BuildRequires: kdesdk-devel >= 4.6
  16. BuildRequires: pcre-devel
  17. BuildRequires: subversion-devel
  18. BuildRequires: apr-util-devel
  19. BuildRequires: soprano-devel
  20. BuildRequires: qjson-devel
  21. Requires: %{name}-libs = %{version}-%{release}
  22. Requires(postun): gtk2
  23. Requires(posttrans): gtk2
  24. %description
  25. %{kde} Development platform, the foundations upon which
  26. KDevelop and Quanta are built.
  27. %package libs
  28. Summary: Runtime libraries for %{name}
  29. Summary(ja): %{name} のランタイムライブラリ
  30. Group: System Environment/Libraries
  31. Requires: kdelibs4
  32. %description libs
  33. %{summary}.
  34. %package devel
  35. Summary: Developer files for %{name}
  36. Summary(ja): %{name} の開発用ファイル
  37. Group: Development/Libraries
  38. Requires: %{name}-libs = %{version}-%{release}
  39. Requires: libboost-devel
  40. Requires: commoncpp2-devel
  41. Requires: kdelibs4-devel
  42. Requires: subversion-devel
  43. %description devel
  44. %{summary}.
  45. %prep
  46. %setup -q -n kdevplatform-%{version}
  47. %build
  48. mkdir -p %{_target_platform}
  49. pushd %{_target_platform}
  50. %cmake \
  51. -DCMAKE_BUILD_TYPE=release \
  52. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  53. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  54. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  55. -DLIB_INSTALL_DIR:PATH=%{_libdir} \
  56. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  57. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  58. ..
  59. popd
  60. make %{?_smp_mflags} -C %{_target_platform}
  61. %install
  62. rm -rf %{buildroot}
  63. make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
  64. %find_lang %{name} --all-name --with-kde
  65. %clean
  66. rm -rf %{buildroot}
  67. %post
  68. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  69. %posttrans
  70. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  71. %postun
  72. if [ $1 -eq 0 ] ; then
  73. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  74. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  75. fi
  76. %post libs -p /sbin/ldconfig
  77. %postun libs -p /sbin/ldconfig
  78. %files -f %{name}.lang
  79. %defattr(-,root,root,-)
  80. %doc COPYING.PLUGINS COPYING.SRC
  81. %{_bindir}/kdev_dbus_socket_transformer
  82. %{_bindir}/kdev_format_source.sh
  83. %{_bindir}/kdevplatform_shell_environment.sh
  84. %{_datadir}/kde4/apps/kdev*/
  85. %{_datadir}/kde4/services/*.desktop
  86. %{_datadir}/kde4/servicetypes/*.desktop
  87. %{_datadir}/icons/hicolor/*/*/*
  88. %files libs
  89. %defattr(-,root,root,-)
  90. %{_libdir}/lib*.so.*
  91. %{_libdir}/kde4/*.so
  92. %files devel
  93. %defattr(-,root,root,-)
  94. %{_libdir}/lib*.so
  95. %{_includedir}/kde4/kdevplatform/
  96. %{_libdir}/cmake/kdevplatform/
  97. %changelog
  98. * Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.1-2
  99. - rebuild with libboost-1.54.0
  100. * Sun Nov 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.1-1
  101. - new upstream release
  102. * Sat Oct 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.0-1
  103. - new upstream release
  104. - add BuildRequires: qjson-devel
  105. * Sat Sep 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.3.1-1
  106. - new upstream release
  107. * Sat Jun 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.3-1
  108. - new upstream release
  109. * Sat May 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.0-2
  110. - add BuildRequires: soprano-devel
  111. * Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-1
  112. - new upstream release
  113. * Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.1.2-1
  114. - new upstream release
  115. - added Japanese summary
  116. * Sun May 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.0-3
  117. - removed R: kdevplatform from libs package
  118. * Sat May 8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.0-2
  119. - Initial build for Vine Linux
  120. * Thu Apr 29 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-1
  121. - kdevplatform-1.0.0
  122. * Sat Apr 17 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.10.2-1
  123. - kdevplatform-0.10.2
  124. * Thu Apr 08 2010 Rex Dieter <rdieter@fedoraproject.org. - 0.10.0-1
  125. - kdevplatform-0.10.0
  126. * Mon Mar 08 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.9.99-1
  127. - kdevplatform-0.9.99
  128. * Mon Feb 22 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.9.98-1
  129. - kdevplatform-0.9.98
  130. * Sat Jan 16 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.9.97-2
  131. - rebuild (boost)
  132. - BR: kdelibs4-devel
  133. * Thu Jan 07 2010 Rex Dieter <rdieter@fedoraproject.org> 0.9.97-1
  134. - kdevplatform-0.9.97
  135. - kdevplatform: file conflict with kdelibs (FindKDevPlatform.cmake) (#541690)
  136. * Sun Nov 22 2009 Rex Dieter <rdieter@fedoraproject.org> 0.9.95-0.6.20091015svn1035382
  137. - rebuild (fc13+, qt-4.6.0-rc1)
  138. * Thu Oct 15 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.5.20091015svn1035382
  139. - New snapshot
  140. * Sun Oct 11 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.4.beta5
  141. - Fix finding Kompare includes
  142. * Tue Sep 29 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.3.beta5
  143. - Use official release
  144. * Mon Sep 14 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.2
  145. - Add icon scriptlets
  146. * Mon Sep 14 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.1
  147. - Update tarball
  148. * Fri May 29 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.93-0.1
  149. - 1.0 Beta 3
  150. * Sat Feb 21 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 0.9.91-0.2.20090221svn929301
  151. - Post KDevplatform 1.0 Beta 1 snapshot
  152. * Fri Jan 09 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 0.9.85-1
  153. - 0.9.85 snapshot