gnash-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. # ghelp/omf/scrollkeeper support
  3. # not working as of version 0.8.7
  4. %define scrollkeeper 0
  5. # kde and klash support
  6. %define kde_support 0
  7. Name: gnash
  8. Version: 0.8.10
  9. Release: 2%{?_dist_release}
  10. Summary: GNU flash movie player
  11. Group: Applications/Multimedia
  12. License: GPLv3+
  13. URL: http://www.gnu.org/software/gnash/
  14. Source0: http://ftp.gnu.org/gnu/gnash/%{version}/%{name}-%{version}.tar.bz2
  15. Patch0: %{name}-%{version}-add-unistd-header.patch
  16. Patch1: %{name}-%{version}-integer-overflow.patch
  17. Patch2: %{name}-%{version}-libboost-1.50.0.patch
  18. # register KComponentData properly in KDE 4 KPart
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  20. BuildRequires: libxml2-devel libpng-devel libjpeg-devel libogg-devel
  21. BuildRequires: libboost-devel curl-devel freetype-devel fontconfig-devel
  22. BuildRequires: libboost-date-time libboost-serialization libboost-thread
  23. BuildRequires: SDL-devel
  24. BuildRequires: agg-devel
  25. BuildRequires: python-devel
  26. BuildRequires: libXv-devel
  27. %if %{kde_support}
  28. #BuildRequires: kde-filesystem
  29. BuildRequires: kdelibs-devel
  30. %endif
  31. BuildRequires: gtkglext-devel
  32. BuildRequires: docbook2X
  33. #BuildRequires: %{_bindir}/docbook2pdf
  34. BuildRequires: gstreamer-devel >= 0.10%
  35. BuildRequires: gstreamer-plugins-base-devel >= 0.10
  36. %if %{scrollkeeper}
  37. BuildRequires: scrollkeeper
  38. %endif
  39. BuildRequires: giflib-devel
  40. BuildRequires: gettext
  41. BuildRequires: desktop-file-utils
  42. BuildRequires: speex-devel
  43. BuildRequires: gstreamer-plugins-base-devel
  44. BuildRequires: pygtk2-devel
  45. BuildRequires: libtool-ltdl-devel
  46. BuildRequires: dejagnu
  47. BuildRequires: GConf2-devel
  48. BuildRequires: xulrunner-devel
  49. BuildRequires: autoconf automake libtool
  50. BuildRequires: libboost-devel
  51. BuildRequires: libboost-program-options
  52. BuildRequires: libboost-iostreams
  53. BuildRequires: mesa-libGLU-devel
  54. BuildRequires: libXmu-devel
  55. %if %{scrollkeeper}
  56. Requires(post): scrollkeeper
  57. Requires(postun): scrollkeeper
  58. %endif
  59. Requires(post): /sbin/ldconfig
  60. Requires(postun): /sbin/ldconfig
  61. Requires(post): /sbin/install-info
  62. Requires(preun): /sbin/install-info
  63. %description
  64. Gnash is capable of reading up to SWF v9 files and opcodes, but primarily
  65. supports SWF v7, with better SWF v8 and v9 support under heavy development.
  66. Gnash includes initial parser support for SWF v8 and v9. Not all
  67. ActionScript 2 classes are implemented yet, but all of the most heavily
  68. used ones are. Many ActionScript 2 classes are partially implemented;
  69. there is support for all of the commonly used methods of each
  70. class.
  71. %package plugin
  72. Summary: Web-client flash movie player plugin
  73. Requires: %{name} = %{version}-%{release}
  74. # this doesn't prevent wrong dependencies, in case a package
  75. # provides %%{_libdir}/mozilla/plugins (like kdebase for konqueror)
  76. # and another unrelated webbrowser is installed, like w3m-el.
  77. # Moreover konqueror could provide webclient some day
  78. #Requires: %{_libdir}/mozilla/plugins webclient
  79. Requires: webclient
  80. Group: Applications/Internet
  81. %description plugin
  82. The gnash flash movie player plugin for firefox or mozilla.
  83. %if %{kde_support}
  84. %package klash
  85. Summary: Konqueror flash movie player plugin
  86. Requires: %{name} = %{version}-%{release}
  87. Group: Applications/Multimedia
  88. %description klash
  89. The gnash flash movie player plugin for Konqueror.
  90. %endif
  91. %package cygnal
  92. Summary: Streaming media server
  93. Requires: %{name} = %{version}-%{release}
  94. Group: Applications/Multimedia
  95. %description cygnal
  96. Cygnal is a streaming media server that's Flash aware.
  97. %package devel
  98. Summary: Gnash header files
  99. Requires: %{name} = %{version}-%{release}
  100. Group: Development/Libraries
  101. %description devel
  102. Gnash header files can be used to write external Gnash extensions or to embed
  103. the Gnash GTK+ widget into a C/C++ application.
  104. %package -n python-gnash
  105. Summary: Gnash Python bindings
  106. Requires: %{name} = %{version}-%{release}
  107. Group: Applications/Multimedia
  108. %description -n python-gnash
  109. Python bindings for the Gnash widget. Can be used to embed Gnash into any PyGTK
  110. application.
  111. %prep
  112. %setup -q
  113. %patch0 -p1 -b .unistd-header
  114. %patch1 -p1 -b .integer-overflow
  115. %patch2 -p1 -b .boost
  116. autoreconf -if
  117. %build
  118. %configure --disable-static \
  119. --with-npapi-plugindir=%{_libdir}/mozilla/plugins \
  120. --enable-docbook --enable-ghelp --enable-media=GST \
  121. --disable-dependency-tracking --disable-rpath \
  122. --disable-testsuite \
  123. --without-swfdec-testsuite \
  124. --without-ming \
  125. --enable-cygnal \
  126. --enable-sdkinstall \
  127. --enable-python \
  128. %if %{kde_support}
  129. --enable-gui=gtk,kde4,sdl,fb \
  130. --with-kde4-prefix=%{_kde4_prefix} \
  131. --with-kde4-lib=%{_kde4_libdir}/kde4/devel \
  132. --with-kde4-incl=%{_kde4_includedir} \
  133. %else
  134. --enable-gui=gtk,sdl,fb \
  135. %endif
  136. --enable-renderer=all \
  137. --with-plugins-install=system \
  138. --disable-jemalloc \
  139. --enable-doublebuf \
  140. --htmldir=%{_datadir}/gnash/html
  141. %if %{kde_support}
  142. # make sure the Qt 4 moc etc. tools are found
  143. export PATH=%{_qt4_prefix}/bin:$PATH
  144. #doesn't work currently: %%{?_smp_mflags}
  145. # override KDE4_LIBS because configure doesn't detect it properly
  146. make KDE4_LIBS='-L%{_kde4_libdir}/kde4/devel -lkparts -lkdeui -lkdecore'
  147. %else
  148. #doesn't work currently: %%{?_smp_mflags}
  149. make
  150. %endif
  151. %install
  152. rm -rf $RPM_BUILD_ROOT
  153. make install install-plugins \
  154. DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p' \
  155. %if %{kde_support}
  156. KDE4_PLUGINDIR=%{_kde4_libdir}/kde4 \
  157. KDE4_SERVICESDIR=%{_kde4_datadir}/kde4/services \
  158. KDE4_CONFIGDIR=%{_kde4_configdir} \
  159. KDE4_APPSDATADIR=%{_kde4_appsdir}/klash
  160. %endif
  161. rm $RPM_BUILD_ROOT%{_libdir}/gnash/*.la
  162. %if %{kde_support}
  163. # KDE 4 doesn't need the .la file anymore, thankfully
  164. rm $RPM_BUILD_ROOT%{_kde4_libdir}/kde4/libklashpart.la
  165. %endif
  166. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  167. %find_lang %{name}
  168. %clean
  169. rm -rf $RPM_BUILD_ROOT
  170. %post
  171. /sbin/ldconfig
  172. %if %{scrollkeeper}
  173. scrollkeeper-update -q -o %{_datadir}/omf/%{name} || :
  174. %endif
  175. /sbin/install-info %{_infodir}/gnash_ref.info %{_infodir}/dir || :
  176. /sbin/install-info %{_infodir}/gnash_user.info %{_infodir}/dir || :
  177. update-desktop-database &> /dev/null || :
  178. touch --no-create %{_datadir}/icons/hicolor
  179. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  180. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  181. fi
  182. %preun
  183. if [ $1 = 0 ]; then
  184. /sbin/install-info --delete %{_infodir}/gnash_ref.info %{_infodir}/dir || :
  185. /sbin/install-info --delete %{_infodir}/gnash_user.info %{_infodir}/dir || :
  186. fi
  187. %postun
  188. /sbin/ldconfig
  189. %if %{scrollkeeper}
  190. scrollkeeper-update -q || :
  191. %endif
  192. update-desktop-database &> /dev/null || :
  193. touch --no-create %{_datadir}/icons/hicolor
  194. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  195. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  196. fi
  197. %files -f %{name}.lang
  198. %defattr(-,root,root,-)
  199. %doc README AUTHORS COPYING NEWS
  200. %config(noreplace) %{_sysconfdir}/gnashpluginrc
  201. %config(noreplace) %{_sysconfdir}/gnashrc
  202. %{_bindir}/fb-gnash
  203. %{_bindir}/gtk-gnash
  204. %{_bindir}/gnash-gtk-launcher
  205. %{_bindir}/rtmpget
  206. %{_bindir}/sdl-gnash
  207. %{_bindir}/gnash
  208. %{_bindir}/gprocessor
  209. %{_bindir}/findmicrophones
  210. %{_bindir}/findwebcams
  211. %dir %{_libdir}/gnash
  212. %{_libdir}/gnash/*.so*
  213. %{_mandir}/man1/gnash.1*
  214. %{_mandir}/man1/gprocessor.1*
  215. %{_mandir}/man1/findmicrophones.1*
  216. %{_mandir}/man1/findwebcams.1*
  217. %{_mandir}/man1/gtk-gnash.1*
  218. %{_mandir}/man1/gnash-gtk-launcher.1*
  219. %{_mandir}/man1/fb-gnash.1*
  220. %{_mandir}/man1/sdl-gnash.1*
  221. %{_mandir}/man1/rtmpget.1*
  222. %{_infodir}/gnash*
  223. %{_datadir}/gnash/
  224. %{_datadir}/icons/hicolor/32x32/apps/*.xpm
  225. %{_datadir}/applications/*.desktop
  226. %files plugin
  227. %defattr(-,root,root,-)
  228. %{_libdir}/mozilla/plugins/libgnashplugin.so
  229. %if %{kde_support}
  230. %files klash
  231. %defattr(-,root,root,-)
  232. %{_kde4_bindir}/kde4-gnash
  233. %{_kde4_libdir}/kde4/libklashpart.so
  234. %{_kde4_appsdir}/klash/
  235. %{_kde4_datadir}/kde4/services/klash_part.desktop
  236. %{_mandir}/man1/kde4-gnash.1*
  237. %endif
  238. %files cygnal
  239. %defattr(-,root,root,-)
  240. %config(noreplace) %{_sysconfdir}/cygnalrc
  241. %{_bindir}/cygnal
  242. %{_bindir}/flvdumper
  243. %{_bindir}/soldumper
  244. %{_mandir}/man1/cygnal.1*
  245. %{_mandir}/man1/flvdumper.1*
  246. %{_mandir}/man1/soldumper.1*
  247. %dir %{_libdir}/cygnal
  248. %{_libdir}/cygnal/plugins/*.so*
  249. %files devel
  250. %defattr(-,root,root,-)
  251. %{_includedir}/gnash/
  252. %{_libdir}/pkgconfig/gnash.pc
  253. %files -n python-gnash
  254. %defattr(-,root,root,-)
  255. %{python_sitearch}/gtk-2.0/*
  256. %changelog
  257. * Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.10-2
  258. - rebuild with libboost-1.54.0
  259. - add Patch2 (%%{name}-%%{version}-libboost-1.50.0.patch)
  260. * Mon Apr 22 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.10-1
  261. - update to 0.8.10
  262. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.7-5
  263. - rebuild with python-2.7.2
  264. * Sun May 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.7-4
  265. - add BuildRequires: python-devel, libXv-devel
  266. * Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> 0.8.7-3
  267. - rebuilt with libboost-1.45.0
  268. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 0.8.7-2
  269. - rebuilt with rpm-4.8.1 for pkg-config
  270. * Wed Mar 17 2010 IWAI, Masaharu <iwai@alib.jp> 0.8.7-1
  271. - initial build for Vine Linux: based Fedora 0.8.7-1.fc14
  272. * Sat Feb 27 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.7-1
  273. - update to 0.8.7
  274. - make scrollkeeper a conditional (still disabled as it's not working)
  275. - drop gnash-0.8.3-manual.patch, should no longer be needed
  276. - drop gnash-0.8.6-python-install-dir.patch, fixed upstream
  277. * Fri Feb 12 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-13
  278. - delete bundled libltdl stuff to make sure it's not used
  279. * Thu Feb 11 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-12
  280. - don't build libltdlc.a
  281. * Thu Feb 11 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-11
  282. - --without-included-ltdl (CVE-2009-3736)
  283. * Fri Jan 22 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-10
  284. - Rebuild for new Boost (1.41.0)
  285. * Sat Jan 02 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-9
  286. - Add missing Epoch to Requires
  287. * Sat Jan 02 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-8
  288. - Install icon to the correct place (#551621)
  289. * Wed Dec 30 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-7
  290. - One more try at using the correct dir
  291. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-6
  292. - Patch was reversed
  293. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-5
  294. - Patch Makefile.in, not Makefile.am
  295. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-4
  296. - Pick up python modules from the right dir
  297. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-3
  298. - Install python modules in the right dir
  299. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-2
  300. - Add cygnal plugins
  301. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-1
  302. - Update to 0.8.6, increase epoch.
  303. * Thu Sep 10 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.8.20090910bzr11506
  304. - update to HEAD
  305. * Thu Sep 10 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.7.20090910bzr11505
  306. - update to HEAD
  307. * Mon Aug 10 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.9.0-0.6.20090809bzr11401
  308. - don't package headers in -widget, only in -devel (no duplicate files)
  309. - own %%{_includedir}/gnash/ in -devel
  310. - add missing %%defattr for -devel and -widget
  311. - make -devel and -widget require the main package (with exact VR)
  312. - fix -devel group and description
  313. - rename gnash-widget to python-gnash as per the naming guidelines
  314. * Sun Aug 09 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.9.0-0.5.20090809bzr11401
  315. - use %%{_includedir}, not %%{_prefix}/include
  316. * Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.4.20090809bzr11401
  317. - Install the python module in the sitearch dir
  318. * Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.3.20090809bzr11401
  319. - One more 64bit fix
  320. * Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.3.20090809bzr11400
  321. - Fix the packaging in 64bits
  322. * Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.2.20090809bzr11400
  323. - upload the .swf file
  324. * Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.1.20090809bzr11400
  325. - merge upstream changes into the spec
  326. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.5-5
  327. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  328. * Fri May 22 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.5-4
  329. - rebuild for new Boost
  330. * Fri Mar 06 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.5-3
  331. - explicitly link the KlashPart against the libraries it uses
  332. * Fri Mar 06 2009 Jaroslav Reznik <jreznik@redhat.com> 0.8.5-2
  333. - add missing speex-devel and gstreamer-plugins-base-devel BR
  334. * Fri Mar 06 2009 Jaroslav Reznik <jreznik@redhat.com> 0.8.5-1
  335. - update to 0.8.5
  336. - remove use_kde3_executable_hack
  337. - remove autoreconf
  338. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 0.8.4-7
  339. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  340. * Thu Dec 18 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-6
  341. - rebuild for new boost
  342. * Thu Nov 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-5
  343. - add missing portions of KDE 4 port from upstream kde4 branch
  344. * Thu Nov 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-4
  345. - add 3 more patches from bero to fix the KDE 4 viewer executable
  346. - disable use_kde3_executable hack
  347. * Sun Oct 19 2008 Patrice Dumas <pertusus@free.fr> 0.8.4-3
  348. - add a desktop file
  349. * Sat Oct 18 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-2
  350. - update KDE 4 patch (undo the backporting and use original patch)
  351. - patch to make autoreconf work
  352. - add missing BR giflib-devel, gettext
  353. - omit unrecognized --with-qtdir
  354. * Sat Oct 18 2008 Patrice Dumas <pertusus@free.fr> 0.8.4-1
  355. - update to 0.8.4
  356. * Sat Oct 4 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.3-6
  357. - use the KDE 3 executable with the KDE 4 KPart for now (making this conditional
  358. so it can easily be disabled or removed once the KDE 4 executable is fixed)
  359. * Sat Oct 4 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.3-5
  360. - register KComponentData properly in KDE 4 KPart
  361. * Fri Oct 3 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.3-4
  362. - KDE 4 port of klash by Benjamin Wolsey and Bernhard Rosenkränzer
  363. * Fri Aug 29 2008 Michael Schwendt <mschwendt@fedoraproject.org> 0.8.3-3
  364. - include %%_libdir/gnash directory
  365. * Wed Jun 25 2008 Patrice Dumas <pertusus@free.fr> 0.8.3-2
  366. - add glib in the link, thanks Daniel Drake (#452767)
  367. * Sun Jun 22 2008 Patrice Dumas <pertusus@free.fr> 0.8.3-1
  368. - update to 0.8.3
  369. * Wed Apr 9 2008 Patrice Dumas <pertusus@free.fr> 0.8.2-3
  370. - ship libklashpart (#441601)
  371. * Mon Mar 10 2008 Patrice Dumas <pertusus@free.fr> 0.8.2-2
  372. - don't ship libltdl.so.3 (#436725)
  373. * Fri Mar 7 2008 Patrice Dumas <pertusus@free.fr> 0.8.2-1
  374. - update to 0.8.2
  375. * Sat Oct 27 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-6
  376. - add patch from Martin Stransky to fix wrapped plugin #281061
  377. * Thu Sep 20 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-5
  378. - info files are empty, don't install them
  379. * Thu Sep 20 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-4
  380. - omf/scrollkeeper doc is broken, remove it
  381. * Fri Sep 7 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-3
  382. - better documentation generation
  383. * Wed Sep 5 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-2
  384. - update to 0.8.1
  385. - agg is now the default renderer
  386. * Fri Aug 3 2007 Patrice Dumas <pertusus@free.fr> 0.8.0-2
  387. - rebuild for boost soname change
  388. * Sun Jun 17 2007 Patrice Dumas <pertusus@free.fr> 0.8.0-1
  389. - update to 0.8.0
  390. * Wed May 9 2007 Patrice Dumas <pertusus@free.fr> 0.7.2-2
  391. - fix CVE-2007-2500 (fix 239213)
  392. * Mon Nov 6 2006 Patrice Dumas <pertusus@free.fr> 0.7.2-1
  393. - update for 0.7.2 release.
  394. * Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.7.1-9
  395. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  396. * Sun Sep 24 2006 Patrice Dumas <pertusus@free.fr> 0.7.1-8
  397. - plugin requires %%{_libdir}/mozilla/plugins. Fix (incompletly and
  398. temporarily, but there is no better solution yet) #207613
  399. * Sun Aug 27 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-7
  400. - add defattr for klash
  401. - add warnings in the description about stability
  402. * Mon Aug 21 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-6
  403. - remove superfluous buildrequires autoconf
  404. - rename last patch to gnash-plugin-tempfile-dir.patch
  405. - add README.fedora to plugin to explain tmpdirs
  406. * Wed Aug 16 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-5
  407. - source qt.sh and configure --with-qtdir (Dominik Mierzejewski)
  408. - add plugin-tempfile-dir.patch for plugin to use a safe tempdir
  409. * Fri Jul 28 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-4
  410. - buildrequire autotools (Michael Knox)
  411. * Fri Jun 2 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-3
  412. - add gnash-continue_on_info_install_error.patch to avoid
  413. - buildrequire libXmu-devel
  414. * Wed May 17 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-2
  415. - configure with --disable-rpath
  416. - buildrequire docbook2X
  417. - remove devel files
  418. * Sun May 7 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-1
  419. - update to 0.7.1 alpha release
  420. * Sat Apr 22 2006 Rob Savoye <rob@welcomehome.org> - 0.7-1
  421. - install the info file. Various tweaks for my system based on
  422. Patrice's latest patch,
  423. * Fri Feb 3 2006 Patrice Dumas <dumas@centre-cired.fr> - 0.7-1
  424. - initial packaging