flac-vl.spec 8.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299
  1. # set 1 if you want to build input plugin for xmms
  2. %define build_xmms_plugin 0
  3. %define xmmsinputdir %{_libdir}/xmms/Input
  4. #%%define extraver beta
  5. Name: flac
  6. Summary: FLAC - Free Lossless Audio Codec
  7. Summary(ja): FLAC - フリーの可逆音声圧縮コーデック
  8. Version: 1.2.1
  9. Release: 2%{?_dist_release}
  10. Group: Applications/Multimedia
  11. License: BSD and GPLv2+
  12. URL: http://flac.sourceforge.net/
  13. Source: http://prdownloads.sourceforge.net/flac/%{name}-%{version}%{?extraver:-%extraver}.tar.gz
  14. Patch1: flac-1.2.1-asm.patch
  15. Patch2: flac-1.2.1-gcc43.patch
  16. Patch3: flac-1.2.1-hidesyms.patch
  17. Patch4: flac-1.2.1-tests.patch
  18. Patch5: flac-1.2.1-cflags.patch
  19. Patch6: flac-1.2.1-bitreader.patch
  20. Patch10: flac-xmms-euc-jp-ms.patch
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  22. BuildRequires: libogg-devel
  23. BuildRequires: automake autoconf libtool gettext-devel
  24. %ifarch %ix86
  25. # 2.0 supports symbol visibility
  26. BuildRequires: nasm >= 2.0
  27. %endif
  28. Vendor: Project Vine
  29. Distribution: Vine Linux
  30. %description
  31. FLAC stands for Free Lossless Audio Codec. Grossly oversimplified, FLAC is
  32. similar to MP3, but lossless.
  33. The FLAC project consists of:
  34. * the stream format
  35. * libFLAC - reference encoders and decoders in library form
  36. * flac - a command-line program to encode and decode FLAC files
  37. * metaflac - a command-line metadata editor for FLAC files
  38. # * input plugins for various music players (the xmms plugin is in a xmms-
  39. # flac package)
  40. %description -l ja
  41. FLAC (Free Lossless Audio Codec) はフリーの可逆音声圧縮コーデックです。
  42. MP3 に似ていますが、音質が劣化しません。
  43. FLAC プロジェクトは以下により構成されています。
  44. * ストリーム形式
  45. * libFLAC - リファレンスエンコーダ/デコーダを実装するライブラリ
  46. * flac - FLAC ファイルのエンコード/デコードに使用するコマンドライン版
  47. プログラム。
  48. * metaflac - FLAC ファイルのコマンドライン版メタデータエディタ
  49. # * 各種音楽再生プログラム用入力プラグイン (XMMS プラグインは xmms-flac パッ
  50. # ケージに含まれます)
  51. %package devel
  52. Summary: Development libraries and header files from FLAC
  53. Summary(ja): FLAC アプリケーション開発用ライブラリ及びヘッダファイル
  54. Group: Development/Libraries
  55. Requires: %{name} = %{version}
  56. Requires: pkgconfig
  57. %description devel
  58. This package contains all the files needed to develop applications that
  59. will use the Free Lossless Audio Codec (FLAC).
  60. %description -l ja devel
  61. このパッケージには FLAC (Free Lossless Audio Codec) を扱うアプリケーションを
  62. 開発するために必要なライブラリ及びヘッダファイルが含まれています。
  63. %if %{build_xmms_plugin}
  64. %package -n xmms-flac
  65. Summary: X MultiMedia System plugin to play FLAC files
  66. Summary(ja): FLAC ファイルを再生するための XMMS プラグイン
  67. Group: Applications/Multimedia
  68. Requires: xmms, %{name} = %{version}
  69. BuildRequires: xmms-devel >= 0.9.5.1, gtk+-devel
  70. %description -n xmms-flac
  71. An input plugin that enables playback of FLAC files in xmms.
  72. %description -l ja -n xmms-flac
  73. XMMS で FLAC ファイル (*.flac) を再生するための入力プラグインです。
  74. %endif
  75. %prep
  76. %define srcver %{version}%{?extraver:-%extraver}
  77. %setup -q -n %{name}-%{srcver}
  78. %patch1 -p1 -b .asm
  79. %patch2 -p1 -b .gcc43
  80. %patch3 -p1 -b .hidesyms
  81. # reduce number of tests
  82. %patch4 -p1 -b .tests
  83. %patch5 -p1 -b .cflags
  84. %patch6 -p0 -b .bitreader
  85. %if %{build_xmms_plugin}
  86. %patch10 -p1 -b .euc-jp-ms
  87. %endif
  88. %build
  89. ./autogen.sh -V
  90. %configure \
  91. --disable-static \
  92. %if !%{build_xmms_plugin}
  93. --disable-xmms-plugin \
  94. %endif
  95. %ifarch ppc
  96. --disable-asm-optimizations \
  97. %endif
  98. --disable-thorough-tests
  99. %__make %{?_smp_mflags}
  100. %install
  101. %__rm -rf %{buildroot}
  102. %makeinstall \
  103. %if %{build_xmms_plugin}
  104. xmmsinputplugindir=%{buildroot}%{xmmsinputdir}
  105. %endif
  106. # remove unneeded files
  107. %{_bindir}/find %{buildroot} -name "*.la" -exec %__rm -f "{}" \;
  108. %{_bindir}/find doc/ -name "Makefile*" -exec %__rm -f "{}" \;
  109. %check
  110. make -C test check &> /dev/null
  111. %clean
  112. %__rm -rf %{buildroot}
  113. %post -p %{_syssbindir}/ldconfig
  114. %postun -p %{_syssbindir}/ldconfig
  115. %files
  116. %defattr(-,root,root)
  117. %doc AUTHORS COPYING.* README
  118. %{_bindir}/*
  119. %{_libdir}/*.so.*
  120. %{_mandir}/*/*
  121. %files devel
  122. %defattr(-,root,root)
  123. %doc doc/html COPYING.*
  124. %{_includedir}/*
  125. %{_libdir}/*.so
  126. %{_libdir}/pkgconfig/*.pc
  127. %{_datadir}/aclocal/*.m4
  128. %if %{build_xmms_plugin}
  129. %files -n xmms-flac
  130. %defattr(-,root,root)
  131. %{xmmsinputdir}/*.so
  132. %endif
  133. %changelog
  134. * Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-2
  135. - rebuilt with rpm-4.8.1 for pkg-config
  136. - added Patch1-6 from Fedora
  137. * Sun Jul 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
  138. - applied new versioning policy
  139. - spec in UTF-8
  140. * Sat Sep 22 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 1.2.1-0vl1
  141. - new upstream release
  142. - drop bmp-plugin.patch (patch1)
  143. - disable xmms plugin
  144. * Sat Aug 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
  145. - new upsteram release
  146. - dropped Patch2 (merged into upstream)
  147. - do not build beepmp plugin
  148. * Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.2-0vl7
  149. - rebuilt with new toolchain
  150. * Sun Oct 29 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl6
  151. - add '--disable-static' option to %%configure
  152. - remove *.la
  153. * Wed Jul 26 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl5
  154. - rebuild
  155. * Mon Mar 27 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.2-0vl4
  156. - --disable-asm-optimizations on ppc
  157. * Thu Feb 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl3
  158. - rebuild
  159. * Wed Feb 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl2
  160. - initialize flac_cfg.stream with NULL to avoid crashing (patch2)
  161. * Sun Feb 06 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl1
  162. - upstream release
  163. - update bmp-plugin.patch
  164. * Thu Feb 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl0.0beta
  165. - upstream release
  166. - update bmp-plugin.patch
  167. * Fri Jan 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl5
  168. - fix typo
  169. * Sat Dec 18 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl4
  170. - move html docs to devel package
  171. * Wed Dec 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl3
  172. - add input plugin for beepmp based on for xmms (patch1)
  173. - BuildRequires: beepmp-devel >= 0.9.7
  174. - define build_*_plugin macros to build input plugin sub-packages
  175. - update description
  176. * Thu Nov 04 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl2
  177. - drop BuildRequires: zlib-devel (was required to build with id3lib)
  178. * Fri Oct 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl1
  179. - upstream release
  180. - drop (Build)Requires: id3lib(-devel)
  181. * Sun Aug 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl0.1
  182. - 1.1.1-beta1
  183. - add BuildRequires: gtk+-devel, zlib-devel
  184. * Mon May 03 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl3
  185. - xmms-flac
  186. - enable to convert charset from/to EUC-JP-MS (Patch0)
  187. - Requires: glibc >= 2.3.3
  188. * Tue Apr 20 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl2
  189. - fix docs
  190. * Thu Apr 08 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl1
  191. - first build for Vine Linux
  192. * Mon Mar 31 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
  193. - Rebuilt for Red Hat Linux 9.
  194. - Exclude .la files.
  195. - Updated description.
  196. * Tue Mar 11 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
  197. - Fix nasm dep to be only for ix86.
  198. * Mon Jan 27 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
  199. - Update to 1.1.0.
  200. * Sun Jan 5 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
  201. - Rebuilt against the latest id3lib for the xmms plugin.
  202. * Thu Oct 10 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  203. - Fixed location of include files, doh!
  204. * Sat Sep 28 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  205. - Rebuilt for Red Hat Linux 8.0.
  206. * Thu Sep 25 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  207. - Update to 1.0.4.
  208. - Removed obsolete build patch, the xmms plugin builds cleanly at last!
  209. * Thu Jul 4 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  210. - Update to 1.0.3.
  211. * Tue Apr 23 2002 Daniel Resare <noa@resare.com>
  212. - Fixed plugin build when flac is not already installed
  213. * Mon Apr 8 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  214. - Replaced the hard-coded xmms input path with an expansion.
  215. - Fixed spec (License tag and redundant Group for devel package).
  216. - Fixed defattr for the xmms plugin.
  217. * Sat Apr 6 2002 Daniel Resare <noa@resare.com>
  218. - Update to 1.0.2.
  219. - Splitted out xmms plugin to a separate subpackage.
  220. * Tue Nov 20 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
  221. - Update to 1.0.1.
  222. * Sun Oct 21 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
  223. - Rebuilt for Red Hat 7.2 and added xmms dependency.
  224. * Thu Aug 16 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
  225. - Initial RPM release.
  226. - You cannot rebuild this SRPM easily if you want the xmms plugin.