akonadi-vl.spec 9.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330
  1. %define _qt4_ver 4.8.0
  2. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
  3. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
  4. %define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
  5. ## Can be either MYSQL(uptsream default), SQLITE, or POSTGRES(untested)
  6. %global database_backend SQLITE
  7. Name: akonadi
  8. Summary: PIM Storage Service
  9. Summary(ja): PIM ストレージサービス
  10. Version: 1.11.0
  11. Release: 1%{?_dist_release}
  12. Group: System Environment/Libraries
  13. License: LGPLv2+
  14. URL: http://download.akonadi-project.org/
  15. Source0: http://download.akonadi-project.org/akonadi-%{version}.tar.bz2
  16. %define mysql_conf_timestamp 20110629
  17. # shrink default initial db size a bit (approx 140mb->28mb)
  18. Patch1: akonadi-mysql_conf.patch
  19. ## upstream patches
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. BuildRequires: cmake >= 2.6.0
  22. BuildRequires: qt4-devel >= 4.4
  23. BuildRequires: automoc4
  24. BuildRequires: MySQL-devel
  25. BuildRequires: MySQL-server
  26. # for xsltproc
  27. BuildRequires: libxslt
  28. BuildRequires: shared-mime-info
  29. BuildRequires: libboost-devel libboost-program-options
  30. BuildRequires: soprano-devel >= 2.5.0
  31. BuildRequires: sqlite3-devel
  32. BuildRequires: libICE-devel libXext-devel
  33. Requires: qt4 >= %{_qt4_version}
  34. %if "%{?database_backend}" == "MYSQL"
  35. Requires: qt4-MySQL
  36. # not *strictly* required, but we need a functional default configuration
  37. Requires: MySQL-server
  38. %endif
  39. Obsoletes: akonadi-sqlite < %{version}-%{release}
  40. Requires(post): /sbin/ldconfig
  41. Requires(postun): /sbin/ldconfig
  42. %description
  43. %{summary}.
  44. %if "%{?database_backend}" == "MYSQL"
  45. Requires an available instance of mysql server at runtime.
  46. Akonadi can spawn a per-user one automatically if the mysql-server
  47. package is installed on the machine.
  48. See also: %{_sysconfdir}/akonadi/mysql-global.conf
  49. %endif
  50. %package devel
  51. Summary: Developer files for %{name}
  52. Summary(ja): %{name} の開発用ファイル
  53. Group: Development/Libraries
  54. Requires: %{name} = %{version}-%{release}
  55. Requires: qt4-devel
  56. %description devel
  57. %{summary}.
  58. %prep
  59. %setup -q
  60. #%patch1 -p1 -b .mysql_conf
  61. #touch -d %{mysql_conf_timestamp} server/src/storage/mysql-global.conf
  62. %build
  63. %ifarch x86_64
  64. PATH="$PATH:`/usr/bin/pkg-config --variable=bindir Qt`"
  65. %endif
  66. mkdir -p %{_target_platform}
  67. pushd %{_target_platform}
  68. %cmake \
  69. -DCONFIG_INSTALL_DIR=%{_sysconfdir} \
  70. -DINSTALL_QSQLITE_IN_QT_PREFIX:PATH=%{_qt4_plugindir} \
  71. %{?database_backend:-DDATABASE_BACKEND=%{database_backend}} \
  72. ..
  73. popd
  74. make %{?_smp_mflags} -C %{_target_platform}
  75. %install
  76. rm -rf $RPM_BUILD_ROOT
  77. make install DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  78. mkdir -p $RPM_BUILD_ROOT%{_datadir}/akonadi/agents
  79. # create "big" config (analog to -mobile.conf)
  80. install -p \
  81. $RPM_BUILD_ROOT%{_sysconfdir}/akonadi/mysql-global.conf \
  82. $RPM_BUILD_ROOT%{_sysconfdir}/akonadi/mysql-global-big.conf
  83. # default to small/mobile config
  84. install -p \
  85. $RPM_BUILD_ROOT%{_sysconfdir}/akonadi/mysql-global-mobile.conf \
  86. $RPM_BUILD_ROOT%{_sysconfdir}/akonadi/mysql-global.conf
  87. touch -d %{mysql_conf_timestamp} \
  88. $RPM_BUILD_ROOT%{_sysconfdir}/akonadi/mysql-global*.conf \
  89. $RPM_BUILD_ROOT%{_sysconfdir}/akonadi/mysql-local.conf
  90. # create/own %{_libdir}/akondi
  91. mkdir -p $RPM_BUILD_ROOT%{_libdir}/akonadi
  92. #%check
  93. #make test -C %{_target_platform}
  94. #export PKG_CONFIG_PATH=$RPM_BUILD_ROOT%{_datadir}/pkgconfig:$RPM_BUILD_ROOT%{_libdir}/pkgconfig
  95. #test "$(pkg-config --modversion akonadi)" = "%{version}"
  96. %clean
  97. rm -rf $RPM_BUILD_ROOT
  98. %post -p /sbin/ldconfig
  99. %posttrans
  100. update-mime-database %{_datadir}/mime &> /dev/null || :
  101. %postun
  102. /sbin/ldconfig ||:
  103. if [ $1 -eq 0 ] ; then
  104. update-mime-database %{_datadir}/mime &> /dev/null ||:
  105. fi
  106. %files
  107. %defattr(-,root,root,-)
  108. %doc AUTHORS lgpl-license
  109. %dir %{_sysconfdir}/akonadi
  110. # example conf's
  111. %{_sysconfdir}/akonadi/mysql-global-big.conf
  112. %{_sysconfdir}/akonadi/mysql-global-mobile.conf
  113. %config(noreplace) %{_sysconfdir}/akonadi/mysql-global.conf
  114. %config(noreplace) %{_sysconfdir}/akonadi/mysql-local.conf
  115. %{_bindir}/akonadi_agent_launcher
  116. %{_bindir}/akonadi_agent_server
  117. %{_bindir}/akonadi_control
  118. %{_bindir}/akonadi_rds
  119. %{_bindir}/akonadictl
  120. %{_bindir}/akonadiserver
  121. %{_bindir}/asapcat
  122. %{_libdir}/libakonadi*.so.1*
  123. %{_datadir}/dbus-1/interfaces/org.freedesktop.Akonadi.*.xml
  124. %{_datadir}/dbus-1/services/org.freedesktop.Akonadi.*.service
  125. %{_datadir}/mime/packages/akonadi-mime.xml
  126. %{_datadir}/akonadi
  127. %{_qt4_plugindir}/sqldrivers/libqsqlite3.so
  128. %files devel
  129. %defattr(-,root,root,-)
  130. %{_includedir}/akonadi
  131. %{_libdir}/pkgconfig/akonadi.pc
  132. %{_libdir}/libakonadi*.so
  133. %{_libdir}/cmake/Akonadi
  134. %changelog
  135. * Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.11.0-1
  136. - new upstream release
  137. * Sat Sep 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.2-1
  138. - new upstream release
  139. * Wed Jun 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.9.2-1
  140. - new upstream release
  141. * Sun Nov 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.1-1
  142. - new upstream release
  143. * Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.0-1
  144. - new upstream release
  145. * Mon Jan 9 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.6.2-2
  146. - rebuilt with qt-4.8.0
  147. * Sun Oct 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.6.2-1
  148. - new upstream release
  149. * Sun Sep 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.6.1-1
  150. - new upstream release
  151. * Sat Aug 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.6.0-2
  152. - rebuilt with soprano-2.7.0-2
  153. * Sat Jul 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.6.0-1
  154. - new upstream release
  155. * Thu Mar 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.5.0-2
  156. - rebuilt with qt4-4.7.2
  157. * Mon Jan 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.5.0-1
  158. - new upstream release
  159. * Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.0-2
  160. - rebuilt with rpm-4.8.1
  161. * Sun Aug 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.0-1
  162. - new upstream release
  163. - added BR: sqlite3-devel
  164. - added sqlite subpackage
  165. * Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.1-3
  166. - new upstream release
  167. * Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.1-3
  168. - updated Patch1
  169. - added BR: MySQL-server
  170. * Sun Feb 14 2010 Shu KONNO <owa@bg.wakwak.com> - 1.3.1-2
  171. - added qmake path to PATH (if x86_64)
  172. * Sat Feb 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.1-1
  173. - new upstream release
  174. - built with new toolchain
  175. * Thu Sep 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.1-1
  176. - new upstream release
  177. * Wed Sep 02 2009 NAKAMURA Kenta <kenta@vinelinux.org> - 1.2.0-4
  178. - use %%cmake macro
  179. - removed MySQL-server from BuildRequires:
  180. * Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-3
  181. - fixed Requires
  182. * Sat Aug 15 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-2
  183. - Initial build for Vine
  184. * Thu Jul 30 2009 Lukáš Tinkl <ltinkl@redhat.com> - 1.2.0-1
  185. - Akonadi 1.2.0
  186. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.95-2
  187. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  188. * Thu Jun 25 2009 Than Ngo <than@redhat.com> - 1.1.95-1
  189. - 1.1.95
  190. * Wed Jun 03 2009 Rex Dieter <rdieter@fedoraproject.org> 1.1.90-1
  191. - akonadi-1.1.90
  192. * Tue May 26 2009 Rex Dieter <rdieter@fedoraproject.org> 1.1.85-3
  193. - akonadi.pc.cmake: s/AKONADI_LIB_VERSION_STRING/AKONADI_VERSION_STRING/
  194. * Tue May 12 2009 Than Ngo <than@redhat.com> 1.1.85-2
  195. - fix rpm file list
  196. * Wed May 06 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.85-1
  197. - akonadi-1.1.85
  198. * Thu Apr 30 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.2-1
  199. - akonadi-1.1.2
  200. - optimize scriptlets a bit
  201. * Wed Feb 25 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.1-6
  202. - rev startup patch
  203. - BR: cmake >= 2.6.0
  204. - preserve timestamp's on mysql*.conf's
  205. * Tue Feb 24 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.1-5
  206. - own %%_sysconfig/akonadi/mysql-local.conf
  207. - startup patch: reset conf only when needed, and clear mysql log file on update
  208. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.1-4
  209. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  210. * Fri Feb 20 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.1-3
  211. - shrink default db initial size a bit (approx 140mb->28mb)
  212. - drop extraneous RPATH-cmake baggage
  213. * Wed Jan 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.1-1
  214. - 1.1.1
  215. * Sun Jan 04 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.0-1
  216. - 1.1.0
  217. * Tue Dec 16 2008 Rex Dieter <rdieter@fedoraproject.org> - 1.0.81-1
  218. - 1.0.81
  219. * Mon Dec 08 2008 Rex Dieter <rdieter@fedoraproject.org> - 1.0.80-3
  220. - restore Requires: mysql-server
  221. * Mon Dec 01 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.0.80-2
  222. - own /usr/share/akonadi and /usr/share/akonadi/agents (#473595)
  223. * Wed Nov 26 2008 Than Ngo <than@redhat.com> - 1.0.80-1
  224. - 1.0.80
  225. * Wed Oct 22 2008 Rex Dieter <rdieter@fedoraproject.org> 1.0.0-4
  226. - drop Requires: mysql-server (for now), mention in %%description
  227. * Wed Jul 30 2008 Rex Dieter <rdieter@fedoraproject.org> 1.0.0-3
  228. - Requires: mysql-server
  229. * Wed Jul 30 2008 Rex Dieter <rdieter@fedoraproject.org> 1.0.0-2
  230. - BR: mysql-server
  231. - Requires: qt4-mysql
  232. - cleanup spec
  233. * Wed Jul 23 2008 Than Ngo <than@redhat.com> - 1.0.0-1
  234. - 1.0.0
  235. * Wed Jun 18 2008 Rex Dieter <rdieter@fedoraproject.org> 0.82.0-1
  236. - akonadi-0.82.0
  237. * Tue Jun 3 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.81.0-0.2.20080526svn812787
  238. - BR automoc, drop automoc hack
  239. * Mon May 26 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.81.0-0.1.20080526svn812787
  240. - update to revision 812787 from KDE SVN (to match KDE 4.1 Beta 1)
  241. - restore builtin automoc4 for now
  242. - update file list, require pkgconfig in -devel (.pc file now included)
  243. * Mon May 5 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.80.0-2
  244. - -devel: remove bogus Requires: pkgconfig
  245. * Sat May 3 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.80.0-1
  246. - first Fedora package