WebKit3-vl.spec 7.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250
  1. %define add_to_doc_files() \
  2. mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}; \
  3. cp -p %1 %{buildroot}%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') \
  4. echo %%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') >> docfiles.list
  5. #define svn_revision 43436
  6. # --with coverage: Enables compile-time checking of code coverage. (default: no)
  7. %bcond_with coverage
  8. # --with jit: Enable JIT ("just-in-time") JavaScript compiling support.
  9. #%bcond_with jit
  10. # --with pango : use pango for font rendering instead of freetype2 (default: use freetype2)
  11. %bcond_with pango
  12. # --with wml: Build support for WML
  13. %bcond_with wml
  14. Name: WebKit3
  15. Version: 2.2.3
  16. Release: 1%{?_dist_release}
  17. Summary: Web content engine library
  18. Summary(ja): ウェブコンテンツエンジンライブラリ
  19. Group: Development/Libraries
  20. License: LGPLv2+ and BSD
  21. URL: http://webkitgtk.org/
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Packager: Takemikaduchi
  25. Source0: http://www.webkitgtk.org/webkitgtk-%{version}.tar.xz
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  27. BuildRequires: bison
  28. BuildRequires: flex
  29. BuildRequires: gperf
  30. BuildRequires: ruby
  31. BuildRequires: gtk3-devel
  32. BuildRequires: at-spi2-core-devel
  33. BuildRequires: gtk2-devel
  34. BuildRequires: harfbuzz-icu-devel
  35. BuildRequires: libjpeg-turbo-devel
  36. BuildRequires: libtool
  37. BuildRequires: libxslt-devel
  38. BuildRequires: libXt-devel
  39. BuildRequires: pcre-devel
  40. BuildRequires: sqlite3-devel
  41. BuildRequires: geoclue-devel
  42. BuildRequires: gcr-devel
  43. BuildRequires: gstreamer1-devel
  44. BuildRequires: gstreamer1-plugins-base-devel
  45. BuildRequires: enchant-devel
  46. BuildRequires: libwebp-devel
  47. BuildRequires: libsecret-devel
  48. BuildRequires: gobject-introspection-devel
  49. BuildRequires: gsettings-desktop-schemas
  50. BuildRequires: gtk-doc
  51. %if %{with pango}
  52. BuildRequires: pango-devel
  53. %else
  54. BuildRequires: cairo-devel
  55. BuildRequires: fontconfig-devel
  56. BuildRequires: freetype2-devel
  57. %endif
  58. BuildRequires: libsoup-devel >= 2.28.2
  59. %description
  60. WebKit is an open source web browser engine.
  61. %package gtk
  62. Summary: GTK+ port of WebKit
  63. Summary(ja): WebKit の GTK+ ポート
  64. Group: Development/Libraries
  65. %description gtk
  66. %{name} is an open-source Web content engine library. This package contains
  67. the shared libraries for the WebKit GTK+ port as well as the sample
  68. GtkLauncher tool.
  69. %package gtk-devel
  70. Summary: Development package for %{name}
  71. Summary(ja): %{name} の開発パッケージ
  72. Group: Development/Libraries
  73. Requires: %{name}-gtk = %{version}-%{release}
  74. Requires: pkgconfig
  75. Requires: gtk3-devel
  76. Requires: libsoup-devel >= 2.28.2
  77. %description gtk-devel
  78. The %{name}-gtk-devel package contains libraries, build data, and header
  79. files for developing applications that use %{name}-gtk.
  80. Please note that the WebKit/GTK+ API is not yet stable. This should
  81. only be used as a "preview" rather than a stable platform library.
  82. %package docs
  83. Summary: Documentation for %{name}
  84. Summary(ja): %{name} のドキュメント
  85. Group: Documentation
  86. BuildArch: noarch
  87. Provides: %{name}-doc = %{version}-%{release}
  88. %description docs
  89. %{name} is an open-source Web content engine library. This package contains
  90. the documentation for %{name}, including various LICENSE, README, and
  91. AUTHORS files.
  92. %prep
  93. %setup -q -n webkitgtk-%{version}
  94. %build
  95. %configure \
  96. --with-gtk=3.0 \
  97. --with-gstreamer=1.0 \
  98. --enable-icon-database \
  99. --enable-geolocation \
  100. --enable-introspection=yes \
  101. --enable-dependency-tracking \
  102. %{?with_coverage: --enable-coverage } \
  103. %{?with_pango: --with-font-backend=pango } \
  104. %{?with_wml: --enable-wml }
  105. make %{?_smp_mflags}
  106. #make V=1
  107. # workaround for bug 488112
  108. # Compile libJavaScriptCore.a with -fno-strict-aliasing
  109. ##touch JavaScriptCore/AllInOneFile.cpp
  110. ##make %{?_smp_mflags} CXXFLAGS="%{optflags} -fno-strict-aliasing"
  111. %install
  112. rm -rf %{buildroot}
  113. make install DESTDIR=%{buildroot}
  114. install -d -m 755 %{buildroot}%{_libexecdir}/%{name}
  115. install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
  116. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  117. # conflict with WebKit-doc
  118. rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc
  119. # Finally, copy over and rename the various files for %%doc inclusion.
  120. %add_to_doc_files Source/WebKit/LICENSE
  121. %add_to_doc_files Source/WebKit/gtk/NEWS
  122. %add_to_doc_files Source/WebCore/icu/LICENSE
  123. %add_to_doc_files Source/WebCore/LICENSE-APPLE
  124. %add_to_doc_files Source/WebCore/LICENSE-LGPL-2
  125. %add_to_doc_files Source/WebCore/LICENSE-LGPL-2.1
  126. %add_to_doc_files Source/JavaScriptCore/COPYING.LIB
  127. %add_to_doc_files Source/JavaScriptCore/THANKS
  128. %add_to_doc_files Source/JavaScriptCore/AUTHORS
  129. %add_to_doc_files Source/JavaScriptCore/icu/README
  130. %find_lang WebKitGTK-3.0
  131. %clean
  132. rm -rf %{buildroot}
  133. %post gtk -p /sbin/ldconfig
  134. %posttrans gtk
  135. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  136. %postun gtk
  137. /sbin/ldconfig
  138. if [ $1 -eq 0 ] ; then
  139. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  140. fi
  141. # %files -f webkit.lang gtk
  142. %files gtk -f WebKitGTK-3.0.lang
  143. %defattr(-,root,root,-)
  144. %{_bindir}/jsc-3
  145. %{_libdir}/*.so.*
  146. %{_libdir}/webkit2gtk-3.0/injected-bundle/libwebkit2gtkinjectedbundle.so
  147. %{_libdir}/girepository-1.0/*.typelib
  148. %{_libexecdir}/WebKit3/
  149. %{_libexecdir}/WebKitPluginProcess
  150. %{_libexecdir}/WebKitWebProcess
  151. %{_datadir}/webkitgtk-3.0/*
  152. %files gtk-devel
  153. %defattr(-,root,root,-)
  154. %exclude %{_libdir}/*.la
  155. %{_includedir}/webkitgtk-3.0
  156. %{_libdir}/*.so
  157. %{_libdir}/pkgconfig/*.pc
  158. %{_datadir}/gir-1.0/*.gir
  159. %files docs -f docfiles.list
  160. %defattr(-,root,root,-)
  161. %changelog
  162. * Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.3-1
  163. - new upstream release
  164. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.2-1
  165. - new upstream release
  166. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.1-1
  167. - new upstream release
  168. - add BuildRequires: at-spi2-core-devel, libwebp-devel, libsecret-devel
  169. - change BuildRequires: harfbuzz-icu-devel instead of libicu-devel
  170. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.2-1
  171. - new upstream release
  172. * Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.1-1
  173. - new upstream release
  174. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.0-1
  175. - new upstream release
  176. - add BuildRequires: ruby, gtk2-devel
  177. - change BuildRequires: gstreamer1-devel instead of gstreamer-devel
  178. - change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-pluings-base-devel
  179. * Tue Aug 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.3-1
  180. - new upstream release
  181. * Thu Aug 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.2-1
  182. - new upstream release
  183. * Sat Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.1-1
  184. - new upstream release
  185. - change BuildRequires: gcr-devel instead of gnome-keyring-devel
  186. - add BuildRequires: gsettings-desktop-schemas, gtk-doc
  187. * Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.6.1-1
  188. - new upstream release
  189. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.90-1
  190. - new upstream release
  191. * Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.2-1
  192. - new upstream release
  193. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.1-1
  194. - initial build for Vine Linux