WebKit-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391
  1. %define add_to_doc_files() \
  2. mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}; \
  3. cp -p %1 %{buildroot}%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') \
  4. echo %%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') >> docfiles.list
  5. #define svn_revision 43436
  6. # --with coverage: Enables compile-time checking of code coverage. (default: no)
  7. %bcond_with coverage
  8. # --with jit: Enable JIT ("just-in-time") JavaScript compiling support.
  9. #%bcond_with jit
  10. # --with pango : use pango for font rendering instead of freetype2 (default: use freetype2)
  11. %bcond_with pango
  12. # --with wml: Build support for WML
  13. %bcond_with wml
  14. Name: WebKit
  15. Version: 2.2.3
  16. Release: 1%{?_dist_release}
  17. Summary: Web content engine library
  18. Summary(ja): ウェブコンテンツエンジンライブラリ
  19. Group: Development/Libraries
  20. License: LGPLv2+ and BSD
  21. URL: http://webkitgtk.org/
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Packager: yasumichi
  25. Source0: http://www.webkitgtk.org/webkitgtk-%{version}.tar.xz
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  27. BuildRequires: bison
  28. BuildRequires: flex
  29. BuildRequires: gperf
  30. BuildRequires: ruby
  31. BuildRequires: gtk2-devel
  32. BuildRequires: harfbuzz-icu-devel
  33. BuildRequires: libjpeg-turbo-devel
  34. BuildRequires: libtool
  35. BuildRequires: libxslt-devel
  36. BuildRequires: libXt-devel
  37. BuildRequires: pcre-devel
  38. BuildRequires: sqlite3-devel
  39. BuildRequires: geoclue-devel
  40. BuildRequires: gcr-devel
  41. BuildRequires: gstreamer1-devel
  42. BuildRequires: gstreamer1-plugins-base-devel
  43. BuildRequires: enchant-devel
  44. BuildRequires: libwebp-devel
  45. BuildRequires: libsecret-devel
  46. BuildRequires: gobject-introspection-devel
  47. BuildRequires: gsettings-desktop-schemas
  48. BuildRequires: gtk-doc
  49. %if %{with pango}
  50. BuildRequires: pango-devel
  51. %else
  52. BuildRequires: cairo-devel
  53. BuildRequires: fontconfig-devel
  54. BuildRequires: freetype2-devel
  55. %endif
  56. BuildRequires: libsoup-devel >= 2.28.2
  57. %description
  58. WebKit is an open source web browser engine.
  59. %package gtk
  60. Summary: GTK+ port of WebKit
  61. Summary(ja): WebKit の GTK+ ポート
  62. Group: Development/Libraries
  63. %description gtk
  64. %{name} is an open-source Web content engine library. This package contains
  65. the shared libraries for the WebKit GTK+ port as well as the sample
  66. GtkLauncher tool.
  67. %package gtk-devel
  68. Summary: Development package for %{name}
  69. Summary(ja): %{name} の開発パッケージ
  70. Group: Development/Libraries
  71. Requires: %{name}-gtk = %{version}-%{release}
  72. Requires: pkgconfig
  73. Requires: gtk2-devel
  74. Requires: libsoup-devel >= 2.28.2
  75. %description gtk-devel
  76. The %{name}-gtk-devel package contains libraries, build data, and header
  77. files for developing applications that use %{name}-gtk.
  78. Please note that the WebKit/GTK+ API is not yet stable. This should
  79. only be used as a "preview" rather than a stable platform library.
  80. %package docs
  81. Summary: Documentation for %{name}
  82. Summary(ja): %{name} のドキュメント
  83. Group: Documentation
  84. Provides: %{name}-doc = %{version}-%{release}
  85. %description docs
  86. %{name} is an open-source Web content engine library. This package contains
  87. the documentation for %{name}, including various LICENSE, README, and
  88. AUTHORS files.
  89. %prep
  90. %setup -q -n webkitgtk-%{version}
  91. %build
  92. %configure \
  93. --with-gtk=2.0 \
  94. --disable-webkit2 \
  95. --enable-icon-database \
  96. --enable-jit \
  97. --enable-geolocation \
  98. --enable-introspection=yes \
  99. --enable-webgl \
  100. --enable-dependency-tracking \
  101. %{?with_coverage: --enable-coverage } \
  102. %{?with_pango: --with-font-backend=pango } \
  103. %{?with_wml: --enable-wml }
  104. make %{?_smp_mflags}
  105. # workaround for bug 488112
  106. # Compile libJavaScriptCore.a with -fno-strict-aliasing
  107. ##touch JavaScriptCore/AllInOneFile.cpp
  108. ##make %{?_smp_mflags} CXXFLAGS="%{optflags} -fno-strict-aliasing"
  109. %install
  110. rm -rf %{buildroot}
  111. make install DESTDIR=%{buildroot}
  112. install -d -m 755 %{buildroot}%{_libexecdir}/%{name}
  113. install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
  114. # Finally, copy over and rename the various files for %%doc inclusion.
  115. %add_to_doc_files Source/WebKit/LICENSE
  116. %add_to_doc_files Source/WebKit/gtk/NEWS
  117. %add_to_doc_files Source/WebCore/icu/LICENSE
  118. %add_to_doc_files Source/WebCore/LICENSE-APPLE
  119. %add_to_doc_files Source/WebCore/LICENSE-LGPL-2
  120. %add_to_doc_files Source/WebCore/LICENSE-LGPL-2.1
  121. %add_to_doc_files Source/JavaScriptCore/COPYING.LIB
  122. %add_to_doc_files Source/JavaScriptCore/THANKS
  123. %add_to_doc_files Source/JavaScriptCore/AUTHORS
  124. %add_to_doc_files Source/JavaScriptCore/icu/README
  125. %find_lang WebKitGTK-2.0
  126. %clean
  127. rm -rf %{buildroot}
  128. %post gtk -p /sbin/ldconfig
  129. %posttrans gtk
  130. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  131. %postun gtk
  132. /sbin/ldconfig
  133. if [ $1 -eq 0 ] ; then
  134. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  135. fi
  136. # %files -f webkit.lang gtk
  137. %files gtk -f WebKitGTK-2.0.lang
  138. %defattr(-,root,root,-)
  139. %doc
  140. %{_libdir}/*.so.*
  141. %{_libexecdir}/WebKit/
  142. %{_bindir}/jsc-1
  143. %{_libdir}/girepository-1.0/*.typelib
  144. #%{_datadir}/glib-2.0/schemas/org.webkitgtk-1.0.gschema.xml
  145. %{_datadir}/webkitgtk-1.0/*
  146. %files gtk-devel
  147. %defattr(-,root,root,-)
  148. %exclude %{_libdir}/*.la
  149. %{_includedir}/webkitgtk-1.0
  150. %{_libdir}/*.so
  151. %{_libdir}/pkgconfig/*.pc
  152. %{_datadir}/gir-1.0/*.gir
  153. %files docs -f docfiles.list
  154. %defattr(-,root,root,-)
  155. %{_datadir}/gtk-doc/html/webkitgtk
  156. %changelog
  157. * Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.3-1
  158. - new upstream release
  159. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.2-1
  160. - new upstream release
  161. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.1-1
  162. - new upstream release
  163. - add BuildRequires: libwebp-devel, libsecret-devel
  164. - change BuildRequires: harfbuzz-icu-devel instead of libicu-devel
  165. - change BuildRequires: gstreamer1-devel instead of gstreamer-devel
  166. - change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-plugins-base-devel
  167. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.2-1
  168. - new upstream release
  169. * Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.1-1
  170. - new upstream release
  171. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.0-1
  172. - new upstream release
  173. - add BuildRequires: ruby
  174. * Tue Aug 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.3-1
  175. - new upstream release
  176. * Thu Aug 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.2-1
  177. - new upstream release
  178. * Sun Apr 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.1-1
  179. - new upstream release
  180. - change BuildRequires: gcr-devel instead of gnome-keyring-devel
  181. - add BuildRequires: gsettings-desktop-schemas, gtk-doc
  182. * Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.6.1-1
  183. - new upstream release
  184. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.90-1
  185. - new upstream release
  186. * Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.2-1
  187. - new upstream release
  188. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.1-1
  189. - new upstream release
  190. * Sun Jul 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.2-1
  191. - new upstream release
  192. - delete Patch0
  193. - add BuildRequires: gtk-doc
  194. * Fri Apr 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.7-1
  195. - new upstream release
  196. * Sat Jan 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.6-1
  197. - new upstream release
  198. * Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.5-1
  199. - new upstream release
  200. - add BuildRequires: gobject-introspection-devel
  201. - add configure option (--enable-introspection=yes)
  202. - add Patch0 (WebKit-1.2.5-gir.patch)
  203. * Thu Sep 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.4-1
  204. - new upstream release (built with rpm-4.8.1-1 for pkg-config file)
  205. - changed BuildRequires: libjpeg-devel to libjpeg-turbo-devel
  206. * Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.3-1
  207. - new upstream release
  208. - add Requires: libsoup-devel (devel package)
  209. - fix configure (remove unrecognized option)
  210. - drop Patch100
  211. * Wed Apr 14 2010 MATSUBAYASHI Kohji <shaoliN@vinelinux.org> - 1.2.0-2
  212. - rebuilt again on ppc
  213. * Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-1
  214. - new upstream release
  215. - rebuilt with libicu-4.4
  216. - added Patch100 for compiling with libicu-4.4
  217. - s/sqlite-devel/sqlite3-devel/
  218. - s/freetype-devel/freetype2-devel/
  219. * Mon Jan 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.18-1
  220. - updated to 1.1.18
  221. * Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-2
  222. - change BR from libsoup to libsoup-devel
  223. * Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-1
  224. - new upstream release.
  225. - add Vendor, Distribution and Packager.
  226. * Mon Jul 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.10-1
  227. - update to webkit-1.1.10 release version
  228. - added BuildRequires: enchant-devel
  229. * Sun May 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-1
  230. - update to webkit-1.1.6 release version
  231. * Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-8.svn41944
  232. - update to new upstream snapshot (svn r41944)
  233. * Mon Feb 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-7.svn40471
  234. - update to new upstream snapshot (svn r40471)
  235. * Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-6.svn37056
  236. - update to new upstream snapshot (svn r37056)
  237. - disable html5video by default
  238. * Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-5.svn36882
  239. - update to new upstream snapshot (svn r36882)
  240. - build with gnome-2.24
  241. * Thu Sep 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-4.svn36053
  242. - build without pango by default.
  243. * Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-3.svn36053
  244. - update to new upstream snapshot (svn r36053)
  245. * Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2.svn34655
  246. - update to new upstream snapshot (svn r34655)
  247. * Mon Jun 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1.svn34279
  248. - initial build for Vine Linux
  249. * Tue Jun 3 2008 Caol叩n McNamara <caolanm@redhat.com> - 1.0.0-0.12.svn34279
  250. - rebuild for new icu
  251. * Tue Jun 3 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.11.svn34279
  252. - Update to new upstream snapshot (SVN 34279) anyway
  253. - Add BR: libXt-devel
  254. * Tue Apr 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.10.svn32531
  255. - Remove the -Qt subpackage stuff. QtWebKit is now included in Qt proper, as
  256. of qt-4.4.0-0.6.rc1. (We no longer need separate build-qt and build-gtk
  257. subdirectories either.)
  258. - Reference: bug 442200 (RFE: WebKit Migration)
  259. - Add libjpeg dependency (was previously pulled in by the qt4-devel dependency
  260. tree).
  261. * Mon Apr 28 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.9.svn32531
  262. - Update to new upstream snapshot (SVN 32531).
  263. - Fix bug 443048 and hopefully fix bug 444445
  264. - Modify the process of building GTK+ port a bit
  265. - on qt port WebKit/qt/Plugins is not built for qt >= 4.4.0
  266. * Sat Apr 12 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.8.svn31787
  267. - Update to new upstream snapshot (SVN 31787).
  268. - Resolves: CVE-2008-1010 (bug 438532: Arbitrary code execution) and
  269. CVE-2008-1011 (bug 438531: Cross-Site Scripting).
  270. - Switch to using autotools for building the GTK+ port.
  271. * Wed Mar 05 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.7.svn30667
  272. - Fix the WebKitGtk pkgconfig data (should depend on gtk+-2.0). Resolves
  273. bug 436073 (Requires: gtk+-2.0 missing from WebKitGtk.pc).
  274. - Thanks to Mamoru Tasaka for helping find and squash these many bugs.
  275. * Sat Mar 01 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.6.svn30667
  276. - Fix include directory naming. Resolves: bug 435561 (Header file <> header
  277. file location mismatch)
  278. - Remove qt4-devel runtime dependency and .prl file from WebKit-gtk-devel.
  279. Resolves: bug 433138 (WebKit-gtk-devel has a requirement on qt4-devel)
  280. * Fri Feb 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.5.svn30667
  281. - Update to new upstream snapshot (SVN 30667)
  282. - Add some build fixes for GCC 4.3:
  283. + gcc43.patch
  284. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.0-0.5.svn29336
  285. - Autorebuild for GCC 4.3
  286. * Wed Jan 09 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.4.svn29336
  287. - Update to new upstream snapshot (SVN 29336).
  288. - Drop TCSpinLock pthread workaround (fixed upstream):
  289. - TCSpinLock-use-pthread-stubs.patch
  290. * Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.3.svn28482
  291. - Add proper %%defattr line to qt, qt-devel, and doc subpackages.
  292. - Add patch to forcibly build the TCSpinLock code using the pthread
  293. implementation:
  294. + TCSpinLock-use-pthread-stubs.patch
  295. * Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.2.svn28482
  296. - Package renamed from WebKitGtk.
  297. - Update to SVN 28482.
  298. - Build both the GTK and Qt ports, putting each into their own respective
  299. subpackages.
  300. - Invoke qmake-qt4 and make directly (with SMP build flags) instead of using
  301. the build-webkit script from upstream.
  302. - Add various AUTHORS, README, and LICENSE files (via the doc subpackage).
  303. * Tue Dec 04 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.1.svn28383
  304. - Initial packaging for Fedora.