ode-vl.spec 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198
  1. Summary: High performance library for simulating rigid body dynamics
  2. Name: ode
  3. Version: 0.11.1
  4. Release: 2%{?_dist_release}
  5. Group: System Environment/Libraries
  6. License: BSD or LGPLv2+
  7. URL: http://www.ode.org
  8. Source0: http://downloads.sourceforge.net/opende/ode-%{version}.tar.bz2
  9. # This works around a bug in rpmbuild, where with localbuilds it will pass
  10. # the machine being build on as host param to configure instead of the machine
  11. # on which the code will run
  12. Patch0: ode-0.10.0-no-pentium-on-i386.patch
  13. Patch1: ode-0.11.1-multilib.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildRequires: libGL-devel
  16. BuildRequires: libGLU-devel
  17. %description
  18. ODE is an open source, high performance library for simulating rigid body
  19. dynamics. It is fully featured, stable, mature and platform independent with
  20. an easy to use C/C++ API. It has advanced joint types and integrated collision
  21. detection with friction. ODE is useful for simulating vehicles, objects in
  22. virtual reality environments and virtual creatures. It is currently used in
  23. many computer games, 3D authoring tools and simulation tools.
  24. %package double
  25. Summary: Ode physics library compiled with double precision
  26. Group: System Environment/Libraries
  27. %description double
  28. The %{name}-double package contains a version of the ODE library for simulating
  29. rigid body dynamics compiled with double precision.
  30. %package devel
  31. Summary: Development files for %{name}
  32. Group: Development/Libraries
  33. Requires: %{name} = %{version}-%{release}
  34. Requires: %{name}-double = %{version}-%{release}
  35. %description devel
  36. The %{name}-devel package contains libraries and header files for
  37. developing applications that use %{name} or %{name}-double.
  38. %prep
  39. %setup -q
  40. %patch0 -p1
  41. %patch1 -p1
  42. # to stop autoxxx from getting regenerated because of our configure patch
  43. touch -r CHANGELOG.txt configure.in
  44. # stop rpmlint from complaining about executable files in the debug package
  45. chmod -x ode/src/stepfast.cpp include/ode/collision_trimesh.h \
  46. include/ode/odeconfig.h
  47. %build
  48. %configure --enable-shared --disable-static --enable-double-precision
  49. make %{?_smp_mflags} X_LIBS=-lX11 \
  50. libode_la_LDFLAGS="-release double -version-info 2:1:1"
  51. sed -i 's|-lode|-lode-double|g' ode-config ode.pc
  52. mv ode-config ode-double-config
  53. mv ode.pc ode-double.pc
  54. mv ode/src/.libs/libode-double.so.1.1.1 .
  55. make distclean
  56. CFLAGS="%{optflags} -ffast-math"
  57. CXXFLAGS="%{optflags} -ffast-math"
  58. %configure --enable-shared --disable-static
  59. make %{?_smp_mflags} X_LIBS=-lX11
  60. %install
  61. rm -rf $RPM_BUILD_ROOT
  62. make install DESTDIR=$RPM_BUILD_ROOT
  63. rm $RPM_BUILD_ROOT%{_libdir}/libode.la
  64. # DIY libode-double install
  65. install -m 755 ode-double-config $RPM_BUILD_ROOT%{_bindir}
  66. install -m 755 libode-double.so.1.1.1 $RPM_BUILD_ROOT%{_libdir}
  67. ln -s libode-double.so.1.1.1 $RPM_BUILD_ROOT%{_libdir}/libode-double.so.1
  68. ln -s libode-double.so.1.1.1 $RPM_BUILD_ROOT%{_libdir}/libode-double.so
  69. install -m 644 ode-double.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig
  70. %clean
  71. rm -rf $RPM_BUILD_ROOT
  72. %post -p /sbin/ldconfig
  73. %postun -p /sbin/ldconfig
  74. %post double -p /sbin/ldconfig
  75. %postun double -p /sbin/ldconfig
  76. %files
  77. %defattr(-,root,root,-)
  78. %doc CHANGELOG.txt LICENSE*.TXT README.txt
  79. %{_libdir}/libode.so.1*
  80. %files double
  81. %defattr(-,root,root,-)
  82. %doc CHANGELOG.txt LICENSE*.TXT README.txt
  83. %{_libdir}/libode-double.so.1*
  84. %files devel
  85. %defattr(-,root,root,-)
  86. %{_bindir}/%{name}-config
  87. %{_bindir}/%{name}-double-config
  88. %{_includedir}/%{name}
  89. %{_libdir}/libode.so
  90. %{_libdir}/libode-double.so
  91. %{_libdir}/pkgconfig/%{name}.pc
  92. %{_libdir}/pkgconfig/%{name}-double.pc
  93. %changelog
  94. * Sun Oct 26 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.11.1-2
  95. - rebuilt on current VineSeed
  96. - moved double subpackage to System Environment/Libraries Group
  97. * Fri Jan 07 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.11.1-1
  98. - initial build for Vine Linux based on fedora development
  99. * Mon Nov 8 2010 Hans de Goede <hdegoede@redhat.com> 0.11.1-5
  100. - Add a -double subpackage providing a version of ode compiled with
  101. double precision (#574034)
  102. * Tue Feb 16 2010 Hans de Goede <hdegoede@redhat.com> 0.11.1-4
  103. - Fix FTBFS (#564642)
  104. * Thu Nov 12 2009 Hans de Goede <hdegoede@redhat.com> 0.11.1-3
  105. - Fix multilib conflict in -devel sub package (#507981)
  106. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11.1-2
  107. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  108. * Mon May 25 2009 Hans de Goede <hdegoede@redhat.com> 0.11.1-1
  109. - New upstream release 0.11.1
  110. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11-2
  111. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  112. * Fri Jan 30 2009 Hans de Goede <hdegoede@redhat.com> 0.11-1
  113. - New upstream release 0.11
  114. * Mon Sep 15 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.1-1
  115. - New upstream release 0.10.1 (bz 460033)
  116. * Thu Apr 3 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.9-4
  117. - Force proper use of RPM_OPT_FLAGS during build
  118. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.9-3
  119. - Autorebuild for GCC 4.3
  120. * Thu Oct 18 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.9-2
  121. - Drop workaround for stormbaancoureur crash, it is now fixed in
  122. stormbaancoureur
  123. * Fri Oct 12 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.9-1
  124. - New upstream release 0.9 (final)
  125. * Fri Sep 28 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.9-0.1.rc1
  126. - New upstream release 0.9-rc1
  127. * Tue Sep 11 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.8.1-0.1.rc1
  128. - New upstream release 0.8.1-rc1
  129. * Wed Aug 15 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.8-2
  130. - Update License tag for new Licensing Guidelines compliance
  131. * Wed Feb 14 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.8-1
  132. - New upstream release 0.8
  133. * Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.7-2
  134. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  135. * Fri Sep 22 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 0.7-1
  136. - New upstream release 0.7
  137. * Mon Aug 28 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 0.6-3
  138. - FE6 Rebuild
  139. * Wed Jul 5 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 0.6-2
  140. - Change name from libode to ode
  141. - Fix soname & /usr/lib64 usage
  142. - Patch configure to accept our CFLAGS instead of always using its own
  143. - Patch configure to never activate the generation of asm-code which is then
  144. used unconditionally, the build CPU may be very different from the CPU on
  145. which the package gets run.
  146. * Sun Jun 18 2006 Hugo Cisneiros <hugo@devin.com.br> 0.6-1
  147. - Initial RPM release