nettle-vl.spec 6.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: nettle
  3. Version: 2.7.1
  4. Release: 3%{?_dist_release}
  5. Summary: A low-level cryptographic library
  6. Summary(ja): 低レベル暗号化ライブラリ
  7. Group: System Environment/Libraries
  8. License: LGPLv2+
  9. URL: http://www.lysator.liu.se/~nisse/nettle/
  10. Source0: http://www.lysator.liu.se/~nisse/archive/%{name}-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: gmp-devel
  13. BuildRequires: m4
  14. Requires(post): /sbin/install-info
  15. Requires(preun): /sbin/install-info
  16. Vendor: Project Vine
  17. Distribution: Vine Linux
  18. %package devel
  19. Summary: Development headers for a low-level cryptographic library
  20. Summary(ja): 低レベル暗号化ライブラリの開発ヘッダ
  21. Group: Development/Libraries
  22. Requires: %{name} = %{version}-%{release}
  23. #%package static
  24. #Summary: Static libraries for a low-level cryptographic library
  25. #Group: Development/Libraries
  26. #Requires: %{name}-devel = %{version}-%{release}
  27. %if %{build_compat32}
  28. %package -n compat32-%{name}
  29. Summary: A low-level cryptographic library
  30. Summary(ja): 低レベル暗号化ライブラリ
  31. Group: System Environment/Libraries
  32. Requires: %{name} = %{version}-%{release}
  33. %package -n compat32-%{name}-devel
  34. Summary: Development headers for a low-level cryptographic library
  35. Summary(ja): 低レベル暗号化ライブラリの開発ヘッダ
  36. Group: Development/Libraries
  37. Requires: %{name}-devel = %{version}-%{release}
  38. Requires: compat-32%{name} = %{version}-%{release}
  39. %endif
  40. %description
  41. Nettle is a cryptographic library that is designed to fit easily in more
  42. or less any context: In crypto toolkits for object-oriented languages
  43. (C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
  44. kernel space.
  45. %description devel
  46. Nettle is a cryptographic library that is designed to fit easily in more
  47. or less any context: In crypto toolkits for object-oriented languages
  48. (C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
  49. kernel space. This package contains kernel headers.
  50. %if %{build_compat32}
  51. %description -n compat32-%{name}
  52. Nettle is a cryptographic library that is designed to fit easily in more
  53. or less any context: In crypto toolkits for object-oriented languages
  54. (C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
  55. kernel space.
  56. %description -n compat32-%{name}-devel
  57. Nettle is a cryptographic library that is designed to fit easily in more
  58. or less any context: In crypto toolkits for object-oriented languages
  59. (C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
  60. kernel space. This package contains compat libraries.
  61. %endif
  62. #%description static
  63. #Nettle is a cryptographic library that is designed to fit easily in more
  64. #or less any context: In crypto toolkits for object-oriented languages
  65. #(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
  66. #kernel space. This package contains a static library.
  67. %prep
  68. %setup -q
  69. %build
  70. %configure --enable-shared
  71. make %{?_smp_mflags}
  72. %install
  73. rm -rf $RPM_BUILD_ROOT
  74. make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
  75. make install-shared DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
  76. #/usr/bin/iconv -f iso8859-1 -t utf-8 README > README.conv && /bin/mv -f README.conv README
  77. #/usr/bin/iconv -f iso8859-1 -t utf-8 ChangeLog > ChangeLog.conv && /bin/mv -f ChangeLog.conv ChangeLog
  78. #/usr/bin/iconv -f iso8859-1 -t utf-8 nettle.info > nettle.info.conv && /bin/mv -f nettle.info.conv nettle.info
  79. mkdir -p $RPM_BUILD_ROOT%{_infodir}
  80. install -p -m 644 nettle.info $RPM_BUILD_ROOT%{_infodir}/
  81. chmod 755 $RPM_BUILD_ROOT%{_libdir}/libhogweed.so.*
  82. chmod 755 $RPM_BUILD_ROOT%{_libdir}/libnettle.so.*
  83. rm -rf %{buildroot}/%{_libdir}/*.a
  84. rm -rf %{buildroot}/%{_infodir}/dir
  85. %check
  86. make check
  87. %clean
  88. rm -rf $RPM_BUILD_ROOT
  89. %files
  90. %defattr(-,root,root,-)
  91. %doc AUTHORS ChangeLog COPYING.LIB NEWS README TODO
  92. %{_infodir}/nettle.info.gz
  93. %{_bindir}/nettle-hash
  94. %{_bindir}/nettle-lfib-stream
  95. %{_bindir}/pkcs1-conv
  96. %{_bindir}/sexp-conv
  97. %{_libdir}/libhogweed.so.*
  98. %{_libdir}/libnettle.so.*
  99. %files devel
  100. %defattr(-,root,root,-)
  101. %doc descore.README nettle.html nettle.pdf COPYING.LIB
  102. %{_libdir}/libhogweed.so
  103. %{_libdir}/libnettle.so
  104. %{_includedir}/nettle
  105. %{_libdir}/pkgconfig/
  106. # compat32
  107. %if %{build_compat32}
  108. %files -n compat32-%{name}
  109. %defattr(-, root, root, 0755)
  110. %{_libdir}/libhogweed.so.*
  111. %{_libdir}/libnettle.so.*
  112. %files -n compat32-%{name}-devel
  113. %defattr(-, root, root, 0755)
  114. %{_libdir}/libhogweed.so
  115. %{_libdir}/libnettle.so
  116. %{_libdir}/pkgconfig/
  117. %endif
  118. #%files static
  119. #%defattr(-,root,root,-)
  120. #%doc COPYING
  121. #%{_libdir}/libhogweed.a
  122. #%{_libdir}/libnettle.a
  123. %post
  124. /sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
  125. /sbin/ldconfig
  126. %preun
  127. if [ $1 = 0 ]; then
  128. /sbin/install-info --delete %{_infodir}/%{name}.info.gz %{_infodir}/dir || :
  129. fi
  130. %postun -p /sbin/ldconfig
  131. %if %{build_compat32}
  132. %post -n compat32-%{name} -p /sbin/ldconfig
  133. %postun -n compat32-%{name} -p /sbin/ldconfig
  134. %endif
  135. %changelog
  136. * Sun Oct 26 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.7.1-3
  137. - moved nettle to System Environment/Libraries Group
  138. * Sun Feb 9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.7.1-2
  139. - add compat32,compat32-devel packages
  140. * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.7.1-1
  141. - update to 2.7.1
  142. * Fri Dec 02 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.4-1
  143. - initial build for VineSeed
  144. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15-7
  145. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  146. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15-6
  147. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  148. * Thu Apr 10 2008 Ian Weller <ianweller@gmail.com> 1.15-5
  149. - Moved static lib to -static
  150. * Mon Mar 24 2008 Ian Weller <ianweller@gmail.com> 1.15-4
  151. - Added libraries and ldconfig
  152. * Mon Feb 18 2008 Ian Weller <ianweller@gmail.com> 1.15-3
  153. - Added provides -static to -devel
  154. * Sun Feb 17 2008 Ian Weller <ianweller@gmail.com> 1.15-2
  155. - Removed redundant requires
  156. - Removed redundant documentation between packages
  157. - Fixed license tag
  158. - Fixed -devel description
  159. - Added the static library back to -devel
  160. - Added make clean
  161. * Fri Feb 08 2008 Ian Weller <ianweller@gmail.com> 1.15-1
  162. - First package build.