webkitgtk4-vl.spec 9.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296
  1. ## NOTE: Lots of files in various subdirectories have the same name (such as
  2. ## "LICENSE") so this short macro allows us to distinguish them by using their
  3. ## directory names (from the source tree) as prefixes for the files.
  4. %global add_to_license_files() \
  5. mkdir -p _license_files ; \
  6. cp -p %1 _license_files/$(echo '%1' | sed -e 's!/!.!g')
  7. Name: webkitgtk4
  8. Version: 2.18.5
  9. Release: 1%{?_dist_release}
  10. Summary: GTK+ Web content engine library
  11. License: LGPLv2
  12. Group: System Environment/Libraries
  13. URL: http://www.webkitgtk.org/
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. Source0: http://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
  17. Patch3: webkitgtk-2.5.2-commit_align.patch
  18. BuildRequires: at-spi2-core-devel
  19. BuildRequires: bison
  20. BuildRequires: cairo-devel
  21. BuildRequires: cmake
  22. BuildRequires: enchant-devel
  23. BuildRequires: flex
  24. BuildRequires: fontconfig-devel
  25. BuildRequires: freetype-devel
  26. BuildRequires: geoclue2-devel
  27. BuildRequires: gettext
  28. BuildRequires: glib2-devel
  29. BuildRequires: gobject-introspection-devel
  30. BuildRequires: gperf
  31. BuildRequires: gstreamer1-devel
  32. BuildRequires: gstreamer1-plugins-base-devel
  33. BuildRequires: gtk2-devel
  34. BuildRequires: gtk3-devel
  35. BuildRequires: harfbuzz-icu-devel
  36. BuildRequires: libicu-devel
  37. BuildRequires: libjpeg-turbo-devel
  38. BuildRequires: libpng-devel
  39. BuildRequires: libsecret-devel
  40. BuildRequires: libsoup-devel
  41. BuildRequires: libwebp-devel
  42. BuildRequires: libxslt-devel
  43. BuildRequires: libXt-devel
  44. BuildRequires: mesa-libGL-devel
  45. BuildRequires: pcre-devel
  46. BuildRequires: ruby
  47. BuildRequires: sqlite3-devel
  48. BuildRequires: libnotify-devel
  49. BuildRequires: hyphen-devel
  50. %ifarch ppc
  51. BuildRequires: libatomic
  52. %endif
  53. Requires: geoclue2
  54. # Require the jsc subpackage
  55. Requires: %{name}-jsc = %{version}-%{release}
  56. # Obsolete libwebkit2gtk from the webkitgtk3 package
  57. Obsoletes: libwebkit2gtk < 2.4.5-3
  58. Provides: libwebkit2gtk = %{version}-%{release}
  59. # Filter out provides for private libraries
  60. %global __provides_exclude_from ^%{_libdir}/webkit2gtk-4\\.0/.*\\.so$
  61. %description
  62. WebKitGTK+ is the port of the portable web rendering engine WebKit to the
  63. GTK+ platform.
  64. This package contains WebKitGTK+ for GTK+ 3.
  65. %package devel
  66. Summary: Development files for %{name}
  67. Group: Development/Libraries
  68. Requires: %{name} = %{version}-%{release}
  69. Requires: %{name}-jsc-devel = %{version}-%{release}
  70. %description devel
  71. The %{name}-devel package contains libraries, build data, and header
  72. files for developing applications that use %{name}.
  73. %package jsc
  74. Summary: JavaScript engine from %{name}
  75. Group: System Environment/Libraries
  76. %description jsc
  77. This package contains JavaScript engine from %{name}.
  78. %package jsc-devel
  79. Summary: Development files for JavaScript engine from %{name}
  80. Group: Development/Libraries
  81. Requires: %{name}-jsc = %{version}-%{release}
  82. %description jsc-devel
  83. The %{name}-jsc-devel package contains libraries, build data, and header
  84. files for developing applications that use JavaScript engine from %{name}.
  85. %prep
  86. %setup -q -n webkitgtk-%{version}
  87. %ifarch %{power64} aarch64 ppc
  88. %patch3 -p1 -b .commit_align
  89. %endif
  90. # Remove bundled libraries
  91. rm -rf Source/ThirdParty/leveldb/
  92. rm -rf Source/ThirdParty/gtest/
  93. rm -rf Source/ThirdParty/qunit/
  94. %build
  95. # binutils-2.23 doesn't support "reduce-memory-overheads"
  96. # Use linker flags to reduce memory consumption
  97. # global optflags %{optflags} -Wl,--no-keep-memory -Wl,--reduce-memory-overheads
  98. %ifarch s390 %{arm}
  99. # Decrease debuginfo verbosity to reduce memory consumption even more
  100. %global optflags %(echo %{optflags} | sed 's/-g /-g1 /')
  101. %endif
  102. %ifarch ppc
  103. # Use linker flag -relax to get WebKit build under ppc(32) with JIT disabled
  104. %global optflags %{optflags} -Wl,-relax -latomic
  105. %endif
  106. %global optflags %{optflags} -DENABLE_YARR_JIT=0
  107. mkdir -p %{_target_platform}
  108. pushd %{_target_platform}
  109. %cmake \
  110. -DPORT=GTK \
  111. -DCMAKE_BUILD_TYPE=Release \
  112. -DENABLE_JIT=OFF \
  113. -DENABLE_LLINT_C_LOOP=ON \
  114. ..
  115. popd
  116. make %{?_smp_mflags} -C %{_target_platform}
  117. %install
  118. %make_install -C %{_target_platform}
  119. %find_lang WebKit2GTK-4.0
  120. # Finally, copy over and rename various files for %%license inclusion
  121. %add_to_license_files Source/JavaScriptCore/COPYING.LIB
  122. %add_to_license_files Source/JavaScriptCore/icu/LICENSE
  123. %add_to_license_files Source/ThirdParty/ANGLE/LICENSE
  124. %add_to_license_files Source/ThirdParty/ANGLE/src/third_party/compiler/LICENSE
  125. %add_to_license_files Source/ThirdParty/ANGLE/src/third_party/murmurhash/LICENSE
  126. %add_to_license_files Source/WebCore/icu/LICENSE
  127. %add_to_license_files Source/WebCore/LICENSE-APPLE
  128. %add_to_license_files Source/WebCore/LICENSE-LGPL-2
  129. %add_to_license_files Source/WebCore/LICENSE-LGPL-2.1
  130. %add_to_license_files Source/WebInspectorUI/UserInterface/External/CodeMirror/LICENSE
  131. %add_to_license_files Source/WebInspectorUI/UserInterface/External/Esprima/LICENSE
  132. %add_to_license_files Source/WTF/icu/LICENSE
  133. %add_to_license_files Source/WTF/wtf/dtoa/COPYING
  134. %add_to_license_files Source/WTF/wtf/dtoa/LICENSE
  135. %post -p /sbin/ldconfig
  136. %postun -p /sbin/ldconfig
  137. %post jsc -p /sbin/ldconfig
  138. %postun jsc -p /sbin/ldconfig
  139. %files -f WebKit2GTK-4.0.lang
  140. %license _license_files/*
  141. %{_libdir}/libwebkit2gtk-4.0.so.*
  142. %{_libdir}/girepository-1.0/WebKit2-4.0.typelib
  143. %{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
  144. %{_libdir}/webkit2gtk-4.0/
  145. %{_libexecdir}/webkit2gtk-4.0/*
  146. %exclude %{_libexecdir}/webkit2gtk-4.0/jsc
  147. %{_bindir}/WebKitWebDriver
  148. %files jsc
  149. %license _license_files/*JavaScriptCore*
  150. %dir %{_libexecdir}/webkit2gtk-4.0/
  151. %{_libexecdir}/webkit2gtk-4.0/jsc
  152. %{_libdir}/libjavascriptcoregtk-4.0.so.*
  153. %{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
  154. %files devel
  155. %{_includedir}/webkitgtk-4.0/*
  156. %exclude %{_includedir}/webkitgtk-4.0/JavaScriptCore/
  157. %{_libdir}/libwebkit2gtk-4.0.so
  158. %{_libdir}/pkgconfig/webkit2gtk-4.0.pc
  159. %{_libdir}/pkgconfig/webkit2gtk-web-extension-4.0.pc
  160. %{_datadir}/gir-1.0/WebKit2-4.0.gir
  161. %{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
  162. %files jsc-devel
  163. %dir %{_includedir}/webkitgtk-4.0
  164. %{_includedir}/webkitgtk-4.0/JavaScriptCore/
  165. %{_libdir}/libjavascriptcoregtk-4.0.so
  166. %{_libdir}/pkgconfig/javascriptcoregtk-4.0.pc
  167. %{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
  168. %changelog
  169. * Thu Jan 11 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.5-1
  170. - new upstream release.
  171. - added subpackages webkitgtk4-jsc{,-devel}.
  172. * Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.4-1
  173. - new upstream release.
  174. * Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.12.3-2
  175. - rebuilt with new toolchain.
  176. * Sun Jun 12 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.3-1
  177. - new upstream release
  178. (including security fix for CVE-2016-1856,1857)
  179. * Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.2-1
  180. - new upstream release
  181. - remove Patch0
  182. - add BuildRequires: libnotify-devel, hyphen-devel
  183. * Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-3
  184. - rebuild with gnutls-3.4.7
  185. * Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-2
  186. - rebuild with icu-56.1
  187. * Mon Aug 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-1
  188. - new upstream release
  189. * Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.4-1
  190. - new upstream release
  191. * Fri May 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.3-1
  192. - new upstream release
  193. * Fri May 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-1
  194. - new upstream release
  195. * Wed Apr 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.1-1
  196. - new upstream release
  197. * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
  198. - new upstream release
  199. - update Patch0
  200. * Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
  201. - new upstream release
  202. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-2
  203. - add Group tag
  204. * Mon Nov 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-1
  205. - new upstream release
  206. * Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.3-1
  207. - new upstream release
  208. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
  209. - initial build for Vine Linux
  210. * Thu Sep 25 2014 Tomas Popela <tpopela@redhat.com> - 2.6.0-1
  211. - Add the wrongly removed CLoop patch and remove the one that was upstreamed
  212. * Wed Sep 24 2014 Kalev Lember <kalevlember@gmail.com> - 2.6.0-1
  213. - Update to 2.6.0
  214. * Mon Sep 22 2014 Tomas Popela <tpopela@redhat.com> - 2.5.90-1
  215. - Update to 2.5.90
  216. * Tue Aug 26 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-7
  217. - Obsolete libwebkit2gtk from the webkitgtk3 package
  218. * Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 2.5.3-6
  219. - rebuild for ICU 53.1
  220. * Mon Aug 25 2014 Tomas Popela <tpopela@redhat.com> - 2.5.3-5
  221. - Add support for secondary arches
  222. * Fri Aug 22 2014 Michael Catanzaro <mcatanzaro@gnome.org> - 2.5.3-4
  223. - Add webkitgtk-2.5.3-toggle-buttons.patch
  224. * Thu Aug 21 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-3
  225. - More package review fixes (#1131284)
  226. - Correct the license tag to read LGPLv2
  227. - Filter out provides for private libraries
  228. * Tue Aug 19 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-2
  229. - Remove bundled leveldb, gtest, qunit in %%prep (#1131284)
  230. * Fri Aug 15 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-1
  231. - Update to 2.5.3
  232. * Fri Aug 01 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.1-1
  233. - Initial Fedora packaging, based on the webkitgtk3 package